АФИША@MAIL.RU: Москва

Почта Почта Агент Агент Открытки Открытки Фото Фото Анекдоты Анекдоты Блоги Блоги Все проекты
Rambler's Top100

19 мая, пятница Город: Москва · Изменить
главная кино клубы концерты театр выставки дети тв
Адреса | Новости | Обзоры CD | Конкурсы | Фитнес

Расписание событий
на
Поиск по сайту

Кино

Сайлент Хилл
Смешная и скучная экранизация одноименной игры. С истеричными мамашами, нелепыми монстрами и обиженным... (afisha.mail.ru)

Кино

Остаться в живых
Остаться в живых
Азартные американские геймеры играют с венгерской Кровавой Графиней и пытаются остаться в живых... (afisha.mail.ru)

Кино

Код Да Винчи
Код Да Винчи
Если вы читали одноименный и далеко не бесспорный роман Дэна Брауна, то фильм (тоже далеко неоднозначный)... (afisha.mail.ru)

Клубы

"Аквариум"
"Аквариум" записал альбом "Беспечный русский бродяга" ("брАдяГГа" - версия для городских афиш, выдуманная...

Клубы

"Калинов мост"
Культовая фолк-группа, главная надежда и опора рокеров-славянофилов – "Калинов Мост" в Москве. Новый...

Концерты

Леонид Федоров
Леонид Федоров забрасывает пространство и людей компакт-дисками со своей музыкой. Не успели массы прийти...

Новости

  • Нэлли Уварова соблазняет мужчин - ТВ
  • Журналистам достаются объедки - Канны 2006
  • Под знаком Эйзенштейна - Канны 2006
  • Лопез отменяет концерты из-за беременности - Музыка
  • Страсть в большом городе - Музыка
  • Бесплатный вход в музеи - Арт
  • Самая гламурная вечеринка планеты - Музыка
  • Портрет эпохи в Госдуме - Арт
  • Топалов женится на «Тату» - Музыка
  • «Код да Винчи» в Каннах освистали - Канны 2006

Конкурс

Приглашения на фильм "Кастинг" в киноклуб СИНЕ ФАНТОМ
Среди приславших правильные ответы на вопросы конкурса будут выявлены 3 победителя, которые получат приглашения на 2 лица на фильм «Кастинг» в киноклуб СИНЕ ФАНТОМ. Сеанс состоится 24 мая в 20.00.

Скоро

Фильм
Плакат
Фильм рассказывает о событии, произошедшем в России в 2002 году. На обочине Киевского шоссе, недалеко...

Концерт/вечеринка
"МультFильмы"
"Мультфильмы" - группа с самым тощим вокалистом современного рокапопса

По максимуму

Колонка редактора
На этой неделе будет много хороших концертов и вечеринок, пара отличных фильмов, куча выставок, которые можно посетить бесплатно, и спектаклей, которые обязательно нужно увидеть, – хотя бы для общего развития. Хочется, чтобы именно эти семь дней были максимально насыщены культурными событиями. Тем более, что дома сейчас особенно грустно - отключили отопление и горячую воду... Дальше »

Леди@Mail.Ru

Мир магии
Любви поможет древнее ...
Любовь и секс
Без истерики - к оргазму
Праздники
Выход в свет: как сроч...
© 1999-2006, Mail.Ru Условия использования материалов · Обратная связь · Реклама на Mail.Ru · О компании


Mail.ru Агент

загрузить

Пользовательское
соглашение

  • Загрузка и установка
  • Настройка контакт листа
  • Общение
    • Переписка
    • Звонки VoIP
    • Отправка SMS
    • Общение в чате
    • Голосовое общение
    • Образы
  • Оповещения
  • Игры
  • Частые вопросы
  • Разработчикам

Поболтай со мной!

1 | Щелкни, чтобы пообщаться с этим человеком в Mail.Ru Агенте | Аркаев Батраз (23 года)
2 | Щелкни, чтобы пообщаться с этим человеком в Mail.Ru Агенте | hrundel-hrun
3 | Щелкни, чтобы пообщаться с этим человеком в Mail.Ru Агенте | xryu
4 | Щелкни, чтобы пообщаться с этим человеком в Mail.Ru Агенте | agoi2004
5 | Щелкни, чтобы пообщаться с этим человеком в Mail.Ru Агенте | Андрюха (23 года)
 |  | Весь список »
Как попасть в этот список?

Друзья агента

 | ЗНАКОМСТВА (16)
 | Евгения-частная эротика (8)
 | Всё для мобильных (8)
 | ЧАТ, MP3, ВИДЕО ... (7)
 | Эротические рассказы (4)
 | Все друзья »
Разместить здесь свой сайт Вход для Друзей

Новый Mail.ru Агент 4.6 (с технологией VoIP)

В новой версии появилась возможность совершать
междугородные и международные звонки прямо
из Агента! высокое качество связи и низкие цены!

Но кроме этого, Mail.ru Агент остается отличным бесплатным средством для:

общения с друзьями, не только текстовыми сообщениями, но и голосом
обмена файлами, ссылками и контактами
развлечения, благодаря возможности играть в морской бой, шашки и шахматы

Загрузите программу и начинайте общаться!

Если у вас еще нет учетной записи на Mail.ru, пожалуйста, зарегистрируйтесь.

загрузить сейчас!
требования к системе · история · настройки сети

Возможности

Общайтесь «накоротке»

Общайтесь «накоротке»

Обменивайтесь мгновенными сообщениями, отправляйте ссылки, пересылайте фотографии, музыку и любые другие файлы собеседникам.
Экономьте на междугородных звонках

Экономьте на междугородных звонках

Звоните своим родственникам, друзьям или деловым партнерам с помощью Агента.
Общайтесь по SMS

Общайтесь по SMS

Бесплатно отсылайте SMS на мобильные ваших друзей прямо из Агента и получайте сообщения в Агент с мобильных телефонов ваших друзей
Общайтесь голосом!

Общайтесь голосом!

вызывайте друзей и знакомых на голосовую беседу так, как бы вы это сделали с мобильным телефоном.
Играйте!

Играйте!

Хотите отдохнуть? Играйте с вашими друзьями online. Соревнуйтесь с соперниками из разных уголков мира.

Расширяйте круг общения

Расширяйте круг общения

Находите собеседников по анкетным данным, обменивайтесь контактами с друзьями, заходите в крупнейший чат рунета chat.mail.ru и добавляйте собеседников прямо в комнате чата.

Впервые здесь?

  • Узнайте с чего начать
  • Все вопросы по программе

ваш статус на сайте

Введите e-mail и получите html-код картинки, которая покажет статус вашего Mail.ru Агента и позволит другим пользователям добавить вас в список контактов.

© 1999-2006, Mail.Ru Служба поддержки Реклама на Mail.ru · О компании


AlgoList - алгоритмы, методы, исходники

:: алгоритмы и методы :: :: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Оглавление
Математика
-- Длинные числа
-- Эффективное вычисление ДПФ и ДПХ
-- Теория чисел
-- Геометрия
-- Графы и маршруты
-- Комбинаторика и перебор
-- Приближение функций
-- Быстрые вычисления
-- Псевдослучайные последовательности
-- Линейная алгебра
-- Математическая статистика
-- Корни функций и нелинейных систем
-- Разное

Сортировка
-- Поразрядная
-- Быстрая
-- Пирамидальная
-- Слиянием
-- Пузырьком + модификации
-- Вставками
-- Шелла
-- Выбором
-- FAQ
-- Топологическая
-- Быстрая с составными ключами

Структуры данных
-- Введение в абстрактные структуры
-- АВЛ-деревья
-- Красно-черные деревья
-- Деревья со случайным поиском
-- Слоёные списки (скип-списки)
-- Хеш-таблицы
-- Б, Б+ и Б++ деревья
-- Обходы бинарных деревьев
-- Hashed Array Trees[Перевод]
-- StringBTree
-- Triangle Mesh

Поиск. Строки и последовательности
-- Точный подстроки в строке
-- Нечеткий поиск
-- Проверка на подпоследовательность
-- Общие подпоследовательности. Дистанция
-- Поиск hcs, lis, his
-- Максимальная повторяющаяся подстрока
-- Общие элементы двух массивов
-- Бинарный поиск
-- Интерполяционный поиск
-- Бинарный поиск с определением ближайших узлов
-- Частный случай lis

Графика
-- Удаление скрытых линий и поверхностей
-- Эффекты
-- Поиск ближайшего цвета
-- Рисование
-- Заливка области/многоугольника
-- Перевод цветов из режима RGB в HSV
-- Квантизация
-- Фильтры и спецэффекты. Яркость и контраст
-- Отсечение отрезка
-- Отсечение многоугольника
-- 2D Бампмэппинг
-- Вpащение pастpовой каpтинки
-- Demodesign FAQ
-- Фракталы
-- Лист папоротника
-- Множество Мандельброта
Защита информации и ее взлом
-- Введение в криптографию
-- Атаки
-- Стеганография
-- Известные алгоритмы
-- Новые алгоритмы
-- Аутентификация и хэш-функции

Разбор выражений. Компиляторы и интерпретаторы.
-- Классические алгоритмы
-- Обpатная польская нотация
-- Tail-Recursive Stack Disciplines for an Interpreter
-- Representing Type Information in Dynamically Typed Languages

Сжатие и кодирование
-- Звука
-- Изображений
-- Общие алгоритмы

АИ, ГА, Нейронные сети
-- Нейронные сети
-- Генетические алгоритмы

Игры
-- Генерация лабиринтов
-- Волновой алгоритм
-- Крестики-нолики
-- Альфа-бета отсечения
-- Калах
-- Изометрическая проекция
-- Smart Moves[Перевод]

Разное
-- Cимвол O()
-- Динамическое программирование
-- 'Японский кроссворд'
-- Морфология
-- Проверка високосности года. Вычисление недели
-- Игра: Быки и коровы
-- Алгоритм сбора кубика-рубика

Copyright © 2000-2006 Ilia Kantor. All Rights Reserved
При поддержке компании Relmax и проекта MANUAL.RU


AИ, ГА, Нейронные сети

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: АИ, ГА, Нейронные сети
AИ, ГА, Нейронные сети

Нейронные сети, нейроинформатика
Моделирование человеческого разума и мозга Приложения нейросетей.

Генетические алгоритмы
Моделирование эволюции. 'Выживает' наилучшее решение проблемы.


Генетические алгоритмы

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: АИ, ГА, Нейронные сети » Генетические алгоритмы
Генетические алгоритмы

Введение в ГА и Генетическое Программирование

Пример ГА: Решение Диофантова уравнения

Решение Диофантова уравнения - разбор исходников
Что такое генетические алгоритмы. Их схема и отличия от стандартных методов. Простейшие алгоритмы - разбор и применение. Советую начинающим..

Популярно о генетических алгоритмах

Генетические алгоритмы - эволюционные методы поиска

Оптимизация многоэкстремальных функций с помощью генетических алгоритмов
Более продвинутый комплекс статей, позволяющий намного глубже понять методы решений задач с применением ГА, а также различные применения идеи, лежащих в их основе.

Дополнительные материалы:

Естественный отбор в мире битов z i p
Попытка использовать ГА для нахождения максимума функции. Немного псевдокода и ряд полезных замечаний.


Нейронные сети, нейроинформатика

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: АИ, ГА, Нейронные сети » Нейронные сети
Нейронные сети, нейроинформатика

Нейронные сети: основные положения z i p
Основы теории нейронных сетей, позволяющие в дальнейшем обратиться к конкретным структурам, алгоритмам и идеологии практического применения сетей в компьютерных приложениях.

Нейронные сети: алгоритм обратного распространения z i p
Алгоритм обучения нейронной сети с помощью процедуры обратного распространения, описана библиотека классов для С++.

Нейронные сети: обучение без учителя z i p
Алгоритмы обучения искусственных нейронных сетей без учителя. Приведена библиотека классов на C++ и тестовый пример.

Нейронные сети Хопфилда и Хэмминга z i p
Известный вид сетей, не подходящий под категорию ни 'с учителем', ни без него. С исходником на Си++.

Дополнительные материалы:

Using Neural Networks for Nonlinear Predictive Coding z i p
Использование нейронных сетей для адаптивного сжатия информации. С исходниками.

Конспект лекций: 'основы проектирования систем искусственного интеллекта' z i p
Неплохая книжка. Много 'растекания мысли по древу', нет исходников, но все равно очень много полезного.

Запись лекций и семинаров по нейроинформатике z i p
Большой и классный талмуд. От азов до серьезных методов. Рассмотрены различные применения нейронных сетей и алгоритмы с ними.

Нейрокомпьютерная техника: Теория и практика z i p
Простым языком, с азов, даны нейронные сети и алгоритмы с ними, основную часть которых можно реализовать на обычном PC. Книга ориентированна на нематематиков по профессии.


Сжатие информации и кодирование

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Сжатие и кодирование
Сжатие информации и кодирование

Сжатие аудиосигналов

Сжатие изображений
Ввиду высокой специфики проблемы, эти алгоритмы выделены отдельно.

Общие алгоритмы cжатия и кодирования
Методы, используемые в обычных случаях, например, в архиваторах, для сжатия текста или исполнимых файлов.

Дополнительные материалы:

CRC и как его восстановить после изменений файла z i p
Что такое CRC, как он считается, как восстанавливать различные типы CRC после изменений. Рассмотрены конкретные примеры применения алгоритмов.

Элементарное руководство по CRC-алгоритмам обнаружения ошибок z i p
CRC с азов. Очень доступно, с примерами, разъяснена суть CRC алгоритмов и описаны их различные виды. Исходник на Си..


Сжатие аудиосигналов

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Сжатие и кодирование » Звука
Сжатие аудиосигналов

Дополнительные материалы:

Improved Lossless Transform Coding of Audio Signals z i p
Мощный алгоритм сжатия без потерь. Слабо распространенная ветвь такого рода алгоритмов.

Lossless Audio Coding z i p
Дано краткое описание основных методов сжатия аудиофайлов без потерь.

Digital Audio Compression z i p
Обзор различных методов сжатия цифрового звука.


Сжатие изображений

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Сжатие и кодирование » Изображений
Сжатие изображений

Основы алгоритма сжатия JPEG
Кратко описан и продемонстрирован на примере алгоритм сжатия JPEG.

Статья: Алгоритмы сжатия изображений
Пособие знакомит с основными понятиями сжатия изображений, базовыми алгоритмами и современными направлениями развития теории сжатия изображений. Пособие можно рассматривать как практическое руководство. Рассчитано на читателей, знакомых с C++ и имеющих представление о базовых алгоритмах.

Два курса по вейвлет-анализу
Подробное, математическое описание вейвлет-анализа и его применение в сжатии изображений.

Дополнительные материалы:

FELICS z i p
Алгоритм сжатия без потерь, равный по эффективности Jpeg, но многократно превосходящий его по скорости.

Fast and Efficient Compression Method for Binary Images z i p
Совмещение статического моделирования и арифметической компрессии, дающее на 41% большую скорость при том же сжатии.

Study of DCT coefficient distributions z i p
Изучение ДКП - основного, используемого почти везде метода распределения образа/видео по частотам.

Guide to 'Fractal-Based' Function Approximation and Image Compression z i p
Основные методы фрактальной аппроксимации и сжатия изображений.

Wavelet-Based Image Coding: An Overview z i p
Обзор вейвлет-методов кодирования и квантизации изображений.

Систематизация вейвлет-преобразований z i p
Попытка систематизировать распространенные типы вейвлет-преобразований.

Transform Methods and Image Compression z i p
Краткое ознакомление с Jpg-transform и Wavelet методами на высоком теоретическом уровне.

Nonlinear Wavelet Transforms for Image Coding z i p
Описан нелинейный аналог вейвлет-преобразований.

Wavelet Transforms that Map Integers to Integers z i p
Описаны два подхода к проблеме, а также их использование для сжатия изображений без потерь.

Factoring Wavelet Transforms Into Lifting Steps z i p
Метод, использующий Евклидов алгоритм для вдвое более быстрого вейвлет-преобразования, а также некоторых других интересных результатов.

Building Your Own Wavelets at Home z i p
Необычная статья, отдельно дающая математическое и практически-применимое описание вейвлетов и преобразований.

Wavelet Spectra compared to Fourier Spectra z i p
Описана связь между спектрами Фурье и вейвлетов.

Lifting Scheme: New Philosophy in Biortogonal Wavelet Constructions z i p
С точки зрения вейвлетов анализируется lifting scheme - конструкция биортогональных вейвлетов, не использующая преобразования Фурье.


 К разделу 'Сжатие изображений' сайта AlgoList.

МОСКОВСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ
ИМ. М.В.ЛОМОНОСОВА
ФАКУЛЬТЕТ ВЫЧИСЛИТЕЛЬНОЙ
МАТЕМАТИКИ И КИБЕРНЕТИКИ

Д.С.Ватолин

Алгоритмы cжатия изображений

Методическое пособие
Москва
1999

ISBN 5-89407-041-4
Скачать это пособие в виде
WORD файла (1.3Мб)
 Содержание
  • Общие положения алгоритмов сжатия изображений
    • Введение
    • Классы изображений
    • Классы приложений
    • Критерии сравнения алгоритмов
    • Контрольные вопросы к разделу
  • Алгоритмы архивации без потерь
    • Алгоритм RLE
    • Алгоритм LZW
    • Алгоритм Хаффмана
    • JBIG
    • Lossless JPEG
    • Заключение
    • Контрольные вопросы к разделу
  • Алгоритмы архивации с потерями
    • Проблемы алгоритмов архивации с потерями
    • Алгоритм JPEG
    • Фрактальный алгоритм
    • Рекурсивный (волновой) алгоритм
    • Заключение
    • Контрольные вопросы к разделу
  • Различия между форматом и алгоритмом
  • Литература
    • Литература по алгоритмам сжатия
    • Литература по форматам изображений
  • Приложение. Таблицы сравнения алгоритмов
    • Архивация двуцветного изображения
    • Архивация 16-цветного изображения
    • Архивация изображения в градациях серого
    • Архивация полноцветного изображения
    • Архивация полноцветного изображения в 100 раз
  • Приложение. Апплет, обеспечивающий фрактальную декомпрессию
  • Ссылки на ресурсы по сжатию изображений в сети
Последнее изменение: 04.03.99 3:15 (Версия с 26.10.98 1:05) Напечатан: 13.04.99
ble>
УДК 681.3

Ватолин Д.С. Алгоритмы сжатия изображений. Методическое пособие.

Пособие знакомит с основными понятиями сжатия изображений, базовыми алгоритмами и современными направлениями развития теории сжатия изображений. Пособие можно рассматривать как практическое руководство. Оно рассчитано на читателей, знакомых с языком программирования C++ и имеющих представление о базовых алгоритмах. Рекомендуется студентам, аспирантам, научным сотрудникам и инженерам весьма широкого круга специальностей.

Рецензенты:

Баяковский Ю.М., к.ф.-м.н.s
Кумсков М.И., д.ф.-м.н. Издательский отдел факультета Вычислительной Математики и Кибернетики МГУ им. М.В.Ломоносова (лицензия ЛР N 040777 от 23.07.96), 1999 г. — 76 с.

Печатается по решению Редакционно-Издательского Совета факультета Вычислительной Математики и Кибернетики Московского Государственного Университета им. М.В. Ломоносова

ISBN 5-89407-041-4

Издательский отдел факультета Вычислительной Математики и Кибернетики МГУ им. М.В. Ломоносова, 1999 г
(c) 1999 Ватолин Д.С.
(с) 1999 Лаборатория Компьютерной Графики ВМиК МГУ им. М.В. Ломоносова


Учебные курсы по Вейвлет-анализу

 К разделу 'Сжатие изображений' сайта AlgoList.

Учебная программа 8-й международной конференции по компьютерной графике и визуализации ГрафиКон'98.

Два курса по ВЕЙВЛЕТ-АНАЛИЗУ

Леонид Левкович-Маслюк
e-mail: levkovl@spp.keldysh.ru

Антон Переберин
e-mail: avpereb@cs.msu.su

I. Введение в вейвлет-анализ

Лекция 1.
Ортогональные вейвлеты и многомасштабный анализ

  • Введение
  • v Разложение по поддиапазонам
  • Пирамидное представление
  • Ортогональный многомасштабный анализ
  • Литература

Лекция 2.
Биортогональные вейвлеты, вейвлет-пакеты, сжатие изображений

  • Конструкция ортогональных вейвлетов
  • Биортогональный многомасштабный анализ
  • Вейвлет-пакеты
  • Двумерный случай
  • Сжатие изображений
  • Литература

II. Вейвлет-анализ и его приложения

Лекция 1.
Вейвлет-анализ в компьютерой графике

  • Введение. Матричная запись. Используемые обозначения.
  • Вейвлеты и обработка растровых изображений
  • Многомасштабное представление кривых...
  • ... и поверхностей
  • Вейвлеты в задачах глобальной освещенности.

Лекция 2.
Лифтинг. Мультивейвлеты.

  • Лифтинг. Целочисленное вейвлет-преобразование.
  • Мультивейвлеты.
  • Литература.


Общие алгоритмы cжатия и кодирования

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Сжатие и кодирование » Общие алгоритмы
Общие алгоритмы cжатия и кодирования

Идея арифметического кодирования
Стандартный метод сжатия файлов. Хорош для любой информации. Двухпроходной. Лучше Хаффмана, но в чистом виде не используется.

Метод LZW-сжатия данных
LZW-сжатие выделяется среди прочих, когда встречается с потоком данных, содержащим повторяющиеся строки любой структуры ( текст, сжатие видеоформ и копий экранов). Сжатие однопроходное и может быть осуществлено 'на лету'.

Использование алгоритма расширяющегося префикса для кодирования и схожих пpоцессов
Статья дает описание арифметического кодирования с применением 'splay trees' - расширяющихся деревьев. C исходниками..

Сжатие по алгоритму Хаффмана
Старый, добрый двухпроходной Хаффман. Классика кодирования. Исходник прилагается.

RLE (Групповое кодирование)
Старейший двухпроходной алгоритм сжатия информации. Применяется только как дополнение к другим методам. Легок для освоения и реализации.

UUE-кодирование
Основные алгоритмы UUE-кодирования. Описание используемого при UUE CRC-алгоритма. Исходник прилагается.

Кодирование методом Шеннона-Фано

Дополнительные материалы:

Модели в компрессии. Различные алгоритмы сжатия z i p
Общий обзор методов компрессии и моделей. Даны основные принципы работы многих известных алгоритмов.

Experiments on the Zero Frequency Problem z i p
The focus of this paper is the problem of transforming the set of counts accumulated for a particular context into a probability distribution. Довольно интересные общие рассуждения без конкретных алгоритмов.

Fast Text Compression Based on Quasi-Arithmetic Code z i p
Описан метод сжатия информации, лишь немного уступающий PPMC в сжатии, но сильно превосходящий по скорости.

Range encoding: an algorithm for removing redundancy z i p
Алгоритм для устранения избыточности сообщения. Больше интересно теоретически, нежели для практики.

Sub-Linear Decoding of Huffman Codes Almost in-place z i p
Сублинейное декодирование Хаффмана, требующее в несколько раз меньше памяти, нежели обычные реализации.

Flexible Parsing for Dynamic Dictionary Based Compression z i p
Улучшение обычного 'жадного' парсинга, заглядывающее назад. Как результат - на 35% улучшение по сравнению с обычным dynamic dictionary compression в gzip и compress.

A Rapid Entropy-Coding Algorithm z i p
Алгоритм entropy coding, сравнимый по быстродействию и скорости с Q- и QM-coder. С исходниками на Си.

Using Neural Networks for Nonlinear Predictive Coding z i p
Использование нейронных сетей для адаптивного сжатия информации. С исходниками.

A Generalization and Improvement to PPM's 'Blending' z i p
Улучшение одного из наиболее мощных методов адаптивной компрессии - PPM blending.


Защита и сокрытие информации. Атаки и взлом

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Защита информации и ее взлом
Защита и сокрытие информации. Атаки и взлом

Введение в криптографию
Основные типы и классы алгоритмов, используемых в криптографии.

Атаки на системы защиты информации
Cпособы вскрытия известных криптоалгоритмов и другие нападения на оборудование, протоколы пользовалей ;-).

Стеганография. Сокрытие информации
Лучший метод защитить информацию - не дать обнаружить, что она есть.

Известные криптографические алгоритмы
Наиболее известные и широко используемые криптопротоколы DES, RSA, Еl-gamal, TEA Советую.

Новые и перспективные алгоритмы, функции, протоколы
Новые направления в криптографии Некоторые алгоритмы изучены слабо, другие уже превратились в стандарты Все новое здесь.

Аутентификация. Криптографические хэш-функции
Алгоритмы вычисления стойких необратимых функций от информации, меняющих значение при любом ее изменении Цифровая подпись.

Дополнительные материалы:

А. Саломаа. Криптография с открытым ключом z i p
На довольно неплохом теоретическом уровне охвачена вся open-key криптография.

Прикладная криптография, Брюс Шнайер z i p
Очень хорошая книга. Криптографические и смежные алгоритмы даны на неплохом теоретическом и хорошем практическом уровне, с рядом исходников и атаками на некоторые методы.

Handbook of Applied Cryptography, by A.Menezes et al z i p
Еще одна великолепная книга, где более конкретно объяснены алгоритмы и математическая база. Must read для каждого, кто серьезно изучает криптографию.

Криптография и компьютерная безопасность z i p
Довольно неплохо объяснена схема 'взбивальщиков' и некоторых других простых шифров.

Андрей Винокуров. Как устроен блочный шифр ? z i p
Хорошая и интересная статья на эту тему.

Lecture notes on Cryptography z i p
Довольно-таки большой и продвинутый конспект лекций, освещающий большей частью теоретические аспекты криптографии.


Атаки на системы защиты информации

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Защита информации и ее взлом » Атаки
Атаки на системы защиты информации

Почему криптосистемы ненадежны? П. Семьянов

Слабые места криптографических систем Б. Шнайер
Четкий и последовательный анализ основных слабостей криптосистем и тех, кем они применяются ;-).

Криптоанализ туннельного протокола типа точка-точка (PPTP) от Microsoft
Описание системы и атаки на этот, часто используемый Microsoft'ом протокол.

Общее описание временной атаки
При некоторых условиях весьма действенный метод вскрытия RSA, DSS и т.п.

Атаки на RSA
Безключевое чтение RSA, атака на подпись RSA в схеме с нотариусом, атака на подпись RSA по выбранному шт.

Метод встречи в середине атаки
Метод применяется для атаки на блочные шифры Обладает значительно меньшей трудоемкостью по сравнению с методом полного перебора.

Дополнительные материалы:

Типичные дефекты в криптографических протоколах z i p
Рассмотрено много видов атак на известные криптографические протоколы и алгоритмы.


Аутентификация. Криптографические хэш-функции

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Защита информации и ее взлом » Аутентификация и хэш-функции
Аутентификация. Криптографические хэш-функции

TIGER. С исходниками z i p
Хэш-функция, созданная для эффективной реализации на 64-битных процессорах.

Elliptic Curves in Cryptography z i p
Сильные алгоритмы шифрования и электронной подписи на основе эллиптических кривых.

Дополнительные материалы:

Проблема аутентификации данных и блочные шифры z i p
Хорошая и интересная статья на эту тему..


Стеганография. Сокрытие информации

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Защита информации и ее взлом » Стеганография
Стеганография. Сокрытие информации

Techniques of data hiding z i p
Способы скрытия информации, в изображениях, тексте и аудиосигналах.

An Information-Theoretic Model of Steganography z i p
Теоретические аспекты стеганографии - скрытия одного сообщения внутри другого.


Новые и перспективные алгоритмы, функции, протоколы

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Защита информации и ее взлом » Новые алгоритмы
Новые и перспективные алгоритмы, функции, протоколы

NTRU: Ring Based Cryptosystem z i p
Новая система, основанная на комбинации двух методов шифрования, за счет чего имеет время (де)шифрования порядка О(N2).

Diamond z i p
Криптографический алгоритм, ориентированный на высокую стойкость и легкость в генерации ключей.

ICE z i p
Улучшение DES. Описано, как при создании алгоритмов добиваться стойкости к дифференциальным и линейным криптоатакам.

LUC z i p
Анализ RSA и его улучшение, имеющее гораздо большую стойкость при некотором увеличении вычислений.

Public-key Cryptosystems from Lattice Reduction Problems z i p
Криптосистема с ключом O(N2) и вычислительной сложностью O(N2), базирующаяся на других принципах, нежели классические RSA/El-Gamal.

Rijndael z i p
Быстрый и мощный блочный шифр с переменной длиной ключа (до 256 бит) и переменной длиной блока. С исходниками.

RC6 z i p
По утверждениям статьи, во всех отношениях прекрасный алгоритм, на который до сих пор /1999 год/ не найдено успешных атак.

SEAL z i p
Криптографический алгоритм, специально созданный для выполнения на обычных компьютерах, а не специализированных устройствах.

Fast Key Exchange With Elliptic Curve Systems z i p
Обмен ключами Деффи-Халлмана может быть гораздо быстрее осуществлен через эллиптические кривые.

WAKE z i p
Криптографический алгоритм средней скорости и высокой секретности. Для каждого нового ключа требуется генерация особой таблицы.


Известные криптографические алгоритмы

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Защита информации и ее взлом » Известные алгоритмы
Известные криптографические алгоритмы

Криптосистема RSA
Одна из наиболее сильных криптосистем Применяется как часть PGP Основа стойкости - сложность факторизации Время (де)шифрования O(N3), ключ - O(N).

Шифр Эль-Гамаля
Классика криптографии Основа стойкости - дискретное логарифмирование Время (де)шифрования O(N3), ключ - O(N).

DES z i p
Программа, разъясняющая алгоритм DES и обучающая его применению. Сам алгоритм очень старый и очень классический, ключ - 56бит. С исходником на Си.

TEA, XTEA, XXTEA с исходниками z i p
Криптографический алгоритм с маленьким исходником и высокой эффективностью. Известная и широко применяемая реализация. С исходниками на Си.

TWOFISH. С исходниками z i p
Известная и мощная криптосистема с ключом 128-256 бит.

DEAL z i p
Размер блока - 128 бит, ключ до 128-256 бит, высокая стойкость шифрования против всех известных атак. Скорость - как у тройного DES.

ГОСТ 28147-89 z i p
Cтатья содержит описание алгоритма, принятого в качестве стандарта шифрования в РФ и его реализации для процессоров семейства Intel x86, а также обсуждение различных вопросов его практического использования.


Структуры данных и хэширование

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Структуры данных
Структуры данных и хэширование

Введение в абстрактные структуры
Очень доступно объясняется, что такое эти структуры, что такое список и как с ним работать, а также что такое очередь, стек и дек. Описаны различные реализации. Ниже предполагается, что читатель знаком с основными понятиями.

Словари для произвольных данных

АТД Словарь используется для манипулирования набором элементов, встроенных в линейном порядке. Он поддерживает динамическое редактирование элементов (создание, внесение и удаление) и различные формы поиска внутри набора (например, поиск заданного элемента, наименьшего, наибольшего элемента, предшественника или последователя элемента).

Основными характеристиками словаря являются затраты на вставку элемента, удаление и поиск. Однако некоторые реализации словарей позволяют эффективно выполнять другие дополнительные операции, такие как объединение словарей, переход к большему/меньшему соседу и т.п. Оценки времени для таких эффективно выполняемых операций мы также будем также включать в таблицы.

Как правило, для эффективного доступа словари организуются на основе упорядоченных структур данных. Если такого упорядочения нет, то оно вводится. Например: лексикографический порядок для строк, порядок для треугольников значению координаты x самой левой вершины. Зачастую алгоритм, использующий словарь в качестве структуры данных, сам подсказывает необходимый порядок.

Списки

Простейший словарь можно реализовать в виде списка элементов в порядке их поступления.

Характеристики несортированного списка:
 | вставка | поиск | удаление | объединение словарей
время | O(1) | O(n) | O(n)* | O(1)
память | один-два указателя на каждый элемент данных

Если дополнительно поддерживать упорядоченность этого списка, то имеем следующие оценки:

Характеристики сортированного списка:
 | вставка | поиск | удаление | переход к большему/меньшему элементу
время | O(n) | O(n) | O(n)* | O(1)
память | один-два указателя на каждый элемент данных
* - чтобы удалить данные из списка, их нужно сначала найти.

Двоичные деревья

В ряде приложений, где не требуется быстрый поиск и удаление произвольного элемента, и где ценны дополнительные преимущества, предоставляемые структурой списка, такой выбор представляется оптимальным. Однако весьма часто от словаря требуются гораздо лучшие основные характеристики.

Хорошим выбором может послужить двоичное дерево поиска.

Характеристики двоичного дерева поиска:
(основные операции стоят одинаково)
 | среднее | худшее
время | O(logn) | O(n)
память | два указателя на каждый элемент данных

Реальное время выполнения операций зависит от формы дерева. Если оно похоже на список - имеем O(n), как в списке, если на дерево - то O(log n). Можно доказать, что при последовательном включении в дерево случайных данных получается именно среднее время выполнения операций. Однако, если входные данные, например, образуют возрастающую последовательность, то получается список и все преимущество дерева потеряно.

На практике двоичные деревья поиска очень удобны во многих приложениях, где входные данные случайны или есть другие причины надеяться на сохранение деревом хорошей формы. Существуют способы добиться времени O(log n) на любых входах, они полезны, но дают небольшие накладные расходы на хранение специальной информации.

Есть одна задача, которая не может быть эффективно решена с помощью двоичных деревьев поиска: для заданного элемента в двоичном дереве поиска найти ближайшие больший и меньший элементы. Хотя при симметричном обходе все элементы выстраиваются в порядке увеличения, это не позволяет эффективно определить предшественника и последователя для произвольного элемента.

Проблема может быть эффективно решена с помощью пополнения структуры двоичного дерева. Классическим решением являются связанные двоичные деревья поиска, которые являются двоичными деревьями поиска со связным списком, охватывающим все узлы в порядке возрастания.

Обходы бинарных деревьев
Существует достаточно много алгоритмов работы с древовидными структурами, в которых часто встречается понятие обхода (traversing) дерева или "прохода" по дереву. При таком методе исследования дерева каждый узел посещается только один раз, а полный обход задает линейное упорядочивание узлов, что позволяет упростить алгоритм, так как при этом можно использовать понятие "следующий" узел. т.е. узел стоящий после данного при выбранном порядке обхода.

Улучшенные двоичные деревья

Очевидно, поиск осуществляется тем быстрее, чем ближе к корню расположен искомый элемент. В идеале двоичное дерево поиска сбалансировано, т. е. его форма такова, что каждый элемент располагается сравнительно близко к корню. Сбалансированное двоичное дерево поиска размера n имеет высоту O(log n), в предположении, что путь от корня до каждого узла имеет длину более, чем O(log n). Но совсем несбалансированное дерево поиска имеет высоту O(n); поиск в таком дереве так же неэффективен, как в связанном списке.

Сбалансированное двоичное дерево
Рис. 1: Сбалансированное двоичное дерево
Несбалансированное двоичное дерево
Рис. 2: Несбалансированное двоичное дерево

Причин, по которым дерево может стать плохо сбалансированным, несколько. Во-первых, во многих приложениях входной поток элементов не обязательно будет случайным (в крайнем случае элементы вводятся в возрастающем или убывающем порядке и получающееся дерево в большинстве случаев оказывается несбалансированным). Во-вторых, порядок операций поиска (перемежающихся с операциями ввода) может быть непредсказуем (поиск недавно введенных элементов может оказаться особенно дорогим, поскольку элемент может оказаться на самом нижнем уровне двоичного дерева). В третьих, ожидаемые свойства деревьев поиска, получившихся после выполнения операций удаления не всегда хорошо понятны.

В этом подразделе будут расмотрены различные вариации двоичных деревьев, позволяющие добиться более стабильной, а, значит, более быстрой работы.

Один из подходов заключается в балансировке дерева после каждой операции. Таким образом получаются строгие ограничения на высоту узла, и, как следствие, гарантированная оценка O(logn) для операций.

АВЛ-деревья z i p
При помощи вращений дерево балансируется таким образом, что высота узла не более, чем на 44% превышает минимальную возможную для двоичных деревьев.

Красно-черные деревья
Узлы раскрашиваются в два цвета, следуя правилам. Некоторые сочетания цветов объявляются неправильными и от них избавляются путем вращений. Высота узла не более, чем в 2 раза превышает минимальную возможную для двоичного дерева. С исходником на Си.

Несколько заметок.

  • Верхние оценки высот листов для АВЛ-деревьев и красно-черных деревьев разные, но на практике деревья сбалансированы примерно одинаково;
  • Красно-черные деревья при правильной реализации лучше, чем АВЛ-деревья. Дело в том, что вставка и удаление элемента можно осуществить за один проход по дереву: сверху вниз[подробнее читайте здесь zip]. В АВЛ-деревьях требуется сначала пройти вниз, произвести операцию, а потом сделать балансирующий проход обратно вверх;
  • Реализация АВЛ-деревьев и красно-черных деревьев может быть как рекурсивной, так и итеративной. Для АВЛ-деревьев рекурсивная реализация работает в 1.5-2 раза медленнее. Красно-черные деревья, ввиду возможности вставки/удаления за один проход, также имеют большое преимущество при итеративной реализации.

Другой подход заключается в рандомизации алгоритма, то есть введения датчика случайных чисел, от которого (а не от входной последовательности) и будет зависеть форма дерева. Таким образом, дерево получается 'случайным', с оценкой O(log n).

Деревья со случайным поиском
Каждому узлу сопоставляется приоритет - случайное число, доопределяющая место элемента дополнительно к самому ключу. Структура также обеспечивает быструю операцию нахождения большего/меньшего элемента. С исходником на С++.

Слоёные списки (скип-списки)
Вероятнастная альтернатива сбалансированным деревьям. Проста в реализации и почти так же эффективна, как деревья. Основана на сопоставлении словаря и записной книжки. Как правило, медленнее деревьев. С исходником на Си.

Другие словари

Хеш-таблицы
Лучший выбор, если не нужна сортировка информации, а только быстрый доступ к ней. Тратится дополнительная память.

Б, Б+ и Б++ деревья
Предназначены для индексации больших словарей на диске. Б-деревья читают несколько ключей при одном обращении к диску, минимизируя обращения, а значит, и связанные с этим большие задержки.

Несколько особняком стоят хэш-таблицы. Их поведение сильно зависит от коэффициента заполненности. Реальное ухудшение результатов при закрытом хэшировании появляется после заполнения таблицы на 80%. Асимптотически основные операции требуют O(1) в среднем и O(n) - в худшем случае. На практике хэш-таблицы работают гораздо быстрее, чем деревья, но при использовании хэш-таблиц сложно эффективно реализовать какие-либо другие операции, кроме основных.

Б-деревья и их вариации дают очень большой рост в скорости при работе с файлами.

Специализированные словари

Специализированные словари создают, чтобы быстро выполнять определенные для конкретного типа особые операции, иногда ценой замедления других, менее значимых функций.

StringBTree z i p
Комбинация Patricia и B-tree. Обладает рядом больших преимуществ и перед тем и перед другим. Подходит для хранения, поиска информации и индексации баз данных(строк) как на диске, так и в памяти.

Triangle Mesh z i p
Структура для хранения треугольников, позволяющая легко узнавать то, как соединяются ее элементы, а также эффективно вставлять и удалять треугольники. Есть реализация совмещения вершин с ее использованием.

Информацию об использовании различных структур данных в конкретных задачах можно найти также в разделе Олимпиадные задачи: структуры данных.

Дополнительные материалы:

Suffix Arrays: A New Method of on-line string searches z i p
Структура данных, занимающая в 3-5 раз меньше места, чем suffix tree, однако обеспечивающая почти такую же эффективность точного поиска подстроки в строке.

Перевод статьи HATs: Hashed Array Trees z i p
Эффективный и удобный способ реализации массивов переменной длины. Для языка вроде С++ очень даже неплохо.

Д. Кнут. Основные алгоритмы: 1-й том 'Искусства программирования на ЭВМ' z i p
Классическая монография, с обширной теоретической информацией о базовых структурах.


#include <stdio.h>
#include <stdlib.h>
#include <stdarg.h>
#include <string.h>

/*
 * this file is divided into sections:
 *   stuff you'll probably want to place in a .h file...
 *     implementation dependent
 *       - you'll probably have to change something here
 *     implementation independent
 *       - types and function prototypes that typically go in a .h file
 *     function prototypes
 *       - prototypes for user functions
 *   internals
 *     - local functions
 *     - user functions
 *   main()
 */

/****************************
 * implementation dependent *
 ****************************/
typedef long eAdrType;          /* record address for external record */
typedef long bAdrType;          /* record address for btree node */

#define CC_EQ           0
#define CC_GT           1
#define CC_LT          -1

/* compare two keys and return:
 *    CC_LT     key1 < key2
 *    CC_GT     key1 > key2
 *    CC_EQ     key1 = key2
 */
typedef int (*bCompType)(const void *key1, const void *key2);

/******************************
 * implementation independent *
 ******************************/

/* statistics */
int maxHeight;          /* maximum height attained */
int nNodesIns;          /* number of nodes inserted */
int nNodesDel;          /* number of nodes deleted */
int nKeysIns;           /* number of keys inserted */
int nKeysDel;           /* number of keys deleted */
int nDiskReads;         /* number of disk reads */
int nDiskWrites;        /* number of disk writes */

/* line number for last IO or memory error */
int bErrLineNo;

typedef enum {false, true} bool;
typedef enum {
    bErrOk,
    bErrKeyNotFound,
    bErrDupKeys,
    bErrSectorSize,
    bErrFileNotOpen,
    bErrFileExists,
    bErrIO,
    bErrMemory
} bErrType;

typedef void *bHandleType;

typedef struct {                /* info for bOpen() */
    char *iName;                /* name of index file */
    int keySize;                /* length, in bytes, of key */
    bool dupKeys;               /* true if duplicate keys allowed */
    int sectorSize;             /* size of sector on disk */
    bCompType comp;             /* pointer to compare function */
} bOpenType;

/***********************
 * function prototypes *
 ***********************/
bErrType bOpen(bOpenType info, bHandleType *handle);
    /*
     * input:
     *   info                   info for open
     * output:
     *   handle                 handle to btree, used in subsequent calls
     * returns:
     *   bErrOk                 open was successful
     *   bErrMemory             insufficient memory
     *   bErrSectorSize         sector size too small or not 0 mod 4
     *   bErrFileNotOpen        unable to open index file
     */

bErrType bClose(bHandleType handle);
    /*
     * input:
     *   handle                 handle returned by bOpen
     * returns:
     *   bErrOk                 file closed, resources deleted
     */

bErrType bInsertKey(bHandleType handle, void *key, eAdrType rec);
    /*
     * input:
     *   handle                 handle returned by bOpen
     *   key                    key to insert
     *   rec                    record address
     * returns:
     *   bErrOk                 operation successful
     *   bErrDupKeys            duplicate keys (and info.dupKeys = false)
     * notes:
     *   If dupKeys is false, then all records inserted must have a
     *   unique key.  If dupkeys is true, then duplicate keys are
     *   allowed, but they must all have unique record addresses.
     *   In this case, record addresses are included in internal
     *   nodes to generate a "unique" key.
     */

bErrType bDeleteKey(bHandleType handle, void *key, eAdrType *rec);
    /*
     * input:
     *   handle                 handle returned by bOpen
     *   key                    key to delete
     *   rec                    record address of key to delete
     * output:
     *   rec                    record address deleted
     * returns:
     *   bErrOk                 operation successful
     *   bErrKeyNotFound        key not found
     * notes:
     *   If dupKeys is false, all keys are unique, and rec is not used
     *   to determine which key to delete.  If dupKeys is true, then
     *   rec is used to determine which key to delete.
     */

bErrType bFindKey(bHandleType handle, void *key, eAdrType *rec);
    /*
     * input:
     *   handle                 handle returned by bOpen
     *   key                    key to find
     * output:
     *   rec                    record address
     * returns:
     *   bErrOk                 operation successful
     *   bErrKeyNotFound        key not found
     */

bErrType bFindFirstKey(bHandleType handle, void *key, eAdrType *rec);
    /*
     * input:
     *   handle                 handle returned by bOpen
     * output:
     *   key                    first key in sequential set
     *   rec                    record address
     * returns:
     *   bErrOk                 operation successful
     *   bErrKeyNotFound        key not found
     */

bErrType bFindLastKey(bHandleType handle, void *key, eAdrType *rec);
    /*
     * input:
     *   handle                 handle returned by bOpen
     * output:
     *   key                    last key in sequential set
     *   rec                    record address
     * returns:
     *   bErrOk                 operation successful
     *   bErrKeyNotFound        key not found
     */

bErrType bFindNextKey(bHandleType handle, void *key, eAdrType *rec);
    /*
     * input:
     *   handle                 handle returned by bOpen
     * output:
     *   key                    key found
     *   rec                    record address
     * returns:
     *   bErrOk                 operation successful
     *   bErrKeyNotFound        key not found
     */

bErrType bFindPrevKey(bHandleType handle, void *key, eAdrType *rec);
    /*
     * input:
     *   handle                 handle returned by bOpen
     * output:
     *   key                    key found
     *   rec                    record address
     * returns:
     *   bErrOk                 operation successful
     *   bErrKeyNotFound        key not found
     */

/*************
 * internals *
 *************/

/*
 *  algorithm:
 *    A B+tree implementation, with keys stored in internal nodes,
 *    and keys/record addresses stored in leaf nodes.  Each node is
 *    one sector in length, except the root node whose length is
 *    3 sectors.  When traversing the tree to insert a key, full
 *    children are adjusted to make room for possible new entries.
 *    Similarly, on deletion, half-full nodes are adjusted to allow for
 *    possible deleted entries.  Adjustments are first done by
 *    examining 2 nearest neighbors at the same level, and redistibuting
 *    the keys if possible.  If redistribution won't solve the problem,
 *    nodes are split/joined as needed.  Typically, a node is 3/4 full.
 *    On insertion, if 3 nodes are full, they are split into 4 nodes,
 *    each 3/4 full.  On deletion, if 3 nodes are 1/2 full, they are
 *    joined to create 2 nodes 3/4 full.
 *
 *    A LRR (least-recently-read) buffering scheme for nodes is used to
 *    simplify storage management, and, assuming some locality of reference,
 *    improve performance.
 *
 *    To simplify matters, both internal nodes and leafs contain the
 *    same fields.
 *
 */

/* macros for addressing fields */

/* primitives */
#define bAdr(p) *(bAdrType *)(p)
#define eAdr(p) *(eAdrType *)(p)

/* based on k = &[key,rec,childGE] */
#define childLT(k) bAdr((char *)k - sizeof(bAdrType))
#define key(k) (k)
#define rec(k) eAdr((char *)(k) + h->keySize)
#define childGE(k) bAdr((char *)(k) + h->keySize + sizeof(eAdrType))

/* based on b = &bufType */
#define leaf(b) b->p->leaf
#define ct(b) b->p->ct
#define next(b) b->p->next
#define prev(b) b->p->prev
#define fkey(b) &b->p->fkey
#define lkey(b) (fkey(b) + ks((ct(b) - 1)))
#define p(b) (char *)(b->p)

/* shortcuts */
#define ks(ct) ((ct) * h->ks)

typedef char keyType;           /* keys entries are treated as char arrays */

typedef struct {
    unsigned int leaf:1;        /* first bit = 1 if leaf */
    unsigned int ct:15;         /* count of keys present */
    bAdrType prev;              /* prev node in sequence (leaf) */
    bAdrType next;              /* next node in sequence (leaf) */
    bAdrType childLT;           /* child LT first key */
    /* ct occurrences of [key,rec,childGE] */
    keyType fkey;               /* first occurrence */
} nodeType;

typedef struct bufTypeTag {     /* location of node */
    struct bufTypeTag *next;    /* next */
    struct bufTypeTag *prev;    /* previous */
    bAdrType adr;               /* on disk */
    nodeType *p;                /* in memory */
    bool valid;                 /* true if buffer contents valid */
    bool modified;              /* true if buffer modified */
} bufType;

/* one node for each open handle */
typedef struct hNodeTag {
    struct hNodeTag *prev;      /* previous node */
    struct hNodeTag *next;      /* next node */
    FILE *fp;                   /* idx file */
    int keySize;                /* key length */
    bool dupKeys;               /* true if duplicate keys */
    int sectorSize;             /* block size for idx records */
    bCompType comp;             /* pointer to compare routine */
    bufType root;               /* root of b-tree, room for 3 sets */
    bufType bufList;            /* head of buf list */
    void *malloc1;              /* malloc'd resources */
    void *malloc2;              /* malloc'd resources */
    bufType gbuf;               /* gather buffer, room for 3 sets */
    bufType *curBuf;            /* current location */
    keyType *curKey;            /* current key in current node */
    unsigned int maxCt;         /* minimum # keys in node */
    int ks;                     /* sizeof key entry */
    bAdrType nextFreeAdr;       /* next free b-tree record address */
} hNode;

static hNode hList;             /* list of hNodes */
static hNode *h;                /* current hNode */

#define error(rc) lineError(__LINE__, rc)

static bErrType lineError(int lineno, bErrType rc) {
    if (rc == bErrIO || rc == bErrMemory)
        if (!bErrLineNo)
            bErrLineNo = lineno;
    return rc;
}

static bAdrType allocAdr(void) {
    bAdrType adr;
    adr = h->nextFreeAdr;
    h->nextFreeAdr += h->sectorSize;
    return adr;
}

static bErrType flush(bufType *buf) {
    int len;            /* number of bytes to write */

    /* flush buffer to disk */
    len = h->sectorSize;
    if (buf->adr == 0) len *= 3;        /* root */
    if (fseek(h->fp, buf->adr, SEEK_SET)) return error(bErrIO);
    if (fwrite(buf->p, len, 1, h->fp) != 1) return error(bErrIO);
    buf->modified = false;
    nDiskWrites++;
    return bErrOk;
}

static bErrType flushAll(void) {
    bErrType rc;                /* return code */
    bufType *buf;               /* buffer */

    if (h->root.modified)
        if ((rc = flush(&h->root)) != 0) return rc;

    buf = h->bufList.next;
    while (buf != &h->bufList) {
        if (buf->modified)
            if ((rc = flush(buf)) != 0) return rc;
        buf = buf->next;
    }
}

static bErrType assignBuf(bAdrType adr, bufType **b) {
    /* assign buf to adr */
    bufType *buf;               /* buffer */
    bErrType rc;                /* return code */

    if (adr == 0) {
        *b = &h->root;
        return bErrOk;
    }

    /* search for buf with matching adr */
    buf = h->bufList.next;
    while (buf->next != &h->bufList) {
        if (buf->valid && buf->adr == adr) break;
        buf = buf->next;
    }

    /* either buf points to a match, or it's last one in list (LRR) */
    if (buf->valid) {
        if (buf->adr != adr) {
            if (buf->modified) {
                if ((rc = flush(buf)) != 0) return rc;
            }
            buf->adr = adr;
            buf->valid = false;
        }
    } else {
        buf->adr = adr;
    }

    /* remove from current position and place at front of list */
    buf->next->prev = buf->prev;
    buf->prev->next = buf->next;
    buf->next = h->bufList.next;
    buf->prev = &h->bufList;
    buf->next->prev = buf;
    buf->prev->next = buf;
    *b = buf;
    return bErrOk;
}

static bErrType writeDisk(bufType *buf) {
    /* write buf to disk */
    buf->valid = true;
    buf->modified = true;
    return bErrOk;
}

static bErrType readDisk(bAdrType adr, bufType **b) {
    /* read data into buf */
    int len;
    bufType *buf;               /* buffer */
    bErrType rc;                /* return code */

    if ((rc = assignBuf(adr, &buf)) != 0) return rc;
    if (!buf->valid) {
        len = h->sectorSize;
        if (adr == 0) len *= 3;         /* root */
        if (fseek(h->fp, adr, SEEK_SET)) return error(bErrIO);
        if (fread(buf->p, len, 1, h->fp) != 1) return error(bErrIO);
        buf->modified = false;
        buf->valid = true;
        nDiskReads++;
    }
    *b = buf;
    return bErrOk;
}

typedef enum { MODE_FIRST, MODE_MATCH } modeEnum;

static int search(
    bufType *buf,
    void *key,
    eAdrType rec,
    keyType **mkey,
    modeEnum mode) {
    /*
     * input:
     *   p                      pointer to node
     *   key                    key to find
     *   rec                    record address (dupkey only)
     * output:
     *   k                      pointer to keyType info
     * returns:
     *   CC_EQ                  key = mkey
     *   CC_LT                  key < mkey
     *   CC_GT                  key > mkey
     */
    int cc;                     /* condition code */
    int m;                      /* midpoint of search */
    int lb;                     /* lower-bound of binary search */
    int ub;                     /* upper-bound of binary search */
    bool foundDup;              /* true if found a duplicate key */

    /* scan current node for key using binary search */
    foundDup = false;
    lb = 0;
    ub = ct(buf) - 1;
    while (lb <= ub) {
        m = (lb + ub) / 2;
        *mkey = fkey(buf) + ks(m);
        cc = h->comp(key, key(*mkey));
        if (cc < 0)
            /* key less than key[m] */
            ub = m - 1;
        else if (cc > 0)
            /* key greater than key[m] */
            lb = m + 1;
        else {
            /* keys match */
            if (h->dupKeys) {
                switch (mode) {
                case MODE_FIRST:
                    /* backtrack to first key */
                    ub = m - 1;
                    foundDup = true;
                    break;
                case MODE_MATCH:
                    /* rec's must also match */
                    if (rec < rec(*mkey)) {
                        ub = m - 1;
                        cc = CC_LT;
                    } else if (rec > rec(*mkey)) {
                        lb = m + 1;
                        cc = CC_GT;
                    } else {
                        return CC_EQ;
                    }
                    break;
                }
            } else {
                return cc;
            }
        }
    }
    if (ct(buf) == 0) {
        /* empty list */
        *mkey = fkey(buf);
        return CC_LT;
    }
    if (h->dupKeys && (mode == MODE_FIRST) && foundDup) {
        /* next key is first key in set of duplicates */
        *mkey += ks(1);
        return CC_EQ;
    }
    /* didn't find key */
    return cc;
}

static bErrType scatterRoot(void) {
    bufType *gbuf;
    bufType *root;

    /* scatter gbuf to root */

    root = &h->root;
    gbuf = &h->gbuf;
    memcpy(fkey(root), fkey(gbuf), ks(ct(gbuf)));
    childLT(fkey(root)) = childLT(fkey(gbuf));
    ct(root) = ct(gbuf);
    leaf(root) = leaf(gbuf);
    return bErrOk;
}

static bErrType scatter(bufType *pbuf, keyType *pkey, int is, bufType **tmp) {
    bufType *gbuf;              /* gather buf */
    keyType *gkey;              /* gather buf key */
    bErrType rc;                /* return code */
    int iu;                     /* number of tmp's used */
    int k0Min;                  /* min #keys that can be mapped to tmp[0] */
    int knMin;                  /* min #keys that can be mapped to tmp[1..3] */
    int k0Max;                  /* max #keys that can be mapped to tmp[0] */
    int knMax;                  /* max #keys that can be mapped to tmp[1..3] */
    int sw;                     /* shift width */
    int len;                    /* length of remainder of buf */
    int base;                   /* base count distributed to tmps */
    int extra;                  /* extra counts */
    int ct;
    int i;

    /*
     * input:
     *   pbuf                   parent buffer of gathered keys
     *   pkey                   where we insert a key if needed in parent
     *   is                     number of supplied tmps
     *   tmp                    array of tmp's to be used for scattering
     * output:
     *   tmp                    array of tmp's used for scattering
     */

    /* scatter gbuf to tmps, placing 3/4 max in each tmp */

    gbuf = &h->gbuf;
    gkey = fkey(gbuf);
    ct = ct(gbuf);

   /****************************************
    * determine number of tmps to use (iu) *
    ****************************************/
    iu = is;

    /* determine limits */
    if (leaf(gbuf)) {
        /* minus 1 to allow for insertion */
        k0Max= h->maxCt - 1;
        knMax= h->maxCt - 1;
        /* plus 1 to allow for deletion */
        k0Min= (h->maxCt / 2) + 1;
        knMin= (h->maxCt / 2) + 1;
    } else {
        /* can hold an extra gbuf key as it's translated to a LT pointer */
        k0Max = h->maxCt - 1;
        knMax = h->maxCt;
        k0Min = (h->maxCt / 2) + 1;
        knMin = ((h->maxCt+1) / 2) + 1;
    }

    /* calculate iu, number of tmps to use */
    while(1) {
        if (iu == 0 || ct > (k0Max + (iu-1)*knMax)) {
            /* add a buffer */
            if ((rc = assignBuf(allocAdr(), &tmp[iu])) != 0)
                return rc;
            /* update sequential links */
            if (leaf(gbuf)) {
                /* adjust sequential links */
                if (iu == 0) {
                    /* no tmps supplied when splitting root for first time */
                    prev(tmp[0]) = 0;
                    next(tmp[0]) = 0;
                } else {
                    prev(tmp[iu]) = tmp[iu-1]->adr;
                    next(tmp[iu]) = next(tmp[iu-1]);
                    next(tmp[iu-1]) = tmp[iu]->adr;
                }
            }
            iu++;
            nNodesIns++;
        } else if (iu > 1 && ct < (k0Min + (iu-1)*knMin)) {
            /* del a buffer */
            iu--;
            /* adjust sequential links */
            if (leaf(gbuf) && tmp[iu-1]->adr) {
                next(tmp[iu-1]) = next(tmp[iu]);
            }
            next(tmp[iu-1]) = next(tmp[iu]);
            nNodesDel++;
        } else {
            break;
        }
    }

    /* establish count for each tmp used */
    base = ct / iu;
    extra = ct % iu;
    for (i = 0; i < iu; i++) {
        int n;

        n = base;
        /* distribute extras, one at a time */
        /* don't do to 1st node, as it may be internal and can't hold it */
        if (i && extra) {
            n++;
            extra--;
        }
        ct(tmp[i]) = n;
    }

    /**************************************
     * update sequential links and parent *
     **************************************/
    if (iu != is) {
        /* link last node to next */
        if (leaf(gbuf) && next(tmp[iu-1])) {
            bufType *buf;
            if ((rc = readDisk(next(tmp[iu-1]), &buf)) != 0) return rc;
            prev(buf) = tmp[iu-1]->adr;
            if ((rc = writeDisk(buf)) != 0) return rc;
        }
        /* shift keys in parent */
        sw = ks(iu - is);
        if (sw < 0) {
            len = ks(ct(pbuf)) - (pkey - fkey(pbuf)) + sw;
            memmove(pkey, pkey - sw, len);
        } else {
            len = ks(ct(pbuf)) - (pkey - fkey(pbuf));
            memmove(pkey + sw, pkey, len);
        }
        /* don't count LT buffer for empty parent */
        if (ct(pbuf))
            ct(pbuf) += iu - is;
        else
            ct(pbuf) += iu - is - 1;
    }

   /*******************************
    * distribute keys to children *
    *******************************/
    for (i = 0; i < iu; i++) {

        /* update LT pointer and parent nodes */
        if (leaf(gbuf)) {
            /* update LT, tmp[i] */
            childLT(fkey(tmp[i])) = 0;

            /* update parent */
            if (i == 0) {
                childLT(pkey) = tmp[i]->adr;
            } else {
                memcpy(pkey, gkey, ks(1));
                childGE(pkey) = tmp[i]->adr;
                pkey += ks(1);
            }
        } else {
            if (i == 0) {
                /* update LT, tmp[0] */
                childLT(fkey(tmp[i])) = childLT(gkey);
                /* update LT, parent */
                childLT(pkey) = tmp[i]->adr;
            } else {
                /* update LT, tmp[i] */
                childLT(fkey(tmp[i])) = childGE(gkey);
                /* update parent key */
                memcpy(pkey, gkey, ks(1));
                childGE(pkey) = tmp[i]->adr;
                gkey += ks(1);
                pkey += ks(1);
                ct(tmp[i])--;
            }
        }

        /* install keys, tmp[i] */
        memcpy(fkey(tmp[i]), gkey, ks(ct(tmp[i])));
        leaf(tmp[i]) = leaf(gbuf);

        gkey += ks(ct(tmp[i]));
    }
    leaf(pbuf) = false;

   /************************
    * write modified nodes *
    ************************/
    if ((rc = writeDisk(pbuf)) != 0) return rc;
    for (i = 0; i < iu; i++)
        if ((rc = writeDisk(tmp[i])) != 0) return rc;

    return bErrOk;
}

static bErrType gatherRoot(void) {
    bufType *gbuf;
    bufType *root;

    /* gather root to gbuf */
    root = &h->root;
    gbuf = &h->gbuf;
    memcpy(p(gbuf), root->p, 3 * h->sectorSize);
    leaf(gbuf) = leaf(root);
    ct(root) = 0;
    return bErrOk;
}

static bErrType gather(bufType *pbuf, keyType **pkey, bufType **tmp) {
    bErrType rc;                /* return code */
    bufType *gbuf;
    keyType *gkey;

    /*
     * input:
     *   pbuf                   parent buffer
     *   pkey                   pointer to match key in parent
     * output:
     *   tmp                    buffers to use for scatter
     *   pkey                   pointer to match key in parent
     * returns:
     *   bErrOk                 operation successful
     * notes:
     *   Gather 3 buffers to gbuf.  Setup for subsequent scatter by
     *   doing the following:
     *     - setup tmp buffer array for scattered buffers
     *     - adjust pkey to point to first key of 3 buffers
     */

    /* find 3 adjacent buffers */
    if (*pkey == lkey(pbuf))
        *pkey -= ks(1);
    if ((rc = readDisk(childLT(*pkey), &tmp[0])) != 0) return rc;
    if ((rc = readDisk(childGE(*pkey), &tmp[1])) != 0) return rc;
    if ((rc = readDisk(childGE(*pkey + ks(1)), &tmp[2])) != 0) return rc;

    /* gather nodes to gbuf */
    gbuf = &h->gbuf;
    gkey = fkey(gbuf);

    /* tmp[0] */
    childLT(gkey) = childLT(fkey(tmp[0]));
    memcpy(gkey, fkey(tmp[0]), ks(ct(tmp[0])));
    gkey += ks(ct(tmp[0]));
    ct(gbuf) = ct(tmp[0]);

    /* tmp[1] */
    if (!leaf(tmp[1])) {
        memcpy(gkey, *pkey, ks(1));
        childGE(gkey) = childLT(fkey(tmp[1]));
        ct(gbuf)++;
        gkey += ks(1);
    }
    memcpy(gkey, fkey(tmp[1]), ks(ct(tmp[1])));
    gkey += ks(ct(tmp[1]));
    ct(gbuf) += ct(tmp[1]);

    /* tmp[2] */
    if (!leaf(tmp[2])) {
        memcpy(gkey, *pkey+ks(1), ks(1));
        childGE(gkey) = childLT(fkey(tmp[2]));
        ct(gbuf)++;
        gkey += ks(1);
    }
    memcpy(gkey, fkey(tmp[2]), ks(ct(tmp[2])));
    ct(gbuf) += ct(tmp[2]);

    leaf(gbuf) = leaf(tmp[0]);

    return bErrOk;
}

bErrType bOpen(bOpenType info, bHandleType *handle) {
    bErrType rc;                /* return code */
    int bufCt;                  /* number of tmp buffers */
    bufType *buf;               /* buffer */
    int maxCt;                  /* maximum number of keys in a node */
    bufType *root;
    int i;
    nodeType *p;

    if ((info.sectorSize < sizeof(hNode)) || (info.sectorSize % 4))
        return bErrSectorSize;

    /* determine sizes and offsets */
    /* leaf/n, prev, next, [childLT,key,rec]... childGE */
    /* ensure that there are at least 3 children/parent for gather/scatter */
    maxCt = info.sectorSize - (sizeof(nodeType) - sizeof(keyType));
    maxCt /= sizeof(bAdrType) + info.keySize + sizeof(eAdrType);
    if (maxCt < 6) return bErrSectorSize;

    /* copy parms to hNode */
    if ((h = malloc(sizeof(hNode))) == NULL) return error(bErrMemory);
    memset(h, 0, sizeof(hNode));
    h->keySize = info.keySize;
    h->dupKeys = info.dupKeys;
    h->sectorSize = info.sectorSize;
    h->comp = info.comp;

    /* childLT, key, rec */
    h->ks = sizeof(bAdrType) + h->keySize + sizeof(eAdrType);
    h->maxCt = maxCt;

    /* Allocate buflist.
     * During insert/delete, need simultaneous access to 7 buffers:
     *  - 4 adjacent child bufs
     *  - 1 parent buf
     *  - 1 next sequential link
     *  - 1 lastGE
     */
    bufCt = 7;
    if ((h->malloc1 = malloc(bufCt * sizeof(bufType))) == NULL)
        return error(bErrMemory);
    buf = h->malloc1;

    /*
     * Allocate bufs.
     * We need space for the following:
     *  - bufCt buffers, of size sectorSize
     *  - 1 buffer for root, of size 3*sectorSize
     *  - 1 buffer for gbuf, size 3*sectorsize + 2 extra keys
     *    to allow for LT pointers in last 2 nodes when gathering 3 full nodes
     */
    if ((h->malloc2 = malloc((bufCt+6) * h->sectorSize + 2 * h->ks)) == NULL)
        return error(bErrMemory);
    p = h->malloc2;

    /* initialize buflist */
    h->bufList.next = buf;
    h->bufList.prev = buf + (bufCt - 1);
    for (i = 0; i < bufCt; i++) {
        buf->next = buf + 1;
        buf->prev = buf - 1;
        buf->modified = false;
        buf->valid = false;
        buf->p = p;
        p = (nodeType *)((char *)p + h->sectorSize);
        buf++;
    }
    h->bufList.next->prev = &h->bufList;
    h->bufList.prev->next = &h->bufList;

    /* initialize root */
    root = &h->root;
    root->p = p;
    p = (nodeType *)((char *)p + 3*h->sectorSize);
    h->gbuf.p = p;      /* done last to include extra 2 keys */

    h->curBuf = NULL;
    h->curKey = NULL;

    /* initialize root */
    if ((h->fp = fopen(info.iName, "r+b")) != NULL) {
        /* open an existing database */
        if ((rc = readDisk(0, &root)) != 0) return rc;
        if (fseek(h->fp, 0, SEEK_END)) return error(bErrIO);
        if ((h->nextFreeAdr = ftell(h->fp)) == -1) return error(bErrIO);
    } else if ((h->fp = fopen(info.iName, "w+b")) != NULL) {
        /* initialize root */
        memset(root->p, 0, 3*h->sectorSize);
        leaf(root) = 1;
        h->nextFreeAdr = 3 * h->sectorSize;
    } else {
        /* something's wrong */
        free(h);
        return bErrFileNotOpen;
    }

    /* append node to hList */
    if (hList.next) {
        h->prev = hList.next;
        h->next = &hList;
        h->prev->next = h;
        h->next->prev = h;
    } else {
        /* first item in hList */
        h->prev = h->next = &hList;
        hList.next = hList.prev = h;
    }

    *handle = h;
    return bErrOk;
}

bErrType bClose(bHandleType handle) {
    h = handle;
    if (h == NULL) return bErrOk;

    /* remove from list */
    if (h->next) {
        h->next->prev = h->prev;
        h->prev->next = h->next;
    }

    /* flush idx */
    if (h->fp) {
        flushAll();
        fclose(h->fp);
    }

    if (h->malloc2) free(h->malloc2);
    if (h->malloc1) free(h->malloc1);
    free(h);
    return bErrOk;
}

bErrType bFindKey(bHandleType handle, void *key, eAdrType *rec) {
    keyType *mkey;              /* matched key */
    bufType *buf;               /* buffer */
    bErrType rc;                /* return code */

    h = handle;
    buf = &h->root;

    /* find key, and return address */
    while (1) {
        if (leaf(buf)) {
            if (search(buf, key, 0, &mkey, MODE_FIRST) == 0) {
                *rec = rec(mkey);
                h->curBuf = buf; h->curKey = mkey;
                return bErrOk;
            } else {
                return bErrKeyNotFound;
            }
        } else {
            if (search(buf, key, 0, &mkey, MODE_FIRST) < 0) {
                if ((rc = readDisk(childLT(mkey), &buf)) != 0) return rc;
            } else {
                if ((rc = readDisk(childGE(mkey), &buf)) != 0) return rc;
            }
        }
    }
}

bErrType bInsertKey(bHandleType handle, void *key, eAdrType rec) {
    int rc;                     /* return code */
    keyType *mkey;              /* match key */
    int len;                    /* length to shift */
    int cc;                     /* condition code */
    bufType *buf, *root;
    bufType *tmp[4];
    unsigned int keyOff;
    bool lastGEvalid;           /* true if GE branch taken */
    bool lastLTvalid;           /* true if LT branch taken after GE branch */
    bAdrType lastGE;            /* last childGE traversed */
    unsigned int lastGEkey;     /* last childGE key traversed */
    int height;                 /* height of tree */

    h = handle;
    root = &h->root;
    lastGEvalid = false;
    lastLTvalid = false;

    /* check for full root */
    if (ct(root) == 3 * h->maxCt) {
        /* gather root and scatter to 4 bufs */
        /* this increases b-tree height by 1 */
        if ((rc = gatherRoot()) != 0) return rc;
        if ((rc = scatter(root, fkey(root), 0, tmp)) != 0) return rc;
    }
    buf = root;
    height = 0;
    while(1) {
        if (leaf(buf)) {
            /* in leaf, and there' room guaranteed */

            if (height > maxHeight) maxHeight = height;

            /* set mkey to point to insertion point */
            switch(search(buf, key, rec, &mkey, MODE_MATCH)) {
            case CC_LT:  /* key < mkey */
                if (!h->dupKeys && h->comp(key, mkey) == CC_EQ)
                    return bErrDupKeys;
                break;
            case CC_EQ:  /* key = mkey */
                return bErrDupKeys;
                break;
            case CC_GT:  /* key > mkey */
                if (!h->dupKeys && h->comp(key, mkey) == CC_EQ)
                    return bErrDupKeys;
                mkey += ks(1);
                break;
            }

            /* shift items GE key to right */
            keyOff = mkey - fkey(buf);
            len = ks(ct(buf)) - keyOff;
            if (len) memmove(mkey + ks(1), mkey, len);

            /* insert new key */
            memcpy(key(mkey), key, h->keySize);
            rec(mkey) = rec;
            childGE(mkey) = 0;
            ct(buf)++;
            if ((rc = writeDisk(buf)) != 0) return rc;

            /* if new key is first key, then fixup lastGE key */
            if (!keyOff && lastLTvalid) {
                bufType *tbuf;
                keyType *tkey;
                if ((rc = readDisk(lastGE, &tbuf)) != 0) return rc;
                tkey = fkey(tbuf) + lastGEkey;
                memcpy(key(tkey), key, h->keySize);
                rec(tkey) = rec;
                if ((rc = writeDisk(tbuf)) != 0) return rc;
            }
            nKeysIns++;
            break;
        } else {
            /* internal node, descend to child */
            bufType *cbuf;      /* child buf */

            height++;

            /* read child */
            if ((cc = search(buf, key, rec, &mkey, MODE_MATCH)) < 0) {
                if ((rc = readDisk(childLT(mkey), &cbuf)) != 0) return rc;
            } else {
                if ((rc = readDisk(childGE(mkey), &cbuf)) != 0) return rc;
            }

            /* check for room in child */
            if (ct(cbuf) == h->maxCt) {

                /* gather 3 bufs and scatter */
                if ((rc = gather(buf, &mkey, tmp)) != 0) return rc;
                if ((rc = scatter(buf, mkey, 3, tmp)) != 0) return rc;

                /* read child */
                if ((cc = search(buf, key, rec, &mkey, MODE_MATCH)) < 0) {
                    if ((rc = readDisk(childLT(mkey), &cbuf)) != 0) return rc;
                } else {
                    if ((rc = readDisk(childGE(mkey), &cbuf)) != 0) return rc;
                }
            }
            if (cc >= 0 || mkey != fkey(buf)) {
                lastGEvalid = true;
                lastLTvalid = false;
                lastGE = buf->adr;
                lastGEkey = mkey - fkey(buf);
                if (cc < 0) lastGEkey -= ks(1);
            } else {
                if (lastGEvalid) lastLTvalid = true;
            }
            buf = cbuf;
        }
    }

    return bErrOk;
}

bErrType bDeleteKey(bHandleType handle, void *key, eAdrType *rec) {
    int rc;                     /* return code */
    keyType *mkey;              /* match key */
    int len;                    /* length to shift */
    int cc;                     /* condition code */
    bufType *buf;               /* buffer */
    bufType *tmp[4];
    unsigned int keyOff;
    bool lastGEvalid;           /* true if GE branch taken */
    bool lastLTvalid;           /* true if LT branch taken after GE branch */
    bAdrType lastGE;            /* last childGE traversed */
    unsigned int lastGEkey;     /* last childGE key traversed */
    bufType *root;
    bufType *gbuf;

    h = handle;
    root = &h->root;
    gbuf = &h->gbuf;
    lastGEvalid = false;
    lastLTvalid = false;

    buf = root;
    while(1) {
        if (leaf(buf)) {

            /* set mkey to point to deletion point */
            if (search(buf, key, *rec, &mkey, MODE_MATCH) == 0)
                *rec = rec(mkey);
            else
                return bErrKeyNotFound;

            /* shift items GT key to left */
            keyOff = mkey - fkey(buf);
            len = ks(ct(buf)-1) - keyOff;
            if (len) memmove(mkey, mkey + ks(1), len);
            ct(buf)--;
            if ((rc = writeDisk(buf)) != 0) return rc;

            /* if deleted key is first key, then fixup lastGE key */
            if (!keyOff && lastLTvalid) {
                bufType *tbuf;
                keyType *tkey;
                if ((rc = readDisk(lastGE, &tbuf)) != 0) return rc;
                tkey = fkey(tbuf) + lastGEkey;
                memcpy(key(tkey), mkey, h->keySize);
                rec(tkey) = rec(mkey);
                if ((rc = writeDisk(tbuf)) != 0) return rc;
            }
            nKeysDel++;
            break;
        } else {
            /* internal node, descend to child */
            bufType *cbuf;      /* child buf */

            /* read child */
            if ((cc = search(buf, key, *rec, &mkey, MODE_MATCH)) < 0) {
                if ((rc = readDisk(childLT(mkey), &cbuf)) != 0) return rc;
            } else {
                if ((rc = readDisk(childGE(mkey), &cbuf)) != 0) return rc;
            }

            /* check for room to delete */
            if (ct(cbuf) == h->maxCt/2) {

                /* gather 3 bufs and scatter */
                if ((rc = gather(buf, &mkey, tmp)) != 0) return rc;

                /* if last 3 bufs in root, and count is low enough... */
                if (buf == root
                && ct(root) == 2
                && ct(gbuf) < (3*(3*h->maxCt))/4) {
                    /* collapse tree by one level */
                    scatterRoot();
                    nNodesDel += 3;
                    continue;
                }

                if ((rc = scatter(buf, mkey, 3, tmp)) != 0) return rc;

                /* read child */
                if ((cc = search(buf, key, *rec, &mkey, MODE_MATCH)) < 0) {
                    if ((rc = readDisk(childLT(mkey), &cbuf)) != 0) return rc;
                } else {
                    if ((rc = readDisk(childGE(mkey), &cbuf)) != 0) return rc;
                }
            }
            if (cc >= 0 || mkey != fkey(buf)) {
                lastGEvalid = true;
                lastLTvalid = false;
                lastGE = buf->adr;
                lastGEkey = mkey - fkey(buf);
                if (cc < 0) lastGEkey -= ks(1);
            } else {
                if (lastGEvalid) lastLTvalid = true;
            }
            buf = cbuf;
        }
    }

    return bErrOk;
}

bErrType bFindFirstKey(bHandleType handle, void *key, eAdrType *rec) {
    bErrType rc;                /* return code */
    bufType *buf;               /* buffer */

    h = handle;
    buf = &h->root;
    while (!leaf(buf)) {
        if ((rc = readDisk(childLT(fkey(buf)), &buf)) != 0) return rc;
    }
    if (ct(buf) == 0) return bErrKeyNotFound;
    memcpy(key, key(fkey(buf)), h->keySize);
    *rec = rec(fkey(buf));
    h->curBuf = buf; h->curKey = fkey(buf);
    return bErrOk;
}

bErrType bFindLastKey(bHandleType handle, void *key, eAdrType *rec) {
    bErrType rc;                /* return code */
    bufType *buf;               /* buffer */

    h = handle;
    buf = &h->root;
    while (!leaf(buf)) {
        if ((rc = readDisk(childGE(lkey(buf)), &buf)) != 0) return rc;
    }
    if (ct(buf) == 0) return bErrKeyNotFound;
    memcpy(key, key(lkey(buf)), h->keySize);
    *rec = rec(lkey(buf));
    h->curBuf = buf; h->curKey = lkey(buf);
    return bErrOk;
}

bErrType bFindNextKey(bHandleType handle, void *key, eAdrType *rec) {
    bErrType rc;                /* return code */
    keyType *nkey;              /* next key */
    bufType *buf;               /* buffer */

    h = handle;
    if ((buf = h->curBuf) == NULL) return bErrKeyNotFound;
    if (h->curKey == lkey(buf)) {
        /* current key is last key in leaf node */
        if (next(buf)) {
            /* fetch next set */
            if ((rc = readDisk(next(buf), &buf)) != 0) return rc;
            nkey = fkey(buf);
        } else {
            /* no more sets */
            return bErrKeyNotFound;
        }
    } else {
        /* bump to next key */
        nkey = h->curKey + ks(1);
    }
    memcpy(key, key(nkey), h->keySize);
    *rec = rec(nkey);
    h->curBuf = buf; h->curKey = nkey;
    return bErrOk;
}

bErrType bFindPrevKey(bHandleType handle, void *key, eAdrType *rec) {
    bErrType rc;                /* return code */
    keyType *pkey;              /* previous key */
    keyType *fkey;              /* first key */
    bufType *buf;               /* buffer */

    h = handle;
    if ((buf = h->curBuf) == NULL) return bErrKeyNotFound;
    fkey = fkey(buf);
    if (h->curKey == fkey) {
        /* current key is first key in leaf node */
        if (prev(buf)) {
            /* fetch previous set */
            if ((rc = readDisk(prev(buf), &buf)) != 0) return rc;
            pkey = fkey(buf) + ks((ct(buf) - 1));
        } else {
            /* no more sets */
            return bErrKeyNotFound;
        }
    } else {
        /* bump to previous key */
        pkey = h->curKey - ks(1);
    }
    memcpy(key, key(pkey), h->keySize);
    *rec = rec(pkey);
    h->curBuf = buf; h->curKey = pkey;
    return bErrOk;
}

int comp(const void *key1, const void *key2) {
    unsigned int const *p1;
    unsigned int const *p2;
    p1 = key1; p2 = key2;
    return (*p1 == *p2) ? CC_EQ : (*p1 > *p2 ) ? CC_GT : CC_LT;
}

int main(void) {
    bOpenType info;
    bHandleType handle;
    bErrType rc;
    unsigned int key;

    remove("t1.dat");

    info.iName = "t1.dat";
    info.keySize = sizeof(int);
    info.dupKeys = false;
    info.sectorSize = 256;
    info.comp = comp;
    if ((rc = bOpen(info, &handle)) != bErrOk) {
        printf("line %d: rc = %d\n", __LINE__, rc);
        exit(0);
    }

    key = 0x11;
    if ((rc = bInsertKey(handle, &key, 0x300)) != bErrOk) {
        printf("line %d: rc = %d\n", __LINE__, rc);
        exit(0);
    }

    bClose(handle);

    printf("statistics:\n");
    printf("    maximum height: %8d\n", maxHeight);
    printf("    nodes inserted: %8d\n", nNodesIns);
    printf("    nodes deleted:  %8d\n", nNodesDel);
    printf("    keys inserted:  %8d\n", nKeysIns);
    printf("    keys deleted:   %8d\n", nKeysDel);
    printf("    disk reads:     %8d\n", nDiskReads);
    printf("    disk writes:    %8d\n", nDiskWrites);

    return 0;
}


/* hash table */

#include <stdio.h>
#include <stdlib.h>

/* modify these lines to establish data type */
typedef int T;                  /* type of item to be stored */
typedef int hashTableIndex;     /* index into hash table */
#define compEQ(a,b) (a == b)

typedef struct Node_ {
    struct Node_ *next;         /* next node */
    T data;                     /* data stored in node */
} Node;

Node **hashTable;
int hashTableSize;

hashTableIndex hash(T data) {

   /***********************************
    *  hash function applied to data  *
    ***********************************/

    return (data % hashTableSize);
}

Node *insertNode(T data) {
    Node *p, *p0;
    hashTableIndex bucket;

   /************************************************
    *  allocate node for data and insert in table  *
    ************************************************/

    /* insert node at beginning of list */
    bucket = hash(data);
    if ((p = malloc(sizeof(Node))) == 0) {
        fprintf (stderr, "out of memory (insertNode)\n");
        exit(1);
    }
    p0 = hashTable[bucket];
    hashTable[bucket] = p;
    p->next = p0;
    p->data = data;
    return p;
}

void deleteNode(T data) {
    Node *p0, *p;
    hashTableIndex bucket;

   /********************************************
    *  delete node containing data from table  *
    ********************************************/

    /* find node */
    p0 = 0;
    bucket = hash(data);
    p = hashTable[bucket];
    while (p && !compEQ(p->data, data)) {
        p0 = p;
        p = p->next;
    }
    if (!p) return;

    /* p designates node to delete, remove it from list */
    if (p0)
        /* not first node, p0 points to previous node */
        p0->next = p->next;
    else
        /* first node on chain */
        hashTable[bucket] = p->next;

    free (p);
}

Node *findNode (T data) {
    Node *p;

   /*******************************
    *  find node containing data  *
    *******************************/

    p = hashTable[hash(data)];
    while (p && !compEQ(p->data, data))
        p = p->next;
    return p;
}

int main(int argc, char **argv) {
    int i, *a, maxnum, random;

    /* command-line:
     *
     *   has maxnum hashTableSize [random]
     *
     *   has 2000 100
     *       processes 2000 records, tablesize=100, sequential numbers
     *   has 4000 200 r
     *       processes 4000 records, tablesize=200, random numbers
     *
     */
    maxnum = atoi(argv[1]);
    hashTableSize = atoi(argv[2]);
    random = argc > 3;

    if ((a = malloc(maxnum * sizeof(*a))) == 0) {
        fprintf (stderr, "out of memory (a)\n");
        exit(1);
    }

    if ((hashTable = malloc(hashTableSize * sizeof(Node *))) == 0) {
        fprintf (stderr, "out of memory (hashTable)\n");
        exit(1);
    }

    if (random) { /* random */
        /* fill "a" with unique random numbers */
        for (i = 0; i < maxnum; i++) a[i] = rand();
        printf ("ran ht, %d items, %d hashTable\n", maxnum, hashTableSize);
    } else {
        for (i=0; i<maxnum; i++) a[i] = i;
        printf ("seq ht, %d items, %d hashTable\n", maxnum, hashTableSize);
    }

    for (i = 0; i < maxnum; i++) {
        insertNode(a[i]);
    }

    for (i = maxnum-1; i >= 0; i--) {
        findNode(a[i]);
    }

    for (i = maxnum-1; i >= 0; i--) {
        deleteNode(a[i]);
    }
    return 0;
}


  function принадлежит (t: T): boolean;
  | var i: integer;
  begin
  | i := h (t);
  | while used [i] and (val [i] <> t) do begin
  | | i := (i + 1) mod n;
  | end; {not used [i] or (val [i] = t)}
  | belong := used [i] and (val [i] = t);
  end;

  procedure добавить (t: T);
  | var i: integer;
  begin
  | i := h (t);
  | while used [i] and (val [i] <> t) do begin
  | | i := (i + 1) mod n;
  | end; {not used [i] or (val [i] = t)}
  | if not used [i] then begin
  | | used [i] := true;
  | | val [i] := t;
  | end;
  end;

  procedure исключить (t: T);
  | var i, gap: integer;
  begin
  | i := h (t);
  | while used [i] and (val [i] <> t) do begin
  | | i := (i + 1) mod n;
  | end; {not used [i] or (val [i] = t)}
  | if used [i] and (val [i] = t) then begin
  | | used [i] := false;
  | | gap := i;
  | | i := (i + 1) mod n;
  | | while used [i] do begin
  | | | if i = h (val[i]) then begin
  | | | | i := (i + 1) mod n;
  | | | end else if dist(h(val[i]),i) < dist(gap,i) then begin
  | | | | i := (i + 1) mod n;
  | | | end else begin
  | | | | used [gap] := true;
  | | | | val [gap] := val [i];
  | | | | used [i] := false;
  | | | | gap := i;
  | | | | i := i + 1;
  | | | end;
  | | end;
  | end;
  end;

     Здесь  dist  (a, b) - измеренное по часовой стрелке (слева
направо) расстояние от a до b, т.е.

     dist (a,b) = (b - a + n) mod n.

(Мы прибавили n, так как функция mod правильно работает  только
при положительном делимом.)


Введение в абстрактные структуры

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Структуры данных » Введение в абстрактные структуры
Введение в абстрактные структуры

Абстрактные структуры данных предназначены для удобного хранения и доступа к информации. Они предоставляют удобный интерфейс для типичных операций с хранимыми объектами, скрывая детали реализации от пользователя. Конечно, это весьма удобно и позволяет добиться большей модульности программы. Абстрактные структуры данных иногда делят на две части: интерфейс, набор операций над объектами, который называют АТД(абстрактный тип данных) и реализацию. Ниже, где возможно, собственно АТД будут отделены от их реализации.

Каждый уже имел дело с простыми абстрактными структурами данных - например, когда оперировал с числами. Языки программирования высокого уровня(Паскаль, Си..) предоставляют удобный интерфейс для чисел: операции +, *, = .. и т.п, но при этом скрывают саму реализацию этих операций, машинные команды.

Статические структуры данных

Статические структуры относятся к разряду непримитивных структур, которые, фактически, представляют собой структурированное множество примитивных, базовых, структур. Например, вектор может быть представлен упорядоченным множеством чисел. Поскольку по определению статические структуры отличаются отсутствием изменчивости, память для них выделяется один раз и ее объем остается неизменным до уничтожения структуры. Слово 'статический' относится скорее к реализации структуры, нежели к АТД.

Простейшая статическая структура данных - массив, где обращение к элементу происходит через его номер.

Слово 'массив' употребляется в различных контекстах:

как АТД, т.е множество с операциями:

  • Получить элемент с номером N
  • Записать элемент с номером N

и как физическая структура, реализованая в виде непрерывной области памяти.

В случае реализации массива через такую структуру(языки Паскаль, Си) номер соответствует смещению от начала области. В некоторых языках, например, PHP, массив(здесь АТД!) реализован по-другому.

Плюсов у массива(здесь реализация) всего два, но зато больших:
  • доступ за константное время к любому элементу
  • память тратится только на данные*
* - здесь и далее будут опущены константные затраты памяти операционной системой, возникающие при реализации структуры. В частности, в большинстве ОС, при динамическом выделении памяти под массив, в начале соответствующей области памяти ставится специальная метка.

Минус - один, но тоже большой: статичность, неизменность структуры. Одномерный массив иногда называют вектором.

Динамические структуры данных

Динамические структуры по определению характеризуются отсутствием физической смежности элементов структуры в памяти непостоянством и непредсказуемостью размера (числа элементов) структуры в процессе ее обработки.

Поскольку элементы динамической структуры располагаются по непредсказуемым адресам памяти, адрес элемента такой структуры не может быть вычислен из адреса начального или предыдущего элемента. Для установления связи между элементами динамической структуры используются указатели, через которые устанавливаются явные связи между элементами. Такое представление данных в памяти называется связным. Элемент динамической структуры состоит из двух полей:

  • информационного поля или поля данных, в котором содержатся те данные, ради которых и создается структура; в общем случае информационное поле само является интегрированной структурой - вектором, массивом, другой динамической структурой и т.п.;
  • поле связок, в котором содержатся один или несколько указателей, связывающий данный элемент с другими элементами структуры;

Когда связное представление данных используется для решения прикладной задачи, для конечного пользователя "видимым" делается только содержимое информационного поля, а поле связок используется только программистом-разработчиком.

Достоинства связного представления данных - в возможности обеспечения значительной изменчивости структур;

  • размер структуры ограничивается только доступным объемом машинной памяти;
  • при изменении логической последовательности элементов структуры требуется не перемещение данных в памяти, а только коррекция указателей;
  • большая гибкость структуры.

Вместе с тем связное представление не лишено и недостатков, основные из которых:

  • на поля связок расходуется дополнительная память;
  • доступ к элементам связной структуры может быть менее эффективным по времени.

Последний недостаток является наиболее серьезным и именно им ограничивается применимость связного представления данных. Если в смежном представлении данных для вычисления адреса любого элемента нам во всех случаях достаточно было номера элемента и информации, содержащейся в дескрипторе структуры, то для связного представления адрес элемента не может быть вычислен из исходных данных. Дескриптор связной структуры содержит один или несколько указателей, позволяющих войти в структуру, далее поиск требуемого элемента выполняется следованием по цепочке указателей от элемента к элементу. Поэтому связное представление практически никогда не применяется в задачах, где логическая структура данных имеет вид вектора или массива - с доступом по номеру элемента, но часто применяется в задачах, где логическая структура требует другой исходной информации доступа (таблицы, списки, деревья и т.д.).

Cписки

Списком называется упорядоченное множество, состоящее из переменного числа элементов, к которым применимы операции включения, исключения. Список, отражающий отношения соседства между элементами, называется линейным. Длина списка равна числу элементов, содержащихся в списке, список нулевой длины называется пустым списком. Линейные связные списки являются простейшими динамическими структурами данных.

Графически связи в списках удобно изображать с помощью стрелок. Если компонента не связана ни с какой другой, то в поле указателя записывают значение, не указывающее ни на какой элемент. Такая ссылка обозначается специальным именем - nil.

На рис. 1 приведена структура односвязного списка. На нем поле INF - информационное поле, данные, NEXT - указатель на следующий элемент списка. Каждый список должен иметь особый элемент, называемый указателем начала списка или головой списка, который обычно по формату отличен от остальных элементов. В поле указателя последнего элемента списка находится специальный признак nil, свидетельствующий о конце списка.

Представление односвязного списка в памяти
Рис. 1: Представление односвязного списка в памяти

Двусвязный список характеризуется наличием пары указателей в каждом элементе: на предыдущий элемент и на следующий:

Представление двусвязного списка в памяти
Рис. 2: Представление двусвязного списка в памяти

Очевидный плюс тут в том, что от данного элемента структуры мы можем пойти в обе стороны. Таким образом упрощаются многие операции. Однако на указатели тратится дополнительная память.

[Реализация односвязного и двусвязного списков]

Разновидностью рассмотренных видов линейных списков является кольцевой список, который может быть организован на основе как односвязного, так и двухсвязного списков. При этом в односвязном списке указатель последнего элемента должен указывать на первый элемент; в двухсвязном списке в первом и последнем элементах соответствующие указатели переопределяются, как показано на рис.3.

При работе с такими списками несколько упрощаются некоторые процедуры. Однако, при просмотре такого списка следует принять некоторых мер предосторожности, чтобы не попасть в бесконечный цикл.

Структура кольцевого двухсвязного списка
Рис. 3: Структура кольцевого двухсвязного списка
[Реализация кольцевого двухсвязного списка]

Описываемые ниже АТД могут быть организованы на базе

  1. массива: выделяется место под N элементов разом, а затем описываются операции над данным типом данных в терминах операций над элементами массива.
  2. списка: память выделяется и освобождается по мере необходимости.
Первый вариант быстрее, но лишь второй истинно динамический. Соответственно, в различных приложениях может быть предпочтителен первый(размер структуры известен и небольшой) или второй(размер заранее неизвестен). Мы будем рассматривать преимущественно динамические решения.

Cтек

Стек - такой последовательный список с переменной длиной, включение и исключение элементов из которого выполняются только с одной стороны списка, называемого вершиной стека. Применяются и другие названия стека - магазин и очередь, функционирующая по принципу LIFO (Last - In - First- Out - "последним пришел - первым исключается"). Примеры стека: винтовочный патронный магазин, тупиковый железнодорожный разъезд для сортировки вагонов.

Основные операции над стеком - включение нового элемента (английское название push - заталкивать) и исключение элемента из стека (англ. pop - выскакивать).

Полезными могут быть также вспомогательные операции:

  • определение текущего числа элементов в стеке;
  • очистка стека;
  • неразрушающее чтение элемента из вершины стека, которое может быть реализовано, как комбинация основных операций:

 x:=pop(stack);  push(stack,x);

Некоторые авторы рассматривают также операции включения/исключения элементов для середины стека, однако структура, для которой возможны такие операции, не соответствует стеку по определению.

Для наглядности рассмотрим небольшой пример, демонстрирующий принцип включения элементов в стек и исключения элементов из стека. На рис. 4 (а,б,с) изображены состояния стека:

  • а). пустого;
  • б-г). после последовательного включения в него элементов с именами 'A', 'B', 'C';
  • д, е). после последовательного удаления из стека элементов 'C' и 'B';
  • ж). после включения в стек элемента 'D'.

Включение и исключение элементов из стека
Рис. 4: Включение и исключение элементов из стека

Как видно из рис. С.1, стек можно представить, например, в виде стопки книг (элементов), лежащей на столе. Присвоим каждой книге свое название, например A,B,C,D... Тогда в момент времени, когда на столе книг нет, про стек аналогично можно сказать, что он пуст, т.е. не содержит ни одного элемента. Если же мы начнем последовательно класть книги одну на другую, то получим стопку книг (допустим, из n книг), или получим стек, в котором содержится n элементов, причем вершиной его будет являться элемент n+1. Удаление элементов из стека осуществляется аналогичным образом т. е. удаляется последовательно по одному элементу, начиная с вершины, или по одной книге из стопки.

[Статическая реализация стека на основе массива]
[Динамическая реализация стека на основе односвязного списка]
[Реализация стека на основе ранее рассмотренного кольцевого списка]

[Использование стека: развертка рекурсии]

Очередь FIFO

Очередью FIFO (First - In - First- Out - "первым пришел - первым исключается"). называется такой последовательный список с переменной длиной, в котором включение элементов выполняется только с одной стороны списка (эту сторону часто называют концом или хвостом очереди), а исключение - с другой стороны (называемой началом или головой очереди). Те самые очереди к прилавкам и к кассам, которые мы так не любим, являются типичным бытовым примером очереди FIFO.

Основные операции над очередью - те же, что и над стеком - включение, исключение, определение размера, очистка, неразрушающее чтение.

[Статическая реализация очереди на основе массива]
Динамическая реализация очереди аналогична реализации стека.

Дек

Дек - особый вид очереди. Дек (от англ. deq - double ended queue,т.е очередь с двумя концами) - это такой последовательный список, в котором как включение, так и исключение элементов может осуществляться с любого из двух концов списка. Частный случай дека - дек с ограниченным входом и дек с ограниченным выходом. Логическая и физическая структуры дека аналогичны логической и физической структуре кольцевой FIFO-очереди. Однако, применительно к деку целесообразно говорить не о начале и конце, а о левом и правом конце.

Операции над деком:

  • включение элемента справа;
  • включение элемента слева;
  • исключение элемента справа;
  • исключение элемента слева;
  • определение размера;
  • очистка.

Физическая структура дека в статической памяти идентична структуре кольцевой очереди. Динамическая реализация является очевидным объединением стека и очереди.

Задачи, требующие структуры дека, встречаются в вычислительной технике и программировании гораздо реже, чем задачи, реализуемые на структуре стека или очереди. Как правило, вся организация дека выполняется программистом без каких-либо специальных средств системной поддержки.

Примером дека может быть, например, некий терминал, в который вводятся команды, каждая из которых выполняется какое-то время. Если ввести следующую команду, не дождавшись, пока закончится выполнение предыдущей, то она встанет в очередь и начнет выполняться, как только освободится терминал. Это FIFO очередь. Если же дополнительно ввести операцию отмены последней введенной команды, то получается дек.


Игры, и все с ними связанное

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Игры
Игры, и все с ними связанное

Генерация лабиринтов
Стандартный и простой алгоритм.

Путь в двумерном лабиринте - волновой алгоритм
Довольно простой и часто применяющихся в пошаговых играх и статических лабиринтах метод.

Крестики-нолики (пять в pяд). Оценочная функция.
Сyть оценочной фyнкции - оценить насколько выгодно нам поставить в даннyю точкy свою фишкy.

Анализ альфа-бета отсечений
При поиске хода в таких играх, как шахматы, приходится производить просмотр большого дерева возможных продолжений Чтобы ускорить этот процесс и не потерять информацию, обычно используют метод, называемый альфа-бета отсечениями (метод граней и оценок).

Описание программы, играющей в калах
Иллюстрация метода альфа-бета отсечений на примере известной игры.

Растровая визуализация в изометрической проекции
Псевдотрехмерные игры. Создание трехмерных объектов и пространств из спрайтов На текущий момент этот метод несколько устарел.

Перевод статьи Smart Moves: Intelligent Pathfinding
Перевод статьи о поиске пути из одной точки в другую.

Дополнительные материалы:

Maze Classification z i p
Виды лабиринтов и алгоритмы генерации. Великолепная статья. Не слишком много, однако конкретно и по делу.

Разные переводы, посвященные игровым алгоритмам z i p
Прилично всего. Переводы рассматривают, в основном, real-time стратегии.

Алгоритм D* нахождения путей z i p
Эта статья представляет новый алгоритм, D*, способный к планированию путей в неизвестном, частично известном, и в измененяющемся окружении эффективным, оптимальным, и полным способом.


Растровая визуализация в изометрической проекции

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Игры » Изометрическая проекция
Растровая визуализация в изометрической проекции

Владимиp В. Федоpов

Далее в тексте будет идти pечь о изометpической пpоекции, пpи котоpой пpоекции осей X' и Y' на плоскость экpана обpазуют с веpтикальной осью экpана Y угол +-120 гpадусов, а ось Z' совпадает с осью Y экpана. Такая пpоекция известна под названием "2/3-2/3", и далее в тексте я так ее и буду называть, или даже еще коpоче - пpосто "2/3".

Во всех случаях пpедполагается модель игpового пpостpанства с пеpпендикуляpными осями X' и Y', лежащими в гоpизонтальной плоскости, и осью Z', напpавленной веpтикально ввеpх.

Аналогично, во всех случаях пpинята модель экpана с осью Y, напpавленной веpтикально вниз, и осью X, напpавленной слева напpаво (коpоче, по напpавлению увеличения адpеса пиксела).

Часто упоминаемый теpмин "Спpайт" подpазумевает под собой pастpовый битмап, обычно пpямоугольный, но в общем случае пpоизвольной фоpмы. В тексте, если фоpма спpайта мной специально не оговоpена - считайте, что он пpямоугольный.

Часть 1. Существенные особенности пpоекции '2/3-2/3'

Часть 2. Как пpактически постpоить пол?

Часть 3. Реализация обpатной модели экpана

Часть 4. Веpтикальные объекты в пpоекции '2/3'

Часть 5. Различные планы местности (пола)

Часть 6. Стpуктуpиpованный иеpаpхический план

Часть 7. Работа с камеpой в пpоекции '2/3'

Часть 8. Плавные скpоллинги и отсечения в пpоекции '2/3'


Графика и обработка изображений. Фракталы

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Графика
Графика и обработка изображений. Фракталы

Смежные разделы: Сжатие изображений, Вычислительная геометрия

 | Удаление скрытых линий и поверхностей Есть определенный набор трехмерных объектов, который требуется изобразить на двумерном экране При этом 'невидимые' линии и поверхности надо удалить из получившейся проекции Рассмотрены алгоритм Робертса, алгоритм удаления поверхностей с Z-буфером, построчный алгоритм с Z-буфером, алгоритм разбиения области Варнока, построчный алгоритм Уоткинса и алгоритм трассировки лучей.
 | Графические эффекты Линза, волны, огонь, туман и т.д..
 | Поиск ближайшего цвета в палитре Нахождение в RGB палитре цвета, максимально похожего /для глаза/ на данный.
 | Рисование простых графических объектов Генерация отрезка по алгоритму Брезенхейма, ЦДА и т.п, алгоритм Брезенхейма генерации окружности, рисование кривой Безье и так далее.
 | Заполнение многоугольника и заливка области Заполнение многоугольника, заданного коодринатами Заливка области, которая либо очерчена границей с кодом пиксела, отличающимся от кодов любых пикселов внутри области, либо закрашена пикселами с заданным кодом.
 | Перевод цветов из режима RGB в HSV
 | Квантизация - уменьшение цветов изображения Уменьшает количество цветов изображения, оставляя те, которые дают наименьшую потерю качества.
 | Фильтры и спецэффекты. Яркость и контраст Тиснение, сглаживание, акварелизация изображения и тому подобное. Яркость и контраст..
 | Отсечение отрезка Имеется 'окно' - некий многоугольник(особый случай - прямоугольник) и отрезок Нужно отсечь все, что вне окна Рассмотрены алгоритмы: Коэна-Сазерленда, FC-алгоритм, Лианга-Барски, Кируса-Бека.
 | Отсечение многоугольника Имеется 'окно' и многоугольник Нужно отсечь все, что вне окна Рассмотрены: алгоритм Сазерленда-Ходгмана, простой алгоритм отсечения многоугольника и алгоритм отсечения многоугольника Вейлера-Азертона.
 | 2D Бампмэппинг ( Bumpmapping ) Алгоритм выбора цвета в зависимости от освещенности пикселя, если источник света бесконечно близок к плоскости Исходник на Паскале.
 | Вpащение pастpовой каpтинки Дан исходник на Си и в комментариях расписан весь алгоритм.
 | demodesign 3D programming FAQ Нужен какой-то алгоритм для графики 3D, а его нет на страничке? Загляните сюда.
Фракталы
 | Введение во фракталы
 | Лист папоротника
 | Множество Мандельброта Заголовки говорят сами за себя. Просто, подробно и по делу.

Дополнительные материалы:

Кодирование изображений z i p
Обзор режимов цветокодирования и методов перехода от одного режима цветности к другому. Также рассказано об основных принципах сжатия изображений.

Цвет в Компьютерной Графике z i p
Очень много всего: от восприятия цвета человеком и различных режимов кодирования до формул и методов обработки цвета при использовании различных мониторов (гамма-коррекция и т.п.). Советую!.

Цифровая обработка изображений в информационных системах z i p
Рассмотрены следующие задачи обработки изображений: дискретизации и квантования, улучшения визуального качества путем поэлементного преобразования, подавления помех и восстановления, геометрического преобразования и привязки, фотограмметрии и стереовидения.

Подробно: двумерное и трехмерное отсечение z i p
Глава из книги Роджерса. Даны фундаментальные алгоритмы для различных случаев.

Модели освещения. Факторизация и трассировка лучей. z i p
Глава из книги Роджерса. Есть и математическая модель и псевдокод.


demo.design 3D programming FAQ. Содержание.

 К разделу 'Компьютерная Графика' сайта AlgoList.

СОДЕРЖАНИЕ

Текущий release - 2.На этой странице расположено зеркало, официальный сайт документа: http://www.enlight.ru/faq3d/. Автором является Андрей Аксенов.

1. Введение
1.1 Предположения и соглашения

2. Основы 3D графики
2.1. Задание объектов и сцен
2.2. Проецирование
2.3. Матричные преобразования
2.4. Рисование одноцветного треугольника
2.5. Работа с произвольной камерой

3. Удаление невидимых частей
3.1. Отсечение нелицевых граней
3.2. Алгоритм художника
3.3. Z-буфер
3.4. Порталы
3.5. Z-отсечение
3.6. Отсечение
3.6.1. Отсечение при растеризации
3.6.2. Алгоритм Сазерленда-Ходжмана
3.6.3. 3D-отсечение

4. Текстурирование
4.1. Точное
4.2. Аффинное
4.3. Перспективно-корректное
4.4. Параболическое
4.5. Билинейная фильтрация текстур
4.6. Мипмэппинг

5. Освещение
5.1. Модель освещения
5.2. Расчет нормали к объекту
5.3. Освещение по Ламберту
5.4. Освещение по Гуро
5.5. Освещение по Фонгу
5.6. Как совместить текстуру и освещение
5.6.1. 256-цветные режимы
5.6.2. 24/32-битные режимы
5.6.3. 15/16-битные режимы

6. Оптимизация
6.1. Приемы оптимизации для процессоров Intel Pentium
6.1.1. Спаривание целочисленных команд
6.1.2. Кэш-память
6.1.3. Разные трюки
6.2. Примеры внутренних циклов текстурирования
6.3. Использование инструкций MMX
6.4. Тайловые текстуры

7. Разное
7.1. Субпиксельная точность
7.2. Субтексельная точность
7.3. Поворот 3D вектора за шесть умножений
7.4. Алгоритм "бегущих кубиков" для полигонизации изоповерхностей
7.5. Формат 3DS-файла
7.6. Сплайны Кочанека-Бартельса
7.7. Кватернионы
7.8. Обратная трассировка лучей


Графические эффекты

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Графика » Эффекты
Графические эффекты

Линза
Изображение участка изображения 'под линзой' Есть исходники на Пасксале и Watcom C.

Скручивание
Еще один интересный эффект Есть исходник на Watcom C.

Волны и алгоритм их создания
Построение модели воды Исходник на Паскале.

Создание объемного тумана
Туман различного цвета и плотности.

Алгоритм пламени
Огонь, возможно из нескольких очагов Исходник на Пасе.

Real-time Object Morphing
Плавное превращение одной фигуры в другую.


Фильтры и спецэффекты. Яркость и контраст

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Графика » Фильтры и спецэффекты. Яркость и контраст
Фильтры и спецэффекты. Яркость и контраст

Общие принципы фильтрации

Размывание и увеличение резкости

Тиснение

Акварелизация

Сглаживание, замутнение, оконтуривание

Коррекция яркости и контраста


Рисование простых графических объектов

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Графика » Рисование
Рисование простых графических объектов

Рисование окружности
Алгоритм Брезенхейма описан полностью, алгоритм Минчера пока только в исходнике.

Генерация отрезка
Рассмотрено два алгоритма ЦДА(DDA) - цифрового дифференциального анализатора для генерации векторов, а также алгоритмы Брезенхейма: простой и модифицированный.

Рисование кривой Безье по 4 точкам


Квантизация - уменьшение цветов изображения

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Графика » Квантизация
Квантизация - уменьшение цветов изображения

Color Quantization Overview
Обзор и сравнение наиболее известных алгоритмов квантизации.

Local K-means Algorithm for Color Quantization z i p
Новый, мощный и быстрый алгоритм квантизации.


Математика

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика
Математика

Длинные числа и операции с ними
Подробное описание алгоритмов с исходниками на Си.

Дискретные преобразования Фурье,Хартли
Преобразования для комплексных и действительных векторов, пути повышения точности..

Теория чисел
Возведение в степень, определение простоты числа, разложение на множители, НОД и многое другое.

Вычислительная геометрия
Разные геометрические фигуры, многоугольники и операции с ними, проверка принадлежности и другие алгоритмы, связанные с геометрией и приложениями.

Графы. Поиск маршрутов
Граф - система точек и связывающих их линий-ребер Точками могут выступать, например, города, а ребрами - маршруты. Рассматриваются различные алгоритмы на графах.

Комбинаторика и переборные задачи
Ферзи, рюкзаки, последовательности, разложения в суммы и тому подобное. Общие методы.

Приближение функций
Интерполяция, аппроксимация и тому подобное.

Быстрое вычисление функций и констант
Алгоритмы для вычисления элементарных и неэлементарных функций, а также важных математических постоянных.

Генерация псевдослучайных последовательностей
Различные генераторы случайных чисел, их характеристики и применения. С исходниками.

Линейная алгебра
Решение линейных систем, вычисление собственных значений, и многое другое.

Математическая статистика(теория вероятности)
Распределения, их основные свойства, алгоритмы их получения, вычисление функции распределения и квантилей.

Нахождение корней функций и нелинейных систем уравнений
Стандартные квадратные, кубические уравнения, а также общие методы.

Разное
Нет выше ? Возможно, это здесь.

Дополнительные материалы:

Fast Machine Code for Modular Multiplication z i p
Cоздание ассемблерных программ, реализующих быстрое умножение по модулю. На правах исходника.


Комбинаторика и переборные задачи

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Комбинаторика и перебор
Комбинаторика и переборные задачи

Методы программрования: переборные алгоритмы
Описано, как создавать подобные программы. Доступно, и даны основные приемы..

Задача о рюкзаке z i p
Дано n целых ai>0 и целое S>0. Нужно найти подмножество ai, сумме которого равна S или показать, что такого нет.

Hапечатать все последовательности длины N из чисел 1,2..M

Подсчитать количество слов длины К из данных N букв, не содержащих данное подслово

Hапечатать все перестановки чисел 1..N

Сгенерировать все подмножества данного n-элементного множества {0,.., n-1}

Дана строка S и набор A слов А[1],.. , A[k]. Разбить строку S на слова набора всеми возможными способами

Перечислить все разбиения N на целые положительные слагаемые

Перечислить все различные представление числа N в виде всевозможных произведений (сумм) K натуральных чисел

У продавца и покупателя имеется неограниченное кол-во монет достоинством (1,2,5,10,20,50,100,200,500 к примеру). Покупатель купил товар на сумму n. Hужно найти минимальное кол-во монет, которые будут использованы при расплате. Деньги может давать как покупатель, так и продавец

Перечислить все расстановки 8-ми ферзей на шахматной доске, при которых они не бьют друг друга

A Story about the N-Queens Problem: From Exponential to (Almost) Constant Time
Перечислить все расстановки n ферзей на шахматной доске размера NxN, при которых никакие два не бьют друг друга. Намного более продвинутые методы, нежели в статье выше.

Обход доски шахматным конем
Нужно конем обойти всю шахматную доску NxN, побывав в каждой клетке всего лишь раз.

Ханойские башни

Информацию по решению конкретных задач этой области также можно найти в разделах
Олимпиадные задачи: переборные задачи
Олимпиадные задачи: рекуррентные соотношения и динамическое программирование

Дополнительные материалы:

В. Липский "Введение в комбинаторику" z i p
Алгоритмы комбинаторики, немного алгоритмов на графах и матроиды.


Быстрое вычисление функций и констант

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Быстрые вычисления
Быстрое вычисление функций и констант

Функции
 | Быстрое возведение в степень Логарифмический алгоритм возведения в степень. Применяется практически везде.
 | Тригонометрические функции Быстрое вычисление функций и аркфункций с нужной точностью.
 | Вычисление функции Эйлера Количество чисел, меньших N и взаимно простых с ним.
 | Вычисление факториала Точный алгоритм вычисления факториала и наметки к реализации.
 | Gamma function Эффективные методы вычисления аппроксимации факториала и гамма-функции.
 | Квадратный корень - метод Ньютона Разобрано применение метода Ньютона для квадратного корня. С исходником.
 | Вычисление квадратного корня из целого числа Целочисленное приближение к квадратному корню из целого числа.
 | Точное вычисление обратного числа, корня m-й степени Быстрые итеративные методы для корней и обратного числа.
Константы
 | Вычисление с нужной точностью числа Пи Вычисление с использованием ряда Грегори и формулы Гаусса.
 | Квадратный корень из 2 Вкусно, быстро, полезно. С исходником..
 | The Euler constant gamma Вычисление гамма - константы Эйлера.
 | The Apery's constant Вычисление константы Apery: дзета-функции от 3. Т.е бесконечной суммы 1/n, n=1,2....
 | Логарифм 2 Вычисление логарифма 2 разными способами.
 | Вычисление числа е - школьный метод
 | Вычисление с большой точностью числа е Классический метод с исходником, а также ряд продвинутых.
 | Вычисление N-го знака Способы быстрого вычисления N-го бита различных констант. С примерами..
 | Числа Фибоначчи за O(logn)
 | Binary splitting method Большинство рядов, используемых для вычисления констант, имеют время O(n2) Этот метод вкупе с FFT-умножением позволяет вычислять за O(n log(n)3) (или даже O(n log(n)2). С примерами.
 | Acceleration of the convergence of series Методы улучшения сходимости бесконечных серий с целью более быстрых и точных вычислений.

Ссылки на материалы о быстрых алгоритмах от Е.А. Карацубы

Быстрые алгоритмы и метод БВЕ

Метод Карацубы "Divide and conquer"

Ответы на часто задаваемые


Нахождение корней функций и нелинейных систем уравнений

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Корни функций и нелинейных систем
Нахождение корней функций и нелинейных систем уравнений

Решение квадратных уравнений
Рассмотрен стандартный метод и его улучшение, позволяющее обходить ошибки округления.

Решение кубических уравнений
Даны формулы для счета хоть вручную хоть на компе Может пригодиться на экзаменах.

Окружение и локализация корня функции
Выяснение интервала, на котором содержится корень нелинейной функции. Алгоритм поиска такого интервала и ограничения на его применение.

Newton's method and high order iterations
Подробно описываются 'методы Ньютона' решения линейного или простого уравнения f(x)=0 и их сходимость.


Генерация псевдослучайных последовательностей

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Псевдослучайные последовательности
Генерация псевдослучайных последовательностей

Статья предоставлена
(c) Nikitine Valeri F. 2000,
web: algorithm.narod.ru

'Грязные' генераторы:

Как правило, грязные генераторы (псевдо)случайных чисел используются тогда, когда в моделируемый процесс нужно внести некоторую стохастику (хаос), не слишком заботясь о точном соответствии свойств генерируемого распределения математически равномерному.

Кроме того, к грязным отнесены те генераторы, которые используют свойства представления чисел в конкретном компьютере для оптимального по быстродействия коду. При этом они могут иметь хорошее распределение.

Наиболее характерная черта грязных генераторов равномерного распределения - не слишком длинный период либо сильное отличие от математически равномерного распределения.

С другой стороны, время работы грязных генераторов может в быть в десять и более раз меньшим, чем время работы чистых, что также может сделать выбор в пользу первых.

Генератор случайных чисел, поставляемый с системой
Cтандартный генератор, не рекомендованный для серьезных приложений.

Генератор с малым кодом
Не очень хорошая последовательность, зато сверхмалый inline-код.

Самый быстрый генератор для 32-битового представления целых и действительных чисел
Его 'грязность' заключается в том, что он зависит от представления числа в компьютере. Работает почти везде.

'Чистые' генераторы:

Равномерное распределенние случайных чисел и независимость от конкретной машины.

Как плата, существенно меньшее быстродействие.

Минимальный генератор Парка-Миллера с перетасовкой и без
Очень хорошее поведение до 108.

Алгоритм Л'Экюера, комбинирующий две последовательности
Период генерируемой последовательности практически недостижим: длина оценивается по порядку как 1018.


Вычислительная геометрия

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия
Вычислительная геометрия

Системы координат
Введение в вычислительную геометрию. Системы координат.

Структуры геометрических данных, основные операции
Грамотная и безглючная реализация на С++ классов 'Точка', 'Многоугольник', 'Ребро/Линия' с подробными объяснениями и основными операциями.

Уравнения различных фигур и их составление по разным данным
Окружность по трем точкам, уравнение плоскости и т.п.

Построение выпуклой оболочки конечного множества точек
Среди множества произвольных точек выделяем образующие выпуклый многогранник, в котором лежат все остальные.

Нахождение пересечения и объединения геометрических объектов
Отрезки, прямые, окружности и т.п. Установка количества точек пересечения и их координат...

Принадлежит или не принадлежит?
Плоскости, многоугольнику, прямой....

Нахождение расстояния между различными объектами
Точкой, прямой, отрезком....

Работа с многоугольниками
Алгоритмы, не рассмотренные ранее и решающие специфические задачи с многоугольниками на плоскости в целом, а не с их точками/линиями.

Разное
Многие алгоритмы не так-то просто классифицировать. Поэтому они здесь.

Триангуляция Делоне

  • Пусть задано множество A точек на плоскости
  • Для каждой точки определена высота f(p)
  • Как наиболее естественно аппроксимировать высоты точек не из A ?

Такая задача возникает, например, при построении графиков функций, генерации сложных ландшафтов.

Возможное решение этой проблемы состоит в дискретизации: для всех точек не из A пусть f(p) равняется высоте ближайшей точки из A. Получится нечто вроде нарисованного ниже.

Выглядит довольно неестественно... Гораздо лучше воспользоваться триангуляцией данного набора точек, а потом поднять каждую точку на высоту, соответствующую ее положению в треугольнике.

Формальное определение триангуляции: планарный граф, получающийся при соединении точек A отрезками, такой, что нельзя добавить ни одного нового отрезка без нарушения планарности (т.е без пересечения отрезками друг друга). При этом граница триангуляции будет, очевидно, выпуклой оболочкой множества A.

Одно и то же множество можно триангулировать разными способами. Рассмотрим углы в получающихся треугольниках. Выберем минимальный угол. Триангуляция дает тем лучшую аппроксимацию, чем больше ее минимальный угол, при этом формируемые треугольники 'стремятся к равноугольности'. Особенно важна максимизация минимального угла в задачах вычислительной математики, когда точность производимых вычислений очень сильно зависит от размера минимального угла триангуляции графика. Наилучшей в этом смысле триангуляцией является триангуляция Делоне.

Простейшим способом ее построения является инкрементальный алгоритм, работающий за O(n2) операций. Реализация из соответствующей статьи не поддерживает вырожденные случаи, когда 4 точки из множества лежат на одной окружности: в этом случае триангуляция Делоне не уникальна, их несколько, но минимальные углы этих триангуляций равны.

Иногда даже минимальный угол триангуляции Делоне оказывается слишком малым для устойчивой работы использующего ее алгоритма. Тогда ее можно улучшить, используя метод Раперта. При этом будут добавлены новые вершины триангуляции и образованы дополнительные треугольники, но их количество невелико, а стабильность алгоритма (метода конечных элементов, например) может возрасти многократно за счет появления нижней границы для углов. Метод описан в оригинальной статье zip. Для его практической реализации также весьма интересны комментарии Максима Щербакова. Существуют и другие методы аналогичного улучшения триангуляции, но они дают худшие результаты.

Много различных алгоритмов построения триангуляции Делоне описываются и сравниваются в статье А. В. Скворцова zip.

Обычно рассматривают триангуляцию на плоскости, однако триангуляция Делоне аналогично определяется и для n-мерного пространства.

Диаграмма Вороного

Рассмотрим следующую задачу: есть почтовые службы pi, мы хотим знать, какую область плоскости обслуживает каждая. При этом каждую точку q обслуживает та служба, которая ближе. Ответ на этот и ряд других вопросов, связанных с близостью на плоскости, дает диаграмма Вороного.

Диаграмма Вороного изображена на рисунке выше. Она состоит из вершин(v) диаграммы и ее сторон(e). Формальное определение:

  • Пусть P - множество из n различных точек плоскости
  • Диаграмма Вороного - деление плоскости на n ячеек, по одной на каждую точку P
  • Точка q принадлежит ячейке, относящейся к pi из P, если расстояние от q до pi меньше, чем расстояние от q до любой другой точки P.

Можно провести очень интересную аналогию из области кристаллографии. Предположим, что точки представляются в виде зерен кристалла, которые растут с постоянной скоростью во всех направлениях. Предположим также, что рост зерен кристалла продолжается до тех пор, пока два или более зерен не встретятся. Через некоторое достаточное время каждое выросшее зерно будет представлено в виде ячейки диаграммы Вороного для своего ядра(вполне очевидно, что рост крайних неограниченных областей может продолжаться бесконечно). В результате будет получена диаграмма Вороного для множества P.

Весьма забавно представить более быстрый процесс роста в одном из направлений и при расположении ядер в фиксированных точках в пространстве. Полученная в результате диаграмма Вороного в трехмерном пространстве будет состоять из ограниченных и неограниченных полиэдральных областей.

Диаграмма Вороного аналогично определяется для n-мерного пространства. Алгоритм построения диаграммы Вороного описан в англоязычной статье.

Связь между диаграммой Вороного и триангуляцией Делоне

Эти две конструкции двойственны. То есть из одной можно просто получить другую. Вообще говоря, диаграмма Вороного уникальна для данного набора точек, а триангуляция Делоне - не всегда. Однако, если есть несколько триангуляций, то они эквивалентны в том смысле, что их минимальные углы равны.

Так что можно говорить об однозначном соответствии между диаграммой Вороного и триангуляциями Делоне. Посмотрим, например, как из диаграммы получается триангуляция.

  1. Если две точки pi и pj из P имеют общее ребро диаграммы(их ячейки смежные), провести дугу между pi и pj. Получится граф Делоне, обозначенный на первом рисунке буквой G
  2. Затем натягиваем дуги, превращая в отрезки.

Таким образом, триангуляция получается соединением всех смежных точек P отрезками. Единственная проблема: четыре или более точек в графе Делоне могут лежать на одной окружности.

Такие точки образуют выпуклые полигоны, которые триангулируются добавлением произвольных непересекающихся диагоналей. Тогда триангуляция будет окончательной. Можно сказать, что триангуляция Делоне получается из графа Делоне добавлением 0 или более ребер.

Связь выпуклой оболочки с триангуляцией Делоне и диаграммой Вороного

N-мерная триангуляция Делоне и диаграмма Вороного могут быть получены путем вычисления N+1-мерной выпуклой оболочки. Процесс довольно простой, но выходит за рамки общего раздела, а потому описан в отдельной статье. Там же описано и получение выпуклой оболочки на плоскости из диаграммы.

Информацию о решении конкретных задач можно также найти в разделе Олимпиадные задачи: геометрия.

Дополнительные материалы:

Препарата и Шаймос, "Вычислительная геометрия: введение"
Классический учебник во вычислительной геометрии. Несколько устаревшая, но по-прежнему актуальная книга.


Принадлежит или не принадлежит?

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия » Принадлежит или нет?..
Принадлежит или не принадлежит?

Проверка принадлежности точки многоугольнику

Проверка принадлежности точки прямой

Проверка принадлежности точки отрезку


Построение выпуклой оболочки конечного множества точек

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия » Выпуклая оболочка
Построение выпуклой оболочки конечного множества точек

Пусть задано некоторое множество точек на плоскости. Выпуклая оболочка - наименьший выпуклый многоугольник, содержащий данные точки.

Вообразим, что плоскость - это деревянная доска, утыканная гвоздями в каждой точке из данного множества. Теперь натянем вокруг гвоздей резиновое кольцо. Оно стянется и образует выпуклую оболочку, как показано на рисунке выше.

Выпуклые оболочки очень важны в ряде геометрических положений не только сами по себе, но и как части других алгоритмов, использующих построение выпуклой оболочки в качестве элементарной операции.

Асимптотика числа вершин выпуклой оболочки для n точек,

  • равномерно распределенных внутри единичного круга - Theta(n1/3)
  • равномерно распределенных внутри фиксированного выпуклого многоугольника - Theta(log n)
  • подчиненных двумерному нормальному распределению - Theta((log n)1/2)

Алгоритмы 2D

В оценках ниже n - количество точек, h - количество точек выпуклой оболочки.

Простой многоугольник - замкнутая ломаная без самопересечений.

  • Gift wrapping
    Простой алгоритм, время работы:
    • Лучший случай, все точки внутри оболочки: O(n)
    • Худший случай, все точки на оболочке: O(n2)
    • Среднее время: nh
  • Graham's scan
    Алгоритм состоит из двух частей: сначала точки сортируются по полярному углу - O(nlogn). Если взять точки в порядке возрастания полярного угла, то получается простой многоугольник. Выпуклую оболочку произвольного простого многоугольника за O(n) находит вторая часть алгоритма.
  • Алгоритм Мелькмана
    Находит выпуклую оболочку простого многоугольника за O(n) операций.
  • Quickhull
    Рекурсивный, простой алгоритм. Время работы:
    • Лучший случай, все точки внутри оболочки: O(n)
    • Худший случай, все точки на оболочке: O(n2)
    • Среднее время: O(nlogn)
    На случайном наборе точек этот алгоритм работает быстрее всех.
  • Разделяй-и-властвуй
    Вообще говоря, этот алгоритм медленнее, чем Quickhull. Но у него есть два важных преимущества:
    • Время работы всегда O(nlogn)
    • Легко распараллеливается: множество точек делится на N частей, выпуклые оболочки которых вычисляются независимо, а затем быстро сливаются.
    Существует две вариации алгоритма:

    В одной исходное множества точек разделяется на N частей, отсортированных по координате X: все точки из (k-1)-ой части левее точек из частей k..N. Этого можно достичь в процессе предобработки за O(nlogN) операций(нахождение середины: O(n)). А уже потом каждая часть вычисляется независимо(возможно, на своей машине/процессоре) и результаты объединяются.

    В другой - и именно она описана в статье, точки делятся на N любых равных частей. Никаких ограничений на части нет.

    Принципиальное отличие между этими вариациями в том, что в первом случае выпуклые оболочки разных частей никогда не пересекаются => используется более простой алгоритм слияния двух выпуклых оболочек в одну общую.

Наконец, заметим, что быстрее, чем за nlogn выпуклую оболочку произвольного множества точек построить нельзя, так как задача сводится к сортировке n произвольных чисел.

Выпуклая оболочка онлайн

Алгоритмы выше принимают на вход все множество точек сразу, обрабатывают его и возвращают результат. А что, если точки подаются одна за другой, а задача состоит в том, чтобы поддерживать выпуклую оболочку имеющихся точек? Самый простой выход - после каждой добавленной точки вызывать какой-нибудь из описанных выше алгоритмов. Он построит выпуклую оболочку за Omega(nlogn) операций. Это приведет к сложности Omega(n2logn). Если хочется сделать побыстрее и поизящнее, то можно применить модифицированный алгоритм, работающий за O(n2).

Алгоритм 3D

Алгоритм QuickHull может быть естественным образом обобщен на случай произвольной размерности.

Трехмерный случай подробно описан в англоязычной статье, а общий, произвольной размерности, в оригинальной работе Барбера zip


Нахождение расстояния между различными объектами

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия » Расстояние между...
Нахождение расстояния между различными объектами

Вычисление расстояния между точкой и прямой/лучом/отрезком

Вычисление расстояния от точки до плоскости


Уравнения различных фигур и их составление по разным данным

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия » Способы задания фигур
Уравнения различных фигур и их составление по разным данным

Уравнения плоскости

Окружность по трем точкам 2D

Сфера


Нахождение пересечения и объединения геометрических объектов

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия » Нахождение пересечения и объединения геометрических объектов
Нахождение пересечения и объединения геометрических объектов

На плоскости

Пересечение: Прямая(отрезок) и прямая (отрезок)

Пересечение: Две окружности

Пересечение: Два выпуклых многоугольника

Пересечение: Коллекция полуплоскостей

В пространстве

Пересечение: Три плоскости

Пересечение: Два треугольника

Пересечение: Прямая(или отрезок) и плоскость

Пересечение: Отрезок и треугольник


Разное

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия » Разное
Разное

Куда попадает перпендикуляр из точки: на отрезок или на его продолжение?

Найти прямую, имеющую общие точки с макс. числом заданных отрезков и напечатать в порядке возрастания номера отрезков, которые она пересекает

Дано множество, содеpжащее n точек. Постpоить описаннyю окpyжность минимального pадиyса

Найти порядок, в котором можно соединить N точек, чтобы получился N-угольник (те не было бы пересечений сторон)

Найти на прямой такую точку z, сумма расстояний от которой до заданных N точек минимальна

Даны точки A и B Определить, какой из отрезков, OA или OB, образует больший угол с осью OX

На плоскости расположены N точек. Найти на оси абсцисс точку, наибольшее из расстояний от которой до выбранных точек было бы минимальным

Построить окружность минимального радиуса с центром на оси абсцисс так, чтобы она содержала внутри себя и на своей границе все эти точки
( Это Переформулировка задачи выше ).


Работа с многоугольниками

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия » Многоугольники
Работа с многоугольниками

Большенство алгоритмов сформулировано для простых многоугольников. Простой многоугольник - замкнутая ломаная без самопересечений. Как следствие, в простом многоугольнике нет 'дыр'.

Площадь
Стандартная формула и ее обоснование.

Центр тяжести
Несколько интерпретаций понятия 'центр тяжести' и алгоритмы его нахождения.

Нахождение ориентации простого многоугольника
Многоугольник задан списком вершин по мере обхода.. По часовой стрелке или против ?..

Определение: выпуклый многоугольник или нет
На входе произвольный простой многоугольник.

Триангуляция

Триангуляцией полигона называется декомпозиция полигона в набор треугольников. Триангуляция часто используется для упрощения решения задачи в пределах области со сложной конфигурацией, и сведения ее к более простой задаче в пределах треугольника, поскольку треугольник относится к простейшей области и в этом случае задачу можно решить гораздо проще. Например, для определения, лежит ли точка внутри невыпуклого полигона, можно осуществить триангуляцию полигона и ответить "да" только в том случае, если точка принадлежит по крайней мере хотя бы одному треугольнику. Или при анализе сложных поверхностей, расположенных в пространстве, можно эти поверхности аппроксимировать сеткой треугольников, проанализировать которые значительно легче.

Пожалуй, самым простым алгоритмом триангуляции является метод Разделяй-и-властвуй. Требуется O(nlogn) операций в среднем и O(n2) - в худшем случае. Многоугольник рекурсивно делится на части путем проведения хорды вплоть до треугольников.

Более сложные и эффективные алгоритмы(простейшие из таковых) используют понятие монотонных полигонов. Общая стратегия триангуляции состоит из двух этапов:

  1. Декомпозиция полигона на монотонные части.
  2. Триангуляция монотонных частей за общее время О(n).

Быстрее, чем за O(n) триангуляцию осуществить нельзя, поэтому общее время задается первой частью алгоритма.

Довольно старый, но весьма эффективный подход заключается в декомпозиции на монотонные полигоны методом сканирующей линии.

Недавно появился гораздо более эффективный алгоритм Зейделя, простой и работающий за почти линейное время. Существует его реализация, написанная Narkhede и Manocha. В их коде есть и общая функция триангуляции, делающая второй шаг алгоритма. Кроме того (!) их код поддерживает полигоны с дырами, чего не скажешь о методах выше. Также доступна оригинальная статья Зейделя.


Препарата и Шаймос, "Вычислительная геометрия: введение"

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Геометрия » Препарата и Шаймос, "Вычислительная геометрия: введение"
Препарата и Шаймос, "Вычислительная геометрия: введение"

Глава 1. ВВЕДЕНИЕ zip
1.1. Исторический обзор
1.2. Алгоритмические основы
1.3. Геометрические предпосылки
1.4. Модели вычислений
Глава 2. ГЕОМЕТРИЧЕСКИЙ ПОИСК zip
2.1. Введение в геометрический поиск
2.2. Задачи локализации точки
2.3. Задачи регионального поиска
2.4. Замечания и комментарии
2.5. Упражнения
Глава 3. ВЫПУКЛЫЕ ОБОЛОЧКИ: ОСНОВНЫЕ АЛГОРИТМЫ(здесь же глава 4) zip
3.1. Предварительные сведения
3.2. Постановка задачи и нижние оценки сложности
3.3. Алгоритм построения выпуклой оболочки на плоскости
3.4. Выпуклые оболочки в пространствах размерности большей двух
3.5. Замечания и комментарии
3.6. Упражнения
Глава 4. ВЫПУКЛЫЕ ОБОЛОЧКИ: РАСШИРЕНИЯ И ПРИЛОЖЕНИЯ
4.1. Расширения и варианты
4.2. Приложения в статистике
4.3. Замечания и комментарии
4.4. Упражнения
Глава 5. БЛИЗОСТЬ: ОСНОВНЫЕ АЛГОРИТМЫ zip
5.1. Набор задач
5.2. Задача о единственности элементов
5.3. Нижние оценки
5.4. Решение задачи о ближайшей паре методом "разделяй и властвуй"
5.5. Решение задач о близости методом локусов; диаграмма Вороного
5.6. Решение задач о близости с помощью диаграммы Вороного
5.7. Замечания и комментарии
5.8. Упражнения
Глава 6. БЛИЗОСТЬ: ВАРИАНТЫ И ОБОБЩЕНИЯ zip
6.1. Евклидовы минимальные остовные деревья
6.2. Планарные триангуляции
6.3. Обобщения диаграммы Вороного
6.4. Промежутки и покрытия
6.5. Замечания и комментарии
6.6. Упражнения
Глава 7. ПЕРЕСЕЧЕНИЯ zip
7.1. Примеры из приложений
7.2. Плоские приложения
7.3. Трехмерные приложения
7.4. Замечания и комментарии
7.5. Упражнения
Глава 8. ГЕОМЕТРИЯ ПРЯМОУГОЛЬНИКОВ zip
8.1. Некоторые приложения геометрии прямоугольников
8.2. Область применения результатов
8.3. Общие замечания по алгоритмам статического типа
8.4. Мера и периметр объединения прямоугольников
8.5. Контур объединения прямоугольников
8.6. Замыкание объединения прямоугольников
8.7. Внешний контур объединения прямоугольников
8.8. Пересечения прямоугольников и связанные с этим задачи
8.9. Замечания и комментарии
8.10. Упражнения
Литература, именной указатель, предметный указатель zip


Графы. Поиск маршрутов

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Графы и маршруты
Графы. Поиск маршрутов

Задача о кратчайших путях
Рассмотрены различные варианты задачи нахождения кратчайших путей, в том числе - различных условиях на данные.

Поиск на графе и его обход
Стандартные алгоритмы обхода/поиска вширь и вглубь Пример использования.

Нахождение на графе минимального остовного дерева
Остовное дерево связного графа - наименьший связный подграф без циклов, содержащий все вершины данного (лишние ребра убираются) Находим дерево с наименьшей суммой стоимостей ребер.

Проверка связности графа с ненаправленными ребрами. Выделение связной компоненты графа
Связная компонента - часть графа, в которую можно добраться из некой точки, проходя по ребрам в любую сторону.

Нахождение максимального пропускного потока
Ребрам двунаправленного графа приписаны пропускные способности Потоком называется совокупность путей из 'истока' к 'стоку', где каждому пути приписана величина - сколько груза перемещается (при этом суммарное кол-во груза не должно превышать пропускной способности ребра).

Алгоритмы нахождения максимального потока
Сборник различных алгоритмов решения этой задачи, собранный Александром Труфановым..

Информацию о решении интересных задач можно также найти в разделе Олимпиадные задачи: задачи на графах.

Дополнительные материалы:

Graphs: Weiss, Chapter 9 z i p
Очень хорошая статья про графы, их реализации и различные алгоритмы на графах. Есть достаточно много интересных методов, дается их оценка. Исходники на Си++.


Алгоритмы нахождения максимального потока

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Графы и маршруты » Алгоритмы нахождения максимального потока
Алгоритмы нахождения максимального потока

Введение

 Основные определения

Сводимость задач

Алгоритм Форда-Фалкерсона

Алгоритм Эдмондса-Карпа, кратчайших увеличивающих цепей

Алгоритм Эдмондса-Карпа, локально-максимального увеличения

Алгоритм Диница

Алгоритм Карзанова

Алгоритм Малхотри-Кумара-Махешвари

Алгоритм Галила-Наамада

Алгоритм Слейтора-Тарьяна

Алгоритм Голдберга-Тарьяна

Алгоритм CHM

Алгоритм Кинга

Алгоритм Голдберга-Рао

Хронологическая таблица достижений в решении задачи о максимальном потоке

Список рекомендованной литературы


Задача о кратчайших путях

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Графы и маршруты » Кратчайшие пути
Задача о кратчайших путях

Волновой алгоритм
Прекрасно подойдет, если все пути из вершины в соседнюю равны по длине (цене, весу) Время O(n).

Алгоритм Форда-Беллмана
Найти наименьшие стоимости проезда из 1-го города во все остальные за время O(n3) без ограничений на веса.

Алгоритм Флойда
Найти наименьшие стоимости проезда из всех городов во все за время O(n3) без ограничений на веса.

Алгоритм Дейкстры
Найти наименьшие стоимости проезда из 1-го города во все остальные за время O(n2) при положительных ценах.

Нахождение k кратчайших путей в графе
Находить один путь мы уже умеем. Что, если у нас большой граф,а нам нужно k различных кратчайших путей ? Алгоритм Йена придет на помощь!.

Smart Moves: Intelligent Pathfinding[Перевод]
Большая часть статьи посвящена различным случаям поиска кратчайшего пути на графе применительно к играм. Рассмотрено более 5 алгоритмов. Даны заметки к реализации.


Линейная алгебра

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Линейная алгебра
Линейная алгебра

Решение линейных уравнений

Скачать I главу zip

Основные методы описаны в первой главе 'Практикума на ЭВМ' К.Ю. Богачева.

Оглавление:
Глава I. ТОЧНЫЕ МЕТОДЫ РЕШЕНИЯ ЛИНЕЙНЫХ СИСТЕМ
§1. МАТРИЧНЫЕ НОРМЫ
§2. ОБРАТИМОСТЬ МАТРИЦЫ, БЛИЗКОЙ К ОБРАТИМОЙ МАТРИЦЕ
§3. ОШИБКИ В РЕШЕНИЯХ ЛИНЕЙНЫХ СИСТЕМ
§4. МЕТОД ГАУССА
§4.1. Алгоритм метода Гаусса
§4.2. Оценка количества арифметических операций в методе Гаусса
§4.3. Представление метода Гаусса в виде последовательности элементарных преобразований
§4.4. Алгоритм построения LU-разложения
§4.5. Оценка количества арифметических операций в алгоритме построения LU-разложения
§4.6. Осуществимость метода Гаусса
§5. МЕТОДЫ ПОСЛЕДОВАТЕЛЬНОГО ИСКЛЮЧЕНИЯ НЕИЗВЕСТНЫХ ДЛЯ ЛЕНТОЧНЫХ МАТРИЦ
§5.1. Метод Гаусса для ленточных матриц
§5.2. Алгоритм LU -разложения для трехдиагональных матриц
§5.3. Метод прогонки для трехдиагональных матриц
§6. ЗАДАЧА ОБРАЩЕНИЯ МАТРИЦЫ
§7. МЕТОД ГАУССА С ВЫБОРОМ ГЛАВНОГО ЭЛЕМЕНТА
§8. МЕТОД ЖОРДАНА (ГАУССА-ЖОРДАНА)
§9. ПОЛОЖИТЕЛЬНО ОПРЕДЕЛЕННЫЕ МАТРИЦЫ
§10. МЕТОД ХОЛЕЦКОГО (КВАДРАТНОГО КОРНЯ)
§10.1. Разложение Холецкого
§10.2. Алгоритм построения разложения Холецкого
§10.3. Оценка количества арифметических операций в алгоритме построения разложения Холецкого
§11. МЕТОД ОРТОГОНАЛИЗАЦИИ
§12. МЕТОД ВРАЩЕНИЙ
§12.1. Матрица элементарного вращения и ее свойства
§12.2. Алгоритм метода вращении
§12.3. Оценка количества арифметических операций в методе вращений
§12.4. Построение QR-разложения методом вращении
§12.5. Оценка количества арифметических операций в алгоритме построения QR-разложения методом вращений
§13. МЕТОД ОТРАЖЕНИЙ
§13.1. Матрица отражения и ее свойства
§13.2. Алгоритм метода отражений
§13.3. Оценка количества арифметических операций в методе отражений
§13.4. Построение QR-разложения методом отражений
§13.5. Оценка количества арифметических операций в алгоритме построения QR-разложения методом отражений
§14. ПРИВЕДЕНИЕ МАТРИЦЫ К ПОЧТИ ТРЕУГОЛЬНОМУ ВИДУ УНИТАРНЫМ ПОДОБИЕМ МЕТОДОМ ВРАЩЕНИЙ
§14.1. Случай произвольной матрицы
§14.2. Случай симметричной матрицы
§15. ПРИВЕДЕНИЕ МАТРИЦЫ К ПОЧТИ ТРЕУГОЛЬНОМУ ВИДУ УНИТАРНЫМ ПОДОБИЕМ МЕТОДОМ ОТРАЖЕНИЙ
§15.1. Случай произвольной матрицы
§15.2. Случай самосопряженной матрицы

Методы нахождения собственных значений

Скачать II главу zip

Оглавление:
Глава II. МЕТОДЫ НАХОЖДЕНИЯ СОБСТВЕННЫХ ЗНАЧЕНИЙ
§1. ТОЧНЫЕ И ИТЕРАЦИОННЫЕ МЕТОДЫ
§2. ЛОКАЛИЗАЦИЯ СОБСТВЕННЫХ ЗНАЧЕНИЙ
§3. ОШИБКИ ПРИ НАХОЖДЕНИИ СОБСТВЕННЫХ ЗНАЧЕНИЙ
§4. СТЕПЕННОЙ МЕТОД
§4.1. Описание алгоритма
§4.2. Оценка количества арифметических операций на один шаг алгоритма
§5. МЕТОД ВРАЩЕНИЙ ЯКОБИ
§5.1. Описание алгоритма
§5.2. Выбор угла вращения
§5.3. Стратегии выбора обнуляемого элемента
§5.3.1. Метод вращений с выбором максимального элемента
§5.3.2. Метод вращений с циклическим выбором обнуляемого элемента
§5.3.3. Метод вращений с выбором оптимального элемента
§6. МЕТОД БИСЕКЦИИ
§6.1. Алгоритм вычисления k-го по величине собственного значения методом бисекции
§6.2. Алгоритм вычисления всех собственных значений на заданном интервале методом бисекции
§6.2.1. Рекурсивный алгоритм
§6.2.2. Алгоритм последовательного поиска собственных значений
§6.3. Алгоритм вычисления всех собственных значений методом бисекции
§6.4. Вычисление числа перемен знака в последовательности главных миноров
§6.4.1. Вычисление числа перемен знака в последовательности главных миноров с помощью LU -разложения
§6.4.2. Вычисление числа перемен знака в последовательности главных миноров с помощью рекуррентных формул
§7. LR АЛГОРИТМ
§7.1. LR -разложение, используемое в LR алгоритме
§7.1.1. Алгоритм построения LR -разложения для произвольной матрицы
§7.1.2. Алгоритм построения LR-разложения для почти треугольной матрицы
§7.1.3. Алгоритм построения LR-разложения для трехдиагональной матрицы
§7.2. LR алгоритм нахождения собственных значений
§7.2.1. LR алгоритм нахождения собственных значений для почти треугольной матрицы
§7.2.2. LR алгоритм нахождения собственных значений для трехдиагональной матрицы
§7.3. Ускорение сходимости алгоритма
§7.3.1. Исчерпывание матрицы
§7.3.2. Сдвиги
§7.3.3. Практическая организация вычислений в LR алгоритме
§8. МЕТОД ХОЛЕЦКОГО
§8.1. Разложение Холецкого, используемое в методе Холецкого
§8.1.1. Алгоритм построения разложения Холецкого для произвольной самосопряженной матрицы
§8.1.2. Алгоритм построения разложения Холецкого для трехдиагональной матрицы
§8.2. Метод Холецкого нахождения собственных значений
§8.2.1. Метод Холецкого нахождения собственных значений для трехдиагональной матрицы
§8.3. Ускорение сходимости алгоритма
§8.3.1. Исчерпывание матрицы
§8.3.2. Сдвиги
§8.3.3. Практическая организация вычислений в методе Холецкого
§9. QR АЛГОРИТМ
§9.1. QR-разложение, используемое в QR алгоритме
§9.1.1. Алгоритм построения QR-разложения для произвольной матрицы
§9.1.2. Алгоритм построения QR-разложения для почти треугольной матрицы
§9.1.3. Алгоритм построения QR-разложения для трехдиагональной матрицы
§9.2. QR алгоритм нахождения собственных значений
§9.2.1. QR алгоритм нахождения собственных значений для почти треугольной матрицы
§9.2.2. QR алгоритм нахождения собственных значений для самосопряженной трехдиагональной матрицы
§9.3. Ускорение сходимости алгоритма
§9.3.1. Исчерпывание матрицы
§9.3.2. Сдвиги
§9.3.3. Практическая организация вычислений в QR алгоритме
§10. МЕТОД ОБРАТНОЙ ИТЕРАЦИИ НАХОЖДЕНИЯ СОБСТВЕННЫХ ВЕКТОРОВ
ПРОГРАММА КУРСА
ЛИТЕРАТУРА

Разные задачи

Дана матрица a(m,n) из 0 и 1. Найти в ней квадратную подматрицу из одних единиц максимального размера

Дана матрица a(m,n) из 0 и 1. Найти в ней прямоугольную подматрицу из одних единиц максимального размера

Ортогонализация и выделение максимальной линейно-независимой подсистемы
Алгоритмы преобразования системы векторов в эквивалентную ей линейно-независимую систему ортогональных векторов и выделения эквивалетной линейно-независимой подсистемы векторов.


Справочник по статистическим распределениям

© П.Н.Дубнер, 2000

Оригинал статьи лежит на сайте infoscope.forth.ru, здесь же лишь версия от 20 октября 2001.

Здесь опубликован справочник об основных распределениях, применяемых в статистике. Про каждое распределение рассказано следующее:

  • задающая его формула
  • основные свойства
  • генерация случайных чисел
  • коды на С++, позволяющие вычислять значения функции распределения и ее квантилей.

Пусть дана случайная величина X с областью
Оглавление

  • Предисловие
  • F-распределение
  • Бета-распределение
  • Биномиальное распределение
  • Вейбулла
  • Гамма-распределение
  • Геометрическое
  • Дискретное равномерное
  • Коши
  • Логистическое
  • Логнормальное
  • Нормальное*
  • Отрицательное биномиальное
  • Паскаля
  • Пуассона
  • Равномерное
  • Степенное
  • Стьюдента
  • Хи-квадрат
  • Экспоненциальное
  • Эрланга
  • Приложение А: Вычисление гамма-функции
  • Приложение Б: Схема Блли


Разное

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Разное
Разное

Комплексная арифметика
Хорошая, быстрая реализация комплексных чисел, обходящая большое число 'подводных камней', на которые попадают начинающие.

Минимизация автомата
Автомат задан таблицей входов и таблицей выходов Требуется его минимизировать.

Запись числа прописью

Перевод из арабской в римскую систему и наоборот

Обpатная польская нотация
Разбор выражений. Алгоритм перевода в нее арифметического выражения.


Теория чисел

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Теория чисел
Теория чисел

НОД, решение ax+by=1, нахождение обратного элемента по модулю
Логарифмические алгоритмы. Используются везде.

Тест простоты Рабина
Известный, быстрый и часто используемый вероятностный тест на простоту числа Есть детерминированный вариант.

Генерация больших простых чисел
Полиномиальный алгоритм на основе теоремы Ферма.

Разложение на множители
Сложнейшая проблема криптоаналитиков. Некоторые представленные алгоритмы требуют серьезной математической подготовки.

Перевод из одних систем счисления в другие
Проиллюстрированы общие принципы и даны примеры Краткое, но исчерпывающее описание.

Квадратный корень по простому модулю
Решение сравнения x2=a(mod p) Сложность O(lg4n).

Китайская теорема об остатках
Разложение числа по вычетам и его восстановление.

Период бесконечной дроби 1/n
Дано натуральное число n>1 Определить длину периода десятичной записи дроби 1/n.

Период бесконечной дроби N/M по основанию P
Найти длину периода и сам период бесконечной степенной дроби по основанию Р, представляющей рациональное число N/M.

Приближение числа в виде дроби
Для действительного числа r>0 и натурального числа qmax необходимо найти наилучшее приближение r в виде рациональной дроби p/q, где q<=qmax.

Вычисление символа Якоби (Лежанра) z i p
Небольшая статья на английском языке с исходником.

Дополнительные материалы:

Алгоритмические проблемы теории чисел. Ю.В. Нестеренко z i p
Даны пошаговые описания основных алгоритмов теории чисел. Проблема рассмотрена с математической точки зрения, с соответствующими теоремами и доказательствами.


Разложение на множители

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Математика » Теория чисел » Факторизация
Разложение на множители

Простое деление
Метод сложности O( n1/2 ), используемый для обнаружения и удаления малых делителей.

Методы Монте-Карло
Сложность в худшем случае O( n1/4 ) Успех зависит от везения.

P-1 метод Полларда
Довольно хитрый алгоритм, успех которого зависит от свойств числа p-1, а не от величины простых делителей числа.

Дополнительные материалы:

A Survey of Modern Integer Factorization Methods z i p
Описание современных методов разложения на множители. Все дано очень доступно и понятно. Применение алгоритмов проиллюстрировано на конкретных примерах.

Block Lanczos Algorithm for Finding Dependencies over GF(2) z i p
В наиболее эффективных алгоритмах факторизации требуется найти часть решений большой разреженной матрицы с элементами 0 или 1. Именно такой алгоритм и описан в тексте.

Factoring Integers with Self-Initializing Quadratic Sieve z i p
Глубокое описание одного из мощнейших алгоритмов факторизации - SIQS, и того, как в нем применяется.

Solving Large Sparse Linear Systems Over Finite Fields z i p
Решение больших разреженных систем линейных уравнений над конечными полями путем комбинации нескольких известных методов.

A FFT Extension of the Elliptic Curve Method of Factorization z i p
Описано применение в ECM алгоритме разложения на множители быстрого умножения через FFT.

The Number of Relations in the Quadratic Sieve Algorithm z i p
Выбор параметров в алгоритме факторизации MPQS.

Carl Pomerance: A Tale fo Two Sieves z i p
Статья, на достаточно любительском уровне рассказывающая о методах 'решета', и истории их появления.

Random Combinatorial Structures and Prime Factorizations z i p
Рассмотрена связь комбинаторных процессов и разложения на множители.


Разное

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Разное
Разное

Оценки времени исполнения. Cимвол O()
Cколько же проблем возникает из-за недопонимания этого момента. Рассказано очень подробно и доступно.

Динамическое программирование
Понятное и подробное объяснение сути и принципов метода.

Решения 'Японского кроссворда'
Hа матpице GxV нанесен yзоp, составленный из клеток белого и чеpного цветов. Для каждой стpоки и столбца известна последовательность совокyпностей подpяд стоящих чеpных квадpатиков. По данным последовательностям необходимо опpеделить yзоp.

Компьютерный морфологический разбор слов русского языка
Основные принципы и предназначение компьютерной морфологии с примерами на Prolog и Refal.

Проверка, високосный год или нет. Вычисление дня недели

Игра: Быки и коровы

Алгоритм сбора кубика-рубика


Олимпиадные задачи по программированию

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Олимпиадные задачи по программированию
Олимпиадные задачи по программированию

Эти задачи, разумеется, имеют некоторое прикладное значение, однако весьма небольшое. Они обычно даются на уроках информатики или на соревнованиях по программированию. Впрочем, многие из них есть и в 'родных' разделах сайта.

Базой для собрания послужил задачник Котова (БГУ).

Замечание. Классификация очень условна. Часто задачу можно отнести к нескольким разделам, а реально она только в одном.

  • Рекуррентные соотношения и динамическое программирование.

  • Сортировки и последовательности.

  • Переборные задачи.

  • Структуры данных.

  • Задачи на графах.

  • Арифметика.

  • Геометрия.

  • Поиск.

  • Pазное.


Поиск в строках, массивах, последовательностях

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Поиск. Строки и последовательности
Поиск в строках, массивах, последовательностях

Точный поиск подстроки в строке
Нужно найти все вхождения некоторого образца в данный текст.

Нечеткий поиск
Алгоритмы нахождения 'приблизительно' таких же вхождений образца в текст.

Проверка на вхождение в качестве подпоследовательности
Даны две последовательности x[1..n] и y[1..k] целых чисел Выяснить, является ли вторая последовательность подпоследовательностью первой, те можно ли из первой вычеркнуть некоторые члены так, чтобы осталась вторая Число действий порядка n+k.

Общие подпоследовательности. Дистанция

Поиск самой тяжелой общей подпоследовательности, самой длинной возрастающей подпоследовательности, самой тяжелой возрастающей подпоследовательности
Самая тяжелая общая подпоследовательность (heaviest common subsequence, hcs) - это последовательность, общая для x и y, имеющая при данной весовой функции максимальную сумму весов компонент В общем случае, функция может зависеть как от самих символов, так и от их положения в исходных строках
Самая длинная возростающая подпоследовательность (lis) - это максимальная подпоследовательность строк, компоненты которой, при заданном линейном упорядочении алфавита, строго возрастают
Самая тяжелая возрастающая подпоследовательность (his) - это возрастающая подпоследовательность с максимальным весом.

Нахождение максимальной повторяющейся подстроки
Для данной строки y, |y| = n>0, найти самую длинную подстроку, встречающуюся в y больше одного раза.

Нахождение общих элементов двух массивов
Даны два возрастающих массива целых чисел x[1k] и y[1l] Найти количество тех целых t, для которых t = x[i] = y[j] для некоторых i и j) (Число действий порядка k+l).

Двоичный (бинарный) поиск элемента в массиве
Поиск элемента в упорядоченном массиве за log n операций.

Интерполяционный поиск элемента в массиве
Более быстрый поиск при условии равномерного распределения элементов Скорость log log n Особенно хорош при большом размере базы данных.

Бинарный поиск с определением ближайших узлов
Cущественное улучшение бинарного поиска, оптимизированное для большого количества обращений и для случая, когда цель поиска отличается от элементов массива и нужно найти, например, между какими из них она расположена.

Частный случай задачи lis

Информацию о решении конкретных задач можно также найти в разделе Олимпиадные задачи: поиск.

Дополнительные материалы:

Д. Кнут. Сортировка и поиск: 3-й том 'Искусства программирования на ЭВМ' z i p
Разные алгоритмы поиска и сортировки, описанные на серьезном теоретическом уровне.

Fundamental Algorithms for A Declarative Pattern Matching System z i p
Большая книжка, охватывающая практически все разделы и алгоритмы поиска подстроки в строке и вычисления дистанции. Псевдокод на С++.


Точный поиск подстроки в строке

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Поиск. Строки и последовательности » Точный подстроки в строке
Точный поиск подстроки в строке

В данном обзоре мне хотелось бы рассмотреть наиболее известные алгоритмы поиска. На самом деле их гораздо больше, однако многие мне показались уж слишком неоптимальными.

Описание алгоритмов я перевел, взяв статью 'EXACT STRING MATCHING ALGORITHMS' авторов Christian Charras - Thierry Lecroq.

Оригинал статьи находится на www-igm.univ-mlv.fr/~lecroq/string/index.html

Данные алгоритмы ищут все вхождения подстроки в текст.

Для практических целей рекомендуются в первую очередь улучшения Боуера-Мура:
Боуер-Мур-Хорспул, Быстрый поиск, Оптимальное несовпадение, Максимальный сдвиг и Турбо-БМ,
а также несколько специфичные Турбо-обращение сегмента и Сдвиг-Или.

Обозначения и определения.

Термины не обязательно запоминать: будут в алгоритме - вернетесь.

Искомый образец - строка x = x [ 0 ... m - 1 ]; его длина m.
Текст - строка y = y [ 0 ... n - 1 ]; его длина n.

Алфавит ( множество символов, из которых составлены текст и образец ) - S, в нем s символов.
Слово u - префикс cлова w, если существует слово v : w = uv.
Слово v - суффикс cлова w, если существует слово u : w = uv.
Слово z - подстрока слова w, если существуют u и v : w = uzv.
Слово u - период слова w, если w - префикс слова uk для целого k. Наименьший период мы далее и будем называть периодом и обозначать per(w).
Cлово w длины l - периодичное, если длина per(w) <= l/2, в противном случае оно непериодичное.
Слово называется фундаментальным, если оно не может быть записано в виде степени другого слова, то есть не существует z : w = zl.
Cлово z - граница слова w, если существуют u и w : w = uz = zv, z - одновременно префикс и суффикс w.
Обращение слова w длины l обозначается wR - зеркальный образ w; wR = w[ l-1 ]w[ l-2 ] ... w[1]w[0].

В программах будут использованы следующие функции и константы:

константа ASIZE - размер алфавита,
константа WORD - размер компьютерного слова в битах, обычно 16
константа XSIZE - размер образца,
функция ERROR сообщает об ошибке,
функции MIN / MAX - минимум / максимум,
функция OUTPUT возвращает позицию начала совпадения относительно начала текста.

В остальном же все, я надеюсь, следует стандарту Aнси - Си.

Алгоритмы.

Алгоритм | Время на пред. обработку | Среднее время поиска | Худшее время поиска | Затраты памяти | Примечания
Алгоритм грубой силы | Нет | 2*n | O(n*m) | Нет | Mалые трудозатраты на программу
Построение автомата | O(s+m) | O(n) | O(n) | O(s*m) | -
Алгоритм Карпа-Рабина | Нет | O(n+m) | O(n*m) | Нет | -
Алгоритм Сдвига-Или | O(s+m) | O(n) | O(n) | - | Хорош, если длина образца <= размера компьютерного слова. Легко адаптируем к приблизительному сравнению
Алгоритм Морриса-Пратта | O(m) | O(n+m) | O(n+m) | O(m) | -
Алгоритм Кнута-Морриса-Пратта | O(m) | O(n+m) | O(n+m) | O(m) | -
'Не такой уж наивный' алгоритм | O(1) | O(n+m) | O(n*m) | O(1) | Время и место для предобработки - константа.
Алгоритм Боуера-Мура | O(m+s) | O(n+m) | O(n*m) | O(m+s) | Алгоритмы этой группы наиболее эффективны в обычных ситуациях. Быстродействие повышается при увеличении образца или алфавита.
Tурбо-БМ | O(m+s) | O(n+m) | 2*n | O(m+s) | Улучшение предыдущего алгоритма.
Алгоритм Боуера-Мура-Хорспула | O(m+s) | O(n+m) | O(n*m) | O(m+s) | Легок в реализации. Так же эффективен, как и БМ.
Быстрый поиск | O(m+s) | O(n+m) | O(n*m) | O(m+s) | Очень быстрый алгоритм для обычных текстов и поиска. Эффективность падает с увеличением длины образца, но возрастает - с увеличением алфавита.
Алгоритм обращения сегмента | O ( m ) | O(n(logsm)/m) | O(n*m) | O ( m ) | -
Турбо - обращение сегмента | O ( m ) | O(n(logsm)/m) | 2n | O ( m ) | маленький алфавит и длинный образец
Алгоритм оптимального несовпадения | O(m+s) | O(n+m) | O(n*m) | O(m+s) | Очень быстрый алгоритм для обычных текстов и поиска. Большой объем предварительных вычислений.
Алгоритм максимального сдвига | O(m+s) | O(n+m) | O(n*m) | O(m+s) | Очень быстрый алгоритм для обычных текстов и поиска. Большой объем предварительных вычислений.


Нечеткий поиск

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Поиск. Строки и последовательности » Нечеткий поиск
Нечеткий поиск

Обозначения.

Cтрока x длины |x| = m записывается как x1x2 ... xm, где xi представляет i-й символ x.

Подстрока xixi+1 ... xj строки x, где i<=j<=m, будет обозначаться x(i,j). В случае, когда i>j, обращенная подстрока обозначается так xR(i,j).

Обычно x будет обозначать искомый образец, а y – текстовую строку; |x| = m, |y| = n и, конечно, m<=n.

Пример:

x = trismegistus
|x| = 12
x(7,10) = gist
xR(7,4) = gems

Обобщенная задача сопоставления строк, включающая в себя нахождение подстрок строки текста, близких к заданному образцу строки, называется также задачей нечеткого сопоставления строк. Задачу нечеткого сопоставления строк можно сформулировать следующим образом:

Пусть даны образец x, |x| = m, и текст y, |y| = n, m, n > 0 и m < n. Пусть даны также целое k > 0 и функция расстояния d. Требуется найти все подстроки s текста y такие, что d(x, s) < k.

Здесь и далее, d - метрика.

Расстояние Хемминга [Hamming, 1982] между двумя строками одинаковой длины определяется как число позиций, в которых символы не совпадают. Это эквивалентно минимальной цене преобразования первой строки во вторую в случае, когда разрешена только операция замены с единичным весом. Если допускается сравнение строк разной длины, то, как правило, требуются также вставка и удаление. Если придать им тот же вес, что и замене, минимальная общая цена преобразования будет равна одной из метрик, предложенных Левенштейном [Levenstein, 1965]. Другая метрика равна минимальной цене преобразования в случае, когда разрешены только вставка и удаление. Это эквивалентно назначению цены 1 удалению и вставке, и 2 замене, так как последнюю можно заменить парой вставка-удаление. Первую из этих метрик мы ниже называем расстоянием Левенштейна, а вторую – расстоянием редактирования.

Задача, таким образом, состоит в том, чтобы при заданной функции расстояния найти все подстроки текста, отстоящие от образца не более, чем на k. Если d является расстоянием Хемминга, задача называется сопоставлением строк с k несовпадениями, если же d – расстояние Левенштейна, задача называется сопоставлением строк с k различиями (или, иногда, ошибками).

Наивный подход к задаче сопоставления строк, требующий времени O(mn), легко адаптировать к задаче k несовпадений, разрешив k несовпадений при сравнениях символов подстроки в тексте.

Однако, как и для задачи сопоставления строк, для задач k несовпадений и k различий были изобретены более эффективные подходы.

k несовпадений – Ландау-Вишкин
k-различий – Ландау-Вишкин

Их алгоритм гораздо лучше, если k пропорционально O(m/log n). Для неограниченных алфавитов он алгоритм быстрее, если k пропорционально O(log1/2m). Он, безусловно, превосходен, когда границей k является O(log1/2m). Заметим, однако, что при больших k, то есть когда k равняется O(m), его эффективность не лучше, чем у адаптации прямого, с квадратичным временем, подхода динамического программирования.

Для практических целей особо рекомендую
AGREP zip

Если цель нечеткого поиска - исключить ошибки наборщика, то метод, оптимизированный для поиска очень похожих на образец вхождений описан в статье
Tries for approximate string matching zip

Также советую посетить сайт ITMAN, он посвящен исключительно нечеткому поиску и, на мой взгляд, весьма интересен.

Дополнительные материалы:

A randomized algorithm for approximate string mathing z i p
Цель алгоритма - вектор размера N, который образуется, если сдвигать образец вдоль текста и сохранять количество совпадений на i-й позиции образца в i-й координате вектора. Сложность nlogm.

A New Data Structure for Fast Approximate Matching z i p
Триангуляционные деревья - новые структуры данных, позволяющие производить нечеткий поиск /и не только/ с малым числом сравнений. Разобрано применение для дистанции Хэмминга и для проверки графов на изоморфизм.

VP-tree z i p
Структура данных, позволяющая проводить быстрый поиск ближайшего соседа в любых пространствах, причем не обязательно Евклидовой метрики. Построение - O(nlogn), поиск O(logn).


Общие подпоследовательности. Дистанция

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Поиск. Строки и последовательности » Общие подпоследовательности. Дистанция
Общие подпоследовательности. Дистанция

Обозначения.

Cтрока x длины |x| = m записывается как x1x2 ... xm, где xi представляет i-й символ x.

Подстрока xixi+1 ... xj строки x, где i<=j<=m, будет обозначаться x(i,j). В случае, когда i>j, обращенная подстрока обозначается так xR(i,j).

Обычно x будет обозначать искомый образец, а y – текстовую строку; |x| = m, |y| = m и, конечно, m<=n.

Пример:

x = trismegistus
|x| = 12
x(7,10) = gist
xR(7,4) = gems

Расстояния между строками.

Понятие функции, измеряющей расстояние, или метрики, используется в самых разных областях и часто используется для оценки сходства двух векторов. Такие функции применяют для определения силы связи двух признаков, или, например, в распознавании образов при сопоставлении шаблонов с различными частями изображений.

Здесь и далее, d - метрика.

При обработке строк, однако, символы не всегда уместно считать числами, несмотря на то, что коды символов являются ими. Кроме того, часто требуется сравнивать строки разной длины. Поэтому для сравнения строк обычно используют метрики, оценивающие максимальную стоимость преобразования одной строки в другую. В общем случае, операциям редактирования, используемым в этом преобразовании, а именно замене символов, их вставке и удалению, можно назначить разные цены. Последние две операции иногда объединяют в одну и называют вставуд (indel; от insertion и deletion).

Расстояние Хемминга [Hamming, 1982] между двумя строками одинаковой длины определяется как число позиций, в которых символы не совпадают. Это эквивалентно минимальной цене преобразования первой строки во вторую в случае, когда разрешена только операция замены с единичным весом. Если допускается сравнение строк разной длины, то, как правило, требуются также вставка и удаление.

Если придать им тот же вес, что и замене, минимальная общая цена преобразования будет равна одной из метрик, предложенных Левенштейном [Levenstein, 1965]. Другая метрика равна минимальной цене преобразования в случае, когда разрешены только вставка и удаление. Это эквивалентно назначению цены 1 удалению и вставке, и 2 замене, так как последнюю можно заменить парой вставка-удаление. Первую из этих метрик мы ниже называем расстоянием Левенштейна, а вторую – расстоянием редактирования.

Задача о расстоянии между строками.

Для данных строк x и y, где |x|, |y| > 0, и метрики d, задающей расстояния между строками, вычислить d(x,y).

В задаче поиска различий между файлами x и y через xi обозначим i-ю строку x, а через yj – j-ю строку y. В этом случае требуется определить минимальную последовательность операций редактирования, преобразующую x в y.

По просьбам посетителей помещаю сюда
Исходник: Дистанция Левенштейна zip Также доступен
Исходник: Дистанция Редактирования zip

Алгоритмы для решения этих вопросов чрезывчайно тесно связаны с нахождением наибольшей общей подпоследовательности, поэтому будут даны вместе.

Задача о наибольшей общей подпоследовательности.

Напомню, что подпоследовательность строки получается путем исключения из нее нуля или более символов, не обязательно смежных. Общая подпоследовательность двух строк – это строка, являющаяся подпоследовательностью каждой из них. Самая длинная из таких строк называется, понятное дело, самой длинной общей подпоследовательностью.

Итак, задача состоит в том, чтобы для данных строк x и y (|x|, |y| > 0) найти |lcs(x,y)|, где lcs(x,y) – самая длинная общая подпоследовательность (longest common subsequence) x и y. Как правило, требуется найти не только длину lcs(x,y), но и саму эту последовательность.

Если Вам требуется, не достигая большой эффективности, и не вдаваясь в тонкости данного раздела, просто получить неплохой алгоритм вычисления lcs, то заходите сюда.

Более углубленное изучение вопроса.

Метод динамического программирования Вагнера и Фишера прост в реализации, однако требует квадратичных затрат времени и памяти.

Его идея состоит в том, чтобы последовательно оценивать расстояния между все более длинными префиксами строк – до получения окончательного результата. Промежуточные результаты вычисляются итеративно и хранятся в массиве длины (m+1) * (n+1), что приводит к времени и памяти O(mn). Метод Вагнера и Фишера позволяет вычислить lcs прямо по заполненному массиву расстояний. Алгоритм вычисления расстояния Левенштейна, естественно, представлен.

Поэтому для больших приложений предпочтительна версия Хиршберга с линейным временем.

В его методе итеративно вычисляются длины lcs последовательно увеличивающихся префиксов строк, а не расстояния между ними. Экономия памяти происходит за счет того, что в каждый заданный момент времени в памяти хранятся только две строки массива, требуемого динамическому программированию. Потеря остальной части массива, однако, приводит к более сложному методу выделения lcs двух строк. Предлагается рекурсивно делить пополам первую строку и получать две lcs – для каждой половины и подходящей подстроки второй строки. Рекурсия раскручивается до тех пор, пока, в конце концов, выделение lcs не станет тривиальным. Окончательная lcs полных строк после этого получается простой конкатенацией кусков строк, полученных во время рекурсии.

Однако, алгоритм Ханта-Шиманского во многих приложениях имеет значительно более высокую эффективность, которая достигается ценой того, что в худшем случае временная сложность становится больше квадратичной.

Подход к выделению lcs двух строк эквивалентен определению самого длинного монотонно возрастающего пути на графе, составленном из узлов (i,j), таких, что xi = yi. В то время как описанным методам всегда требуется квадратичное время, время этого алгоритма для строк одинаковой длины – всего лишь O((r+n) * log(n)), где r – общее число упорядоченных пар позиций, в которых символы двух строк совпадают. В худшем случае может понадобиться сравнивать каждый элемент x с каждым символом y, что приводит к n2 таких упорядоченных пар и сложности O(n2 * log(n)). Однако, во многих приложениях, например, в задаче поиска различий в файлах, где каждую строку файла естественно считать атомом, можно ожидать, что r будет близко к n, а это дает эффективность O(n * log(n)) – существенное улучшение по сравнению с процедурами, требующими квадратичного времени.

Алгоритм Машека и Патерсона – единственный из известных алгоритмов, которому в худшем случае требуется субквадратичное время.

Этому методу, однако, требуется, чтобы алфавит был конечным, а ценовые веса – целыми множителями фиксированного действительного числа. Алгоритм использует метод 'четырех русских' [Арлазаров, Диниц, Кронрод и Фараджев, 1970], его время в худшем случае равно O(n2/log n) – для строк равной длины. Основная идея этого метода состоит в разбиении матрицы расстояний на совокупность подматриц. Их нижние и правые края можно затем вычислить по аналогичным краям подматриц, примыкающих к текущей сверху и слева, и соответствующим подстрокам x и y, с помощью предварительно вычисленной таблицы. Хотя асимптотически этот алгоритм быстрее обычного динамического программирования, Машек и Патерсон [Masek, Patterson, 1983) указывают, что его следует использовать только для длинных строк; например, при вычислении расстояния редактирования между двумя бинарными строками он становится по-настоящему быстрым, только когда длины строк превосходят 262418.

В случае, когда две сравниваемые строки похожи, то есть когда d мало, хорош метод Укконена.

В основе его метода лежит поиск пути минимальной цены на графе, который составлен из вершин матрицы расстояний, а также горизонтальных, вертикальных и диагональных ребер, соответствующих связям между смежными узлами. Требуемый путь начинается в (0, 0) и заканчивается в (m, n).

Параллельный метод поиска lcs zip


Нахождение максимальной повторяющейся подстроки

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Поиск. Строки и последовательности » Максимальная повторяющаяся подстрока
Нахождение максимальной повторяющейся подстроки

Обозначения.

Cтрока x длины |x| = m записывается как x1x2 ... xm, где xi представляет i-й символ x.

Подстрока xixi+1 ... xj строки x, где i<=j<=m, будет обозначаться x(i,j). В случае, когда i>j, обращенная подстрока обозначается так xR(i,j).

Обычно x будет обозначать искомый образец, а y – текстовую строку; |x| = m, |y| = m и, конечно, m<=n.

Пример:

x = trismegistus
|x| = 12
x(7,10) = gist
xR(7,4) = gems

Задача нахождения самой длинной подстроки (longest repeated substring), появляющейся в данной строке более одного раза, можно сформулировать следующим образом.

Для данной строки y, |y| = n > 0, найти самую длинную подстроку, встречающуюся в y больше одного раза.
Cамая длинная повторяющаяся подстрока – это самая длинная из строк максимальной длины x, такая что y = uxvxw для некоторых строк u, v и w, где |u| > 0, |v| > 0 и |w| > 0.

Максимальная повторяющаяся подстрока – это подстрока, имеющая в данной строке не меньше двух различных вхождений, причем сопоставление нельзя продолжить ни в одном направлении. Рассмотрим, например, строку PABCQRABCSABTU. Подстроки A, B, C, AB, BC и ABC повторяются. Строки AB и ABC являются максимальными повторяющимися подстроками, и, таким образом, ABC является самой длинной повторяющейся подстрокой.

Наивный подход
Наивный подход к решению этой задачи, которому требуется квадратичное время, состоит в следующем. Строится матрица M размерности n * n, такая что Mi,j = 1 если yi = yj, и Mi,j = 0 в противном случае. За исключением главной диагонали, все диагонали в матрице, состоящие из идущих подряд `1', представляют максимальные повторяющиеся подстроки, самая длинная из которых является, таким образом, самой длинной повторяющейся подстрокой. Обратите внимание, что матрица симметрична относительно главной диагонали, поэтому достаточно вычислять и обрабатывать только одну, скажем, верхнюю, ее половину (то есть элементы M1...n-1,i+1...n+1).

Суффиксные деревья
Более сложный и эффективный алгоритм.


Алгоритмы сортировки

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Сортировка
Алгоритмы сортировки

Kantor Ilia
e-mail: algolist@manual.ru
web: http://algolist.da.ru

Пусть есть последовательность a0, a1... an и функция сравнения, которая на любых двух элементах последовательности принимает одно из трех значений: меньше, больше или равно. Задача сортировки состоит в перестановке членов последовательности таким образом, чтобы выполнялось условие: ai <= ai+1, для всех i от 0 до n.

Возможна ситуация, когда элементы состоят из нескольких полей:

struct element {
  field x;
  field y;
}

Если значение функции сравнения зависит только от поля x, то x называют ключом, по которому производится сортировка. На практике, в качестве x часто выступает число, а поле y хранит какие-либо данные, никак не влияющие на работу алгоритма.

Пожалуй, никакая другая проблема не породила такого количества разнообразнейших решений, как задача сортировки. Существует ли некий "универсальный", наилучший алгоритм ? Вообще говоря, нет. Однако, имея приблизительные характеристики входных данных, можно подобрать метод, работающий оптимальным образом.

Для того, чтобы обоснованно сделать такой выбор, рассмотрим параметры, по которым будет производиться оценка алгоритмов.

  1. Время сортировки - основной параметр, характеризующий быстродействие алгоритма.
  2. Память - ряд алгоритмов требует выделения дополнительной памяти под временное хранение данных. При оценке используемой памяти не будет учитываться место, которое занимает исходный массив и независящие от входной последовательности затраты, например, на хранение кода программы.
  3. Устойчивость - устойчивая сортировка не меняет взаимного расположения равных элементов. Такое свойство может быть очень полезным, если они состоят из нескольких полей, как на рис. 1, а сортировка происходит по одному из них, например, по x.

    Взаимное расположение равных элементов с ключом 1 и дополнительными полями "a", "b", "c" осталось прежним: элемент с полем "a", затем - с "b", затем - с "c".

    Взаимное расположение равных элементов с ключом 1 и дополнительными полями "a", "b", "c" изменилось.
  4. Естественность поведения - эффективность метода при обработке уже отсортированных, или частично отсортированных данных. Алгоритм ведет себя естественно, если учитывает эту характеристику входной последовательности и работает лучше.

Еще одним важным свойством алгоритма является его сфера применения. Здесь основных позиций две:

  • внутренние сортировки работают с данным в оперативной памяти с произвольным доступом;
  • внешние сортировки упорядочивают информацию, расположенную на внешних носителях. Это накладывает некоторые дополнительные ограничения на алгоритм:
    • доступ к носителю осуществляется последовательным образом: в каждый момент времени можно считать или записать только элемент, следующий за текущим
    • объем данных не позволяет им разместиться в ОЗУ
    Кроме того, доступ к данным на носителе производится намного медленнее, чем операции с оперативной памятью.

Данный класс алгоритмов делится на два основных подкласса:

Внутренняя сортировка оперирует с массивами, целиком помещающимися в оперативной памяти с произвольным доступом к любой ячейке. Данные обычно сортируются на том же месте, без дополнительных затрат.

Внешняя сортировка оперирует с запоминающими устройствами большого объема, но с доступом не произвольным, а последовательным (сортировка файлов), т.е в данный момент мы 'видим' только один элемент, а затраты на перемотку по сравнению с памятью неоправданно велики . Это приводит к специальным методам сортировки, обычно использующим дополнительное дисковое пространство.

Основные методы сортировки

Статьи ниже являются частями одной большой, так что в последующих может использоваться информация из предыдущих. В программах используются переопределения:

typedef double          real;
typedef unsigned long   ulong;
typedef unsigned short  ushort;
typedef unsigned char   uchar;

Под переменной size принимается количество элементов в массиве, а для обозначения индекса последнего элемента используется N. Очевидно, size=N+1.

Квадратичные и субквадратичные алгоритмы

Сортировка выбором(SelectSort)
Сортировка пузырьком(BubbleSort) и ее улучшения
Сортировка простыми вставками(InsertSort)
Cортировка Шелла (ShellSort)

Сравнение времени сортировок

Изображенный ниже график иллюстрирует разницу в эффективности изученных алгоритмов.
  • коричневая линия: сортировка пузырьком;
  • синяя линия: шейкер-сортировка;
  • розовая линия: сортировка выбором;
  • желтая линия: сортировка вставками;
  • голубая линия: сортировка вставками со сторожевым элементом;
  • фиолетовая линия: сортировка Шелла.

Логарифмические и линейные алгоритмы

Пирамидальная сортировка (HeapSort)
Быстрая сортировка (QuickSort)
Поразрядная сортировка(Radix sort)

Некоторую информацию, которой нет выше, можно найти в FAQ по сортировкам из эхоконференции RU.ALGORITM.

Если же требуется сортировать большие массивы и наложены очень серьезные требования по быстродейстивю, то весьма хорошее впечатление производит гибрид быстрой и распределяющей сортировок: "Быстрая сортировка с составными ключами". В материале сравниваются различные методы сортировки строк и приводятся исходные тексты на языке C.

Кроме того, существует топологическая сортировка, оперерующая с частично упорядоченными структурами, например, с ориентированными графами без циклов . Она приводит их представление в ЭВМ к виду, при котором все ребра направлены в одну сторону. С циклами такой фокус, естественно, не пройдет.

Информацию о решении родственных сортировке задач можно также найти в разделе: Олимпиадные задачи: сортировки и последовательности.

Дополнительные материалы:

Д. Кнут. Сортировка и поиск: 3-й том 'Искусства программирования на ЭВМ' z i p
Разные алгоритмы поиска и сортировки, описанные на серьезном теоретическом уровне.


Разбор выражений. Компиляторы и интерпретаторы.

:: алгоритмы и методы ::
:: олимпиадные задачи ::
:: связь ::
:: форум ::
:: о сайте ::

Path: Разбор выражений. Компиляторы и интерпретаторы.
Разбор выражений. Компиляторы и интерпретаторы.

Разбор арифметического(и не только) выражения. Классические алгоритмы.
Несколько известных алгоритмов рекурсивного разбора. Вообще говоря, выражение не обязательно арифметическое, а цель - вычисление.

Обpатная польская нотация
Разбор выражений: алгоритм перевода в нее арифметического выражения.

Tail-Recursive Stack Disciplines for an Interpreter z i p
Организация правильной хвостовой рекурсии в интерпретаторе (в константном пространстве).

Representing Type Information in Dynamically Typed Languages z i p
Представление типов данных в языках, которые не дают информации о типе переменной на этапе компиляции. Тип переменной формируется во время работы программы.

Дополнительные материалы:

Варсанофьев, Дымченко 'Основы компиляции' z i p

Серебряков 'Лекции по конструированию компиляторов' z i p
Два дополняющих друг друга конспекта, где в очень доступной форме описаны алгоритмы грамматического разбора, грамматики, а также YACC(CUP) и его язык.

Programming Languages: An Interpreter-Based Approach z i p
Описан механизм работы интерпретаторов - в наше время редких, но часто незаменимых инструментов. Есть реализация объектно-ориентированного программирования, и все это - с исходниками на Си.

Parsing Techniques: a Practical Guide z i p
В очень доступной форме, начиная с азов, рассказывается о парсерах и грамматиках. Рекомендуется для начала, и особенно нематематикам по профессии. С алгоритмами, однако без привязки к конкретному языку программирования.

When are Bytecode Faster Then Direct Execution? z i p
Различные способы 'полукомпиляции', используемой в интерпретаторах (напр. Java). Что когда лучше.

Compiler Techniques for Code Compaction z i p
Новые (2000г) способы оптимизации выполнимого файла при компиляции с целью уменьшения занимаемой им памяти. В результате памяти используется на 30% меньше. Это не архивация.

Variables and Parametres as References and Containers z i p
Способы представления переменных и типов данных в языках. Они не обязательно статические и предопределены заранее.


Некоторые математические алгоритмы

Здесь размещены некоторые математические алгоритмы

Новости сайта

Q: Какие алгоритмы?

A: Мы начали с того, что разместили здесь вычисление трех элементарных функций (без использования стандартных библиотек). Далее предполагается разместить некоторые вещи для решения линейных уравнений, генерации случайных чисел, минимизации, анализа Фурье и решения некоторых видов уравнений в частных производных. Может быть и еще, когда будет время.

Q: Как представлены алгоритмы на сайте?

A: В виде описания порядка действий на русском или английском языке и в виде программы на ANSI C, реализующей этот порядок действий. Для некоторых алгоритмов (особенно, касающихся уравнений в частных производных) имеется или будет иметься небольшая описательная часть, в которой объясняются вещи, не связанные непосредственно с методом решения. Например, физический смысл уравнения или примеры задач.
Язык C выбран мной, поскольку я считаю его наиболее ясно описывающим короткие алгоритмы, а также в силу его реализации на большинстве платформ. Действительные числа представлены в программах в основном как double precision floating point (кроме алгоритмов для элементарных функций).

Q: Как скачивать программы?

A: Если поступать непосредственно методом CTRL-C -- CTRL-V (для некоторых компьютеров ALT-C -- ALT-V), примененным к тексту программы, помещенному на html-странице, то полученный код придется редактировать, поскольку вместо символов >, <, & и др. в нем применены esc-последовательности. Для того, чтобы избежать этого неудобства, тексты программ в "исходном" виде помещены отдельно (доступны с соответствующих страниц по ссылке). Скачивайте их методом Save As вашего браузера.

Содержание

1. Элементарные функции
1.1. Синус и косинус
1.2. Арктангенс, арксинус, арккосинус
1.3. Квадратный корень
1.4. Экспонента, синус и косинус (другой способ)
1.5. Гамма и Бета функции
 2. Линейные уравнения
2.1. LU-декомпозиция
2.2. Трехдиагональные системы
2.3. Проблема собственных векторов и значений (еще не дописано)
 3. Нелинейные уравнения:
3.1. Корни полиномов
3.1.1. Квадратное уравнение
3.1.2. Кубическое уравнение
 3.2. Функции одной переменной
3.2.1. Окружение и локализация корня
 4. Минимизация
5. Случайные числа:
5.1. Быстрые и грязные генераторы
5.2. Равномерное распределение
 6. Дифференциальные уравнения
7. Уравнения в частных производных
8. Анализ Фурье
9. Разное

А здесь устроили гостевую книгу для посетителей, хотя мне и не нравится жестко регламентированный ее дизайн.

Писать и читать сюда

К сему составитель руку приложил начиная с 16 марта 2000
И вон сколько зевак собрал:

Страницы размещены на cистеме сайтов
Последние изменения 22.06.2000


Анекдоты@Mail.ru

Ленты анекдотов

Общайся
по-новому

 0936
Доставьте удовольствие себе и порадуйте друзей, ведь анекдоты можно не только слушать, но и отсылать на любой номер телефона России.

Новые анекдоты:

Джорджа Буша проверяют на детекторе лжи. Ему говорят:
- Если вы скажете правду, то загорится зелёная лампочка, а ес...
дальше»
Приходит Грузин в крутой салон по продаже мерседесов и говорит:
- Дайте мнэ самий крутой мерс!
Ему дали, оплатил с...
дальше»
На приёме у гадалки:
- О да у вас очень интересное переплетение линии жизни с линией ума, под самым горбом марса и ...
дальше»
Маленький мальчик спрашивает у мамы:
- Мам, а почему все дети едят сладкую вату, а я обыкновенную?!
Едет в машине семья: мама, папа, и сынок - даун (на переднем сиденье):
Спрашивает у папы:
- Пап, а где мама?
- Сза...
дальше»

Все анекдоты
ПРИКОЛЫ, РОЗЫГРЫШИ, ПОДАРКИ:
Веселые подарки Веселые подарки | Приколы, розыгрыши Приколы, розыгрыши | Необычные подарки Необычные подарки
Модные игрушки Модные игрушки | Смешные подарки Смешные подарки | Подарки для души Подарки для души
 | Магазины для всей семьи: (095) 952-14-14

Оставьте ваше мнение

Уважаемые пользователи, Администрация проекта будет вам признательна, если вы оставите ваше мнение о работе проекта:

Анекдоты:
Стоят рядом три магазина. Хозяин левого повесил вывеску:
- У нас самые низкие цены.
Хозяин правого:
- У нас самые качественные товары.
А хозяин среднего, подумав, повесил вывеску:
- Главный вход здесь.
Люба - bivshtex@mail.ru 2006-05-18 20:00:00

Истории:
Утро в офисе. Звонит телефон. У кого-то утро не совсем бодрое, судя по голосу:
- А директор есть?
- Еще не подошел, будет позже, - говорю
- А как его найти?
- Позвоните по этому номеру через час,
- М-м-м по этому это по какому такому??? ...
дальше»
Марго 2006-05-18 20:00:00

Афоризмы:
Человек никогда не бывает, так несчастен, как ему кажется и не так счастлив, как ему хочется.
Марина - marishka_forever@list.ru 2006-05-18 20:00:00

Тосты:
Мой прадед говорил: "Я имею желание купить дом, но не имею возможности.
Я имею возможность купить козу, но не имею желания".
Так давайте же выпьем за то, чтобы наши желания совпадали с нашими возможностями.
Арт_м 2006-05-18 20:00:00

Картинки:

делиКЭТно зевнул!!!
Ольга - Samara7@mail.ru 2006-05-18 20:00:00

Пришлите ваш материал:

Раздел
Превью

Превью (картинка-анонс) должна быть размером не более 120х120 pixel в формате *.tif, *.gif, *.jpg
Картинка

Картинка должна иметь максимальный размер не более 600x600 pixel в формате *.tif, *.gif, *.jpg
Ваше имя
E-mail
Текст

Внимание! Прочтите перед отправкой!

Дневники на Блогах@Mail.ru

Ника
Я просто себя не сдерживала... поддалась инстинкту... читать »
Кисуля
Зачем они уходят? Сначала обещают все... Дарят звезды... читать »
Den
Я идиот... я надеялся что ей понравится, то что я честен перед ней читать »

Завести свой дневник »

Избранное

  • Крылатые выражения Лебедя new
Эротика с юмором
  • гороскоп для женщин
  • гороскоп для мужчин
Перлы знаменитостей
  • спортивные комментаторы сообщают
  • и о политике...

Новости DNI.RU

Россияне опасаются НАТО
  • КПРФ защищает экстремистов
  • Путин поблагодарил "НАШИХ"
  • Ужасы Максима Галкина
  • Ведущая "Дома" не выйдет замуж

Пошути над коллегой

  • Приколы на столе
  • Ошибки коврика
  • Оживший CD-ROM

Подписка на веселости:
Анекдоты
Афоризмы
Гороскопы
Истории
Картинки

Знакомства

Я
ищу
возраст от до
© 1999-2006, Mail.Ru Семинары · Реклама на Mail.Ru · О компании · Вакансии · Сувениры


TOYOTA

Пропустить


БЛОГИ@MAIL.RU

Почта Почта Агент Каталог Каталог Новости Новости Авто Авто Путешествия Путешествия Все проекты

Мой блог Мои друзья Сообщества Люди пишут Помощь

Имя ( регистрация )
Пароль ( забыли?)

Любишь фотографировать или рисовать?

Сделай открытку из своего шедевра и борись за призы!

Прямой эфир

(Без темы)
У меня существует какая-то собственная драматургия. Для меня нормально оставаясь на едине с собой ненавидеть себя за то количество вещей, для которых я слишком слаба. Совсем-совсем ненавидеть… Я не знаю за что можно себя любить, если так хорошо...

Автор: Кульпинка - 11-03-2006 01:31
...Мысли Вслух...
"... Весь мир - театр... В нём женщины, мужчины - все актёры... И каждый не одну играет роль..."Как странно устроен человек... Как жесток мир... И как коротка жизнь...Почему многие так боятся быть самими собой, выбирая ложь и...

Автор: marmishka - 19-05-2006 01:34
(Без темы)

Автор: Чёрно-белые фотографии - 19-05-2006 01:31
мужа нет дома
состояние сонное..но спать одной идти совсем не хочется.. мужа нет дома......жду.а может пойти и лечь?кажется я уже сама с собой разговариваю..д а, поговорить то и действительно не с кем, все нормальные люди спят себе уже давно!

Автор: Валечка_28 - 19-05-2006 01:30
OUTLAWZ В МОСКВЕ!!!!!
27 мая состоится их концерт памяти 2pac&#39;a!!!!! кто идет?

Автор: РЕП - ЭТО ПРАВИЛЬНАЯ ДОРОГА В БУДУЩЕЕ! - 19-05-2006 01:32

Блоги@Mail.ru - это ваше личное пространство, ваш мир на Mail.Ru. Здесь вы можете: создать свой дневник, читать и комментировать дневники других пользователей, принимать участие в сообществах на интересные темы и создавать свои сообщества.

Найти:
  • самые свежие
  • самые популярные
  • случайный блог
            •
    Создайте свой блог

    Популярные

    Лень
    Настя Вильямс
    Цвета Солнца
    Владимир Кукк
    Айрин

    Новые

    min Artem
    Игорь
    ReSiDeNt
    Катрин
    KiLLВАП

    Сообщества

             Создать сообщество

    Популярные

    Философия
    Разное
    Одиночки по жизни
    Психология и отношения
    Отношения между мужчинами и женщинами
    Психология и отношения
    Знакомство и Общение.
    Знакомства и любовь
    Кинокритик
    Кино, ТВ
    Леди@Mail.Ru
    Красота и здоровье

    Новые

    КАЧАЕМ ФИЛЬМЫ И МУЗЫКУ БЕСПЛАТНО! КРУПНЕЙШИЕ СЕРВЕРЫ РУНЕТА!
    Кино, ТВ
    Боишься знакомится ? Тогда тебе - СЮДА !
    Знакомства и любовь
    Кучка с первого курса биофака
    Досуг, отдых, хобби
    ВСЕ КТО УМЕЕТ ПЕТЬ ЗАЙДИ!
    Объявления
    Суецид
    Психология и отношения
    НАШИ
    Разное

    Каталог сообществ

    Hi-tech, Интернет | Образование и учеба
Авто и Мото | Общество, политика
Бизнес и финансы | Объявления
Города, страны, регионы | Психология и отношения
Досуг, отдых, хобби | Работа и Карьера
Животные | Разное
Знакомства и любовь | Семья, Дом, Дети
Игры, развлечения, юмор | СМИ и Новости
Кино, ТВ | Советы и консультации
Красота и здоровье | Спорт
Культура и Искусство | Стиль, мода, звезды
Музыка | Темы для взрослых
Наука и Техника | Туризм и Путешествия
Непознанное | Фото и Видео

    Лидер блогов

             Занять это место!
            Ugly MIRAGE
    Мысли, наблюдения и все-все-все... (Для себя и читателей.)
    holod
    Немного красоты. No comments =))
    Stesha
    Караул! Скоро экзамены!! А я каникулы хочу...

    Лидер сообществ

             Занять это место!
    CМАЙЛИКИ ДЛЯ БЛОГОВ!
    Как использовать смайлики (жми чтобы узнать)
    Alone with time
    Привет! Это Aalon, или просто Ээлон. Нас здесь не так уж...
    Сайт Знакомств - JustYou.Ru
    Сайт знакомств - «JustYou.Ru » представляет службу знакомств...

    Выбор Mail.ru

    Жизнь на @Mail.Ru
    Леди@Mail.Ru
    Активный отдых без заграниц
    Отдам даром!
    Мозговой штурм
    Ручная работа

    © 1999-2006, Mail.Ru Пользовательское соглашение Реклама на Mail.Ru · О компании


Мой сайт@Mail.Ru - Сервис бесплатного хостинга

Поиск по Интернету

BOOM

МОЙ САЙТ МОИ ДАННЫЕ ПРЕЗЕНТАЦИЯ ФОРУМ ГОСТЕВАЯ КНИГА ЧАТ РАССЫЛКИ СТАТИСТИКА

Как построить свой сайт?
Придумайте имя вашего сайта, зарегистрируйтесь и вы сможете конструировать свой сайт по готовыми шаблонам

Персональная
страничка
Мой
фотоальбом
Познакомлюсь

Регистрируйтесь и начинайте создание сайта

ДАВАЙ ЭТО СДЕЛАЕМ ПО-БЫСТРОМУ
 | Придумайте имя своего сайта Выберите имя для Вашего сайта и введите это имя в окошко. Нажмите на кнопку "Да", и сайт с этим названием - Ваш!
 | Зарегистрируйтесь Зарегистрируйте автора, заполнив короткую анкету, ознакомьтесь с Правилами Пользования. Теперь мы знакомы.
 | Начните с темы Из предложенных вариантов Вы можете выбрать то, что Вам подходит лучше всего. Вы можете начать с "Главной страницы", сделать "Фотоальбом", рассказать о своих "Увлечениях" или выбрать другую тему для Вашей первой страницы.
 | Выберите дизайн страницы Выберите общий дизайн страницы по Вашему вкусу. Теперь у Вашего сайта есть форма.
 | Наполните форму содержанием Поиграйте с цветами, поместите на страницу Ваш текст, рисунки и фотографии, не забудьте про ссылки. Добавьте гостевую книгу и счетчик посещений. Первая страница вашего сайта готова!
 | Устройте вокруг Вашего сайта BOOM! Разместите сайт в вашем каталоге, добавьте увлекательную аннотацию, сделайте описание для поисковых систем. Сообщите о сайте друзьям и... ждите посетителей!
Регистрируйтесь и начинайте создание сайта
На правах рекламы

ВХОД
логин: |
пароль: |
 | забыли пароль
 | регистрация

BOOM-ОБИТАТЕЛИ
Добавить
фото 		Сегодня нас:
123044

Здесь вы нйдёте некоторую информацию о мне. Сможете прочесть мою первую книгу и стих. В разделе экстра непознанном. Жду Вас.

группа-"Тур-клуб" mp3.тексты ,и т. д.

Родных и друзей жизнь разбросала по всему свету. Для них и всех, кто любит путешествовать, я делаю этот сайт.
Поиск:
В Интернете В Картинках

Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Чаты · WiW · Жуки
Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

Copyright © 1999-2005 Mail.Ru, Обратная связь


пФЛТЩФЛЙ@Mail.Ru: пФЛТЩФЛЙ ОБ ЧУЕ УМХЮБЙ ЦЙЪОЙ. пФРТБЧШ УЧПА ПФЛТЩФЛХ

рПЙУЛ РП йОФЕТОЕФХ
пФЛТЩФПЛ ОБ РТПЕЛФЕ: 4596
змбчобс ртедмпцйфш пфлтщфлх рпрхмстоще пфлтщфлй опчще пфлтщфлй умхюбкобс пфлтщфлб лбмеодбтш
блфхбмшоще пфлтщфлй
19 НБС

дЕОШ рЙПОЕТЙЙ 		19 НБС

дЕОШ уЧСФПЗП йЧП 		21 НБС

дЕОШ ЪБЭЙФЩ ПФ ВЕЪТБВПФЙГЩ

дЕОШЗЙ Й ЛБТШЕТБ

вХИЗБМФЕТ 		уНЕЫБТЙЛЙ

рПЪЧПОЙ НОЕ, РПЪЧПОЙ 		у ОПЧПУЕМШЕН!

у ОПЧПУЕМШЕН! 		лБТЙЛБФХТЩ

чУЕ ТБЧОП, ЬФП-МАВПЧШ! 		оПЧЩЕ ПФЛТЩФЛЙ

нПТЕ ЧПМОХЕФУС...

вЩУФТБС ПФЛТЩФЛБ

рТПЧЕДЕН ЧЕЮЕТ ЧНЕУФЕ?

рТПЧЕДЕН ЧЕЮЕТ ЧНЕУФЕ?

уБНЩЕ РПРХМСТОЩЕ ПФЛТЩФЛЙ

чУФТЕЮЙ Й УЧЙДБОЙС

нЩ ЧНЕУФЕ!

с РП ФЕВЕ УЛХЮБА

у дОЕН тПЦДЕОЙС!

у дОЕН тПЦДЕОЙС!

уПВЕТЙ ВХЛЕФ

лБЛ ОЕ ЪБВЩФШ РПЪДТБЧЙФШ

лБЛ ОЕ ЪБВЩФШ ПФРТБЧЙФШ РПЪДТБЧМЕОЙЕ

рПДТПВОПУФЙ »
лПОЛХТУЩ

цЙЪОШ РТПВХЦДБЕФУС! ·чЕУОБ, УПМОГЕ Й МАВПЧШ ·лПНнЙУУЙС ·оБЛПОЕГ-ФП ЧЕУОБ!

дЕОШ ТПЦДЕОЙС

у дОЕН тПЦДЕОЙС! ·дБФЩ Й аВЙМЕЙ ·ъОБЛЙ ъПДЙБЛБ ·рПДОЙНЕН ВПЛБМЩ! ·рПЪДТБЧМЕОЙС ТПДОЩН Й ВМЙЪЛЙН ·рПЪДТБЧМЕОЙС УПФТХДОЙЛБН ·рПЪДТБЧМСА! ·у дОЕН бОЗЕМБ! ·у ОПЧПТПЦДЕООЩН! ·фПТФЩ Й УЧЕЮЙ

оБ ЛБЦДЩК ДЕОШ

бОЕЛДПФЩ Ч ПФЛТЩФЛБИ ·зТЕИЙ ОБЫЙ ФСЦЛЙЕ ·дМС БЧФПМАВЙФЕМЕК ·дОЙ ОЕДЕМЙ ·лБТЙЛБФХТЩ ·нХЪЩЛБМШОЩЕ ИЙФЩ ·п РПЗПДЕ Й ЧТЕНЕОБИ ЗПДБ ·рТЙЗМБЫЕОЙЕ ОБ ПВЕД ·уПЧЕФУЛЙЕљПФЛТЩФЛЙ ·уРПТФ ·хРХЭЕООЩЕ ЧПЪНПЦОПУФЙ

рЕТУПОБМЙЙ

уНЕЫБТЙЛЙ ·Multi-Pulti ·нЙЫЛЙ ·нЩЫЛЙ-фЩЫЛЙ ·тЕРБ ·уОЕЦЙЛЙ ·жЕЙ ·юЕВХТБЛЙ

мАВПЧШ Й ДТХЦВБ

тПНБОФЙЮЕУЛЙЕ РТЙЪОБОЙС ·рХЫЙУФЩЕ ЮХЧУФЧБ ·вМБЗПДБТОПУФШ ·чПЪДХЫОЩК РПГЕМХК ·чУФТЕЮЙ Й УЧЙДБОЙС ·дТХЦВБ ·цДХ ФЕВС ·ъБКЛБ НПС ·нЩ ЧНЕУФЕ! ·п УФТБООПУФСИ МАВЧЙ ·рТПУФЙ, ЙЪЧЙОЙ ·уЧБДЕВОЩЕ ·уЕТДЕЮЛЙ ·фЩ НОЕ ОТБЧЙЫШУС ·гЧЕФЩ ·с РП ФЕВЕ УЛХЮБА ·с ФЕВС МАВМА!

лБТФЙОЩ Й ЖПФП

чЙТФХБМШОЩК ГЧЕФОЙЛ ·чТЕНЕОБ ЗПДБ ·зПТПДБ ·дЕЧХЫЛЙ ·ъБЛБФЩ ·лПЫЕЮЛЙ ·лТБУПФЩљРТЙТПДЩ ·тБЪОЩЕ ЪЧЕТХЫЛЙ ·тБЪОЩЕ ЖПФП ·уПВБЮЛЙ

рПЦЕМБОЙС Й РТЙЧЕФУФЧЙС

вХДШ ЧЕУЕМЕК ·вХДШ ЪДПТПЧ! ·цБМПВЩ ·нЕФЛПЕ УМПЧП ·рПЦЕМБОЙС ·рТЕДПУФЕТЕЦЕОЙС ·рТЙЧЕФ, ЛБЛ ФЩ? ·рТЙЗМБЫЕОЙС ·рТПУЩРБКУС! ·тБУУМБВШУС ·у ОПЧПУЕМШЕН! ·уРПЛПКОПК ОПЮЙ ·хДБЮЙ

тБВПФБ Й ХЮЕВБ

дЕОШЗЙ Й ЛБТШЕТБ ·рПТБ ПФРХУЛПЧ ·тБВПФБ - ОЕ ЧПМЛ... ·уЕУУЙС... ·фТХДПЧЩЕ ВХДОЙ ·хЮЕВБ

ьТПФЙЛБ

Art of Memory ·La Femme... ·бОЙНБГЙС... ·йОФЕТБЛФЙЧОБС ЬТПФЙЛБ

оБЫЙ БЧФПТЩ

A.Lalenkov ·Alla Skliar ·Argus ·Axis ·Delia ·L.L. ·Natali-Filatkina ·TamKoffe ·Tanusha ·TATJANA SEDOVA ·бОДТЕК лХЪОЕГПЧ ·бОДТЕК нХИЙО ·чБМЕТЙК иПНСЛПЧ ·зМЕВ бОДТПУПЧ ·дНЙФТЙК фТХВЙО ·дНЙФТЙК ыЕМЙИПЧ ·мБЪБТЕЧБ ·нБЫБ сЛХЫЙОБ ·рБЧЕМ лБРХУФЙО ·уЕТЗЕК тЕРШЈЧ ·уЙТЙОЯ

лПНРШАФЕТЩ Й ЙОФЕТОЕФ

чЙТФХБМШОБС МАВПЧШ ·чПЛТХЗ РПЮФЩ ·лПНРШАФЕТОЩЕ УФТБУФЙ...

пУПВЕООЩЕ ПФЛТЩФЛЙ

Flash-ПФЛТЩФЛЙ ·йОФЕТБЛФЙЧОЩЕ ПФЛТЩФЛЙ ·лТйБФЙЖЖ ·уФЕТЕПУЛПРЙЮЕУЛЙЕ ПФЛТЩФЛЙ

хЦБУЩ

дЕФУЛЙЕ УБДЙЪНЙЛЙ ·уЛЕМЕФЩ ·хЦБУФЙЛЙ
нбк
1 | рТБЪДОЙЛ чЕУОЩ Й фТХДБ
7 | дЕОШ тБДЙП
9 | дЕОШ рПВЕДЩ
12 | чУЕНЙТОЩК ДЕОШ НЕДЙГЙОУЛЙИ УЕУФЕТ
15 | нЕЦДХОБТПДОЩК ДЕОШ УЕНШЙ
17 | нЕЦДХОБТПДОЩК ДЕОШ ЙОЖПТНБГЙПООПЗП ПВЭЕУФЧБ
19 | дЕОШ рЙПОЕТЙЙ
19 | дЕОШ уЧСФПЗП йЧП
21 | дЕОШ ЪБЭЙФЩ ПФ ВЕЪТБВПФЙГЩ
25 | рПУМЕДОЙК ЪЧПОПЛ
27 | дЕОШ ВЙВМЙПФЕЛ
28 | дЕОШ РПЗТБОЙЮОЙЛБ
28 | дЕОШ ИЙНЙЛБ
30 | дЕОШ ЬНБОУЙРЬ
31 | чУЕНЙТОЩК ДЕОШ ВЕЪ ФБВБЛБ
рпдбтлй у дпуфбчлпк об дпн!
оЕПВЩЮОЩЕ РПДБТЛЙ оЕПВЩЮОЩЕ РПДБТЛЙ | тПНБОФЙЮОЩЕ РПДБТЛЙ тПНБОФЙЮОЩЕ РПДБТЛЙ | рТЙЛПМЩ, ТПЪЩЗТЩЫЙ рТЙЛПМЩ, ТПЪЩЗТЩЫЙ
рПДБТЛЙ ЦЕОЭЙОБН рПДБТЛЙ ЦЕОЭЙОБН | нПДОЩЕ ЙЗТХЫЛЙ нПДОЩЕ ЙЗТХЫЛЙ | рПДБТЛЙ НХЦЮЙОБН рПДБТЛЙ НХЦЮЙОБН
 | нБЗБЪЙОЩ ДМС ЧУЕК УЕНШЙ: (095) 952-14-14

йнеойоойлй

18.05 йТЙОБ, сЛПЧ
19.05 дЕОЙУ, нЙИЕК
20.05 бЛБЛЙК, йПУЙЖ, оЙМ
21.05 бТУЕОЙК, йЧБО, рЙНЕО
22.05 оЙЛПМБК, уЕЧЕТЙО, иТЙУФПЖПТ
рпдрйулб
рТБЪДОЙЮОЩЕ ОПЧПУФЙ ЛБЦДХА ОЕДЕМА РПЮФПК:

учпс пфлтщфлб
ъБЗТХЪЙФЕ УЧПА ПФЛТЩФЛХ ДМС ПФРТБЧЛЙ

йУРПМШЪХКФЕ jpeg- ЙМЙ gif-ЖБКМ, ПВЯЕНПН ДП 50 KB У ТБЪНЕТПН ВПМШЫЕК УФПТПОЩ ДП 400 РЙЛУЕМЕК.

оБКФЙ ЛБТФЙОЛХ ДМС ПФЛТЩФЛЙ »
рТЕДМПЦЙФШ УЧПА ПФЛТЩФЛХ »

чБЫЙ ПФЪЩЧЩ П ОБЫЕК ТБВПФЕ

чБЫ e-mail:

Copyright © 1999-2006 Mail.Ru, пВТБФОБС УЧСЪШ

Rambler's Top100 Service


Чат @MAIL.RU: Многокомнатный чат. 4426 человек в чате.

Поиск по Интернету

• Хотите улучшить или обсудить работу Чата?
Вступайте в сообщество Чат@Mail.ru на Блогах@Mail.ru!

Голосовой портал@Mail.Ru

Голосовой чат
позволяет абонентам общаться в виртуальном чате в режиме on-line. Все очень просто! Абонент звонит по короткому номеру 0936, выбирает опцию «Голосовой чат», заходит в одну из комнат чата и общается!
А также:
РингТаун
Служба знакомств
Голосовые поздравления

Купи на аукционе!

• Ноутбук:
модную сумочку по низкой цене!

         сумки на Молоток.Ру
Сейчас в чате 4426 человек
Имя: (Регистрация)
Пароль: (Забыли?)
Имя в чате:
Цвет имени в чате:
Цвет сообщений в чате:
Початимся про...
Только сообщения посетителей
Без сообщений игнорирования
Нажимая кнопку "ЧатиЦа", Вы принимаете условия пользовательского соглашения

Вход в старый чат »
Скопилось много фотографий?
Покажи друзьям!
Удобно хранить и показывать!
Фото@Mail.ru это:
  • быстрая загрузка,
  • хранение оригиналов,
  • редактирование фотографий,
  • возможность ограничения доступа только для друзей,
  • различные конкурсы

    • Завести свой фотоальбом

    Поиск:
    В Интернете В Картинках

    Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
    Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
    Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Чаты · WiW · Жуки
    Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

    Copyright © 1999-2006 Mail.Ru, Помощь, Обратная связь


Рассылки @MAIL.RU: Служба почтовых рассылок

Рассылки Интернет

КАТАЛОГ РЕЙТИНГ РАССЫЛОК НОВЫЙ ПОДПИСЧИК СОЗДАТЬ РАССЫЛКУ ОТПРАВИТЬ РАССЫЛКУ СТАТИСТИКА

Вниманию авторов:
Полная свобода управления рекламой!
Скидки до 45%
Подробности ...

КАТАЛОГ БЕСПЛАТНЫХ ПОЧТОВЫХ РАССЫЛОК
Авто
Автолитература, Автоновости, Аксессуары и тюнинг, Новости автобрендов, Предложения автомобилей

Бизнес и финансы
Автоматизация бизнеса, Безопасность и бизнес, Бизнес-идеи, Инновации, Бизнес-класс, Бизнес-партнерство, Маркетинг, Реклама, Менеджмент, Налоги, аудит, консалтинг, Финансы

Государство и общество
Политика , Право

Домашний очаг
Братья меньшие, Дамский клуб, Дети, Кухня, Мода и красота, Праздники, Ремонт. Интерьер., Рукоделие

Интернет
e-Business, Обозрения, Создание сайтов

Компьютеры
Безопасность, Все о Windows, Железо, Компьютерная графика, Новости IT, Программирование, Софт

Культура/Искусство
Звёзды театра и кино, Изобразительное искусство, Кино, Видео, TV, Литература, Музыка, Театральная жизнь

Медицина и здоровье
Болезни, В помощь медику, Диетология, Здоровье женщины, Здоровье ребенка, Нетрадиционная медицина, Новости медицины

Наука/Техника
Науки oбщественные, Науки естественные, Психология, Техника

Непознанное
Гороскопы, гадания, Магия, Мистика и паранормальное, Религия

Образование
Гранты и конкурсы, Иностранные языки, Образование за рубежом, Семинары и тренинги, Школа

Отдых
Активный отдых, Знакомства, Игры, Светская жизнь, Хобби

Отрасли экономики
Логистика и транспорт, Металлургия, Недвижимость, Полиграфия, Строительство

Работа и заработок
Работа в России, Советы работнику, Работа@Mail.Ru: Вакансии по специальностям

Связь
IP телефония, Мобильная связь, Новости телекоммуникаций

СМИ
Новости регионов, Новостные ленты, Прогноз погоды

Спорт
Автоспорт, Единоборства, Фитнес, бодибилдинг, Футбол

Товары и услуги
Справки / Объявления, Товары для быта

Туризм и отдых
Америка, Горящие путевки, Европа, Россия, Туробъявления

Юмор
Анекдоты, Афоризмы, Истории, рассказы, Карикатуры, шаржи, картинки

Географический каталог рассылок: Центральный ФО, Северо-Западный ФО, Приволжский ФО, Уральский ФО, Сибирский ФО, Дальневосточный ФО, Южный ФО, Белоруссия, Украина, Израиль, Свердловская область
ПОДПИСЧИКУ
E-mail:
Пароль:
забыли пароль?
регистрация!
ПОМОЩЬ
В первый раз на Рассылки@mail.ru? Тогда загляните сюда.

Как пользоваться Рассылки@mail.ru

АВТОРУ РАССЫЛКИ
List_ID:
Пароль:
забыли пароль?
регистрация!
РЕКЛАМОДАТЕЛЮ
• Прайс-лист на рекламу
• Разместить рекламу
• Своя рассылка

НОВЫЕ РАССЫЛКИ
Рекомендуем:
Как бросить курить? - рекомендации от www.stopsmoke.ru
Секреты успеха в БИЗНЕСЕ и ЖИЗНИ
Топ-аналитика и новости рынка Форекс от FX Global Hedge Fund
Новости высоких технологий от CyberSecurity.ru
Работа в Объединенных Арабских Эмиратах (ОАЭ)
eduABROAD - обучение на Мальте

18.05.2006 RSS Feed
Бонна: все о нянях
Образ Действия. Звучание Жизни
Напитки со всего света!
Все о Нло, пришельцах , внеземных цивилизациях
Советы и полезные статьи по выбору хостинга и многое другое
Невероятное среди нас!
Красота и здоровье
Мои секреты
Фактор матери
Актобе: прогноз погоды
Астана: прогноз погоды
БОКС: методика тренировок
Про Знакомства - ежедневный женский журнал о знакомствах
Все об азартных играх.
Стратегия Трудоустройства
Интернет-курс от Академии Ключевых Вопросов Бизнеса
Формулы правовых конструкций.
Величайшее богатство в мире
ИАА "Новый взгляд" - новый взгляд на бухгалтерию.

Для быстрой подписки проставьте "галочки", введите Ваш E-mail и нажмите "ok".
Поиск:
В Интернете В Картинках

Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Чаты · WiW · Жуки
Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

Copyright © 1999-2006 Mail.Ru, Обратная связь


Компания Mail.ru

Для прессы

о компании
новости
наша история
логотипы и иллюстрации
пресса о нас

Работайте с нами

наши вакансии

Партнерам

что мы предлагаем
логотипы и иллюстрации
аудитория
прайс-лист
технические требования
наши поставщики
наши контакты
как к нам добраться

Национальная почтовая служба Mail.ru - один из крупнейших порталов российского Интернета. Ежедневная аудитория Mail.ru - более 3 миллионов пользователей. Общее число регистраций со дня основания - около 50 миллионов.

Mail.ru - самый быстроразвивающийся российский интернет-ресурс. Через почтовые ящики Mail.ru ежедневно проходит более 25 миллионов писем. Mail.ru занимает лидирующую позицию среди бесплатных почтовых сервисов, предоставляя своим пользователям почтовый ящик неограниченного размера с защитой от спама и вирусов, переводчиком, проверкой правописания, архивом для хранения фотографий и многое другое.

Почта | Каталог | Поиск | Афиша | Финансы | Торг
Авто | Спорт | Работа | Софт | Деньги | Молоток
Анекдоты | Знакомства | Рейтинг | Рассылки | Погода | Игра WiW
Открытки | Форумы | Чат | ТВ | Путешествия | Игра Жуки
Словари | Гороскопы | Фото | Новости | Недвижимость |
Mobile | Блоги | Агент | Мой сайт | Энциклопедии |

Новости

17.05.2006 | У Mail.Ru появился новый «Спутник»
16.05.2006 | Молоток – лучшее средство уборки
15.05.2006 | Афиша@Mail.Ru открыла 4 новых города
Все новости... | Подписка на новости:

Обучение в Mail.ru

Приходите к нам на семинары

Реклама на Mail.ru

Развивайте свой бизнес вместе с нами

Борьба со спамом

Получайте только нужные письма

Положения о безопасности

Охраняйте свои данные

© 1999-2005, Mail.Ru


Энциклопедии@MAIL.RU

[?]

· Русская клавиатура

Интернет Картинки Каталог Товары Софт Словари Энциклопедии

Российский энциклопедический словарь

Материалы словаря освещают проблемы истории и современного состояния человечества, значительное внимание уделено вопросам литературы, искусства, религии, права, философии, социологии, экономики, этнологии, представлены сведения по физической и социально-экономической географии, технике, математике, физике, химии, геологии, биологии, медицине, спорту и т. д.

Всемирный биографический энциклопедический словарь

Включает свыше 23,2 тыс. статей об исторических и современных деятелях различных стран и народов мира.

Всемирная история

Интернет-издание энциклопедического словаря представляет историю Европы, Азии, Африки, Америки, Австралии и Океании.

Энциклопедический словарь Брокгауза и Ефрона

Самая крупная дореволюционная русская универсальная энциклопедия, выпущенная акционерным издательским обществом «Ф. А. Брокгауз - И. А. Ефрон». Состоит из 86 томов (82 основных и 4 дополнительных), выходивших в течение 1890-1907 годов.

Энциклопедия «Мифы народов мира»

В энциклопедии излагаются мифологические представления народов мира, ее статьи посвящены богам, духам, полубожественным и демоническим персонажам, эпическим героям, а также основным мифологическим мотивам и образам.

Энциклопедия «Народы и религии мира»

Интернет-версия энциклопедии включает 1262 статьи в разделе «Народы мира», 490 статей в разделе «Религии мира», 125 статей в словаре этнологических понятий, 757 терминов в этнографическом глоссарии.

Материалы предоставлены проектом Рубрикон

© 1999-2006, Mail.Ru © 2001 - 2006 Russ Portal Company Ltd. © 2001 "Большая Российская энциклопедия" Реклама на Mail.Ru


Финансы@MAIL.RU

Rambler's Top100

Поиск по всему миру

НОВОСТИ ПРОИСШЕСТВИЯ ФИНАНСЫ ОБЩЕСТВО ИНТЕРНЕТ СПОРТ АВТО ПОГОДА

РЫНКИ
» Акции и облигации
» Валюта
» Товарные рынки
ЭКОНОМИКА И ПОЛИТИКА
» В России
» Экономика и политика
» Отрасли и компании
» Банки
» Страхование
» Налоги
» Недвижимость
В МИРЕ
ЧАСТНЫЙ ИНТЕРЕС
» Горящие распродажи
НОВОСТИ ИЗ ПЕРВЫХ РУК
» Экономика
» Макроэкономика
» Компании
» Политика
» Разное
КАЛЬКУЛЯТОР ДОХОДНОСТИ
КАЛЬКУЛЯТОР РАНТЬЕ
КАЛЬКУЛЯТОР ОСАГО
КРЕДИТНЫЙ КАЛЬКУЛЯТОР
КОНВЕРТЕР ВАЛЮТ
СЛОВАРЬ
АРХИВ
RSS Лента новостей
Добавить свою новость »
Последние обсуждения
  • 01.03 Отказ от доллара (754)
  • 22.03 «Газпром» предлагает рассмотреть вопрос об увеличении тарифов на газ (280)
  • 07.09 Москвичей в России ненавидят уже 2\3 сограждан (6697)
  • 17.05 В Москве вводится автоматизированная система учета энергопотребления (3)
  • 13.01 Чей будет Крым? (7454)
  • 18.05 Украина готова перепродать "Криворожсталь" за 6 миллиардов долларов (1)
  • 18.05 Кудрин: Россия поведет переговоры о досрочном погашении долга перед Парижским клубом по номиналу (1)
  • 17.05 Польские сантехники оккупировали Лондон (3)
  • 26.11 Очевидец: что происходит в Киеве сейчас (505)
  • 11.05 Фрадков пообещал расправиться с коррупцией (9)
Наиболее обсуждаемые события
  • 01.11 Великая Россия или Bеликие потрясения?! (1470)
  • 24.11 Подлинное политическое лицо Ющенко (1150)
  • 05.03 42% российских менеджеров - женщины (1091)
  • 14.07 Ющенко подкинули на лекарства (1065)
  • 05.03 Как молодой семье стать семьей с квартирой (875)
  • 29.12 Оранжевая сказка (845)
  • 03.03 Конец СНГ? (835)
  • 30.12 Украина после выборов 30.12 (обновлено 16:45) (596)
  • 08.02 Вызов истории: а есть ли у нас элита? (457)
  • 17.12 Украина 17.12: хроника событий (обновлено в 19:01) (416)
Установи informer!
Словарь Финам.RU - 18000 терминов!
ГЛАВНОЕ
Кудрин: Россия поведет переговоры о досрочном погашении долга перед Парижским клубом по номиналу

Кудрин: Россия поведет переговоры о досрочном погашении долга перед Парижским клубом по номиналу

Россия будет вести переговоры о досрочном погашении долга перед Парижским клубом кредиторов по номиналу. Об этом в интервью ПРАЙМ-ТАСС заявил министр финансов России Алексей Кудрин. «Россия предложила погашение на условиях прошлого года и консультации только-только начались», - сказал Кудрин, отвечая на вопрос о возможности выплаты премии за досрочное погашение этого долга. Министр отметил, что Россия получила принципиальную поддержку стран-членов клуба по вопросу второго досрочного погашения долга. ...

подробнее »
18.05 Доброе утро!
17.05 ВЭФ призывает пересмотреть старую модель энергетической безопасности
17.05 Финансовые итоги дня: 17 мая
ТОВАРНЫЕ РЫНКИ
В Красноярске сняли с продажи 17 тысяч партий вина из Грузии и Молдавии

В Красноярске сняли с продажи 17 тысяч партий вина из Грузии и Молдавии

В Красноярском крае сотрудники Роспотребнадзора сняли с продажи 17 тысяч партий грузинского и молдавского вина. Общий объем изъятого вина составил 312,5 тысяч литров, сообщил в четверг на встрече с журналистами руководитель территориального управления федеральной службы по надзору в сфере защиты прав потребителей и благополучия человека Сергей Куркатов.
По его словам, по заданию главного санитарного врача России, связанного с оценкой качества алкоголя молдавского и грузинского происхождения, ...

подробнее »
18.05 За продажу некачественного бензина в Москве будут сажать
18.05 Финляндия обеспокоена введением Россией пошлины за временную регистрацию иностранных автомобилей
18.05 Почему дешевеет нефть
ЭКОНОМИКА И ПОЛИТИКА
Финансовые итоги дня: 18 мая

Финансовые итоги дня: 18 мая

Официальный курс доллара на 19 мая составил 27 рублей 7 копеек. Курс евро - 34 рубля 51 копейка.

Экономика и политика

Россия будет вести переговоры о досрочном погашении долга перед Парижским клубом кредиторов по номиналу.
Подробнее об этом читайте в статье Кудрин: Россия поведет переговоры о досрочном погашении долга перед Парижским клубом по номиналу

Обещанные недавно президентом беспрецедентные государственные затраты на материальное обеспечение демографической стабилизации ...

подробнее »
18.05 РЖД и Siemens подпишут сегодня контракт на поставку 8 высокоскоростных поездов
18.05 Программа стимулирования рождаемости распухает от расходных статей
18.05 Депутаты хотят приравнять выкуп земли под предприятиями к долгосрочной аренде
ОТРАСЛИ И КОМПАНИИ
Освоение арктического шельфа. Первые шаги.

Освоение арктического шельфа. Первые шаги.

Одним важнейшим участником рынка водных транспортных перевозок являются российские грузоотправители. Сегодня ведущие российские корпорации, будучи нацелены на капитализацию своих активов, заинтересованы в повышении прозрачности структуры и потоков своей финансово-экономической деятельности. Это также двигает спрос в сторону транспортных компаний-резидентов.
Глава Минпромэнерго сказал, что еще три года назад треугольник Судовладелец – Судостроитель – Грузовладелец не вписывался в территорию России. ...

подробнее »
18.05 Христенко не исключает объединения Транснефти и Транснефтепродукта
18.05 «ПАВА» создаст крупнейшую в России оптовую сеть
17.05 «ЛУКОЙЛ» заинтересован в покупке НПЗ и розничной сети в Европе
В МИРЕ
Украина готова перепродать "Криворожсталь" за 6 миллиардов долларов

Украина готова перепродать "Криворожсталь" за 6 миллиардов долларов

Украинский металлургический комбинат "Криворожсталь" может быть продан за 6 миллиардов долларов. Об этом заявила председатель Фона госимущества (ФГИ) республики Валентина Семенюк.
При этом она отказалась конкретизировать предполагаемых покупателей предприятия. "Это несколько национальных и зарубежных инвесторов, которые готовы заплатить 30 миллиардов гривен", - сообщила глава ФГИ.
По ее словам, речь идет не о реприватизации, а о контроле со стороны государства за выполнением инвестиционных ...

подробнее »
18.05 Инвестиции в основные фонды китайской экономики выросли на 29,6%
18.05 Финансовые биржи Бразилии лихорадит от резких колебаний доллара
18.05 Fitch: Растущие риски в развивающихся странах Европы
НАЛОГИ
С командировочных будет взыматься подоходный налог

С командировочных будет взыматься подоходный налог

Минфин добился от правительства внесения в Госдуму поправок в Налоговый кодекс, в соответствии с которыми с 2007 года суточные в размере свыше 100 руб. для командировок по России должны будут облагаться тринадцатипроцентным налогом на доходы физических лиц (НДФЛ). Принятием этих поправок Минфин хочет положить конец тянущемуся полтора года спору с Высшим арбитражным судом (ВАС) России, который в январе прошлого года признал недействующим письмо Федеральной налоговой службы (ФНС) о взимании налога ...

подробнее »
12.05 IT-компаниям могут дать налоговые льготы
11.05 Подоходные налоги граждан предлагают «привязать» к месту жительства
04.05 Сколько даст пошлина на нефть?
АКЦИИ И ОБЛИГАЦИИ
IPO Роснефти состоится при благоприятных условиях

IPO Роснефти состоится при благоприятных условиях

Первичное публичное размещение акций (IPO) Роснефти состоится, когда для этого будут самые благоприятные условия, заявил глава Минпромэнерго РФ Виктор Христенко.
Отвечая в четверг на вопрос журналистов, успеют ли в этом году провести IPO Роснефти, Христенко сказал: "Всегда важно все делать вовремя, когда рынок хороший, когда риски низкие и когда эффект от той или иной операции самый высокий".
Министр отметил, что в данном случае здесь нет того праздника, к дате которого надо приурочить IPO ...

подробнее »
18.05 "Удмуртнефть" выплатит 16,8 млрд. рублей дивидендов
18.05 На японском фондовом рынке резко упали курсы акций
18.05 ММК хочет купить акции Arcelor
НЕДВИЖИМОСТЬ
ФСФР отменит страховку для граждан, оформивших ипотеку

ФСФР отменит страховку для граждан, оформивших ипотеку

Федеральная служба по финансовым рынкам (ФСФР) предлагает отменить обязательное страхование жизни и здоровья для граждан, оформляющих ипотечные кредиты. Такая мера содержится в разработанных ФСФР поправках в федеральный закон "Об ипотечных ценных бумагах", которые в четверг будут обсуждаться на заседании правительства РФ.
Как отмечается в материалах ФСФР к заседанию правительства, закон об ипотечных ценных бумагах предусматривает, что, если должником по обеспеченному ипотекой обязательству является ...

подробнее »
16.05 Утверждены правила предоставления жилищных субсидий регионам
16.05 Апрельский прирост цен на московские квартиры составил 9,4%
15.05 Темпы роста цен на московскую недвижимость начали спадать
БАНКИ
Банкам не хватает сотрудников

Банкам не хватает сотрудников

Бурный рост банковского розничного бизнеса, увеличение кредитования населения, открытие новых филиалов и допофисов заставили финансовые институты столкнуться с проблемой резкого дефицита кадров. В банках просто физически не хватает людей, которые могли бы обслуживать частных клиентов. Как заявил на прошедшей на днях первой межбанковской конференции «Человек как капитал. Новый этап в управлении человеческими ресурсами в России» директор по персоналу Росбанка Сергей Дерябин, примерно 50% банковских ...

подробнее »
16.05 Потребительские кредиты как причина слеующего банковского кризиса
16.05 Чем опасны для России филиалы иностранных банков
15.05 Morgan Stanley не видит каких-либо кризисных явлений на российском рынке капитала
ВАЛЮТА
Польша не объявила дату присоединения к зоне евро

Польша не объявила дату присоединения к зоне евро

Из десяти новых членов Евросоюза, вступивших в эту региональную организацию с 1 мая 2004 года, с датой присоединения к зоне евро пока не определилась одна лишь Польша, отмечают региональные СМИ.
Согласно последним заявлением польских политиков, Варшава будет готова рассмотреть эту перспективу не ранее 2009 года.
Еврокомиссия и Европейский центральный банк одобрили во вторник переход Словении с толара на евро с 1 января 2007 года, вместе с тем, отложив по причине высокого уровня инфляции ...

подробнее »
17.05 Словения войдет в евро, а Литву просят подождать
11.05 Кувейт ревальвировал курс динара
11.05 Минфин США одобряет полную конвертируемость рубля
ЧАСТНЫЙ ИНТЕРЕС
Матерям будут платить деньги Стабфонда

Матерям будут платить деньги Стабфонда

Спикер нижней палаты российского парламента Борис Грызлов не исключает, что выплаты для женщин, родивших второго ребенка, в размере 250 тысяч рублей с 2010 года будут осуществляться, в том числе, и за счет средств стабилизационного фонда.
В беседе с журналистами он подчеркнул, что для финансовой поддержки молодых семей при рождении детей в 2007 году стабфонд "распечатан не будет".
Грызлов отметил, что все предложения, озвученные президентом в ежегодном послании Федеральному собранию, касающиеся ...

подробнее »
14.04 Наш пофигизм бьет западные методики
14.04 Власти Владивостока заставят китайских торговцев говорить по-русски
10.04 МЧС РФ: С февраля 2006 года в России уничтожено 1,377 млн. птиц
СТРАХОВАНИЕ
РСА намерен всерьез заняться профилактикой ДТП

РСА намерен всерьез заняться профилактикой ДТП

Российский союз автостраховщиков (РСА) объявил о том, что намерен всерьез заняться профилактикой ДТП. Аналогично западным страховым компаниям, которые вкладывают достаточно много сил и денег в предупреждение травматизма на дорогах. Ни о какой благотворительности здесь речи не идет - чистая экономика. Ведь объемы выплат компаний по ОСАГО напрямую зависят от уровня травматизма и количества ДТП, которое в России уверенно растет год от года. На днях РСА представил доклад "Вопросы ОСАГО и безопасность ...

подробнее »
21.04 Бойтесь страховщиков, дары приносящих
18.04 РОСНО будет скупать страховщиков в России и СНГ
30.03 Сколько стоит взорвать Нью-Йорк?
Доходность сектора рынка
Доходность сектора
TOP доходности инструментов
Сбербанк-п | 19.05.05 | 17.05.06 | 390,94
Татнфт 3ап | 19.05.05 | 17.05.06 | 323,81
Татнфт 3ао | 19.05.05 | 17.05.06 | 280,71
ИркЭнерго | 19.05.05 | 17.05.06 | 270,09
ЛУКОЙЛ | 19.05.05 | 17.05.06 | 235,55
РАО ЕЭС-п | 21.11.05 | 17.05.06 | 162,59
РАО ЕЭС | 21.11.05 | 17.05.06 | 157,68
Сбербанк-п | 21.11.05 | 17.05.06 | 154,99
ГМКННик5ао | 21.11.05 | 17.05.06 | 149,69
Аэрофлот | 21.11.05 | 17.05.06 | 149,17
ГМКННик5ао | 19.04.06 | 17.05.06 | 110,59
+МосЭнерго | 19.04.06 | 17.05.06 | 102,97
Сбербанк | 19.04.06 | 17.05.06 | 96,22
Сибнефть | 19.04.06 | 17.05.06 | 94,1
ИркЭнерго | 19.04.06 | 17.05.06 | 93,4
+МосЭнерго | 12.05.06 | 17.05.06 | 101,77
ЮКОС-ао | 12.05.06 | 17.05.06 | 99,42
Ростел -ао | 12.05.06 | 17.05.06 | 98,14
ИркЭнерго | 12.05.06 | 17.05.06 | 98,11
Аэрофлот | 12.05.06 | 17.05.06 | 97,48

Калькулятор доходности
Начальная сумма 100
Базовая валюта
Сектор
Инструмент
Начало периода
. . Календарь
Окончание периода
. . Календарь
Итог
Валюта
USD/RUR | 26.96 | -0.237% | 18.05 ЦБ
EUR/RUR | 34.7 | 0.246% | 18.05 ЦБ
Eur/Usd | 1.2826 | 0.62% | 23:59
Eur/Jpy | 142.36 | 0.643% | 23:59
Usd/Chf | 1.2089 | -0.51% | 23:59
Gbp/Usd | 1.8909 | 0.414% | 23:59
Usd/Jpy | 111.05 | 0.054% | 23:59
Eur/Chf | 1.5501 | 0.136% | 23:58
Индикаторы рынка
Индексы
RTSI | 1490.64 | -3.41% | 18:45
ММВБ10 | 2144.43 | -2.457% | 19:00
S&P Fut | 1265.1 | -0.307% | 23:58
Индексы Финам
IEESR | 0.6342 | 17.095 | -4.409% | 18:44
ILKOH | 79.609 | 2146 | -2.143% | 18:44
IRTKM | 3.2296 | 87.06 | -2.191% | 18:44
ISNGS | 1.417 | 38.198 | -4.023% | 18:44
ISBER | 1561.4 | 42090 | 0.217% | 18:44
IGMKN | 126.61 | 3413 | -3.18% | 18:44
ITATN | 4.6367 | 124.99 | -3.832% | 18:44
IMSNG | 0.1878 | 5.062 | -2.091% | 18:44
IGAZP | 10.535 | 284 | -2.906% | 18:44
IYUKO | 0.9348 | 25.199 | -2.706% | 18:44
АДР (Лондон)
GAZP (Анг) | 10.575 | -2.714% | 21:02
LKOH (Анг) | 81 | -0.613% | 20:42
EESR (Анг) | 0.63 | -5.12% | 20:42
NKEL (Анг) | 127.909 | -4.9% | 20:42
GLDN (NASDAQ) | 27.66 | -0.324% | 23:59
Copyright © 2004 Mail.Ru, Обратная связь

При любом использовании материалов ссылка на Финансы@Mail.ru обязательна.
При цитировании и использовании в интернете гиперссылка на http://finance.mail.ru/ обязательна.

liveinternet.ru: показано число посетителей за сегодня


Компьютерный форум Ru.Board

Перейти из форума на сайт. Реклама на Ru.Board
SurfControl - мировой лидер по разработке средств Web и E-mail фильтрации Директор спросил меня:
"Мы можем контролировать ТРАФИК, блокировать СПАМ, запретить ПОРНО и ICQ?"
Я подумал и ответил: "Да, надо установить SurfControl".
Новости • Файловые архивы
Активные темы • Новые темы • Поиск
Правила • Фотогалерея • Газета • Топ лист • Кто в on-line?
Вход • Забыли пароль? • Первый раз на этом сайте? • Регистрация
Главные новости IT за 19.05.2006, Пятница | Все новости
В Подмосковье загорелась подстанция научного центра | Россия: в борьбу с коррупцией вступают ИТ
Названы самые популярные сайты в мире | Русский стал чемпионом мира по программированию
Хостинг-Центр РБК - НАМ ДОВЕРЯЮТ
Microsoft. Бесплатная разработка плана по повышению уровня безопасности вашей компании.
11-02-2006 В помощь сисадмину: Групповые политики Active Directory
Внимание! Кому не приходит пароль, запросите его тут.
Привет, Guest
Приветствуем новичка по имени basse
Участников 487529, 8403154 сообщ. в 374432 темах
Информация о форуме Ответы Темы Модератор Обновления
Форум Закладки Закладки 777 1 Guest Дата: 02-09-2005
Время: 20:44
Автор:scales01
Последний ответ на форуме Закладки Форум-Закладки. Новая фича на...
» Компьютеры
Форум Операционные системы Операционные системы
Выбор, установка, настройка, решение проблем с операционными системами.
Включает форумы: Microsoft Windows, UNIX, Другие ОС 		195208 17900 Demetrio, lynx, dg, evle, vu1tur Дата: 19-05-2006
Время: 01:34
Автор:krukoff
Последний ответ на форуме Операционные системы Меню "Отправить" ("S...
Форум Игры Игры
Все о компьютерных играх и вокруг них. (Активные темы)
Включает форумы: Общие вопросы, Strategy, Action & Arcade, RPG & Adventure, Sport & Simulation, Небольшие интересные игры, Форумные Онлайн-Игры. 		850738 15328 Vasya Pupkin, Cossack, RapSoldier, VdV Дата: 19-05-2006
Время: 01:03
Автор:Karina
Последний ответ на форуме Игры Флейм НИИ (продолжение 8)
Форум Цифровое изображение Цифровое изображение
Обсуждение цифровой видео и фото техники. 		79166 1782 GoodCos13, xy Дата: 19-05-2006
Время: 01:27
Автор:Lailani
Последний ответ на форуме Цифровое изображение === Фуджи Флейм Кафе #2 ===
Форум Программы
Программы при поддержке SurfControl - мировой лидер по разработке средств Web и E-mail фильтрации
Программное обеспечение компьютеров. 		763026 38510 Nep, Widok Дата: 19-05-2006
Время: 01:36
Автор:p1415
Последний ответ на форуме Программы BitTorrent/Azureus/BitComet/BitLord...
Форум В помощь системному администратору В помощь системному администратору
Решение проблем с локальными и глобальными компьютерными сетями. Выбор и настройка сетевого ПО, оборудования, управление пользователями и правами, теоретические вопросы. 		218910 30902 lynx, Crash_Master, dg, emx Дата: 19-05-2006
Время: 01:02
Автор:Vby
Последний ответ на форуме В помощь системному администратору Какой модем выбрать?
Форум Прикладное программирование Прикладное программирование
Delphi, C\C++, Python, Assembler ... 		99996 13554 ShIvADeSt Дата: 19-05-2006
Время: 01:33
Автор:ShIvADeSt
Последний ответ на форуме Прикладное программирование Delphi , заполненный ComboBox как?
Форум Hardware Hardware
Форум по железной части компьютера. (Активные темы)
Общие вопросы
Драйверы и прошивки BIOS
Видеосистема
Оптические носители информации
Магнитные носители информации
Периферийные устройства
Выбор комплектующих 		431878 31606 storm, Dekker, Dr_StandBy, GoodCos13 Дата: 19-05-2006
Время: 00:51
Автор:nickjust
Последний ответ на форуме Hardware DVD±RW LG GSA-4163B - DVD Multi...
» Интернет
Форум Web-программирование Web-программирование
Perl, PHP, JavaScript, HTML и другие языки под веб. 		113088 20022 Cheery Дата: 18-05-2006
Время: 23:48
Автор:dupatan
Новая тема на форуме Web-программирование страница заданного размера
Форум В помощь вебмастеру В помощь вебмастеру
Раскрутка, скрипты, инструментарий и все, что нужно для сайта. 		80930 11826 Cheery Дата: 18-05-2006
Время: 23:05
Автор:mv4u
Последний ответ на форуме В помощь вебмастеру Скрипт фотогалереи 4images - Image ...
Форум Графика Графика
Компьютерная графика и Web дизайн. 		85084 6004 Ausw Дата: 18-05-2006
Время: 21:18
Автор:freem
Последний ответ на форуме Графика Macromedia Flash. Самые разные...
Форум Хостинг
Хостинг Рекомендуем Хостинг-Центр РБК - НАМ ДОВЕРЯЮТ
Разговоры про хостинг: платный, бесплатный, и все, что с ним связано. 		103948 6692 3xp0 Дата: 18-05-2006
Время: 22:17
Автор:Pleshkov
Последний ответ на форуме Хостинг Где можно беспалтно зарегить домен ...
Форум Зацените-ка! Зацените-ка!
Кидаете ссылку на свой сайт и получаете отзывы, советы, порицания по дизайну, содержанию и т.д. и т.п. 		101338 10232 Ausw Дата: 19-05-2006
Время: 01:32
Автор:diezel
Последний ответ на форуме Зацените-ка! -=Флейм=-
» Тематические
Форум IkonBoard и другие форумы IkonBoard и другие форумы
Лучшие бесплатные движки вебконференций для вашего сайта. Поставьте себе форум! Мы поможем! (Активные темы)
Включает форумы: IkonBoard 2, IkonBoard 3, Invision Board, Другие форумы. 		71780 9944 Antuan, Dekker Дата: 18-05-2006
Время: 15:49
Автор:CheRt
Последний ответ на форуме IkonBoard и другие форумы Расскажите о своем форуме на базе I...
Форум PHP-Nuke и другие порталы PHP-Nuke и другие порталы
Постройте свой веб портал быстро и просто! 		52338 5392 Antuan Дата: 18-05-2006
Время: 21:51
Автор:Jan MOSAD
Последний ответ на форуме PHP-Nuke и другие порталы Koobi
Форум Мобила Мобила
Обсуждение мобильных средств связи. 		145244 7808 Nep, TechSup Дата: 19-05-2006
Время: 00:50
Автор:TechSup
Последний ответ на форуме Мобила Параметры качества услуги GPRS
» Общие
Форум Спорт Спорт
Все о спорте. (Активные темы)
Включает форумы: Общий форум, Ru.Board Прогноз. 		395300 4022 Bunker, Cossack Дата: 19-05-2006
Время: 01:10
Автор:ROBUS
Последний ответ на форуме Спорт Сборная РуБорда на УЕФА
Форум Флейм Флейм
Свобода слова! Разговаривать можно о чем угодно.
Темы по региональным встречам 		695060 18594 TechSup Дата: 19-05-2006
Время: 01:31
Автор:Churchill
Последний ответ на форуме Флейм О современной России рассуждаем зде...
Форум Музыка и Кино Музыка и Кино
Мы это слушаем, мы это смотрим! Обсуждаем, обмениваемся мнениями, критикуем, советуем. 		305204 11608 PrincesskaMarishka, Widok Дата: 19-05-2006
Время: 01:19
Автор:Riviera
Последний ответ на форуме Музыка и Кино Музыка из различных реклам
Форум Юмор Юмор
Юмор, сатира, приколы. 		99656 7572 Dekker Дата: 19-05-2006
Время: 00:37
Автор:krukoff
Последний ответ на форуме Юмор Разговорчик двух девочек
Форум Художественная Литература Художественная Литература 133702 3042 Fair Kender Дата: 19-05-2006
Время: 00:23
Автор:EHOT_XPEHOB
Последний ответ на форуме Художественная Литература А.И. Солженицын.
» Ru.Board
Форум Помощь по Ru.Board Помощь по Ru.Board
Проблемы, технические вопросы, предложения, как по форуму, так и по сайту в целом. 		90182 3508 batva, DimoN Дата: 18-05-2006
Время: 22:09
Автор:NPC
Последний ответ на форуме Помощь по Ru.Board Трансляция новостей от Cnews
» Андеграунд
Форум eBookz eBookz
Техническая, компьютерная, научная и обучающая литература в электронном виде. Вопросы сканирования и распространения. Обсуждение книг. 		226290 3024 kvk, albel Дата: 19-05-2006
Время: 01:22
Автор:reenoip
Последний ответ на форуме eBookz Компьютерные (IT) книги на РУССКОМ ...
Форум Варезник Варезник
Вы что-то ищете? Вам сюда. Объявления о поиске программного обеспечения и все находки в этом форуме. 		2036264 59162 Nep Дата: 19-05-2006
Время: 01:36
Автор:Palixa
Последний ответ на форуме Варезник PE Explorer
Форум Андеграунд Андеграунд
Общие разговоры. Взлом и защита. Хак, трояны, вирусы и все остальное в мире андеграунда обсуждаем тут. 		178336 12410 Nep, emx Дата: 19-05-2006
Время: 01:34
Автор:igcomp
Последний ответ на форуме Андеграунд Юзверь VS Админ!
Форум Игры и Фильмы Игры и Фильмы
Поиск игр и видеофильмов. Здесь только поиск, а обсуждение в соответствующих форумах: Игры, Фильмы.
Поиск небольших интересных игр. 		236736 12754 Nep, Vasya Pupkin, Widok Дата: 19-05-2006
Время: 01:21
Автор:DarkSlayer
Последний ответ на форуме Игры и Фильмы Heroes Of Might And Magic V (c)...
» Специальные
Форум Тестирование Тестирование
Тут и только тут можно и нужно тестировать скрипт этого форума, проверять свои подписи, лого, тренироваться и учиться правильно использовать IB коды и смайлики и т.д. 		267552 6496 articlebot Дата: 19-05-2006
Время: 01:04
Автор:NORIO
Последний ответ на форуме Тестирование ЂЃ‚ѓ„…†‡€‰Љ‹ЊЌЋЏђ‘’“”•–—&...
Форум Блоги Блоги
Тестирование 		5434 388 articlebot Дата: 17-05-2006
Время: 11:11
Автор:ntfs
Последний ответ на форуме Блоги Исправления для Windows Server 2003...
За последние 15 минут были на конференции:
Посетители на форумах
Всего в on-line: 869. Гостей: 461. Постояльцев: 408. Рекорд посещаемости 2375 человек установлен 20-03-2006 16:27.
» Per_aspera_ad_astra » Alessan » Dima1 » Palixa » creasot » SAnTAN » Wolf RU » SPOKAN » ceramist » TrAlex » Dust112 » Donatello » mymuss » SharmanshikKarlo » roze2003 » zorrack » Wassabi » ssopety » ShIvADeSt » citos » airus » kirasir » krukoff » Abs62 » belikto » dimka9 » yODAN » lirus » vpr2 » tiir » Karina » fontomas » manoff » Poltinik » baires » LeeY » megaxep » Cooon » DemonA » ExNehilo » Caira [ Смотреть весь список ].

Как качать с торрента, осла, rapidshare?
Способ скачивать десятки гигабайт на модеме, потребляя килобайты.

Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2007


ФОТО@MAIL.RU

Почта Почта Агент Агент Открытки Открытки Деньги Деньги Блоги Блоги Авто Авто Все проекты
Фотографий на проекте: 19 836 227
Добавлено сегодня: 6 405

Имя ( регистрация )
Пароль ( забыли?)
Главная
Фотографии по темам
Конкурс: Жизнь пробуждается!
Конкурс: «Опубликуй подружку!»
Конкурс: «МОТОПОРТРЕТ»
Конкурс: «Комната смеха»
Конкурс: «Автора на сцену!»
Фотошкола
Фотокамеры
Моя страница

Хотите поговорить о фотографии?

Или показать свои работы?
Присоединяйтесь к фото-соообществам на Блогах@Mail.ru!

Необычные фотографии
Чёрно-белые фотографии
Фото животных
фотографируем

Фото-Лидер

Занять это место!
Рыбак, е-мое...
Автор: VNorway Ставок: 1

Лучшее фото

moto_girl

Автор: Lusik

SMS - топ Занять это место!
where are you..ou es-tu..dov ...
Автор: Aidan Graham
Всё очень просто
Автор: Татьяна Колпакова
Я с дочкой
Автор: Andrey Kuvshinof
Рыбак, е-мое...
Автор: VNorway
<без названия>
Автор: Наталия
Вот он Я
Автор: ЛЁха
<без названия>
Автор: polina003@mail.ru
Биц...
Автор: Космос
<без названия>
Автор: Юлия Девушкина

Фотографии по темам
Лучшие фото

Комната смеха | 2694
Опубликуй подружку! | 5041
Мобилография | 453
Авто,мото | 345753
Город | 594954
Животные | 605699
Звезды | 658394
Искусство | 455209

Макро | 109152
Пейзаж | 326786
Портреты | 2557282
Праздники | 966722
Природа | 652664
Путешествия | 1563207
Разное | 7278544
Рисунки | 438784

Семья | 1190960
Спорт | 279377
Техника | 97815
Эротика | 884932
Юмор для взрослых | 29038
Юмор | 373838

Последние добавления
А это я
Автор: <<M@cHO>>
Наша принцесса
Автор: Елена Зарубина
Гла-МУР в ИКРЕ
Автор: Пчела
Форма
Автор: vzor.n@list.ru
<без названия>
Автор: Татьяна Журавель
Вид со Спинакер Тауэр
Автор: -=Monster=-
Ждем хозяина
Автор: Dark Irbis ®
Морской отлив
Автор: Юрий Савинский
Рысь выходит на след
Автор: Хлебников Александр

© 1999-2006, Mail.Ru Пользовательское соглашение Реклама на Mail.ru · О компании · Вакансии · Сувениры


Поиск@Mail.Ru

Интернет Картинки Каталог Товары Софт Словари Энциклопедии


Гороскопы @MAIL.RU

Поиск по Интернету

АНЕКДОТЫ ГОРОСКОПЫ ФОТОГАЛЕРЕЯ АФИША ТВ

» ЗОДИАКАЛЬНЫЙ
» ВОСТОЧНЫЙ
» ПРОГНОЗ on-line
» НУМЕРОЛОГИЯ
» ФЭН-ШУЙ ПРОГНОЗ
» НАТАЛЬНЫЙ NEW
» СОВМЕСТИМОСТИ
» АСТРОСКОП
» ЭРОТИЧЕСКИЙ
» АСТРОПОРТРЕТ

Подписка:

e-mail:
Ежедневный гороскоп
Астропортреты знаменитостей

Астрологический прогноз
Общайся
по-новому

 0936
На канале «Гороскоп+» в любой момент можно узнать астрологический прогноз на день, неделю или год

История астрологии
  • Древняя астрология
  • Астрология друидов
  • Астрология Вавилона
  • Индийская астрология
  • Астрология Китая
  • Тибетская астрология
  • Астрология в Европе
  • Астрология в США
  • Российская астрология

    • Знаки Зодиака на Молоток.Ру

    Астроминералогия
  • Камни для Знаков Зодиака
  • Огранка камней по Зодиаку
  • Бытовые камни - магия стихий
  • Календарь камней

  • Астрологический словарь
            •
    Прогноз на 19 мая 2006

    Сегодня 29-й солнечный и 21-й лунный день, а с 03:01 - 22-й лунный день (с 03:01 до 03:13, 20 мая). день магии Божественного Слова, Божественного юмора и смеха, в лучах которого гибнет всё зло. Покровитель — Николай Угодник в христианской традиции и Мараспент в авестийской. В этот день снимаются покровы и разоблачаются тайны. Чувство юмора проявляется в этот день как ощущение освобождения от своих комплексов.
    Луна в Водолее.
    Cимвол лунного дня слон Ганеша (сын Шивы, покровитель знаний и мудрости), свиток (книга) и золотой ключик.
    Cимвол солнечного дня -Белый Кот, символ учёности, живого знания. Антитотем — Крыса, грех сомнения, тщеславия и зависти.
    Рекомендуется учёба, чтение. Хорошо — стричься, мыться, париться, гулять, но не путешествовать. Рекомендуется чинить, шить, покупать и надевать одежду. После заката можно организовать застолье. День зачатия при свете. Нежелательны духи и косметика.
    Благоприятно узнавать будущее, можно сосредоточиваться на картинах, на янтрах (это изображения священных звуков на бумаге, на песке). В этот день следует быть альтруистом, учить других, передавать опыт, готовить учеников, проявлять щедрость или просто накапливать знания.
    Энергетический центр крестец, тазобедренный пояс. Предпочтительна растительная пища.
    Из примет: Добрые приметы: чихнуть, проснувшись; если окликнут по имени, хорошо слышать повторяющуюся музыку. Находить кожаные изделия, деньги, споткнуться, упасть или если ветер в спину — знак защиты свыше. Плохими приметами являются материальные потери (в том числе волос и ногтей), рвущаяся одежда, обувь. Пища хороша лёгкая: салаты, растительные масла.
    Планета-управитель- Венера
    Камни дня - пестрая яшма, письменный шпат.
    Цвета дня - в одежде хороши блёстки, пестрота, светло-сиреневый цвет, золотистый, желтоватый. Не желательны — тёмные тона, зелёный цвет. Сны будут вещими, если во сне услышишь голоса, музыку. Предмет силы — ножницы, флейта, деревянные чётки. Числа —29,43,65, 56.

    Прогноз на завтра

    О знаках Зодиака
    Овен Овен | Телец Телец | Близнецы Близнецы | Рак Рак
Лев Лев | Дева Дева | Весы Весы | Скорпион Скорпион
Стрелец Стрелец | Козерог Козерог | Водолей Водолей | Рыбы Рыбы
    Совет астролога на май:
    "Всем отдыхать!"
    Овен
    Египет, Филиппины
    Телец
    Германия, Чехия
    Близнецы
    Италия, Египет
    Рак
    Автобусный тур по Европе или паромный - по Скандинавии
    Лев
    ОАЭ, ГОА, Латинская Америка
    Дева
    Франция, Бали
            Весы
    Греция, о-ва Родос и Крит
    Скорпион
    Таиланд
    Стрелец
    Турция, Испания
    Козерог
    Непал, Китай, Швейцария
    Водолей
    Бельгия, Крым, Прибалтика
    Рыбы
    Западная Европа, Япония

    Гороскоп на сегодня:
    Овен Овен | Телец Телец | Близнецы Близнецы | Рак Рак
Лев Лев | Дева Дева | Весы Весы | Скорпион Скорпион
Стрелец Стрелец | Козерог Козерог | Водолей Водолей | Рыбы Рыбы

    Гороскоп на дату:

    пн | вт | ср | чт | пт | сб | вс
01 | 02 | 03 | 04 | 05 | 06 | 07
08 | 09 | 10 | 11 | 12 | 13 | 14
15 | 16 | 17 | 18 | 19 | 20 | 21
22 | 23 | 24 | 25 | 26 | 27 | 28
29 | 30 | 31 |  |  |  |

    Год огненной собаки
    2006 год
    в каталоге List.Mail.ru
  • 2006 год в Каталоге List.Mail.ru
  • Год Красной огненной Собаки
  • Восточные гороскопы на 2006 год
  • Знаки Зодиака в 2006 году
  • Астропрогнозы на 2006 год
  • Астрология в Каталоге List.Mail.ru
  • Гадания в Каталоге List.Mail.ru

    • Астропортрет

    ДЖОРДЖ ХАРРИСОН
    ЗВЕЗДНАЯ ПОЛИТИКА
    БИЗНЕС-АСТРОЛОГИЯ
    ОГОНЬ Д'АРТАНЬЯНА

    Полезные программы
  • Гадание по книге перемен
  • Магия Рун
  • Feng Shui
  • Древо жизни
  • Face Test - определение красоты лица
            •
    Поиск:
    В Интернете В Картинках

    Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
    Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
    Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Чаты · WiW · Жуки
    Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

    © 1999-2006, Mail.Ru, Обратная связь

    TopList


Mail.ru - Хостинг..

НОВОСТИ
ХОСТИНГ
КОНСТРУКТОР
ДОМЕНЫ
ДОПОЛНИТЕЛЬНЫЕ УСЛУГИ
ЛИЧНАЯ СТРАНИЦА
КОНТРОЛЬНАЯ ПАНЕЛЬ
ПОМОЩЬ
О НАС

Курс доллара:

1 у.е. — 28.80 руб.

Клиентская служба:

(495) 363-0306
clients@hosting.mail.ru

Тех. поддержка:

(495) 363-0326
support@hosting.mail.ru

Как нас найти

Стартовый

Объем дискового пространства | 100 Мб
Кол-во почтовых ящиков | 3 шт
SSH | —
MySql | —
Стоимость | 4 у.е.
Заказать

Минимальный

Объем дискового пространства | 300 Мб
Кол-во почтовых ящиков | 25 шт
SSH | есть
MySql | 1
Стоимость | 6,25 у.е.
Заказать

Оптимальный

Объем дискового пространства | 600 Мб
Кол-во почтовых ящиков | неограниченно
SSH | есть
MySql | 3
Стоимость | 11 у.е.
Заказать

Максимальный

Объем дискового пространства | 2000 Мб
Кол-во почтовых ящиков | неограниченно
SSH | есть
MySql | 5
Стоимость | 23 у.е.
Заказать
Регистрация
Логин:
Пароль:
Забыли пароль?

www.
.su | .ru | .com
.net | .ws | .info
.biz | .bz | .org

Новости

График работы Хостинг@Mail.Ru в праздничные дни.
Подробнее...

Изменение графика работы офиса
Подробнее...

Профилактические работы в офисе
Подробнее...

График работы ХОСТИНГ@MAIL.RU в праздники.
Подробнее...

© 1999-2006, Mail.Ru Служба поддержки Реклама на Mail.ru · О компании


Информационный поиск и поиск по сходству.

Уважаемые посетители! Этот сайт посвящен информационному поиску (information retrieval) и поиску по сходству (fuzzy searching).

В частности в поисковом разделе можно найти

  • Поисковые обзоры;
  • Подборку статей;
  • Исходники различных алгоритмов вычисления расстояния Левенштейна и алгоритмов словарной индексации.

Информацию об обновлениях можно найти в разделе «Новости». Для тех, кто не любит тратить свое время на посещение раздела новостей можно подписаться на список рассылки новостей сайта.

Поддержка проекта

Если данный сайт оказался Вам полезным, то опубликуйте, пожалуйста, у себя на странице следующую ссылку: Site devoted to information retrieval and fuzzy search.

Благодарности:
  • Максиму Губину,
  • Джастину Зобелю,
  • Белоконь Андрею,
  • Олегу Ховайко,
а также всем тем многочисленным людям, к которым я обращался с вопросами и которые нашли время, чтобы ответить мне.


ЛЕДИ@MAIL.RU

Почта Почта Поиск Поиск Агент Агент Открытки Открытки Фото Фото Анекдоты Анекдоты Знакомства Знакомства Авто Авто Все проекты
Rambler's Top100

наш партнер: Woman Journal
Красота и здоровье | Красота и здоровье
Мода | Мода
Любовь и секс | Любовь и секс
Деньги и карьера | Деньги и карьера
Кулинария | Кулинария
Дети | Дети
Знаменитости | Знаменитости
Праздники | Праздники
Мир магии | Мир магии

Конкурсы

Участвуй в конкурсе Проверено на себе!
Есть что рассказать? Пиши и выигрывай!

Мужчины о женщинах

Мужские ответы на женские вопросы.

Общение

Леди@Mail.Ru:
Подскажите действенные ср…
Комментарии: 144
Одиночки по жизни:
Сегодня..,вернее уже вчер…
Комментарии: 97
ПЕДИАТРИЯ:
Здравствуйте, после выявл…
Комментарии: 2
Форумы WMJ.ru

Гороскопы

Гороскопы по знакам зодиака на год, неделю, день, нумерология, Фэнь-Шуй.

Выход в свет

Кино, выставки, театры, музеи, события.

Что нового?

Хитовые новости мира кино и моды, жизни знаменитостей.

Мобильная Леди

Популярные мелодии, веселые картинки и анимация, sms-love.

Опросы

С кем вы предпочитаете проводить отпуск?
 | С любимым, все равно где
 | Одна/с подругой на море
 | С друзьями, путешествовать
 | С семьей на даче
 | С семьей на море

Любовь и секс

Отпуск в Италии: мужчины в стиле Dolce vita
Если во время отдыха в Италии у вас не случилось бурного романа с горячим мачо, этому есть только одно объяснение: вы проводили в Италии свой медовый месяц. Дальше »
  • Аборт. Ты уже думала об этом?
  • Устами младенца

Диета и питание

Я хочу худеть так же быстро, как и он
Если мужчина принимается за диету – он, негодяй, быстро теряет свой вес. Намного быстрее нас, женщин. Откуда такая несправедливость? Дальше »
  • Почему я не могу похудеть?
  • Сладкая жизнь

Здоровье

Здравствуй, овуляция!
Итак, вы твердо решили: пора обзаводиться потомством. Не абы как, а совершенно сознательно и разумно. Пока еще предохраняетесь, но уже прошли необходимые обследования... Дальше »
  • Здравствуй, весна! Привет, аллергия!
  • Право Волоса: рекомендации стилистов по уходу за волосами

Деньги и карьера

Почему стервам все, а «нормальным» женщинам остатки?
"Почему не ценятся добросовестные и ответственные работники? А вот нагловатым, со «стратегическим мышлением» достается все: и чужие должности и чужие мужья..." Дальше »
  • По закону подлости
  • Сменить работу, не изменяя себе

Дети

Гиперактивный карапуз
Слишком подвижный ребенок - сущее наказание как для родителей, так и для всех окружающих. Однако чаще всего ребенок и сам не в состоянии контролировать свое поведение. Дальше »
  • Как занять озорника? 5 идей для мамы
  • Играть поздно, говорить рано

Знаменитости

Дмитрий Дюжев: «Я стал актером по просьбе своего папы!»
Мне действительно интересно сыграть историю, ничего не играя. Ведь мы можем существовать в жизни, ничего не играя. Не изображая, как нам плохо или хорошо. Дальше »
  • Валерий Сюткин: «Я поймал жену с другим»
  • Натали Портман: «Когда мне плохо - я смеюсь!»

Красота

В фонтанах ультрафиолета
Наступило лето, а вместе с ним появились вопросы к солнцу. Как правильно защитить лицо в городе и на пляже? На какие средства для безопасного загара стоит обратить внимание, собираясь в жаркие края? Дальше »
  • Запах женщины
  • Новый аромат: три ноты твоего успеха

Статьи о моде

Одежда для женщин, наполненных жизнью
Современная женщина, округлости которой превышают общепринятый стандарт, в совершенстве освоила высокое искусство наряжаться. Взгляните на нее с восхищением – ее задача изначально труднее вашей. Дальше »
  • Как украсить себя летом
  • SEXy Style - соблазнительно и модно всегда!

Кулинария

Острая тема
Говорят, что театр начинается с вешалки. А с чего начинается кухня? Конечно с ножа! Его по праву можно назвать королем кулинарных принадлежностей. Дальше »
  • Золотой час глинтвейна
  • Секреты приготовления шашлыка

Мир магии

Медитация от альфы до омеги
Находясь в этом состоянии, человек обретает способность одной силой мысли бороться с лишним весом, открывать свою душу для новой любви… Дальше »
  • Каменный век: фетишистам на заметку
  • Примани МАНИ-МАНИ…

НОВОСТЬ ЧАСА!

ПРЯМЫЕ РЕПОРТАЖИ
С МЕСТА СОБЫТИЙ
http://zhuki.mail.ru

Знакомства

я
ищу
— лет

Удобная телепрограмма на ТВ@Mail.Ru

Что посмотреть сегодня вечером?
Выбери на свой вкус:
Новости | Развлекательные
Фильмы | Познавательные
Сериалы | Детям
Спорт | Все »
Всегда к вашим услугам:
• более 200 каналов (в том числе, региональные)
• выбор передач по жанрам
• анонсы популярных передач

Открытки@Mail.RU - открытки на все случаи жизни!

В моем сердце всегда есть место для тебя! В моем сердце всегда есть место для тебя! | Самой кря-сивой! Самой кря-сивой!
Очень скучаю! Очень скучаю! | Хочу к тебе! Хочу к тебе!
Приглашение Приглашение | Эмблема любви Эмблема любви
Отправить другую открытку »
© 1999-2006, Mail.Ru Условия использования материалов · Обратная связь · Реклама на Mail.Ru · О компании


Каталог@MAIL.RU

Каталог
Каталог Интернет
Лист.Ру

Автомобили Торговля Автомастер Новости Запчасти Мотоциклы Иномарки | Бизнес и финансы Менеджмент Валюта Юристы Безопасность Банки Налоги | Домашний очаг Кошки Кухня Фазенда Знакомства Ремонт Красота
Интернет Веб-дизайн Навигация Софт Почта Услуги Чаты Бесплатно Общение | Компьютеры Программирование Обои Игры Железо Периферия | Культура и искусство Литература Театр Кино Фото Музыка Mp3 Библиотеки
Медицина и здоровье Лечение Лекарства Ветеринария Здоровье Специалисты Медтехника | Наука и образование Психология ВУЗы Тесты Рефераты ЕГЭ Школы | Непознанное Религия Целительство Мистика Гороскопы Сны Гадания НЛО
Новости и СМИ Новости Газеты Журналы ТВ Электронные Подписка Радио | Общество и политика День Пионеров Право Карты Страны Армия Эмиграция | Отдых и развлечения Туризм Эротика Игры Клубы Развлечения Хобби Страны
Производство Пищевая Полиграфия Мебель Стройматериалы Машиностроение | Работа и заработок Вакансии Работа летом На дому За рубежом Виртуально Курсы | Спорт Виды спорта Фитнес Футбол ЧМ-2006 Хоккей Новости Теннис
Справки Адреса и телефоны Погода Расписания Словари Цены | Товары и услуги Недвижимость Спорттовары Мебель Транспорт Мобильники | Юмор Анекдоты Юмористы Абсурд Картинки Приколы Байки КВН
Региональный раздел каталога: Австралия, Африка, Азия, Америка, Европа, Россия, Москва
Алфавитный указатель

Самые популярные:
Топ 100 сайтов | Топ 100 категорий

Copyright © 1999—2006 Mail.Ru, Обратная связь


Знакомства@Mail.Ru

Страниц пользователей: 2,681,747, новых: 30,653, сейчас на сайте: 20,781
Знакомства | Топ-100 | Стрелки
Мой Профайл
Войти Войти…
Регистрация | Регистрация
 | В системе уже 6,372,557 пользователей. Присоединяйся!
Кто сейчас на сайте
20,781 человек хотят общаться прямо сейчас.
«Стрелки»
2,069 человек готовы встретиться на неделе.
Топ-100
Самые красивые, 1,075,296 фото.
Служба поддержки

Поиск по 2,681,747 страницам:

Я
Ищу
В возрасте от до
Где искать

Новые лица: ТОП-100:
Лукавая , 21 Девушка Екатеринбург
Ищу: Парня
15 фото
Димка , 22 Парень Екатеринбург
Ищу: Девушку
3 фото
Виктор , 34 Парень Екатеринбург
Ищу: Девушку
2 фото
Катя , 26 Девушка Екатеринбург
Ищу: Парня
7 фото
Вот он Я!!!!

Тёма, 18 Парень Москва
Ищу: Девушку
«Я парень без вредных привычек, ищу де…»

Рейтинг
6.70 баллов

Все рейтинги ... | ТОП-100 Парни
Поиск:
В Интернете В Картинках

Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Форумы · Чаты · WiW · Жуки
Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

Copyright © 1999-2006 Mail.Ru


@MAIL.RU: почта, новости, работа, рассылки, развлечения. Почта @MAIL.RU - бесплатная почта #1

Rambler's Top100

Агент
Имя
Пароль
Забыли?

Котировки

USD ЦБ | 19.05 | 27.0663 | 0.1094
EUR ЦБ | 19.05 | 34.5095 | -0.1921

Погода: г. Москва

19.05 +16° облачно, без осадков 20.05 +13° пасмурно, дождь

ТВ-программа: Екатеринбург

03:05 | Повернуть время в... | Первый
00:30 | Жизнь Дэвида Гейла | Россия
02:30 | Женская бригада | Студи...

Много фотографий?

Загружайте их на Фото@Mail.ru!
Удобно хранить и показывать друзьям!

Леди@Mail.Ru

Любовь и секс
Мы выбираем, нас выбирают+
Деньги и карьера
Вспышки гнева: не дай себя спалить
Знаменитости
Валерий Николаев: "Я не страдаю комплексом красоты"
Мир Магии, Знаменитости, Гороскопы, Мужчины о женщинах, Общение

Поиск Пример: распродажи в Москве
Русская клавиатураСпутник@Mail.Ru
Интернет | Картинки | Каталог | Товары | Софт | Словари | Энциклопедии

Спутник@Mail.ru — новая версия. Удобный поиск прямо из окна браузера. Установить »

Новости

Ученые обнаружили звезду с массой больше Солнца
  • Назван лучший актер России
  • В Москве задержан криминальный "авторитет"
  • Часть самолета упала на кафе с людьми
  • Россия требует от США объяснений
  • Центробанк выпустил новую рублевую купюру
  • В "Код да Винчи" нашли непростительную ошибку
  • Арен Апикян: Финансовый план на будущее
Знакомства | Чаты
Гороскопы | Открытки
Блоги | Фото
Ролевая игра | Анекдоты
Авто | Афиша
Новости | Финансы
Рассылки | Работа
Путешествия | Софт
Недвижимость | Покупки
Молоток | Леди
Знакомства Гороскопы Блоги Ролевая игра Авто Новости Рассылки Путешествия Недвижимость Молоток Чаты Открытки Фото Анекдоты Афиша Финансы Работа Софт Покупки Леди

Товары

Цифровые камеры Более 1000 моделей цифр. камер от 30 интернет- магазинов. Выбрать »
Цифровые камеры Minolta
  • в интернет-магазинах , от $194
  • среди частных предложений
Цифровые камеры Sony
  • в интернет-магазинах , от $160
  • среди частных предложений
Все цифровые камеры
  • в интернет-магазинах , от $81
  • среди частных предложений

Продать свой товар

Знакомства

я
ищу
— лет

Автоновости

  • Гибриды станут прибыльными
  • Роман Абрамович построит трассу Формулы-1

Каталог

По регионам · По алфавиту
Самые популярные · Непознанное · Юмор
Рефераты · Mp3 · Гадания · Гороскопы · Знаки Зодиака · Анекдоты · Обои · Знакомства · Приколы
Товары и услуги · Авто/мото
Мобильники · Иномарки · Запчасти · Недвижимость · Электроника · Транспорт · Спорттовары · Автосервис
Бизнес и финансы · Работа · Производство
Вакансии · За рубежом · Стройматериалы · Мебель · Банки · Юристы · Полиграфия · Работа летом · Налоги
СМИ · Общество и политика
День Пионеров · Армия · Религия · Газеты · Новости · Журналы · Карты · Эмиграция · Подписка · Страны
Наука и образование · Справки
Школы · Экономика · ВУЗы · Тесты · Абитуриентам · Психология · Адреса и телефоны · Словари · Рефераты
Компьютеры · Интернет
Программирование · Веб-дизайн · Обои · Чаты · Бесплатно · Почта · Игры · Общение · Открытки
Отдых и развлечения · Спорт
Турфирмы · Игры · Детский отдых · Футбол · Хоккей · Фитнес · Виды спорта · Гостиницы · ЧМ-2006 · Романтика
Культура и искусство
Фото · Mp3 · Литература · Кино · Театр · Живопись · Библиотеки · Дизайн · Танец · Музыка
Домашний очаг · Здоровье
Ремонт · Кошки · Медицина · Лечение · Лекарства · Баня · Знакомства · Дача · Красота

© 1999-2006, Mail.Ru Помощь · Семинары · Реклама на Mail.Ru · О компании · Вакансии · Сувениры


Mobile.Mail.ru

mobile@mail.ru mail.ru

искать на mobile.mail.ru поиск по всему Интернету

Каталог
Рингтоны
Полифония
Супер-звуки
MP3
Логотипы
Цветные картинки
Картинки 128x128
Картинки 176x220
Анимация
Java-игры
Видео
Мобильные темы
Сервисы
WAP.Mail.ru
PDA.Mail.ru
Голосовой портал
Голосовая почта
Mail.ru-Interactive
SMS-Развлечения
Мобильные открытки
Знакомства
SMS-Fun
SMS-Love
SMS-Игры
• Помощь
• Служба поддержки
• О проекте

Открытки и логотипы
Выберите марку своего телефона, и мы попробуем подобрать наиболее подходящий контент

Mp3 мелодии для мобильного

20 лучших | Новые | Все мелодии
Название | Исполнитель | Скачать
Алина Кабаева | Игра слов | 73851275
Как твои дела | Юлия Савичева | 73851715
Ну, наконец-то! | Массква | 73851825
Любовь и боль | Ленинград | 73852035
9-я рота | Моральный Кодекс | 73852775
Кустурица | Братья Грим | 73852765
Восточная сказка | Блестящие и Arash | 73852635
Чёрные глаза | Айдамир Мугу | 73853135
"Вам и не снилось". Основная тема | Музыка из к/ф | 73854055
Ресницы | Братья Грим | 73859625

Картинки 128x128

20 лучших | Все картинки

Анимационные картинки
© 2001-2005, Mail.Ru Реклама на Mail.Ru · Контакты


Интернет-аукцион Молоток.Ру

 Rambler's Top100 Service
Псевдоним: | Пароль:
Сделать домашней страницей Добавить в закладки
Что в продаже? Продать Страна "Молоток" Мой молоток Помощь
Поиск в аукционе | Расширенный

Каталог
"Весенняя уборка" (317)
Авто, Мото, Запчасти (1748)
Бытовая техника (724)
Домашний быт и уют (4299)
Интернет (1083)
Искусство, Антиквариат (10323)
Книги, Видео, Музыка (16711)
Коллекционирование (122431)
Компьютеры, Программное обеспечение (6432)
Красота и Здоровье (2927)
Недвижимость (285)
Одежда, Обувь, Аксессуары (13322)
Товары для взрослых (36)
Товары для детей (2562)
Туризм, Отдых, Спорт (1109)
Услуги (312)
Фото, Электроника, Связь (7058)
Часы и ювелирные изделия (3080)
Все дешевле $ 1 (1656)
Посмотреть все разделы
Аукционы в Вашем регионе:
Местонахождение показанных аукционов:
Показывать лоты из других регионов с возможностью пересылки
Фильтр позволит отображать в каталоге лоты только с удобным для Вас местонахождением.
Специальные разделы
Реклама на Молотке
Регистрация новых участников
Выставить товар на продажу
Сегодня на аукционе
Весенняя уборка на Молотке! Завалялись старые вещи? Продай их с Молотка, заработай денег на новые и получи приз!
В этот список попадают интересные лоты, имеющие подробное описание и фотографию В этот список попадают интересные лоты, имеющие подробное описание и фотографию
Распродажа грилей, последняя партия... (62) 99.99 р.
AMD-2800+@3800+/512 Dual/80Gb/6600L... 10999 р.
Фотопринтер - EPSON STILUS PHOTO R... (2) $ 5
APC Smart-UPS 1000 I источник бесп... $ 300
P4-3000/ASUS i865/1Gb Dual/80Gb/DVD... 14999 р.
СУМКА CELINE PRESTIGE ZEPHYR 2 POCK... 3000 р.
КОЛЬЦО ЗОЛОТОЕ С БРИЛЛИАНТАМИ GR 06... $ 1439
КОЛЬЦО ЗОЛОТОЕ С БРИЛЛИАНТАМИ "КОРО... $ 2349
КОЛЬЦО ЗОЛОТОЕ С БРИЛЛИАНТАМИ GR 06... $ 1289
далее
В этот список попадают аукционы, которые имеют более 6 заявок на покупку, а также лоты, имеющие более 2 заявок и завершающиеся в течение двух суток В этот список попадают аукционы, которые имеют более 6 заявок на покупку, а также лоты, имеющие более 2 заявок и завершающиеся в течение двух суток
УАЗ 452Д Пожарный. "Русская миниат... (21) 1314 р.
Кронен-пробка "Аттила"(Средняя Азия... (19) 54 р.
Москвич 2141 Юрий Долгорукий (21) 1616 р.
11 Советских Полтинников. Сохран Ок... (16) 69.99 р.
Сувенир брелок!!! (10) 45 р.
ГАЗ 24 ПИКАП (52) 1212 р.
SIEMENS MC60 EXTREME-БОГАТЕЙШАЯ КОМ... (25) 1430 р.
далее
В этот список попадают лоты, которые выставлены на продажу в течение последних 24-х часов В этот список попадают лоты, которые выставлены на продажу в течение последних 24-х часов
Икона- Богородица , с окладом. 19 в... 500 р.
_ПОЛОТЕНЦЕ большое банное (новое) ... 999 р.
продаю неисправный копир MB3012 за ... 600 р.
процессор Р-3 800 мгц 27 р.
сумка BOLINNI Оригинал последняя це... 2000 р.
далее
Вам может это пригодиться
Как работает аукцион?
Как и зачем регистрироваться?
Как делать ставки?
Как продавать?
Как заказать платные услуги?
Как вступить в Клуб Молоток?
Как пополнить свой счет
Кредитной картой С помощью WebMoney Яндекс.Деньги (PayCash) С помощью E-Port Наличными курьеру
Новости
[18.05.06]
Уважаемые пользователи! Сегодня в период с 19:00 до 21:00 Молоток.Ру может быть недоступен в связи с проведением технических работ на сервере. Торги по лотам, завершающимся в период проведения работ, будут продлены в соответствии с нашей политикой в отношении перебоев. Приносим извинения за причиненные неудобства.
Другие новости
Это интересно
Авторские работы Эксклюзив на Молотке: авторские украшения и другие работы!

Товары с доставкой на дом
Красота, похудение Красота, похудение | Необычные подарки Необычные подарки | Товары для дома Товары для дома
Надувные кровати Надувные кровати | Модные игрушки Модные игрушки | Товары для здоровья Товары для здоровья
 | Магазины для всей семьи: (095) 952-14-14

Итоги на: 19.05.2006 01:31:39
Активных аукционов | 196`428
На общую сумму | 42`004`751 $
432`619`883 р.
9`229`483 €


Деньги@Mail.Ru - национальная система платежей и переводов

Уже зарегистрированы?
Первый раз на сайте?

Платежная система Деньги@Mail.ru предоставляет отличную возможность:
  • просто зарегистрироваться
  • быстро оплачивать товары и услуги
  • и даже переводить деньги по e-mail

Пользователям

  • Оплата мобильного телефона
  • Ежемесячные платежи
  • Отправка денег на e-mail
  • Погашение кредита

Магазинам

  • Платежи с сайта и по e-mail
  • Увеличение продаж
  • Программы лояльности
  • Перечисление поступлений в банк

Способы ввода
и вывода денег

Новости

10.05.2006
Совместная акция системы Деньги@Mail.ru и интернет-сервиса Знакомства@Mail.Ru: бонус 20% при оплате услуг через Деньги@Mail.ru
27.04.2006
"Видео Казино" принимает платежи через систему Деньги@Mail.ru
26.04.2006
Возможность пополнения счета в системе Деньги@Mail.ru произвольным плательщиком
20.04.2006
Интернет-казино "Султан" принимает платежи через систему Деньги@Mail.ru
Все новости »

Возникли вопросы?

e-mail:
 info@money.mail.ru
© 1999-2006, Mail.Ru; © 2004-2006 MoneyMail О компании · Тарифы · Контакты


Словари @Mail.Ru: Англо-русский словарь. Русско-английский словарь.

ENG GER FRA ITA SPA POR UZB

Направление перевода: английский → русский → английский

Англо-русские словари: | Русско-английские словари:
Общая лексика. Мюллер (EN-RU) Общая лексика. Ахманова (EN-RU) Сокращения (EN-RU) Компьютер (EN-RU) Великобритания (EN-RU) США (EN-RU) Австралия (EN-RU) Банк (EN-RU) Биология (EN-RU) Строительство (EN-RU) Экономика (EN-RU) Право (EN-RU) Медицина (EN-RU) Социология (EN-RU) Солнечная энергетика (EN-RU) Телекоммуникации (EN-RU) | Общая лексика. Смирницкий (RU-EN) Новый русский лексикон (RU-EN) Общая лексика. Ахманова (RU-EN) Право (RU-EN) Медицина (RU-EN) Физика (RU-EN) Техника (RU-EN) Телекоммуникации (RU-EN) Нефть и газ (RU-EN) Солнечная энергетика (RU-EN) Английские толковые словари: Webster's New World Dictionary (EN-EN) Webster's New World Roget's A-Z Thesaurus (EN-EN)

Словари Мультилекс
Скачать словарь
Скачать словарь
КУПИ МУЛЬТИЛЕКС СЕЙЧАС!
МультиЛекс 5.0 Многоязычный электронный словарь
МультиЛекс 5.0 Многоязычный электронный словарь
2370 руб
Купить

© 1999-2006, Mail.Ru © 2004-2006 ЗАО "МедиаЛингва" Отзывы о Словарях


Новости @MAIL.RU

Rambler's Top100

Поиск по Интернету

НОВОСТИ ПРОИСШЕСТВИЯ ФИНАНСЫ ОБЩЕСТВО ИНТЕРНЕТ СПОРТ АВТО ПОГОДА

Новости интернета
  • Зависите ли вы от Интернета?
  • За что и от кого пострадал Ленин.ру?
  • Jetlink.ru: все голосования Рунета

    • ВАЛЮТА
 | время | знач | изм
USD ЦБ | 19 мая | 27.0663 | 0.1094
EUR ЦБ | 19 мая | 34.5095 | -0.1921

    ТОВАРЫ С ДОСТАВКОЙ НА ДОМ
Красота, похудение Красота, похудение | Необычные подарки Необычные подарки | Товары для дома Товары для дома
Надувные кровати Надувные кровати | Модные игрушки Модные игрушки | Товары для здоровья Товары для здоровья
 | Магазины для всей семьи: (095) 952-14-14

    Сегодня по ТВ
    24 часа
    НТВ,
    19 Мая, Пт,
    21:40-23:50
    Трое преступников - супруги Хики Джо и Черил и кузен Джой Марвин - настолько хорошо знают среду, в которой живут, что сумели ра...

  • Папа Римский принял митрополита Кирилла
  • На Западе сомневаются в ядерных достижениях Ирана
  • ЕС заморозил активы президента Белоруссии
  • Проди обещает вывести войска из Ирака
  • Голливуд берется за Беслан

    • Новости почтой:

    e-mail:
    Все новости дня
    Катастрофы и происшествия
    Общество, культура
    Бизнес-новости
    Курсы, котировки

    ПОГОДА : Москва
Пт - 19.05.2006
НОЧЬ | +5°С Ветер: Ю 5 м/с
ДЕНЬ | +16°С Ветер: Ю 6 м/с
Сб - 20.05.2006
НОЧЬ | +10°С Ветер: Ю 6 м/с
ДЕНЬ | +13°С Ветер: ЮЗ 3 м/с
Подробнее>>
Информация предоставлена ФОБОС, НПЦ Мэп Мейкер

    В Иран прибывают инспекторы МАГАТЭ для проверки ядерных объектов

    Иран занимает ведущее место в мире по количеству проведенных инспекций МАГАТЭ. Их число за последние три года превысило 2000 человеко-дней. ..

    подробнее »

            ПРОИСШЕСТВИЯ

    В Дании вирус птичьего гриппа выявлен у ...

    Это первый случай обнаружения вируса птичьего гриппа у домашней птицы в Дании. Ранее в стране были зарегистрированы случаи птичьего гриппа у диких птиц.
    подробнее »

            ОБЩЕСТВО

    Лучшим актером россияне считают Безрукова, актрисой - Елену Яковлеву

    В список народных любимцев попали также Евгений Миронов, Александр Домогаров, Константин Хабенский и Федор Бондарчук. Все они в ходе опроса набрали по 9%.
    подробнее »

            ФИНАНСЫ

    РЖД и Siemens подпишут сегодня контракт на поставку 8 высокоскоростных поездов

    ОАО «Российские железные дороги» (РЖД) и компания Siemens подпишут сегодня контракт на поставку восьми высокоскоростных поездов для участка Москва-Санкт-Петербург стоимостью 276 млн.
    подробнее »

            СПОРТ

    Крикунов надеется, что ЧМ в Москве будет более удачным для сборной

    Вместе с тем, наставник сборной России признал, что проигрыш в четвертьфинале - неважный результат для его подопечных...

    подробнее »

            АВТО

    Супермодель вышла из едущего автобуса!

    В США белорусская супермодель Татьяна Симонова выпала из едущего на полной скорости автобуса. Причем, сделала это она по собственной воле, просто выйдя из машины...
    подробнее »

    Архив новостей:
    Все новости дня »

    Верховный суд Чили освободил под залог бывшего президента Перу

    Бывший президент Перу обвиняется в различных преступлениях, в том числе коррупции, нарушении прав человека, незаконном отмывании денег и присвоении крупных сумм денег.

    подробнее »

    MOBB предложила России услуги по определению качества грузинских вин

    В связи с запретом на импорт вин министр сельского хозяйства Грузии и посол Молдавии во Франции обратились к генеральному директору организации Федерико Кастеллучи.

    подробнее »

    Новости туризма
    • Участница экстремального тура погибла в пустыне
    • Фотомодель устроила скандал во время перелета через атлантику

    Поиск:
    В Интернете В Картинках

    Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
    Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
    Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Чаты · WiW · Жуки
    Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

    © 1999-2006, Mail.Ru, Обратная связь
    TopList


Спорт @MAIL.RU

Rambler's Top100

Поиск по Интернету

НОВОСТИ ПРОИСШЕСТВИЯ ФИНАНСЫ ОБЩЕСТВО ИНТЕРНЕТ СПОРТ АВТО ПОГОДА

» ФУТБОЛ
» ХОККЕЙ
» АВТОСПОРТ
» ТЕННИС
» ИГРОВЫЕ ВИДЫ
» ЕДИНОБОРСТВА
» CПОРТКАЛЕЙДОСКОП

Спортивная телепрограмма
Мини-футбол. Чемпионат России. (ЦСКА ...
Спорт,
19 Мая, Пт,
18:55-20:30
Мини-футбол гораздо "древнее", чем мы можем себе представить. Его появление было отмечено в 20-х годах нашего века. Произошло э...
Все передачи »

Новости спорта почтой:

E-mail:
Все спортивные новости
Все новости футбола

Крикунов надеется, что ЧМ в Москве будет более удачным для сборной

Вместе с тем, наставник сборной России признал, что проигрыш в четвертьфинале - неважный результат для его подопечных...

подробнее »

ФУТБОЛ

"Локомотив" не интересуется Андреевым

Руководство "Локомотива" опровергло информацию об интересе к нападающему "Левадии" Никите Андрееву. Этот игрок не поедет с командой Муслина на сборы в Италию и Австрию, сообщает корреспондент "СЭ" ...
подробнее »

ХОККЕЙ

Вторую пару полуфиналистов составят Чехия и Финляндия

Рига (Латвия) Чемпионат мира Четвертьфинал Финляндия - Белоруссия - 3:0 (1:0, 0:0, 2:0) Голы: Халь (Рууту, Бергенхейм), 9.24 (1:0), Пелтонен (Нуммелин, Йокинен), 43.58 (2:0).
подробнее »

АВТОСПОРТ

Пилоты "Формулы-1" сыграют в футбол

Накануне седьмого этапа чемпионата мира, который состоится в Монте-Карло 28 мая, по традиции пройдет благотворительный футбольный матч, организатором которого является Альбер Гримальди, правящий ...
подробнее »

ТЕННИС

Давыденко без труда переиграл Ниеминена

подробнее »

ИГРОВЫЕ ВИДЫ

ЦСКА ждет соперника по финалу

Чемпионат России Мужчины Суперлига Полуфинал 4-е матчи УНИКС (Казань) - ЦСКА -69:73 (27:15, 14:16, 17:19, 11:23) У: Штомбергас (19). Лавринович (11).
подробнее »

ЕДИНОБОРСТВА

Мундин оспорит титул у Кесслера

Австралиец Энтони Мундин стал обязательным претендентом на поединок за звание чемпиона мира по версии WBA в весе до 76,2 кг против датчанина Микаэля Кесслера, победив по очкам соотечественника Дэнни ...
подробнее »

Все новости дня »

В матче с чехами россиянам не хватило хладнокровия, считает Сушинский

"Нам не хватило хладнокровия. Мы должны были решать все вопросы в первом периоде, - заявил Сушинский. - Мы не использовали тысячу моментов, в пустые ворота не попадали".

подробнее »

Тренер английского "Арсенала" назвал своих подопечных героями

В среду в финале Лиги чемпионов по футболу испанская "Барселона" со счетом 2:1 в Париже одержала победу над английским "Арсеналом".

подробнее »

Cпорт на Блогах@Mail.ru:

Футбол - это лучшая игра
Участников: 589

Волейбол
Участников: 160

Биатлон
Участников: 144

F1
Участников: 178

Присоединяйтесь к сообществам или создавайте новые!

00:55 "Локомотив" не интересуется Андреевым
00:52 ESM определила сборные мая и сезона
00:40 Акинфеев вновь тренируется с ЦСКА
00:31 ЦСКА и "Спартак" будут "посеяны" при жеребьевках в своих раундах Лиги чемпионов
00:06 Давыденко без труда переиграл Ниеминена
23:59 ЦСКА ждет соперника по финалу
23:55 Ольга Брусникина возглавила школу синхронного плавания
Все новости дня »

ФОТО ДНЯ

Сборная РФ начнет решающую стадию ЧМ по хоккею матчем с командой Чехии
РИА
Поиск:
В Интернете В Картинках

Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Чаты · WiW · Жуки
Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

© 1999-2006, Mail.Ru, Обратная связь
TopList


РАБОТА@MAIL.RU - поиск работы: вакансии, резюме

Вакансий 33610 ▪ Резюме 32287 ▪ Компаний 8491 resume bank

Поиск вакансий Добавить резюме VIP-резюме Поиск сотрудников Добавить вакансии
Войти

Компьютерные курсы

Лучший компьютерный центр России*.
Более 300 курсов по следующим направлениям:
  • Компьютерные курсы для пользователей ПК
  • Курсы web: дизайн, HTML, PHP, ASP, Flash, ActionScript ...
  • Компьютерная графика: курсы Adobe Photoshop, курсы Сorel draw, курсы Adobe Illustrator, курсы 3d studio max, курсы AutoCad ...
  • Администрирование сетей: Microsoft, Cisco, Linux ...
  • Курсы программирования и баз данных: C#, SQL Server, Oracle ...
  • Курсы управления проектами
  • Бухгалтерский учет / Курсы 1С

Новости рынка труда

  • Подписка на рассылку (Ваш email):

Зарплатный монитор

• — Количество резюме;
• — Количество вакансий.

Поиск
Расширенный поиск
Я хочу найти:
С зарплатой:
В отрасли:
В регионе:

Горящие вакансии

$600 | руководитель call - центра
$1000 | конструктор строительных конструкций
$500 | Оператор в call-центр
Хотите сюда?

Вакансии ведущих компаний

Образование, обучение, тренинги

Институт Управления - Место рождение Вашего успеха

Протестируй себя

  • Бесплатное on-line тестирование + сертификат!
  • Авторизованный центр тестирования IT-специалистов
  • Психологическое тестирование

Энциклопедия карьеры

11/05/2006

Оформление на работу: правовые аспекты

В объявлениях о вакансиях часто встречается фраза: 'Соблюдение норм трудового законодательства гарантируется'. Что стоит за этими словами?.. Далее »

11/05/2006

Рынок идей

Во всем мире сотрудники отделов исследований и развития (research&development) относятся к числу наиболее востребованных и высокооплачиваемых... Далее »

03/05/2006

Работа бывает красивой

Что такое ПЕРСОНА? Я Вам расскажу свою историю, Вы сами поймёте Далее »

19/04/2006

Ярмарка вакансий 'День Карьеры в МДМ' (весна)

Весенняя выставка пройдет на двух выставочных площадках - выставочный комплекс 'Манеж' и традиционно в Московском Дворце Молодежи... Далее »

все статьи »

Вакансии в регионах

Санкт-Петербург и область
$700 химик
Хабаровский край
$700 Главный бухгалтер
Свердловская область
$1200 ИНЖЕНЕР-ПРОЕКТИРОВЩИК
Москва и Моск. область
$4000 | Руководитель энергогенерирующей компании
$1500 | Коммерческий сервисный представитель
Краснодарский край
$600 ГЛАВНЫЙ ИНЖЕНЕР ПРОЕКТА
Удмуртская Республика
$230 БУХГАЛТЕР
Тульская область
$700 Технолог по производству печенья
Работа в других регионах »

Наш опрос

 Архив
Ваша зарплата?
Результаты опроса »

© 1999-2006, Mail.Ru ; 2001-2006, Resume-bank.Ru Реклама на сайте Пишите нам Информер вакансий


Недвижимость@mail.ru - Недвижимость и Цены

Недвижимость и Цены
» КУПИТЬ
» СНЯТЬ
» ПРОДАТЬ
» СДАТЬ
» ОБМЕН
+ ПОДАТЬ ОБЪЯВЛЕНИЕ

ПОПУЛЯРНЫЕ ЗАПРОСЫ
  • Новостройки
  • Вторичный рынок
  • Загородная недвижимость
  • Нежилые помещения
  • Недвижимость за рубежом
  • Аренда недвижимости
            •
    УСЛУГИ
  • Кредиты на покупку жилья. Ипотека
  • Оценка и экспертиза
  • Управление и эксплуатация недвижимости
  • Юридические и нотариальные услуги
  • Страховые услуги
  • Экологическое обследование объектов недвижимости
  • Квартирные, дачные, офисные переезды
  • Строительство, ремонт, дизайн
  • Работа и обучение
  • Другие услуги
    • ИНФОРМАЦИЯ
  • Риэлторские агентства
  • Гос. организации
  • Полезные ссылки
            •
    БЫСТРЫЙ ПОИСК НЕДВИЖИМОСТИ
    Цена от до
    НОВОСТРОЙКИ

    ЖК MIRAX PARK

    Жилой комплекс на проспекте Вернадского. Квартиры свободной планировки, с панорамным остеклением. Тел. (495) 721 1000

    Подробнее...

    ЖК Кутузовская Ривьера

    Жилой комплекс на Кутузовском проспекте. Квартиры свободной планировки, с панорамным остеклением. Рядом лес и река. Тел. (495) 721 1000

    Подробнее...

    Бизнес-центр POLLARS

    На набережной, 4 км от кремля. Офисы от 150 кв.м. Объект сдан. Тел. 7211000

    Подробнее...

    "Клубный поселок "Новая Опалиха"

    Таунхаусы и квартиры, индивидуальный проект, вид на лес, 8 км от МКАД по Волоколамскому шоссе ипотека, рассрочка"

    www.newopaliha.info

    "МИАН-агентство недвижимости"

    БЦ "Северное Сияние" Аренда офисных блоков от 300 м2 в новом бизнес-центре кл. А "Северное сияние" на ул. Правды, м. "Савеловская". Наземный и подземный паркинги, современные инженерные системы и коммуникации. 974-62-16

    www.mian.ru

    ГОРОДСКОЙ ИПОТЕЧНЫЙ БАНК

    Внимание! С 3 апреля 2006 г. новые условия получения ипотечных кредитов в ООО "Городской Ипотечный Банк". Лицензия Банка России № 1627. Телефон (495) 540 54 54

    www.gorodskoi.ru

    Уникальный конференц-зал сдается в аренду

    Конференц-зал площадью 100 кв.м., высота потолков - 6,5 м. Панорамные окна с видом на 1-ю Тверскую-Ямскую, высококачественная отделка парадного входа. Уникальная, авторская работа в стиле модерн. Телефон: (495) 726-18-70 Арендная ставка:980$ в год Подробнее...

    Кредит до 3 000 000 руб. без залога и поручителей!

    Способ предоставления: наличными либо перечислением на счет. Подать анкету на кредит on-line или по телефону 221-5-525

    Подробнее...
    ВТОРИЧНЫЙ РЫНОК
    Закладки | Тип объекта | Площадь | Метро | Цена
    Продаю: 4-к Квартира | 70/51/7,5 | Сухаревская | 330 тыс.$
    Продаю: 1-к Квартира | 35/19/10 | Перово | 115 тыс.$
    Продаю: 4-к Квартира | 101/78/10 | Рижская | 420 тыс.$
    Продаю: 5-к Квартира | 122/76/13,5 | Рижская | 455 тыс.$
    Продаю: 2-к Квартира | 47/30/6,7 | Братиславская | 135 тыс.$
    Все объявления »
    АРЕНДА ЖИЛЬЯ
    Закладки | Тип объекта | Площадь | Метро | Цена
    Сдаю: 1-к Квартира | 45/20/7 | Выхино | 450$ всего в мес.
    Сдаю: 2-к Квартира | 55/40/7 | Проспект Вернадского | 650$ всего в мес.
    Сдаю: 2-к Квартира | 73 | Профсоюзная | 700$ всего в мес.
    Сдаю: 3-к Квартира | 91 | Новогиреево | 600$ всего в мес.
    Сдаю: 1-к Квартира | 35/20/6 | Академическая | 600$ всего в мес.
    Все объявления »

    Новости рынка
    18.05.2006 Шесть проектов столицы будут претендовать на получение средств инвестиционного фонда РФ
    18.05.2006 Вестибюль станции "Арбатская" закрылся на реконструкцию
    17.05.2006 Москве и Московской области необходимо подписать соглашение для урегулирования "пограничного вопроса" - Платонов
    16.05.2006 Утверждены правила предоставления молодым семьям субсидий на приобретение жилья в рамках федеральной программы
    Все новости »
    Статьи
    15.05.2006 Москва приглашает инвесторов
    15.05.2006 Рыцарь высокой архитектуры
    15.05.2006 Проект большого масштаба. Стратегия комплексной застройки Московского региона
    15.05.2006 Обзор рынка офисной недвижимости Москвы
    Все статьи »
    регистрация | форум | помощь | реклама на сайте обратная связь
    Новости · Авто · Развлечения · Аукцион · Покупки · Знакомства · Открытки · Чаты · Рассылки · Каталог · Агент
    Издательство "Деловой мир": Товары и Цены · Красота & Здоровье · Услуги и Цены · Обустройство & Ремонт · Работа & Зарплата · Автомобили и Цены
    Перепечатка, включение информации, содержащейся в рекламных и иных материалах, во всевозможные базы данных для дальнейшего их коммерческого использования, размещение таких материалов в любых СМИ и Интернете допускаются только с письменного разрешения редакции.
    Copyright © 1999-2006 Mail.Ru, Издательство "Деловой мир"


MAIL.RU: Рекламная служба

прайс-лист
скидки
баннеры
аудитория
контакты
___________ проекты
новости
пресса о нас
история

Прайс-лист

Условия размещения рекламы на Mail.ru
в период с 01.01.2006 по 31.12.2006

Вводятся сезонные коэффициенты, которые применяются к базовому прайс-листу:
Сезонный коэффициент
Месяц | К | Месяц | К
Январь | -30% | Июль | -10%
Февраль | -10% | Август | -10%
Март | 0% | Сентябрь | 20%
Апрель | 0% | Октябрь | 20%
Май | 0% | Ноябрь | 20%
Июнь | 0% | Декабрь | 20%

Внимание! с 1 июля начинает действовать новый прайс-лист

Мы предлагаем рекламные услуги на следующих площадках:
Mail.Ru

Главная страница Mail.ru | Почта | Авто | Афиша | Фото | Знакомства
Чат | Гороскопы | Софт | Каталог | Финансы | Спорт
Работа | Путешествия | Анекдоты | Рейтинг | Рассылки | Погода
Открытки | Новости | Словари | Mobile | Недвижимость | Хостинг
Леди | WAP

Molotok.ru

Торг.ru


СОФТ@Mail.Ru - бесплатные и условно-бесплатные программы со всего мира!

SoftLine - программное обеспечение

Новости СОФТ@Mail.Ru

Обсудите вопросы учета железа в хорошей компании
Обсудите вопросы учета железа в хорошей компании
В период с 15 по 25 мая на форуме Sysadmin@Mail.ru пройдет встреча с руководителем проекта Hardware Inspector Сергеем Унагаевым. Подробнее »

Все новости »

Каталог софта

  • Интернет и сеть (2059)
  • Системные программы (1301)
  • Диски и файлы (798)
  • Безопасность (645)
  • Текст (425)
  • Графика и дизайн (533)
  • Мультимедиа (545)
  • Программирование (837)
  • Электронные учебники, энциклопедии (38)
  • Карты, навигация, путешествия (8)
  • Образование и наука (492)
  • Деловые программы (2032)
  • Игры и развлечения (1127)
  • Стиль жизни (113)
  • Программы для мобильных устройств (550)
  • Сертификаты (2)

В развернутом виде »

Интервью

PIAdviser облегчает труд трейдера и инвестора, но окончательный результат - в руках пользователя
PIAdviser облегчает труд трейдера и инвестора, но окончательный результат - в руках пользователя
Программа Personal Investment Adviser – это помощник при принятии инвестиционных и спекулятивных торговых решений на российском рынке акций и фьючерсов. Подробнее »

Андрей Шабуров: работодатель вправе требовать, чтобы сотрудник не тратил ресурсы предприятия на свои личные нужды

Все интервью »

Софт-марафон
На этой неделе:

TimeBoss, 2.23

Теперь Вы справитесь с компьютерной зависимостью ваших детей! Вы сможете контролировать время работы, указывать запрещенные каталоги, программы и сайты для каждого пользователя! Сможете получить подр ... Подробнее »

О конкурсе »

Рейтинг софта

24 ч. | 7 дн. | 30 дн. | этот год

1. | Mail.Ru Агент (4.6 (с технологией VoIP)) | +13
2. | PCManager (1.22) | new
3. | Компьютерная эволюция (4.0) | new
4. | SeaStorm 3D Screensaver (1.51) | new
5. | Paint.NET (2.6.2) | -4
6. | Гадания по "Книге Перемен" (3.56) | -1
7. | Приколы на столе (1.0) | -1
8. | EasyNET (5.4 Professional) | new
9. | Face Test (2.1 Standart) | -2
10. | Chess Lines (1.7) | -2

Другие рейтинги »

Комментарии к программам

  • vuDictionary (1)
  • Analog Clock (1)
  • Ethernet Internet traffic Statistic (1)
  • RAMDisk (1)
  • Meteor (S60) (1)
  • CAHEK_p's Школьник (1)
  • Avast! Professional Edition (1)
  • Рендзю (2)

Правила обсуждения

Форум пользователей

  • Посоветуйте хорошего хост-провайдера (2)
  • Как удалить counter-strike 1.6? (0)
  • ASUS WL-500g Premium (3)
  • Исчезли письма в аутлуке (3)
  • Outlook ХР - помогите решить проблему (10)

Последние Активные темы»

Все темы форума »

Сисадмин тоже человек

новые жалобы | рейтинг жалоб

Новости

18.05.2006

Стали известны сроки выхода локализаций продуктов Autodesk 2007
Стали известны сроки выхода локализаций продуктов Autodesk 2007
  • Sun и SAP выпускают совместное решение для контроля над соблюдением требований к защите данных
  • Active Ink Software выпускает новую версию приложения Form Design for the Tablet PC
  • mySAP ERP 2005 – самая популярная в мире система планирования ресурсов предприятия
  • Oracle Berkeley DB Java Edition 3.0 - удобная встраиваемая СУБД для разработчиков Java-приложений
  • Wi-Fi-радиоприемник от компании Magic Box
  • K2 – инновационная технология защиты мультимедийного информационного наполнения
  • Intelligent Scarecrow – электронное пугало против крылатых вредителей
  • Интервью с 1000-ым участником акции "Я ЗА легальный софт"
  • Лаборатория PandaLabs обнаружила фишинговую атаку против клиентов банка SouthTrust

Все новости » | Добавить новость » RSS: новости, интервью, статьи

Новые поступления программ

Everica, 2.0

Everica — это средство для создания говорящих фотоальбомов. Вы выбираете фотографии, добавляете свои голосовые комментарии, сохраняете альбом в один файл и посылаете его своему другу. Теперь он может увидеть ваши фотографии и услышать ваш голос.

Системы: Windows XP, Windows NT, Windows 2000, Windows 2000 Server
4114 КБайт - Рус. интерфейс - Условно-бесплатно

 - Посмотрели: 6 - Скачали: 4

RoboFolder, 1.0.0.15

Мощное и удобное приложение для упорядочения структуры папок с изображениями. В комплект программы входят наиболее популярные у фотографов шаблоны для организации изображений + редактор собственных шаблонов. Возможен предварительный просмотр ожидаемой файловой структуры не дожидаясь операции копирования, менеджер откатов. Автозаполнение IPTC полей для указания копирайтов, описания, и ключевых слов. Автоматический поворот JPEG изобрабражений.

Системы: Windows
2229 КБайт - Рус. интерфейс - Бесплатно

 - Посмотрели: 12 - Скачали: 3

Feed Editor, 3.7

Вы хотите создавать профессиональные RSS ленты, но у вас катастрофически нет времени на изучение технологии RSS, тогда Feed Editor - решение для вас! Feed Editor возьмёт на себя работу с различными RSS форматами, импортирует текст из CSV и HTML файлов, поможет просто отредактировать HTML в WYSIWYG редакторе, отредактирует XML и рисунки, даст возможность просмотреть полученные ленты и опубликовать их.

Системы: Windows XP, Windows NT, Windows 98, Windows 95, Windows ME, Windows 2000, Windows 2003 Server, Windows 2000 Server, Windows
1959 КБайт - Условно-бесплатно

 - Посмотрели: 0 - Скачали: 0

Icon Finder, 1.2

Программа для поиска и извлечения иконок из ресурсныз файлов (EXE, DLL, VXD, ICL, OCX и т.д.).

Системы: Windows
300 КБайт - Рус. интерфейс - Условно-бесплатно

 - Посмотрели: 9 - Скачали: 1

AceFTP 3 Freeware, 3.72.0

Мощный FTP-клиент: имеет поддержку докачки, синхронизации каталогов. Умеет копировать файлы с сервера на сервер (если оба эти сервера поддерживают такой режим работы); включает предварительный просмотр файлов, поддерживает SSL, socks 4 и socks 5; умеет работать по расписанию, поддерживается защита паролем. Интерфейс - в стиле Проводника Windows XP.

Системы: Windows XP, Windows NT, Windows 98, Windows ME, Windows 2000, Windows 2003 Server, Windows 2000 Server, Windows
3064 КБайт - Бесплатно

 - Посмотрели: 15 - Скачали: 6

Коллекция пасьянсов Can't Stop Top Hits для Windows Smartphone, -

Can’t Stop Top Hits – коллекция из 15 самых популярных пасьянсов, собранных в одной игре для смартфонов Windows Smartphone. Для Вашего удобства реализована возможность установки пасьянсов для Windows Smartphone на карту памяти. Коллекция пасьянсов Can’t Stop Top Hits поможет приятно провести время и подарит ощущение реалистичности игры благодаря звуковым эффектам.

Системы: SmartPhone, Windows Mobile
3100 КБайт - Рус. интерфейс - Условно-бесплатно

 - Посмотрели: 6 - Скачали: 3

ZoneAlarm Pro, 6.5.677.000 Beta

Отличный персональный firewall, программа для защиты вашего компьютера от непрошеных гостей извне.

Системы: Windows
13100 КБайт - Условно-бесплатно

 - Посмотрели: 966 - Скачали: 3142
Все новинки »

Новые статьи

  • ACDSee: 7 советов по использованию (16.05.2006)
  • Утилиты для тестирования памяти (12.05.2006)
  • Сравнение производительности двух виртуальных серверов (10.05.2006)

Все статьи »

Опросы и голосования

О каких категориях программного обеспечения Вам интересно узнать побольше?

Антивирусы
Безопасность
Графические программы
Мультимедия
Интернет
Научное ПО
Операционные системы
Офисное ПО
Резервное копирование
САПР
Сетевое ПО
СУБД
Утилиты
Электронная почта

Другие опросы »

Обсуждение материалов

  • Интернет-"наркомания" - эпидемия 21 века... (149)
  • Особенности работы с Adobe PREMIERE - 2... (2)
  • Аль-Каида занялась обучением через Интернет... (189)
  • Online встреча с разработчиками ПО по учету компью... (5)
  • Трубок становится больше чем людей... (3)
  • Государство в XXI веке... (1)
  • Cайт для борьбы с коррупцией среди правительственн... (140)
  • Ученые создают виртуальную цивилизацию... (446)

Правила обсуждения

Лицензионный софт

  • 3D Модель Москвы
  • Антивирусы: Norton AntiVirus 2005, Антивирусы Panda, Dr.Web, антивирус Касперского, NOD32
  • The Bat!, HDDlife Pro, Traffic Inspector
  • Переводчики: Lingvo, PROMT 7.0 Expert
  • Windows XP Home Edition
  • Windows XP Professional Edition
  • Photoshop 8.0 CS, CorelDRAW GS 12
  • Техническая поддержка программного обеспечения

Другой софт »

Праздники

24 июня - Международный день изобретателя
Это праздник был введен в конце 50-х годов прошлого века как "профессиональный" праздник изобретателей и рационализаторов. Хорошим подарком на этот праздник будет:
  • GPS Навигатор
  • Компьютерная техника

Другие подарочные сертификаты »

При использовании материалов сайта ссылка на СОФТ@Mail.Ru обязательна. Пресс-релизы, новости ждем по адресу softclub@soft.mail.ru.
© 2001-2006, Mail.Ru, SoftLine СОФТ@Mail.Ru - совместный проект компаний Mail.Ru и SoftLine Реклама на Mail.Ru · Контакты


Рейтинг@Mail.ru: Рейтинг ресурсов Интернет

Поиск по Интернету

РЕЙТИНГ РЕГИСТРАЦИЯ СТАТИСТИКА НАСТРОЙКИ КОД СЧЕТЧИКА

ПОСТАВЬ У СЕБЯ СЧЕТЧИК
Общая статистика за 17.05.2006:
Счётчиков за день: 173,128, визитов: 350,404,561, хостов: 4,028,023, посетителей: 9,443,044.

КАТАЛОГ РЕЙТИНГА
Вокруг света (8,965) Страны, Посольства, визы, Заказ билетов, Каталоги по туризму... | Государство Российское (6,599) Политика, Выборы, Власть, Право, Организации, Регионы, Города...
Деловой Мир (54,175) Финансы, Торговля, Эл. коммерция, Строительство, Транспорт, Связь... | Предприятия (20,696) Металлургия, Химия, Пищевая и лёгкая пром., Радиоэлектроника...
Домашний очаг (19,573) Знакомства, Досуг, Дети, Кухня, Хозяйка, Гардероб, Братья меньшие... | Интернет (46,895) Навигация, Услуги, Общение, Веб-дизайн, Заработок, Провайдеры...
Карьера (4,556) Агентства, Вакансии, Заграница, Советы, Биржи, Пресса... | Компьютеры (18,997) Софт, Железо, Безопасность, Новости, Издания, Рынок...
Культура/Искусство (27,516) Литература, Театры, Кино, Фото, Музыка, Танец... | Наука/Образование (19,516) ВУЗы, Рефераты, Образовательные программы, Медицина, Техника...
Непознанное (4,969) Религия, Эзотерика, Астрология, Гадания, Мистика, НЛО... | Авто/мото (10,994) Купля-продажа, Информация, Автобизнес, Запчасти и Новости...
Отдых (36,120) Игры, Развлечения, Кино, фото, Меломану, Активный отдых, Хобби... | СМИ (5,859) Онлайн издания, Радио, ТВ, Новости, Газеты, Журналы, Обзоры...
Спорт (8,113) Формула-1, Футбол, Хоккей, Теннис, Атлетизм, Единоборства, Экстрим... | Справки (2,741) Адреса и телефоны, Погода, Каталоги, Словари, Расписания...
Юмор (3,948) Анекдоты, Весёлости, Литература, Из жизни, Клубы, Картинки...

ВАША СТАТИСТИКА
Введите URL Вашего ресурса:

ИЛИ ID счётчика:

Пароль:
(если статистика не общедоступна)
Забыли пароль?
(чтобы получить пароль по почте - введите e-mail, на который был зарегистрирован счетчик, не забудьте указать ID своего счетчика или его URL)

ЛУЧШАЯ ДЕВЯТКА РЕЙТИНГА
обновлено 18 мая в 23:59
1. | Mail.Ru | статистика
2. | Рамблер - главная стр... | статистика
3. | ВЗГЛЯД - деловая газета | статистика
4. | Знакомства@Mail.Ru | статистика
5. | GISMETEO.RU: Погода от ФОБОС | статистика
6. | РБК | статистика
7. | Поиск@Mail.Ru | статистика
8. | Фишки НЕТ | статистика
9. | Фото@Mail.Ru | статистика
весь список »

Поиск:
В Интернете В Картинках

Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Чаты · WiW · Жуки
Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

© 1999—2005 Mail.Ru
rating@corp.mail.ru


Рейтинг@Mail.ru: Компьютеры > Программирование

Поиск по интернету
РЕЙТИНГ РЕГИСТРАЦИЯ СТАТИСТИКА НАСТРОЙКИ КОД СЧЕТЧИКА

ДРУГИЕ КАТЕГОРИИ
  • Безопасность в сети (931)
  • Железо (2,364)
  • Компьютерные издания (611)
  • Новости, события в мире компьютеров (681)
  • Операционные системы (561)
  • Оцифрованный мир (925)
  • Периферия (678)
  • Сервис (1,313)
  • Сети (896)
  • Софт (5,054)
  • Специализированный софт (1,499)
  • Что, где, почем (975)

            •

    ПРИМЕЧАНИЯ

    Вы можете посмотреть объединенный график динамики посещаемости, поставив галочки напротив интересующих вас ресурсов (не более 8) и нажав на

    количество различных страниц ресурса, на которых установлен счётчик

    Подписью новый! отмечены ресурсы, добавленные за последние 3 дня.

    Числа под текущими значениями посетителей и визитов означают изменение количества посетителей и визитов по сравнению со вчерашними значениями в это же время.

    Бегун - система размещения рекламы Компьютеры Gateway из США от Авторизованного реселлера
    Настольные ПК, моноблоки, ноутбуки, сервера компании Gateway (США). Процессор до двухъядерного Pentium Extreme Edition 955 с HT (3.46GHz, 1066MHz, 2x2M cache), чипсет до 975X, видео до NVIDIA 7800GTX. Монитор до 21" (1680x1050) с HDCP. ISO 9001:2000
    Бегун - система размещения рекламы "Тест Лайн": лаборатория восстановления данных и ремонта HDD
    Извлечем информацию, восстановим данные с поврежденных или частично неисправных накопителей, а так же с исправных накопителей с разрушенной логической структурой. Отремонтируем HDD.
    Бегун - система размещения рекламы Разместите здесь ваше рекламное объявление за 0.07$!

    Рейтинг > Компьютеры > Программирование

    рейтинг за: день | неделю | месяц

    1 2 3 4 5 6 7 8 9 10 (...) обновлён 18 мая в 23:59
     | название | посетители | хосты | визиты | количество страниц
1. статистика | Ru.Board Крупный портал для вебмастеров и программистов | 33,480 +6,136 | 31,944 +8,009 | 233,643 +57,458 | 121
2. статистика | RSDN Российская Cеть Разработчиков Программного Обеспечения | 8,880 +4,639 | 7,773 +3,573 | 188,164 +108,578 | 1,433
3. статистика | Исходники.RU | 5,463 +575 | 5,691 +891 | 38,305 +14,065 | 1,728
4. статистика | GameDev.ru - Разработка игр: C++ Delphi DirectX OpenGL | 4,944 +569 | 5,151 +631 | 38,612 +6,937 | 485
5. статистика | ASP.NET, C#, VB.NET - форумы, статьи, бесплатный хостинг | 5,111 +2,784 | 4,792 +2,384 | 21,114 +11,633 | 4,924
6. статистика | Форум программистов Vingrad (международный) | 4,202 +1,912 | 4,445 +1,894 | 28,229 +12,229 | 205
7. статистика | Компьютерная документация от А до Я | 4,384 +442 | 4,388 +562 | 13,317 +178 | 2,434
8. статистика | SQL .RU - Все про SQL и клиент/серверные технологии | 3,813 +2,641 | 3,682 +2,501 | 10,107 +7,265 | 495
9. статистика | Программирование для всех | 3,147 +1,002 | 3,185 +981 | 16,292 +7,014 | 2,875
10. статистика | Русские документы: ежедневный IT-дайджест | 2,793 +1,331 | 2,928 +1,451 | 9,260 +4,576 | 1,533
11. статистика | Клуб разработчиков PHP | 2,669 +922 | 2,777 +1,044 | 19,705 +7,682 | 332
12. статистика | Interface Ltd. Дистрибуция ПО, обучение, документация... | 2,649 +1,413 | 2,681 +1,492 | 12,442 +7,866 | 1,576
13. статистика | W A S M . R U | 2,411 +488 | 2,550 +570 | 13,274 +1,467 | 61
14. статистика | ProgZ.ru - Форумы по программированию | 2,652 +1,241 | 2,467 +992 | 11,063 +5,694 | 39
15. статистика | COMPRESSION.RU: Все о сжатии видео, графики, видео | 2,294 +868 | 2,289 +924 | 7,100 +2,874 | 1,088
16. статистика | Курс борьбы с программированием, windows и web | 2,133 +941 | 2,211 +963 | 5,444 +830 | 370
17. статистика | Мастера DELPHI - крупный портал о Delphi. | 1,922 +818 | 2,093 +849 | 19,935 +8,980 | 331
18. статистика | Исходники.Ру : Портал программиста : Ishodniki.Ru | 1,997 +955 | 2,032 +927 | 13,185 +6,386 | 57
19. статистика | Алгоритмы, методы, исходники | 1,572 +674 | 1,655 +677 | 6,507 +1,699 | 882
20. статистика | INFOCITY - виртуальный город компьютерной документации | 1,582 +691 | 1,624 +718 | 4,316 +1,680 | 1,344
21. статистика | VBStreets.ru - Всё о Visual Basic и ASP! | 1,265 +465 | 1,371 +477 | 8,491 +1,479 | 442
22. статистика | Software-Testing.Ru - сервер тестировщиков и QA. | 1,442 +1,112 | 1,350 +1,012 | 6,999 +5,314 | 805
23. статистика | ASP.NET Mania - все про ASP.NET и .NET Framework. | 1,384 +768 | 1,327 +696 | 11,101 +7,737 | 4,173
24. статистика | Java User Group Alliance (Russia) Java хостинг, форум, и т.п | 1,248 +181 | 1,320 +257 | 7,659 +2,483 | 675
25. статистика | Клуб программистов Весельчак У | 1,288 +519 | 1,288 +477 | 4,319 +1,040 | 894
26. статистика | Каталог бесплатных скриптов (Perl & PHP). Вебтехнологии. | 1,113 +413 | 1,176 +472 | 3,745 +1,502 | 367
27. статистика | "Первые шаги" от новичка до профеcсионала | 1,027 +295 | 1,081 +325 | 3,362 +1,395 | 8
28. статистика | Delphi Plus - ежедневные новости информационных технологий | 1,017 +456 | 1,066 +502 | 2,523 +1,257 | 248
29. статистика | BIB.com.ua - BIBлиотека программиста | 937 +242 | 949 +282 | 2,947 +1,019 | 1,239
30. статистика | ExCode.ru - программирование на высоком уровне | 905 +500 | 932 +503 | 2,402 +1,026 | 900
1 2 3 4 5 6 7 8 9 10 (...)
 | зарегистрировано 953,615 визитов на 2,509 ресурсов
    Поиск:
    В Интернете В Картинках

    Новости · Финансы · Авто · Спорт · Погода · Афиша · ТВ · Софт · Леди · Каталог
    Аукцион · Покупки · Путешествия · Недвижимость · Словари · Мой сайт · Работа · Блоги
    Знакомства · Открытки · Анекдоты · Гороскопы · Mobile · Чаты · WiW · Жуки
    Фото · Рассылки · Энциклопедии · Рейтинг · Деньги · Агент · Хостинг · Реклама на Mail.ru

    © 1999—2005 Mail.Ru, rating@corp.mail.ru


ESMAJ

 Contents Contents
Contents

EXACT STRING MATCHING ALGORITHMS
Animation in Java

Christian Charras - Thierry Lecroq
Laboratoire d'Informatique de Rouen
Université de Rouen
Faculté des Sciences et des Techniques
76821 Mont-Saint-Aignan Cedex
FRANCE

e-mails: {Christian.Charras, Thierry.Lecroq}@laposte.net
  • Introduction
  • Brute Force algorithm
  • Deterministic Finite Automaton algorithm
  • Karp-Rabin algorithm
  • Shift Or algorithm
  • Morris-Pratt algorithm
  • Knuth-Morris-Pratt algorithm
  • Simon algorithm
  • Colussi algorithm
  • Galil-Giancarlo algorithm
  • Apostolico-Crochemore algorithm
  • Not So Naive algorithm
  • Boyer-Moore algorithm
  • Turbo BM algorithm
  • Apostolico-Giancarlo algorithm
  • Reverse Colussi algorithm
  • Horspool algorithm
  • Quick Search algorithm
  • Tuned Boyer-Moore algorithm
  • Zhu-Takaoka algorithm
  • Berry-Ravindran algorithm
  • Smith algorithm
  • Raita algorithm
  • Reverse Factor algorithm
  • Turbo Reverse Factor algorithm
  • Forward Dawg Matching algorithm
  • Backward Nondeterministic Dawg Matching algorithm
  • Backward Oracle Matching algorithm
  • Galil-Seiferas algorithm
  • Two Way algorithm
  • String Matching on Ordered Alphabets algorithm
  • Optimal Mismatch algorithm
  • Maximal Shift algorithm
  • Skip Search algorithm
  • KMP Skip Search algorithm
  • Alpha Skip Search algorithm
  • Postscript
  • Portable Document Format
Tue Jan 14 15:03:31 MET 1997


Adobe - Reader Download

 Accessibility
Adobe
  • Your Cart
  • Welcome, Guest
  • Your Account
  • Sign Out
  • Contact
  • United States (Change)
  • Solutions
    Industries
    Education
    Financial Services
    Government
    Manufacturing
    Telecommunications
    Solutions
    Digital Imaging
    Document Services
    Mobile
    Print Publishing
    Rich Internet Applications
    Training and eLearning
    Video and Audio
    Web Conferencing
    Web Publishing
    All Industries & Solutions ›
  • Products
    • Acrobat Family
    • After Effects
    • Breeze
    • ColdFusion
    • Creative Suite Family
    • Dreamweaver
    • Flash
    • Flex
    • Illustrator
    • InDesign
    • LiveCycle
    • Macromedia Studio
    • Mobile Products
    • Photoshop
    • Premiere
    • All Products ›
  • Support
    • Support Home
    • Customer Service
    • Training
    • Support Programs
    • Forums
    • Documentation
    • Updates
    • More ›
  • Communities
    By User
    Designers
    Developers
    Educators
    Partners
    By Resource
    Adobe Labs
    Forums
    Exchange
    Blogs
  • Company
    • About Adobe
    • Press
    • Investor Relations
    • Corporate Affairs
    • Jobs
    • Showcase
    • Events
    • Contact Adobe
    • More ›
  • Downloads
    • Downloads Home
    • Trial Downloads
    • Updates
    • Get Adobe Reader
    • Get Flash Player
    • More ›
  • Store
    • Store Home
    • Software
    • Fonts
    • Books
    • Support
    • Your Account
    • Volume Licensing
    • Other Ways to Buy ›

  1. Home
  2. Products
  3. Acrobat

Adobe Reader

Download the latest version of Adobe Reader

Latest version for your operating system

Adobe Reader for
Windows XP ,
English

Latest version

Choose a different version.
Adobe Reader for mobile devices.

Also download:

Adobe Yahoo! Toolbar Learn more.

Adobe Photoshop® Album Starter Edition Learn more.

Download information

File size: MB

Est. download time:

hour hours min min sec sec @ T1

hour hours min min sec sec @ 56k

System requirements

Update advisory: It is recommended that version 6.0.1 be updated to version 6.0.2 from within Adobe Reader. Learn more.

Download Adobe Reader

By downloading software from the Adobe web site, you agree to the terms of our license agreements, including that you agree not to use Adobe Reader software with any other software, plug-in or enhancement which uses or relies on Adobe Reader when converting or transforming PDF files into other file formats.
Adobe Reader license agreement
Adobe Photoshop Album Starter Edition license agreement

Adobe Reader updates

Get the latest updates available for your version of Adobe® Reader®.

Distribute Adobe Reader

Find out how to distribute Adobe Reader software on an intranet, CD, or other media, or place an "Includes Adobe Reader" logo on your printed material.

More info

  • Adobe Reader
  • Adobe Reader for Symbian OS™
  • Adobe Reader for Pocket PC
  • Adobe Reader for Palm OS®
  • What is Adobe PDF?

  • Company
  • Online Privacy Policy
  • Terms of Use
  • Contact Us
  • Accessibility
  • Report Piracy
  • Permissions & Trademarks
  • Product License Agreements
  • Send Feedback

Copyright © 2006 Adobe Systems Incorporated. All rights reserved.

Use of this website signifies your agreement to the Terms of Use and Online Privacy Policy.

Search powered by Powered by Google


(in English)

БЫСТРЫЕ АЛГОРИТМЫ И МЕТОД БВЕ *

Е. А. Карацуба

I. БЫСТРЫЕ АЛГОРИТМЫ

Область вычислительной математики, которая называется быстрые алгоритмы, появилась в 1960 году.

Под алгоритмом мы будем понимать правило или способ вычисления, не формализуя это понятие. Далее будем считать, что числа записаны в двоичной системе счисления, знаки которой 0 и 1 называются битами.

Опр. 1. Запись знаков 0, 1 , плюс, минус, скобка; сложение, вычитание и умножение двух битов назовём одной элементарной или битовой операцией.

Быстрые алгоритмы — это область вычислительной математики, которая изучает алгоритмы вычисления заданной функции с заданной точностью с использованием как можно меньшего числа битовых операций. Тем самым, алгоритмы, которые можно назвать быстрыми, являются реальными алгоритмами. Такие алгоритмы, реализованные на ЭВМ в программном (а иногда и аппаратном) обеспечении позволяют существенно увеличить производительность работы компьютера, а иногда и решить задачи, размер которых не позволял найти решение путём применения обычных методов вычисления. Вопрос о размере задачи, которую можно решить за некоторое время с помощью данного компьютера, приводит нас к понятию сложности вычисления.

В дальнейшем, если не оговаривается иначе, под сложностью вычисления подразумевается битовая сложность.

Первые постановки задач о сложности вычислений (1956 г.) принадлежат А. Н. Колмогорову [37], [38], который в то же время подчёркивал, что «цикл моих работ по теории информации был создан под большим влиянием публикаций Норберта Винера и Клода Шеннона».

Прежде чем ввести понятие сложности вычисления, определим, что значит вычислить функцию в заданной точке. Рассмотрим наиболее простой пример вычисления вещественной функции y = f(x) вещественного переменного x, a ≤ x ≤ b. Пусть f(x) на (a,b) удовлетворяет условию Липшица порядка α, 0 < α <1, так что при x1, x2 ∊ (a,b):

|f(x1) – f(x2)| ≤ |x1 – x2|α.

Пусть n — натуральное число.

Опр. 2. Вычислить функцию y = f(x) в точке x = x0 ∊ (a,b) с точностью до n знаков, значит найти число A, что

|f(x0) – A| ≤ 2–n.

Опр. 3. Количество битовых операций, достаточное для вычисления функции f(x) в точке x = x0 с точностью до n знаков посредством данного алгоритма, называется сложностью вычисления f(x) в точке x = x0.

Таким образом, сложность вычисления f(x) в точке x = x0 есть функция n; а также f(x) и x = x0. Эту функцию обозначают символом

Sf(n) = Sf,x0(n).

Ясно, что Sf зависит также от алгоритма вычисления и при разных алгоритмах будет разной. Сложность вычисления непосредственно связана со временем, затрачиваемым компьютером на это вычисление и потому иногда в литературе обозначается «временной» функцией T(n) [36].

Вопрос о поведении Sf(n) при n → ∞ для класса функций или конкретной функции f, был впервые поставлен А. Н. Колмогоровым около 1956 года. Поскольку при вычислениях в первую очередь используются четыре арифметических действия: сложение, вычитание, умножение и деление, то прежде всего нужно знать количество битовых операций, достаточное для выполнения этих действий. Из определений 2 и 3 следует, что числа x0 и A можно представить в виде целой части и n двоичных знаков после запятой, т.е.

A = [A] + 0,ν1ν2ν3 ... νn,
x0 = [x0] + 0,μ1μ2μ3 ... μn,

где νj, μj = 0 или 1, j = 1, 2, ... , n.

Так как целые части [A], [x0] — фиксированные величины, а n → ∞, то действия производятся по существу с n-значными числами. Отсюда прежде всего возникает вопрос о сложности вычисления суммы, разности, произведения и частного двух n-значных чисел a и b. Заметим, что деление (с остатком) сводится к сложению, вычитанию и умножению чисел.

Для записи чисел a и b требуется по меньшей мере 2n битовых операций. Следовательно, сложность сложения (вычитания) a и b не меньше 3n битовых операций, и не больше (если делать это обычным способом), чем 4n битовых операций. Таким образом, порядок количества битовых операций, необходимых и достаточных для выполнения сложения (вычитания), один и тот же.

В дальнейшем для краткости, будем называть «битовые операции» просто «операциями». Следующим вопросом является вопрос о количестве операций, достаточных для вычисления произведения ab, или о сложности умножения. Функция сложности умножения получила специальное обозначение M(n).

Перемножая два n-значных числа обычным школьным способом «в столбик», мы при этом фактически складываем n n-значных чисел. Так что для сложности этого «школьного» или «обычного» метода мы имеем оценку сверху M(n) = O(n2).

В 1956 г. А. Н. Колмогоров высказал гипотезу, что нижняя оценка M(n) при любом методе умножения есть также величина порядка n2 (так называемая «гипотеза n2 Колмогорова»). На правдоподобность «гипотезы n2» указывал тот факт, что метод умножения «в столбик» известен не менее 4-х тысячелетий (например, этим методом пользовались шумеры), и если бы был более быстрый метод умножения, то он, вероятно, уже был бы найден.

В 1960 А. А. Карацуба [20], [21], [22] (см. также [36]) нашёл новый метод умножения двух n-значных чисел с оценкой сложности

M(n) = O(nlog23), log23 = 1,5849... ,

и тем самым опроверг «гипотезу n2». Этот метод впоследствии был назван «Divide and Conquer» («Разделяй и властвуй»); другие, используемые в настоящее время названия этого метода — «Binary Splitting», «Принцип Дихотомии» и т. п.

С момента появления «Divide and Conquer» начала развиваться теория быстрых вычислений. Исследования с целью поиска алгоритма умножения со сложностью, близкой к оптимальной, были продолжены рядом авторов (среди них были Тоом [51], Кук [15], Шёнхаге [45]), и в 1971 г. Шёнхаге и Штрассен [46], [47] построили алгоритм с наилучшей на настоящее время оценкой для M(n),

M(n) = O(n log n loglog n).

При построении этого алгоритма кроме "Divide and Conquer" они использовали идею выполнения арифметических действий по модулю чисел Ферма 22n+ 1, а также быстрое преобразование Фурье.

На основе «Divide and Conquer» были построены алгоритмы быстрого умножения матриц. Первый такой алгоритм в 1970 г. нашёл Штрассен [50], в дальнейшем эти исследования были продолжены Коперсмитом, Виноградом [16], Паном [43] и др.

Приблизительно в это же время стали появляться и первые быстрые алгоритмы для вычисления элементарных алгебраическх функций. Как уже упоминалось выше, деление числа a на число b с остатком, т. е. вычисление чисел q и r в формуле

a = qb + r, 0 ≤ r < b,

сводится к сложению, вычитанию и умножению, и если a и b являются n-значными числами, то сложность деления O(M(n)).

Самый простой алгоритм деления заключается в вычислении методом Ньютона обратной величины 1/b с точностью до n знаков с последующим умножением на a по алгоритму быстрого умножения.

Пусть надо вычислить x = 1/b, где 1/2 ≤ b ≤ 1 (если это не так, то умножая или деля b на 2N получим выполнение указанного условия). Возьмём в качестве начального приближения x0 = 3/2 и вычисляем по формуле

xn+1 = 2xn – bxn2.

Этот метод обеспечивает достаточно быструю сходимость к 1/b, поскольку из равенства xn = 1/b – ε, следует, что xn+1 = 1/b – bε2.

Для извлечения корня k-ой степени из числа, т. е. для вычисления a1/k можно также воспользоваться методом Ньютона. Пусть k ≥ 2 — целое число и надо вычислить x = a1/k, где a ≥ (k + 1)k. Вычисляем x по формуле:

xn+1 = xn(k + 1)/k – xnk+1/(ka).

Заметим, что умножением или делением на 2kN можно всегда добиться выполнения для a условия a ≥ (k + 1)k (иногда это условие оказывается лишним, т. е. указанный процесс быстро сходится и при других a).

За начальное приближение можно взять, например, одно из двух чисел d или d+1, где d — целое число, удовлетворяющее условию dk < a ≤ (d + 1)k. Тогда одно из чисел |d – z1/k| или |d + 1 – z1/k| не превосходит 1/2.

Сложность вычисления этим методом будет O(M(n)).

Первые быстрые алгоритмы для вычисления элементарных алгебраических функций, основанные на методе Ньютона, появились в работах Кука [15], Бендерского [8] и Брента [11] (см. также [36]).

Используя метод Ньютона можно доказать следующую теорему [11]:

Теорема. Если уравнение f(x) = 0 имеет простой корень ζ ≠ 0, f(x) непрерывна по Липшицу в окрестности ζ, и мы можем вычислить f(x) с точностью до n знаков за O(M(n)j(n)) операций, где j(n) — положительная, монотонно возрастающая функция, для любого x из окрестности ζ, то ζ можно вычислить с точностью до n знаков также за O(M(n)j(n)) операций.

В 1976 г. Саламин [44] и Брент [11] предложили первый алгоритм быстрого вычисления константы π, основанный на АГС-методе Гаусса (см., например, [13], [14]). Используя также восходящие преобразования Ландена [39], Брент [11] предложил первые АГС-алгоритмы для быстрого вычисления простейших трансцендентных функций. В дальнейшем исследование и использование АГС-алгоритмов было продолжено многими авторами, среди которых были братья Джонатан и Питер Борвайны,написавшие книгу «The Pi and the AGM» («Пи и АГС») [9], где собрано наибольшее число АГС-алгоритмов. Кроме алгоритмов вычисления простейших трансцендентных функций, в этой книге содержатся также алгоритмы для вычисления некоторых высших трансцендентных функций (гамма-функции Эйлера, например). Чтобы вычислить такие функции с точностью до n знаков с помощью описанных в книге алгоритмов требуется

O(n3/2 log3 n log log n)

операций.

О других результатах, связанных с «Divide and Conquer» и быстрыми вычислениями, см. [1], [2], [3], [6], [7], [17], [18], [36], [41].

II. МЕТОД БВЕ

1. Введение. Определение быстрого алгоритма

Будем называть «быстрым» такой алгоритм вычисления функции f = f(x), что для этого алгоритма

Sf(n) = O(M(n) logc n),

где c есть константа. Здесь и далее предполагаем, что для M(n) справедлива оценка Шёнхаге-Штрассена. Ясно, что для любого алгоритма и любой функции f, выполняется неравенство:

Sf(n) > n.

(Заметим, что только запись числа с точностью до n знаков требует не меньше, чем n + 1 операций.) Следовательно, для быстрого алгоритма

n < Sf(n) < c1 n logc+1n loglog n < n1+ε

для любого ε > 0 и n > n1(ε). Тем самым, быстрым алгоритмам соответствует правильный порядок оценки сверху Sf(n) по n, n → ∞.

Метод БВЕ (от 1990) [23]-[35] (см. также [4]-[6], [40]) является вторым после метода АГС известным на настоящее время методом быстрого вычисления классических констант e и π, и простейших трансцендентных функций. Но, в отличие от АГС, метод БВЕ является также методом быстрого вычисления высших трансцендентных функций. В настоящее время БВЕ является единственным методом, позволяющим вычислить быстро такие высшие трансцендентные функции, как гамма-функцию Эйлера, гипергеометрические функции, цилиндрические, сферические и т. д. функции при алгебраических значениях аргумента и параметров, дзета-функцию Римана и дзета-функцию Гурвица при целых значениях аргумента и алгебраических значениях параметра.

2. Вычисление константы e

Основная идея метода БВЕ проще всего объясняется на примере вычисления классической постоянной e. Рассмотрим сначала алгоритм вычисления n! за log n шагов со сложностью O(n log3 n log log n). Для простоты мы предполагаем, что n = 2k, k ≥ 1.

1-й шаг. Вычисляются n/2 произведений вида:

a1(1) = n(n–1), a2(1) = (n–2)(n–3) , ... , an/2(1) = 2*1;

2-й шаг. Вычисляются n/4 произведений вида:

a1(2) = a1(1)a2(1), a2(2) = a3(1)a4(1), ... , an/4(2) = an/2(1)an/2-1(1),

... и так далее.

k-й, последний шаг. Вычисляется одно произведение:

a1(k) = a1(k–1)a2(k–1),

и это даёт результат: n!

Для вычисления константы e возьмём m = 2k, k ≥ 1, членов ряда Тейлора для e,

e = 1 + 1/1! + 1/2! + ... + 1/(m–1)! + Rm.

При этом выбираем m так, чтобы для остатка Rm выполнялось неравенство Rm ≤ 2–n–1 . Это будет, например, когда m ≥ 4n / log n. Таким образом, возьмем m = 2k таким, что натуральное число k определяется неравенствами: 2k ≥ 4n / log n > 2 k–1.

Будем вычислять сумму

S = 1 + 1/1! + 1/2! + ... + 1/(m–1)! =

за k шагов следующего процесса.

1-й шаг. Объединяя слагаемые S последовательно попарно и вынося за скобки «очевидный» общий множитель, получаем

S = (1 / (m – 1)! + 1 / (m – 2)!) + (1 / (m – 3)! + 1 / (m – 4)!) + ... = (1 / (m – 1)!)(1 + m – 1) + (1 / (m – 3)!)(1 + m – 3) + ...

Будем вычислять только целые значения выражений, стоящих в скобках, т. е. значения m, m – 2, m – 4, ... . Таким образом, на первом шаге сумма S преобразуется к виду

S = S(1);

m1 = m / 2, m = 2k, k ≥ 1. На первом шаге вычисляются m / 2 целых чисел вида

αm1–j(1) = m – 2j, j = 0, 1, ... , m1 – 1.

Далее мы действуем аналогично: объединяя на каждом шаге слагаемые суммы S последовательно попарно, мы выносим за скобки «очевидный» общий множитель и вычисляем только целые значения выражений в скобках. Пусть сделано i шагов такого процесса.

i+1 -й (i + 1 ≤k) шаг.

S = S(i+1);

mi+1 = mi / 2 = m / 2i+1, вычисляем только m / 2i+1 целых чисел вида

j = 0, 1, ... , mi+1 – 1, m = 2k, k ≥ i+1. Здесь ((m – 1 – 2i+1j)! / (m – 1 – 2i – 2i+1j)!) есть произведение 2i целых чисел.

... и так далее.

Последний, k-й шаг. Вычисляем одно целое α1(k), вычисляем, пользуясь вышеописанным быстрым алгоритмом, значение (m – 1)!, и производим одно деление целого числа α1(k) на число (m – 1)! с точностью до n знаков. Получившийся результат и есть сумма S, или константа e с точностью до 2–n. Сложность всех вычислений есть

O(M(m) log2 m) = O(M(n) log n).

3. Метод БВЕ и быстрое суммирование рядов

Метод получил название «БВЕ» (Быстрое Вычисление E-функций) потому, что даёт возможность вычислять быстро E-функции Зигеля, и в частности, ex.

Зигель [49] назвал «E-функциями» класс функций, «похожих на экспоненциальную». К ним принадлежат такие высшие трансцендентные функции как гипергеометрические, сферические, цилиндрические функции и т. д.

С помощью БВЕ можно вычислить быстро любой подходящий степенной ряд. Например, для быстрого вычисления константы π, можно воспользоваться формулой Эйлера

π/4 = arctg 1/2 + arctg 1/3,

а метод БВЕ применить к суммированию рядов Тейлора для

arctg 1/2 = 1 / (1 * 2) – 1 / (3 * 23) + ... + (–1)r–1 / ((2r – 1)22r–1) + R1,
arctg 1/3 = 1 / (1 * 3) – 1 / (3 * 33) + ... + (–1)r–1 / ((2r – 1)32r–1) + R2,

с остаточными членами R1, R2, для которых справедливы оценки

| R1| ≤ 4 / 5 / (2r + 1) / 22r+1;
| R2| ≤ 9 / 10 / (2r + 1) / 32r+1;

и при r = n, 4( |R1| + | R1| ) < 2–n. Чтобы вычислить π с помощью БВЕ можно воспользоваться также и другими приближениями, например из [5].

Чтобы вычислить постоянную Эйлера гамма с точностью до n знаков, нужно просуммировать с помощью БВЕ два ряда. А именно, при m = 6n, k = n, k ≥ 1,

При этом

Sγ(n) = O(M(n) log2n).

Для быстрого вычисления константы γ можно также применить метод БВЕ к приближению из [12].

С помощью БВЕ можно вычислить быстро следующие два вида рядов:

при условии, что a(j), b(j) — целые числа, | a(j) | + | b(j) | ≤ (Cj)K ; | z | < 1; K и C есть константы, и z есть алгебраическое число. Сложность вычисления рядов (1), (2) с точностью до n знаков есть

Sf1(n) = O(M(n) log2n),
Sf2(n) = O(M(n) log n).

4. Вычисления экспоненциальной функции методом БВЕ

Пусть y = f(x) = ex. Вычислим функцию y = ex в точке x = x0 с точностью 2–n , предполагая сначала, что

0 < x0 < 1/4, n > 8. (3)

Возьмём целое число k, удовлетворяющее условиям 2k–1 < n ≤ 2k и положим N = 2k+1 (заметим, что 2n ≤ N < 4n). Пусть xN = α32–3 + α42–4 + ... + αN2–N, где αj = 0 или 1, j = 3, 4, ... , N, и

| x0 – xN | ≤ 2–N.

Тогда

ex0 = exN + 4θ12–N ; | θ1 | ≤ 1.

Будем вычислять exN . Представим xN в виде

xN = β2/24 + β3/28 + β4/216 + ... + βk+1/2N ,

где

β2 = α3α4 ; β3 = α5α6α7α8 ; ... ; βk+1 = αN–2k+1αN–2k+2 ... αN–1αN .

Здесь βν есть 2ν–1-значное целое число, причём 2 ≤ ν ≤ k + 1 и k + 1 = log N. Таким образом, число exN можно представить в виде произведения

Разложим каждый множитель этого произведения в ряд Тейлора:

r = N 2–ν+1 .

Для остаточного члена ряда Rν(r) справедливо следующее неравенство:

Отсюда Rν(r) < 2–N .

Следовательно, (4) можно записать в виде

где

и постоянные θν(r), 0 < θν(r) < 1 . Легко видеть, что сумма (5) является подходящей для её суммирования с помощью БВЕ. На последнем шаге процесса в (5) имеем

а затем производим деление целого числа aν на целое bν с точностью до N знаков. Тем самым, получаем такое ην, что

ξν = aν / bν = ην + θ′ν2–N, | θ′ν | < 1 .

Следовательно exN может быть представлено в виде

| θν | ≤ 1 .

Определим целое число l неравенствами 2l–1 < k ≤ 2l. Предполагая, что ην = 1, θν = 0 для ν > k, мы можем записать последнее выражение в виде

| θν | ≤ 1 .

Ясно, что log k ≤ l < log k + 1. Последнее произведение вычисляется за l шагов процесса, который аналогичен вычислению n! . Перемножим множители (6) последовательно попарно, вычисляя на 1-ом шаге 2l–1 произведений вида

(ην + 2 θν 2–N) (ην+1+ 2 θν+1 2–N) = ηνην+1+ 2 θν 2–Nην+1+ 2 θν+12–N ην + 4 θνθν+12–2N = ην,ν+1+ 8 θν,ν+12–N,

ν ≡ 0(2), ν = 2, 3, ... , 2l+ 1,
где ην,ν+1 есть N-значное число, такое что

ην,ν+1 = ηνην+1+ θ̃ 2–N, | θ̃ | ≤ 1 , | θν,ν+1 | ≤ 1.

Здесь мы учитываем, что | ην | < exN < ex0 < 3/2 .

После 1-го шага такого процесса произведение (6) принимает вид:

ν ≡ 0(2)
| θν,ν+1 | ≤1 .
Далее действуем аналогичным образом.

После 2-го шага такого процесса (6) принимает вид:

ν ≡ 2(4)
| θν,ν+1,ν+2,ν+3 | ≤ 1 .
... и так далее.

Через l шагов получим

| θ2, ..., 2l+1 | ≤ 1 .

Поскольку l < log k + 1, k = log N – 1, 2n ≤ N < 4n, то из последнего соотношения находим

ex0 = η + θ 2–n,

где η = η2, ..., 2l+ 1 , | θ | ≤ 1 .

Сложность вычисления ex0 с помощью такого процесса есть

O(M(n) log2n) .

Замечание 1. Мы рассмотрели случай 0 < x0 < 1/4 . Если x0 ≥ 1/4 , возьмём наименьшее целое число m , такое что m > 4x0. В этом случае 0 < x0/m < 1/4 , ex0 = (ex0/m)m . Тем самым вычисление ex0 сводится к вычислению ex0/m , 0 < x0/m < 1/4 , после чего результат возводится в степень m . Это не ухудшает оценку сложности вычисления, поскольку m есть фиксированное число.

5. Вычисление тригонометрических функций методом БВЕ

Вычисление тригонометрических функций y = f(x) = sin x и y = f(x) = cos x в точке x = x0 может быть сведено к вычислению реальной и мнимой частей eix0. xN представим в том же виде, что и в предыдущем случае, при этом eix0 = eixN + 4θ12–N ,

| θ1- | ≤ 1 .

Запишем

в виде

где

0 < θν(r) < 1. Далее мы производим с суммами (8), (9) те же действия, что и с суммой (4). Пусть ην , fν есть N-значные числа, такие что

ξν = a′ν / bν = ην + θ′ν 2–N, | θ′ν | ≤ 1,
ψν = a″ν / dν = fν + θ″ν 2–N , | θ″ν | ≤ 1,
,

Тогда (7) может быть представлено в виде

| θν | ≤ 1 .

Вычисляем произведение (10) посредством процесса, описанного в предыдущем параграфе. В результате со специально выбранными l, N, r находим

eix0 = f + i η + 2 θ 2–N , | θ | ≤ 1 .

и отсюда

cos x0 = f + θ12–n , | θ1 | ≤ 1 ,
sin x0 = η + θ22–n , | θ2 | ≤ 1 .

Сложность вычисления та же, что и для экспоненциальной функции:

O(M(n) log2n).

В [26] доказана следующая общая теорема:

Теорема. Пусть y = f(x) — простейшая трансцендентная функция, т. е. экспоненциальная функция или тригонометрическая функция, или элементарная алгебраическая функция, или их суперпозиция, или обратная им функция или суперпозиция обратных функций. Тогда

Sf(n) = O(M(n) log2n) .

6. Быстрое вычисление гамма-функции Эйлера при рациональном аргументе

Гамма функция Эйлера y = Γ(s) относится к тем высшим трансцендентным функциям, которые не будучи E-функциями Зигеля, могут быть, тем не менее, быстро вычислены с помощью метода БВЕ. Есть два алгоритма для вычисления Γ(s): 1) для вычисления Γ(s) при рациональных значениях аргумента s; 2) для вычисления Γ(s) при алгебраических значениях s. Первый из этих алгоритмов является более «простым», чем второй. Вычислим функцию y = Γ(x) , при x = x0 = a/b ; (a,b) = 1 , предполагая сначала, что 0 < x0 < 1 , т. е. что 0 < a < b . Воспользуемся представлением гамма-функции в виде интеграла

Легко видеть, что при p = n, 0 < x0 < 1 ,

, 0 < θ1 < 3/4 .

Следовательно,

0 < θ1 < 3/4.

Предполагая, что r ≥ 3n , разложим подинтегральную функцию в (11) y = e–t , в ряд Тейлора по степеням t:

где Rr = θr tr+1/(r+1)! , | θr | ≤ 1 . Отсюда имеем при r+1 = 6n

Γ(x0) = nx0 S + θ2–n , | θ | ≤ 1 , (12)

где

и мы будем вычислять Γ(x0) = Γ(a/b) по формулам (12)-(13). Заметим, что для вычисления nx0 = na/b, с точностью до n знаков достаточно O(M(n)) операций (методом Ньютона). Чтобы вычислить S возьмем r+1 = 2k, 2k–1 < 6n ≤ 2k, k ≥ 1; членов ряда (13). Пусть

Тогда (13) можно записать в виде

S = S1(0) + S2(0) + ... + Sr+1(0) .

Вычислим сумму S с помощью БВЕ за k шагов, объединяя на каждом шаге слагаемые S последовательно попарно и вынося за скобки «очевидный» общий множитель. Однако, в отличие от вычисления константы e методом БВЕ, теперь в скобках будут находиться не целые числа, а дроби. Поэтому теперь на каждом шаге будут вычисляться целый числитель и целый знаменатель дроби, стоящей в скобках (деление не производится до последнего шага). На первом шаге имеем

S =S 1(1) + S2(1) + ... + Sr1(1) , r1 = (r + 1) / 2
Sr1–ν(1) = Sr+1–2ν(0) + Sr–2ν(0) = (–1)r–1nr–2ν–1 / (r-2ν)! (pr1–ν(1) / qr1–ν(1)) .

На 1-ом шаге вычисляем целые числа

pr1–ν(1) = –bn(br–2bν–b+a) + (br–2bν)(br–2bν+a) ;
qr1–ν(1) = (br–2bν +a)(br–2bν–b+a) ;
ν = 0, 1, ... , (r+1)/2–1 ; r+1 = 2k , k ≥ 1 .

На j-ом шаге (j ≤ k) имеем

S = S1(j) + S2(j) + ... + Srj(j) , rj = (r + 1) / 2j ,

где Srj–ν(j) ; ν = 0, 1, ... , rj–1 ; определяются равенствами

На j-ом шаге (j ≤ k) вычисляем целые числа

ν = 0, 1, ... , rj–1 ; rj = (r + 1) / 2j .

И так далее.

На k-ом (последнем) шаге вычисляем целые числа prk(k) = p1(k) , qrk(k) = q1(k) , r! и производим одно деление с точностью до 2–2n по формуле

S = S1(k) = prk(k) / qrk(k) / r! ,

что даёт сумму S с точностью 2–n–1 . Следовательно значение Γ(x0) = Γ(a/b) вычислено с точностью 2–n+1 , n ≥ 1 . Сложность такого вычисления есть

SΓ(n) = O(M(n) log2n) = O(n log3n loglog n).

Замечание 2. Мы вычислили Γ(x0), x0 = a / b , предполагая, что 0 < x0 < 1 . Если x0 ≥ 1 , то, пользуясь соотношением, Γ(x+1) = x Γ(x) , сводим вычисление в нужной точке к вычислению в точке из интервала (0, 1) .

7. Быстрое вычисление гамма-функции Эйлера при алгебраическом аргументе

Вычислим Γ(x0) , при условии, что x0 есть алгебраическое число. В соответствии с Замечанием 2, сведём это вычисление к вычислению Γ(α) , 0 < α < 1 , где α есть алгебраическое число степени μ , μ ≥ 2 . Для простоты, рассмотрим случай, когда α является вещественным числом. Предполагается, что известен многочлен g(x) , наименьшей степени с целыми коэффициентами, корнем которого является число α , т. е.

g(x) = gμxμ + gμ–1xμ–1 + ... + g1x + g0 ; g(α) = 0 ; (14)

gμ, gμ–1, ..., g0 — целые числа, μ ≥ 2 . Как и в случае рационального аргумента воспользуемся формулами (12), (13). Отметим, что вычисление nα с точностью 2–2n по формуле nα = eα log n требует O(M(n) log2n) операций. Сумма S из (12) принимает вид

т. е.

S = S1(0) + S2(0) + ... + Sr+1(0) , (16)

где

Вычисление S выполняется за k шагов, r+1 = 2k , 2k–1 < 6n ≤ 2k , k ≥ 1 . Особенностью этого алгоритма является использование основного свойства алгебраических чисел для ограничения роста сложности вычисления. До шага i , где i определяется условиями 1 ≤ i ≤ k , 2i–1 < μ≤ 2i , производим с суммой (16), (17) действия, аналогичные вышеописанным для случая рационального аргумента. Однако, группируя слагаемые суммы (16) таким же образом как и в предыдущем параграфе, теперь мы вычисляем на каждом шаге не числитель и знаменатель дробей, находящихся в скобках, а лишь целые коэффициенты при степенях α, многочленов, находящихся в числителе и знаменателе дробей «из скобок».
На 1-ом шаге в скобках находятся дроби

вычисляются числа

ν = 0, 1, ... , (r+1)/2–1.

На i-ом шаге в скобках находятся дроби

где

вычисляются числа

0 ≤ m1 ≤ 2i–1–1 , 0 ≤ m2 ≤ 2i–1 .

0 ≤ l1 ≤ 2i–1 , 0 ≤ l2 ≤ 2i–1 .

Заметим, что умножение на степень α и вычисление δ и ρ , так же как и деление δ на ρ , не производится до последнего шага.

Перед i+1 -ым шагом (1 ≤ i ≤k , 2i–1 < μ ≤ 2i) мы редуцируем многочлены (19) по модулю многочлена g(x) при x = α . Таким образом, если

где pt–1 , ..., p0 , qt , ..., q0 целые, t = 2i , то мы делим P(x) и Q(x) на g(x) с остатками:

P(x) = g(x)P0(x) + P1(x) , Q(x) = g(x)Q0(x) + Q1(x) ,

где P1(x) и Q1(x) есть многочлены с рациональными коэффициентами, причем степени P1(x) и Q1(x) не превышают μ–1 . Отсюда и из (14) получаем

P(α) = P1(α) , Q(α) = Q1(α) ,

то есть в (18) имеем

βri–ν(i) = P1(α) / Q1(α) . (20)

Домножая, если нужно, числитель и знаменатель дроби (20) на целый общий множитель, получаем в числителе и знаменателе дробей «из скобок» многочлены с целыми коэффициентами степени не большей, чем μ–1 .

Начиная с шага i , на каждом шаге i , i+1 , ... , k , производится редукция многочленов от α , расположенных в числителе и знаменателе βξ(j) по модулю g(x) . Поскольку коэффициенты g(x) , так же как и степень g(x) являются абсолютными постоянными, то значения этих коэффициентов, участвующие в вышеописанных редукциях могут возрасти лишь не более чем в gμ раз, где

g = max 0≤i≤μ | gi | ,

что не влияет на оценку сложности проводимых вычислений. На последнем, k-ом, шаге такого процесса получаем

где

p, q ≤ μ–1 , и вычисляем δrk(k) , ρrk(k) и S, и следовательно Γ(α) с точностью 2–n+1. Сложность вычисления

SΓ(n) = O(M(n) log2n)

8. Заключение

Представленный метод БВЕ, метод быстрого суммирования специального вида рядов, позволяет вычислить любую элементарную трансцендентную функцию для любого аргумента, классические константы e, π, постоянную Эйлера γ, постоянные Апери и Каталана, такие высшие трансцендентные функции, как гамма-функцию Эйлера, гипергеометрические функции, сферические функции, цилиндрические функции и т. д. для алгебраических значений аргумента и параметров, дзета-функцию Римана для целых значений аргумента, дзета-функцию Гурвица для целого аргумента и алгебраических значений параметра, а также такие специальные интегралы, как интеграл вероятности, интегралы Френеля, интегральную экспоненциальную функцию, интегральные синус и косинус и т. д. при алгебраических значениях аргумента с оценкой сложности вычисления, близкой к оптимальной, а именно

Sf(n) = O(M(n) log2n) .

В настоящее время только метод БВЕ даёт возможность быстро вычислять значения функций из класса высших трансцендентных функций, некоторые специальные интегралы математической физики и такие классические константы, как константы Эйлера, Каталана и Апери. Дополнительным преимуществом метода БВЕ является возможность распараллеливания основанных на БВЕ алгоритмов.

III. О СЛОЖНОСТИ ВЫЧИСЛЕНИЙ

Понятие сложность вычисления возникло в результате развития вычислительных методов и теории информации.

Среди первых исследований в области теории информации были работы Гарри Найквиста [42] и Ральфа Хартли [19], где введено понятие меры информации.

Выше мы рассматривали битовую сложность, которая точнее всего определяет меру эффективности реальных вычислений. В то же время в разных задачах можно определять меру эффективности вычислений разными способами. Так, наряду с битовой, существуют алгебраическая, булева, колмогоровская, рациональная и т.д. сложности. Одни из них определяются количеством затрачиваемых на вычисление битовых, алгебраических и т.п. операций; другие — количеством шагов вычислительного процесса, например, количеством шагов работы машины Тьюринга.

Первым алгоритмом, проанализированным с точки зрения его сложности, был, по-видимому, алгоритм Евклида вычисления наибольшего общего делителя двух целых чисел. Мерой его сложности служило количество шагов-делений в этом алгоритме. Оценки сложности алгоритма Евклида получили [48] Aнтуан-Андрэ-Луи Рейно (грубая оценка числа шагов алгоритма, 1811 г.), Пьер-Жозеф-Этьен Финк (оценка шагов алгоритма, близкая к оптимальной, 1841 г.) и Габриель Ламе (оптимальная оценка, 1844 г.). Последний результат известен в литературе, как теорема Ламе.

Построение алгоритмов вычисления широкого класса функций с оценкой битовой сложности, близкой к оптимальной, а также получение нетривиальных нижних оценок битовой сложности — основные задачи в той области вычислительной математики, которая называется быстрые алгоритмы или быстрые вычисления. В настоящее время здесь остаётся много нерешённых проблем, таких как
— получение нетривиальной оценки снизу сложности умножения или сложности вычисления трансцендентных функций;
— построение быстрых алгоритмов вычисления высших трансцендентных функций в трансцендентных точках;
— построение быстрых алгоритмов вычисления таких констант, как константа Бруна, значения дзета-функции Римана в нецелых точках и т.д.

Эти и многие другие проблемы из области быстрых вычислений ещё ждут своего решения.

Список литературы

[1] В. Б. Алексеев, От метода Карацубы для быстрого умножения чисел к быстрым алгоритмам для дискретных функций. Труды Математического Института им. В. А. Стеклова, т. 218, с. 20-27 (1997).

[2] В. Б. Алексеев, С. А. Ложкин, Элементы теории графов, схем и автоматов. Изд. ВМиК МГУ, 58 с., Москва (2000).

[3] Г. И. Архипов, В. А. Садовничий, В. Н. Чубариков, Лекции по математическому анализу. Изд. Высшая школа, 695 с., Москва (1999).

[4] E. Bach, The complexity of number-theoretic constants. Info. Proc. Letters, N 62, pp. 145-152 (1997).

[5] D. H. Bailey, P. B. Borwein and S. Plouffe, On the rapid computation of various polylogarithmic constants. Math. Comp., v. 66, pp. 903-913 (1997).

[6] J. C. Bajard, J. M. Muller, Calcul et arithmétique des ordinateurs. Hermes Science, 226 pp. (2004).

[7] Л. А. Бассалыго, Замечание о быстром умножении многочленов над полями Галуа. Пробл. Пер. Инф., N 1, pp. 101-102 (1978).

[8] Ю. В. Бендерский, Быстрые вычисления. Доклады Академии Наук СССР, т. 223, N 5, с. 1041-1043 (1975).

[9] J. M. Borwein and P. B. Borwein, Pi and the AGM. Wiley, 414 pp., New York (1987).

[10] J. M. Borwein, D. M. Bradley and R. E. Crandall, Computational strategies for the Riemann zeta function. J. of Comput. Appl. Math., v. 121, N 1-2, pp. 247-296 (2000).

[11] R. P. Brent, Fast Multiple-Precision Evaluation of Elementary Functions. ACM, v. 23, N 2, pp. 242-251 (1976).

[12] R. P. Brent and E. M. McMillan, Some new algorithms for high-precision computation of Euler's constant. Math. Comp., vol. 34, pp. 305-312 (1980).

[13] B. C. Carlson, Algorithms involving arithmetic and geometric means. Amer. Math. Monthly, v. 78, pp. 496-505 (1971).

[14] B. C. Carlson, An algorithm for computing logarithms and arctangents. Math. Comp., v. 26, pp. 543-549 (1972).

[15] S. A. Cook, On the minimum computation time of functions. Thesis, Harvard University (1966).

[16] D. Coppersmith and S. Winograd, On the asymptotic complexity of matrix multiplication. SIAM Journal on Computing, v. 11, N 3, pp. 472-492 (1982).

[17] С. Б. Гашков, О сложности интегрирования рациональных дробей. Труды Математического Института им. В. А. Стеклова, т. 218, с. 122-133, (1997).

[18] С. Б. Гашков, В. Н. Чубариков, Арифметика. Алгоритмы. Сложность вычислений. Изд. Высшая школа, 2-е изд., 320 с., Москва (2000).

[19] R.V.L. Hartley, Transmission of Information. Bell System Technical Journal, v. 7, pp. 535-563 (1928).

[20] А. Карацуба и Ю. Офман, Умножение многозначных чисел на автоматах. Доклады Академии Наук СССР, т. 145, 2, с. 293-294 (1962).

[21] A. Karacuba, Berechnungen und die Kompliziertheit von Beziehungen. EIK, N 11, s. 10-12 (1975).

[22] А. А. Карацуба, Сложность вычислений. Труды Математического института им. Стеклова, т. 211, с. 169-183 (1995).

[23] Е. А. Карацуба, Быстрое вычисление exp(x). Проблемы передачи информации, т. 26, N 3, с. 109, Хроника, 17-ая Всесоюзная школа по теории информации и её приложениям (1990).

[24] Е. А. Карацуба, О новом методе быстрого вычисления трансцендентных функций. Успехи Математических Наук, т. 46, N 2 (278), с. 219-220 (1991).

[25] Е. А. Карацуба, О быстром вычислении трансцендентных функций. Доклады Академии Наук СССР, т. 319, N 2, с. 278-279 (1991).

[26] Е. А. Карацуба, Быстрое вычисление трансцендентных функций. Проблемы передачи информации, т. 27, N 4, с. 87-110 (1991).

[27] Е. А. Карацуба, Быстрое вычисление ζ(3). Проблемы передачи информации, т. 29, N 1, с. 68-73 (1993).

[28] Catherine A. Karatsuba, Fast evaluation of Bessel functions. Integral Transforms and Special Functions, v. 1, N 4, pp. 269-276 (1993).

[29] Е. А. Карацуба, Быстрое вычисление дзета-функции Римана ζ(s) для целых значений аргумента s. Проблемы передачи информации, т. 31, N 4, с. 69-80 (1995).

[30] Е. А. Карацуба, О быстром вычислении дзета-функции Римана для целых значений аргумента .Доклады Академии Наук СССР, т. 349, N 4, с. 463 (1996).

[31] Е. А. Карацуба, Быстрое вычисление дзета-функции Гурвица и L-рядов Дирихле. Проблемы передачи информации, т. 34, N 4, с. 342-353 (1998).

[32] Ekatharine A. Karatsuba, Fast evaluation of hypergeometric function by FEE. Computational Methods and Function Theory (CMFT'97), N. Papamichael, St. Ruscheweyh and E. B. Saff, eds., World Sc. Pub., pp. 303-314 (1999).

[33] E. A. Karatsuba, On the computation of the Euler constant γ. University of Helsinki preprint, 21 pp. (1999); J. of Numerical Algorithms, v. 24, pp. 83-97 (2000).

[34] E. A. Karatsuba, Fast computation of ζ(3) and of some special integrals, using the polylogarithms, the Ramanujan formula and it's generalization. J. of Numerical Mathematics BIT, v. 41, N 4, pp. 722-730 (2001).

[35] E. A. Karatsuba, Fast computation of some special integrals of mathematical physics. Scientific Computing, Validated Numerics, Interval Methods , W. Krämer, J. W. von Gudenberg, eds., pp. 29-41 (2001).

[36] Д. E. Kнут, Искусство программирования на ЭВМ. т. 2, Изд. Мир, 724 с., Москва (1977).

[37] А. Н. Колмогоров, О некоторых асимптотических характеристиках вполне ограниченных метрических пространств. Доклады Академии Наук СССР, т. 108, N 3, с. 385-388 (1956).

[38] А. Н. Колмогоров, Теория информации и теория алгоритмов. Изд. Наука, 303 с., Москва (1987).

[39] J. Landen, An investigation of a general theorem for finding the length of any arc of any conic hyperbola, by means of two elliptic arcs, with some other new and useful theorems deduced therefrom. Philos. Trans. Royal Soc. London v. 65, pp. 283-289 (1775).

[40] D. W. Lozier and F. W. J. Olver, Numerical Evaluation of Special Functions. Mathematics of Computation 1943-1993: A Half -Century of Computational Mathematics, W. Gautschi, eds., Proc. Sympos. Applied Mathematics, AMS, v. 48, pp. 79-125 (1994).

[41] В. И. Нечаев, Элементы криптографии. Основы теории защиты информации. Изд. Высшая школа, 110 с., Москва (1999).

[42] H. Nyquist, Certain factors affecting telegraph speed. Bell System Technical Journal, v. 3, pp. 324-346 (1924).

[43] V. Ya. Pan, Strassen's algorithm is not optimal. Proc. ACM Symp. on the Found. of Comp. Science, pp. 166-176 (1978).

[44] E. Salamin, Computation of π using arithmetic-geometric mean. Math. Comp., vol. 30, N 135, pp. 565-570 (1976).

[45] A. Schönhage, Schnelle Multiplikation grosser Zahlen. Computing, v. 1, pp. 182-196 (1966).

[46] A. Schönhage und V. Strassen, Schnelle Multiplikation grosser Zahlen. Computing, v. 7, pp. 281-292 (1971).

[47] A. Schönhage, A. F. W. Grotefeld and E. Vetter, Fast Algorithms — A Multitape Turing Machine Implementation. BI-Wiss.-Verl., 300 pp., Zürich (1994).

[48] J. Shallit, Origins of the Analysis of the Euclidean Algorithm. Historia Mathematica, v. 21, pp. 401-419 (1994).

[49] C. L. Siegel, Transcendental numbers. Princeton University Press, 102 pp., Princeton (1949).

[50] V. Strassen, Gaussian elimination is not optimal. J. Numer. Math., N 13, pp. 354-356 (1969).

[51] А. Л. Тоом, О сложности схемы из функциональных элементов, реализующей умножение целых чисел. Доклады Академии Наук СССР, т. 150, N 2, с. 496-498 (1963).

J

Ответы на часто задаваемые вопросы

О методе БВЕ в статье:
Е. А. Карацуба,
«Быстрое вычисление дзета-функции Римана ζ(s) для целых значений аргумента s».
Проблемы передачи информации, т. 31, № 4, с. 69-80 (1995).

*) Если какие-нибудь математические символы или формулы Вами не видны, Вы можете скачать себе файл в формате:
  • MS-Word (219 136 байтов);
  • HTML (с элементами векторной графики 323 522 байта);

Содержание этой страницы
I. БЫСТРЫЕ АЛГОРИТМЫ
II. МЕТОД БВЕ
1. Введение. Определение быстрого алгоритма
2. Вычисление константы e
3. Метод БВЕ и быстрое суммирование рядов
4. Вычисления экспоненциальной функции методом БВЕ
5. Вычисление тригонометрических функций методом БВЕ
6. Быстрое вычисление гамма-функции Эйлера при рациональном аргументе
7. Быстрое вычисление гамма-функции Эйлера при алгебраическом аргументе
8. Заключение
III. О СЛОЖНОСТИ ВЫЧИСЛЕНИЙ
Список литературы
© Екатерина Карацуба
Последняя редакция: 28.10.2005.


(in English)

МЕТОД КАРАЦУБЫ «DIVIDE AND CONQUER» *

Здесь представлены два равносильных варианта метода Карацубы «Divide and Conquer» («Binary Splitting»). Первый вариант основан на формуле

(a + bx)2 = a2 + ((a + b)2 – a2 – b2)x + b2x2,

а второй — на формуле

(a + bx)(c + dx) = ac + ((a + b)(c + d) – ac – bd)x + bdx2.

I. Так как 4ab = (a + b)2 – (a – b)2, то умножение двух чисел a и b эквивалентно по сложности выполнения возведению в квадрат.

Пусть X — n -значное число, т. е.

X = ε0 + 2ε1 + ... + 2n–1εn–1,

где εj = 0 или 1, j = 0, 1, ..., n-1. Будем считать для простоты, что n = 2m, m ≥ 1; 2k = n. Представляя X в виде

X = X1 + 2kX2,

где

X1 = ε0 + 2ε1 + ... + 2k–1εk–1 ,
X2 = εk + 2εk+1 + ... + 2k–1εn–1 ,

находим

X2 = (X1 + 2kX2)2 = X12+ ((X1 + X2)2 – (X12 + X22))2k + X222n.
 (1)

Числа X1 и X2 являются k -значными. Число X1 + X2 может быть k+1 -значным. В этом случае представим его в виде 2X3 + X4, где X3 есть k -значное число, X4 — однозначное число. Тогда

(X1 + X2)2 = 4X32 + 4X3X4 + X42 .
(2)

Обозначим через φ(n) количество операций, достаточное для возведения n -значного числа в квадрат по формуле (1). Из (1) следует, что для φ(n) справедливо неравенство

φ(n) ≤ 3φ(n2–1) + cn ,
(3)

где c > 0 — абсолютная постоянная. Действительно, принимая во внимание (2), правая часть (1) содержит сумму трёх квадратов k -значных чисел, k = n2–1, которые для своего вычисления требуют 3φ(k) = 3φ(n2–1) операций. Все остальные вычисления в правой части (1), а именно умножение на 4, 2k, 2n, пять сложений и одно вычитание не более чем 2n -значных чисел требуют по порядку не более :n операций. Отсюда следует (3). Применяя (3) последовательно к φ(n2–1), φ(n2–2) , ... , φ(n2–m+1) и замечая, что φ(n2–m) = φ(1) =1, получаем

φ (n) ≤ 3(φ(n2–1) + cn2–1) + cn = 32φ(n2–2) + 3cn2–1 + cn ≤ ... ≤
≤ 3mφ(n2–m) + 3m–1c(n2–m+1) + 3m–2c(n2–m+2) + ... + 3 c(n2–1) + cn =
= 3m + cn((3/2)m–1 + (3/2)m–2 + … + (3/2) + 1) =
= 3m + 2cn((3/2)m – 1) < 3m (2c + 1) = (2c+1) nlog 23

Тем самым для количества φ(n) операций, достаточного для возведения n -значного числа в квадрат по формуле (1) выполняется оценка

φ(n) < (2c+1) nlog 23 , log 2 3 = 1,5849... .
(4)

Если же n не является степенью двух, то определяя целое число m неравенствами 2m–1 < n ≤ 2m, представим X как 2m -значное число, т. е. полагаем последние 2m–n знаков равными нулю: εn = ... = ε2m–1 = 0. Все остальные рассуждения остаются в силе и для φ(n) получается такая же верхняя оценка по порядку величины n.

II. Второй способ представлет собой непосредственное умножение двух n -значных чисел. Пусть, как и раньше n = 2m, 2k = n; A и B — два n -значных числа. Представляя A и B в виде

A = A1 + 2kA2 , B = B1 + 2kB2,

где A1, A2, B1, B2 — k -значные числа, находим:

AB = A1B1 + 2k((A1 + A2)(B1 + B2) – (A1B1 + A2B2)) + 2nA2B2 .
(5)

Таким образом, в этом случае формула (1) заменяется формулой (5). Если теперь обозначить символом φ(n) количество операций, достаточное для умножения двух n-значных чисел по формуле (5), то для φ(n) выполняется неравенство (3), и, следовательно, справедливо неравенство (4).

Отметим, что представленный выше первый способ умножения можно трактовать как алгоритм вычисления с точностью до n знаков функции y = x2 в некоторой точке x = x1.

Если разбивать X не на два, а на большее количество слагаемых, то можно получать асимптотически лучшие оценки сложности вычисления произведения (возведения в квадрат).

Метод «Divide and Conquer» (его другие названия «Принцип Дихотомии», «Binary Splitting», и т. п.) является основополагающим и наиболее общим быстрым методом. На его основе построены сотни различных алгоритмов.

J

Об истории создания метода: А. А. Карацуба «Сложность вычислений» Труды Матем. инст. им. Стеклова, т. 211, с. 169-183 (1995).

О методе «Divide and Conquer» и его использовании можно также посмотреть на многочисленных WEB-страницах, например:

  • http://212.cmc-msu.ru/files/kniga.html
  • http://educeth.ethz.ch/informatik/werkstatt/multiplik/smult/
  • http://gersoo.free.fr/docs/karat/kar.html
  • http://numbers.computation.free.fr/Constants/Algorithms/representation.html
  • http://www-math.uni-paderborn.de/mca/mult.html
  • http://www.cs.pitt.edu/~kirk/cs1501/animations/
  • http://www.cs.princeton.edu/introcs/79crypto/Karatsuba.java.html
  • http://www-2.cs.cmu.edu/~cburch/251/karat/

БЫСТРЫЕ АЛГОРИТМЫ И МЕТОД БВЕ

*) Если какие-нибудь математические символы или формулы Вами не видны, Вы можете скачать себе файл в формате: MS-Word (40 960 байтов);

© Екатерина Карацуба
Последняя редакция 14.09.2005.


Ответы на часто задаваемые

вопросы

— Кто является автором метода "Binary Splitting" ?

— А. А. Карацуба. «Binary plitting» — это другое имя метода «Divide and Conquer».

— Кто развивал метод «Binary Splitting» (= «Divide and Conquer») ?

— Если под словом «развивал» иметь ввиду основанные на «Divide and Conquer» алгоритмы, то его развивали и применяли на практике сотни людей, и среди этих алгоритмов наиболее широко известными являются алгоритмы Быстрого Преобразования Фурье (FFT) и Быстрого Умножения Матриц.

— Кто является автором метода Быстрого суммирования рядов (специального вида) и когда этот метод возник?

— Этот метод (названный впоследствии БВЕ) найден мной в 1990 году. Особенностью метода БВЕ является то, что с его помощью можно вычислять быстро не только все элементарные трансцендентные функции, но и многие высшие трансцендентные функции (такие, например, как гамма-функция Эйлера, функции Бесселя, гипергеометрические ряды), для вычисления которых до этого быстрых алгоритмов не было.

— Существовал ли до этого какой-либо метод быстрого вычисления константы e, константы π ?

— Только метод Арифметико-Геометрически Средних (Гаусса). Под «быстрым вычислением» подразумевается вычисление, битовая сложность которого близка, асимптотически, к оптимальной (неулучшаемой).

— Почему Вы утверждаете, что метод быстрого вычисления сумм путём попарного сложения возник в 1990 году? Ведь люди с давних времён складывали числа попарно для получения их суммы.

— Сложить несколько чисел попарно (или не попарно) не является проблемой. Проблемой является быстрое вычисление сумм вида (1),(2) (см. текст «Быстрые алгоритмы и метод БВЕ»). Попарного сложения для быстрого вычисления таких сумм не достаточно.

— Используется ли при вычислениях с помощью «БВЕ» метод «Divide and Conquer» (= «Binary Splitting»)?

— Да, конечно. Подразумевается, что произведения чисел вычисляются с помощью «Binary Splitting».

— До 1990 года предлагались алгоритмы для вычисления экспоненциальной функции с помощью «Binary Splitting».

— Действительно, такие алгоритмы были. Метод «Binary Splitting» применяется для быстрого вычисления произведения, и кажется естественным применить его для вычисления мультипликативной функции. Однако, быстрого алгоритма для вычисления экспоненциальной функции построено не было, потому что представить эту функцию в виде «удачно организованного» произведения оказалось недостаточно для создания быстрого алгоритма. Нужно было ещё быстро вычислить каждый множитель этого произведения, который в свою очередь представлял собой «сложную» функцию. Чтобы быстро вычислять такие множители-функции как раз и нужен метод БВЕ.

— Как отличить методы «Binary Splitting» и БВЕ ?

— Очень просто. Если от шага (процесса) к шагу количество участвующих в процессе (вычисления) чисел увеличивается, а их длина (количество их знаков) уменьшается, то это «Binary Splitting» (= «Divide and Conquer»): название процесса соответстует процессу; «splitting» — это «расщепление». Если же от шага к шагу количество участвующих в процессе чисел уменьшается, а их длина растёт, то это метод БВЕ. На последнем шаге в «Divide and Conquer» производится перемножение и сложение многих малозначных чисел. На последнем шаге БВЕ производится деление одного большого целого числа на другое.

— Методы «Binary Splitting» и БВЕ похожи: в первом из них перемножаемые числа представляются в виде суммы двух чисел, во втором числа складываются попарно. Можно ли считать метод БВЕ «параллельным Binary Splittingом»?

— Нет. Это совершенно разные, в некотором смысле обратные друг другу процессы. Кроме того. Недостаточно пошагового расщепления перемножаемых чисел для того, чтобы построить метод быстрого умножения, такой как «Binary Splitting». Недостаточно складывать слагаемые ряда попарно чтобы получить быстрый процесс вычисления сумм (вида (1),(2) и схожих с ними), такой как БВЕ. Об особенностях этих методов см. текст «Быстрые алгоритмы и метод БВЕ».

— В некоторых западных пакетах программ, в том числе в таких, как Mathematica и Maple, по словам разработчиков, метод БВЕ внедрён под именем «Binary Splitting». Может быть стоит согласиться с этим названием, раз многие программисты из западных стран называют этот метод таким именем?

— Нет. Даже если все, как западные, так и восточные, программисты будут называть интегрирование дифференцированием, оно, интегрирование, от этого дифференцированием не станет. Метод быстрого суммирования рядов специального вида — БВЕ — с увеличивающимися от шага к шагу вычисляемыми значениями не может называться «splitting» — расщепление. Это ошибочное название. Это ошибка.

J

© Екатерина Карацуба
Файл размещен: 15.05.2005.
Последняя редакция: 28.10.2005.


Ghostscript, Ghostview and GSview

Welcome to the Home Page for Ghostscript, an interpreter for the PostScript language and for PDF, and related software and documentation.

Software available at this site

  • AFPL Ghostscript (current stablerelease)
    • AFPL Ghostscript 8.54
  • GPL Ghostscript
    • GPL Ghostscript 8.50 released 2005-12-31
    • GPL Ghostscript 8.15 released 2004-09-23
    • GNU Ghostscript 7.07 released 2003-05-17
  • AFPL Ghostscript developer and beta filesets
  • Ghostview and GV previewers for Unix & VMS
  • MacGSView previewer for MacOS
  • GSview previewer for Windows, OS/2 & Linux.
    • GSview 4.8 released 2006-02-25.
    • GSview can be used as a viewer for
      Netscape Navigator and Internet Explorer
    • epstool for adding and removing DOS EPS previews
  • RedMon - Redirect a Windows printer port to Ghostscript.
    • RedMon 1.7 released 2001-10-28
  • ansi2knr - Convert ANSI C programs to traditional ("Kernighan & Richie") C.

Other sites

  • FTP mirror sites. Please download from one near you.
  • Ghostscript news and community site
  • Obtaining GSview and Ghostscript on CD-ROM
  • Links to other sites

Documentation

  • Frequently Asked Questions
  • Introduction to Ghostscript
  • Ghostscript documentation
  • Gripes
  • Printer compatibility
  • Newsgroups for Ghostscript
  • Books about PostScript
Last updated $Date: 2006-05-17 22:52:40 -0500 (Wed, 17 May 2006) $ Corrections to the Ghostscript WWW pages should be mailed to Russell Lang


demo.design 3D programming FAQ

FAQ logo
demo.design
3D programming FAQ


Gateway Authorised Reseller INTERCOM-XXI - Главная страница

Главная
Контактный телефон: (095) 787-0088 E-Mail: sales@gateway.ru
Новости
» Gateway выпускает новый планшетный ноутбук M285-E с двуядерным процессором
» Gateway представил широкоформатный ноутбук E-100M...
» Gateway анонсировала легкий производительный ноутбук....
Прайс-лист

НАШИ ПАРТНЕРЫ:

Москва: Альфа-Системс (495) 507-8327; Санкт-Петербург: Ай-ТиКом.СПб (812) 380-7588, ВидеоТесТ (812) 314-2205; Тверская область: БИТ "Алгол" (48233) 529-92; Нижний Новгород: ТРАНССЕТЬ (8312) 95-6048; Краснодар: IT Мастер Юг (861) 277-0341; Самара: НПП-Куйбышев Телеком (846) 277-9102

ХОТИТЕ СТАТЬ НАШИМ ПАРТНЕРОМ? ЖМИТЕ СЮДА!!!

______________________________________________________________________

МОНОБЛОК GATEWAY PROFILE 5.5 С ЭКРАНОМ 19"!!!

Теперь и с процессором Intel® Pentium®4 660 (3.6GHz/2MB Cache)!!! Видео до 128MB!!!

Cпециальный приз журнала PC Magazine (Russian Edition) "Продукт года"!!!

Приз журнала PC World (США) "Лучшая покупка (Best Buy)"!!!

Презентация Перечень конфигурацийСпецификации

______________________________________________________________________

НОВЫЙ 21-дюймовый LCD ОТ GATEWAY!!!

Разрешение экрана — 1680 x 1050 пикселей (16:10)!!! Время отклика — 8 мс!!!
Контраст — 1000:1!!! Картинка в картинке!!!

Презентация Подробнее о мониторе Спецификации

______________________________________________________________________

НОУТБУК M685 С МАТРИЦЕЙ 17" WSXGA+ (1680 x 1050)!!!

ПРОЦЕССОР ДО Intel® Core™ Duo Processor T2500 (2.00 GHz, 667MHz FSB, 2MB L2 Cache) !!!

ВИДЕО ДО 256MB NVIDIA GeForce Go 7800!!!

Презентация Перечень конфигураций Пресса о ноутбуке

______________________________________________________________________

СЕРВЕРЫ GATEWAY СО СКЛАДА В МОСКВЕ!!!

Теперь и с двухядерными Intel® Dual-Core 3.00 GHz Xeon™ MP w/ 2x2MB Level 2 Cache процессорами!

До 32 GB памяти с "Горячей заменой" модулей!

Объем дискового пространства до 3ТБ!

РАЗМЕРЫ ОПЕРАТИВНОЙ И ДИСКОВОЙ ПАМЯТИ ПО ТРЕБОВАНИЮ ЗАКАЗЧИКА!

Серверы напольныеСерверы стоечные

______________________________________________________________________

НОВАЯ ЛИНЕЙКА ДОМАШНИХ ПК ОТ GATEWAY!!!

ПРОЦЕССОРЫ ДО 955 EXTREME EDITION W/HT!!! 975X ЧИПСЕТ!!! ВСЕ ПК В КОНСТРУКТИВЕ BTX!!!

ВИДЕО ДО 2x512MB ATI RADEON® X1900 XT CROSSFIRE™ SOLUTION!!! ДИСКОВЫЙ МАССИВ ДО 1000GB!!!

Подробнее о линейке ПК Что такое BTX? Перечень моделей

______________________________________________________________________

GATEWAY M285 НОУТБУК + ПЛАНШЕТНЫЙ ПК В ОДНОМ КОРПУСЕ

Возможность рукописного и голосового ввода информации!!!

Презентация Подробнее о ноутбуке Перечень опций

______________________________________________________________________

КОМПЬЮТЕРЫ GATEWAY В КРЕДИТ!!!

Компьютеры в кредит

ЗВОНИТЕ !!!

Copyright (c) 2002 INTERCOM-XXI.
Email: sales@gateway.ru

Rambler's Top100


уБКФ ЪБЛТЩФ - WWW ИПУФЙОЗ дЕНПУ-йОФЕТОЕФ

Demos-Internet

хУМХЗЙ
дПУФХР Ч йОФЕТОЕФ РП ЧЩДЕМЕООПК МЙОЙЙ

дПУФХР Ч йОФЕТОЕФ РП ФЕМЕЖПООПК МЙОЙЙ

чЙТФХБМШОБС НБЫЙОБ

ьМЕЛФТПООБС РПЮФБ

фЕМЕЖПОЙС

тБЪНЕЭЕОЙЕ www-УЕТЧЕТПЧ (ИПУФЙОЗ)

чЙТФХБМШОЩК чЩДЕМЕООЩК уЕТЧЕТ (ччу)

тБЪНЕЭЕОЙЕ ЖЙЪЙЮЕУЛЙИ УЕТЧЕТПЧ

бТЕОДБ ЖЙЪЙЮЕУЛЙИ УЕТЧЕТПЧ

фЕМЕЛПОЖЕТЕОГЙЙ

тЕЗЙУФТБГЙС ДПНЕОПЧ
фБТЙЖЩ
дПУФХР Ч йОФЕТОЕФ РП ЧЩДЕМЕООПК МЙОЙЙ

фЕМЕЖПОЙС

дПУФХР Ч йОФЕТОЕФ РП ФЕМЕЖПООПК МЙОЙЙ

ьМЕЛФТПООБС РПЮФБ

тБЪНЕЭЕОЙЕ www-УЕТЧЕТПЧ (ИПУФЙОЗ)

тБЪНЕЭЕОЙЕ ЖЙЪЙЮЕУЛЙИ УЕТЧЕТПЧ

бТЕОДБ ЖЙЪЙЮЕУЛЙИ УЕТЧЕТПЧ

фЕМЕЛПОЖЕТЕОГЙЙ

тЕЗЙУФТБГЙС ДПНЕОПЧ
рПДДЕТЦЛБ
рПМЕЪОБС ЙОЖПТНБГЙС

дПУФХР Ч йОФЕТОЕФ РП ЧЩДЕМЕООПК МЙОЙЙ

дПУФХР Ч йОФЕТОЕФ РП ФЕМЕЖПООПК МЙОЙЙ

чЙТФХБМШОБС НБЫЙОБ

ьМЕЛФТПООБС РПЮФБ

тБЪНЕЭЕОЙЕ www-УЕТЧЕТПЧ (ИПУФЙОЗ)

тЕЗЙУФТБГЙС ДПНЕОПЧ

фЕМЕЛПОЖЕТЕОГЙЙ
оПЧПУФЙ
п ЛПНРБОЙЙ
лПОФБЛФЩ

пЖЙГЙБМШОЩЕ УЧЕДЕОЙС

мЙГЕОЪЙЙ ЛПНРБОЙЙ

йУФПТЙЮЕУЛБС УРТБЧЛБ

п УЕФЙ йОФЕТОЕФ/тПУУЙС

чБЛБОУЙЙ
лБТФБ УБКФБ
English

дПУФХР Ч йОФЕТОЕФ РП ЧЩДЕМЕООПК МЙОЙЙ

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ
рПДДЕТЦЛБ РПМШЪПЧБФЕМС
ъБСЧЛБ ОБ РПДЛМАЮЕОЙЕ

фЕМЕЖПОЙС

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ

дПУФХР Ч йОФЕТОЕФ РП ФЕМЕЖПООПК МЙОЙЙ

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ
рПДДЕТЦЛБ РПМШЪПЧБФЕМС
тЕЗЙУФТБГЙС ОПЧПЗП
РПМШЪПЧБФЕМС
уФБФЙУФЙЛБ

чЙТФХБМШОБС НБЫЙОБ

пРЙУБОЙЕ ХУМХЗЙ
пУОПЧОЩЕ ЧПЪНПЦОПУФЙ
рПДДЕТЦЛБ РПМШЪПЧБФЕМС
йОФЕТЖЕКУ БДНЙОЙУФТБФПТБ

ьМЕЛФТПООБС РПЮФБ

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ
рПДДЕТЦЛБ РПМШЪПЧБФЕМС
дПУФХР Л РПЮФЕ ЮЕТЕЪ
Web-ЙОФЕТЖЕКУ

тБЪНЕЭЕОЙЕ www-
УЕТЧЕТПЧ (ИПУФЙОЗ)

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ
рПДДЕТЦЛБ РПМШЪПЧБФЕМС

чЙТФХБМШОЩК
ЧЩДЕМЕООЩК УЕТЧЕТ

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ

тБЪНЕЭЕОЙЕ ЖЙЪЙЮЕУЛЙИ УЕТЧЕТПЧ (collocation)

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ
ъБСЧЛБ ОБ ТБЪНЕЭЕОЙЕ

бТЕОДБ ЖЙЪЙЮЕУЛЙИ УЕТЧЕТПЧ

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ

фЕМЕЛПОЖЕТЕОГЙЙ

пРЙУБОЙЕ ХУМХЗЙ
фБТЙЖЩ
рПДДЕТЦЛБ РПМШЪПЧБФЕМС

тЕЗЙУФТБГЙС ДПНЕОПЧ

пРЙУБОЙЕ ХУМХЗЙ
гЕОЩ
ъБСЧЛБ ОБ ТЕЗЙУФТБГЙА
рПДДЕТЦЛБ РПМШЪПЧБФЕМС

уЮЕФБ Й РМБФЕЦЙ

пЖЙГЙБМШОЩЕ ДПЛХНЕОФЩ

лХДБ ПВТБФЙФШУС
пЫЙВЛБ - УБКФ ЪБЛТЩФ

уБКФ, Л ЛПФПТПНХ чЩ ПВТБФЙМЙУШ, Ч ДБООЩК НПНЕОФ ЪБЛТЩФ. чПЪНПЦОП, ПО ОБИПДЙФУС ОБ ТЕЛПОУФТХЛГЙЙ ЙМЙ ЕЭЕ ОЕ УПЪДБО.

еУМЙ чБН ОХЦОП ОБКФЙ РПИПЦЙК ТЕУХТУ, РПРТПВХКФЕ ОБКФЙ ЕЗП Ч ЛБФБМПЗЕ:

еУМЙ чЩ ИПФЙФЕ УПЪДБФШ УЧПК УБКФ, НЩ РТЕДМБЗБЕН ТБЪНЕУФЙФШ ЕЗП Х ОБУ:
иПУФЙОЗ ОБ УЕТЧЕТБИ дЕНПУ-йОФЕТОЕФ
оПЧПУФЙ
лПОФБЛФОБС ЙОЖПТНБГЙС

лПОФБЛФЩ

рТЕКУЛХТБОФ

дПЗПЧПТ ОБ ПВУМХЦЙЧБОЙЕ

тЕЗМБНЕОФ

пРМБФБ ХУМХЗ

вЕЪПРБУОПУФШ РТЙ ТБВПФЕ Ч УЕФЙ

уЕТЧЕТ ТЕЗЙУФТБГЙЙ Й
УФБФЙУФЙЛЙ РПМШЪПЧБФЕМЕК

рПДДЕТЦЛБ РПМШЪПЧБФЕМЕК

ФЕМЕЖПОЩ (495)956-6290, 234-0326; ЖБЛУ 956-4027 НПДЕНОЩЕ РХМЩ: 995-1155, 961-3200, 956-6285


iXBT.com

  • •Конференция•
  • •Подкасты•
  • •RightMark•
  • •Журнал•
  • •Digital Home•
  • •Магазин•
  • •Гид по Ценам•
· CPU и кулеры
· Платформа и RAM
· 3D видео
· Сети и серверы
· CD/DVD
· Принтеры и МФУ
· Мониторы и тюнеры
· HDD и Flash
· Цифровой звук
· ProAudio
· Фото в числах
· Кино и Проекторы
· Цифровое видео
· Ноутбуки
· КПК
· Периферия
· Мобильная связь
· Корпуса и БП
· Software
· Игры и консоли
· MacLife
· Рынок IT
· Колонка редактора
· Все новости
· Карта сайта

19 мая

HARDWARE Hardware Software Рынок IT Игры DVD MacLife News

все новости
архив
поиск
00:10
Детали демонстрации работы Core 2 Duo, проходившей на Е3
00:08
Двухканальные 150-скоростные SD-карты Digitex
00:01
AMD готовит Next Generation Processor Technology. Детали и прогнозы по новой архитектуре.
18:19
Paris AES Show: восьмиканальный рековый конвертер RME ADI-8 QS
17:21
Spansion представляет первые 65-нм MirrorBit Ornand
15:55
MSI начинает продажи S271: ноутбука на Turion 64 X2
15:41
Новые решения LSI Logic для сетевых систем хранения данных
15:15
Sony: внешний пишущий DVD-привод DRX-820UL
14:44
Sapphire выпускает свой Radeon X1900GT
13:45
Пишущий Blu-ray-привод Pioneer BDR-101A уже доступен для заказа

ПРЕДЛОЖЕНИЯ ОТ КОМПАНИЙ

Ты молод? Ты хочешь Большего? Тебе нужна Своя Музыка для каждого момента жизни?

MP3-плееры SAFA сделают желаемое действительным!

Выбери самый стильный, самый компактный, самый функциональный, самый экономичный… — Свой самый-самый-самый MP3-плеер от SAFA и открой новые возможности!

Вместе с плеером ты получишь FM-тюнер и первоклассный цифровой диктофон, часы, встроенные динамики и цветной дисплей.

Раскрой свой потенциал, вырази себя с помощью MP3-плеера SAFA.
Это твоя музыка, твой стиль жизни!

ENKATSU Electric — ведущий производитель надежных и высокоемких аккумуляторов для фото-, видео- и компьютерной техники.

Аккумуляторы ENKATSU производятся для самых популярных моделей цифровых фото- и видеокамер Canon, Nikon, Fujifilm, Sony, Olympus, Pentax, Konica Minolta, Panasonic, Samsung, Casio.

ENKATSU Electric гарантирует эффективную работу своей продукции как в обычных, так и в экстремальных погодных условиях, что очень важно для российского потребителя.

Торговая марка ENKATSU — это настоящее японское качество, подтвержденное многолетним опытом в области производства источников питания.

Meijin — компьютеры высшей пробы!

Компьютеры Meijin для дома и офиса, Hi-End системы для экстремальных игр, современные компьютерные медиацентры. Всегда в наличии последние новинки комплектующих и периферии:

Экстремальный игровой компьютер Meijin FX-Gamer

Домашний медиацентр Meijin Media Center

Новые видеокарты NVIDIA GeForce 7900 GT/GTX

БЕСПЛАТНАЯ доставка компьютеров по Москве.
Полная гарантия 2 года с БЕСПЛАТНЫМ выездом на дом.

И опять новинки от Canon!

Широкий ассортимент цифровых фотоаппаратов в ОнЛайн Трейд:

PowerShot A420 — $160 new / PowerShot A430 — $165 new / PowerShot A530 — $220 new / PowerShot A540 — $285 new / IXUS 60 — $330 new / IXUS 65 — $430 new / EOS 30D — $1550 new / EOS 5D — $2990 new

Фото / видео / аудиотехника, компьютеры, периферия по лучшим ценам в магазине ОнЛайн Трейд или на сайте www.onlinetrade.ru. (495) 737-4748
Мы продаем товары в кредит!

Эксклюзивное предложение!

Fujitsu-Siemens AMILO Pi-1536 — высокопроизводительный ноутбук с технологией Centrino® Duo!

15.4" WXGA-дисплей CrystalView / Двуядерный процессор Intel® Core™ Duo 1.66 ГГц (кэш — 2Мб, шина — 667 МГц) / Видеокарта ATI Mobility Radeon X1400 128 МБ DDR2 / Оперативная память 1024 МБ DDR2 / Привод DVD±RW DL / Адаптер Wi-Fi.

SHOP.NT.RU — возможна покупка в кредит и оплата Eurocard / MasterCard / Visa!

18 мая

SOFTWARE Hardware Software Рынок IT Игры DVD MacLife News

все новости
архив
поиск
18:10
Мониторинг серверов: DEKSI Network Inventory v.4.9.4
17:45
Общение в сети: Skype v.2.5.0.82 Beta
17:20
Антивирусы: AVIRA Removal Tool for Windows v.2.0.2
16:55
Файловые обменники: BitTorrent v.4.9.4 Beta
16:30
Безопасность: Advanced Spyware Remover v.1.88.24636
16:05
Мультимедиа: Reaper v.0.953
15:40
Резервное копирование: SmartBackup v.3.1
15:15
Мониторинг серверов: IPCheck Server Monitor v.5.3.1.578/579
14:50
Антивирусы: RemoveIT Pro XT SE (16.5.2006)
14:25
Настройщики: Ashampoo WinOptimizer Platinum Suite 3 v.3.05

НАМ ВАЖНО ВАШЕ МНЕНИЕ!

Барракуда - это

одна из самых быстрых рыб

одна из самых больших рыб

одна из самых маленьких рыб

Более подробную информацию об викторине можно узнать здесь

18 мая

НОВОСТИ IT-РЫНКА Hardware Software Рынок IT Игры DVD MacLife News

все новости
архив
поиск
17:19
Seagate и Maxtor сольются уже завтра
12:44
ABIUS расширяет сотрудничество с розничными продавцами
12:12
«Едем в Африку!»: SuperWave объявляет программу по продукции Xerox
11:28
ФСТЭК России сертифицировал комплекс шифрования «Континент»
10:45
Pocket LOOX N520 с пакетом ПО для навигации — в автосалонах Санкт-Петербурга
10:08
Нарушителю авторского права на ПО Microsoft вынесен обвинительный приговор
09:49
GN создает крупнейшую в мире компанию по производству гарнитур
22:34
E-Ten выходит на российский рынок смартфонов и коммуникаторов
21:19
ПИРИТ-Дистрибуция объявляет акцию по продукции ASUS
18:16
«Микротест» открывает учебный центр в Тюмени
19 мая

ИГРЫ Hardware Software Рынок IT Игры DVD MacLife News

все новости
архив
поиск
00:58
В продаже: стратегия Hеroes of Might and Magic V (РС)
00:42
Патчи дня (РС)
12:24
E3: MMORPG SUN (PC)
11:48
В продаже: локализация платформера Psychonauts (PC)
11:23
E3: ролевая игра Gothic 3 (РС)
10:31
Bungie о трейлере Halo 3
09:29
Патчи дня (РС)
07:59
В продаже на территории России: квест Dreamfall: The Longest Journey (PC)
01:27
E3: квест Evidence: The Last Ritual (РС)
00:46
В продаже: локализация экшена Advent Rising (PC)
19 мая

GADGETS & ENTERTAINMENT Hardware Software Рынок IT Игры DVD MacLife News

все новости
архив
поиск
00:51
АРМО-Системы анонсировала камеры наружного наблюдения Pelco Camclosure ICS310-MC, которые не боятся ни жары, ни холода…
18:52
DVD R5: фильм "Сотовый"
18:20
Panasonic: VHS/ DVD/ HDD-рекордер DMR-EX95V
16:04
Фоторамки Royal: смотрим 8-мегапиксельные снимки
13:56
Sony не против появления homebrew для PS3
10:28
Кутараги: PlayStation 3 будет стоить слишком мало
00:45
Демонстрация Sony HD-видео на диске Blu-ray оборачивается курьёзом
00:10
Страсти вокруг PS3 продолжают накаляться
16:12
DVD R5: фильм "Искусственный Разум"
16:05
Axion: новый портативный DVD-плеер AXN-6109TN
18 мая

MACLIFE NEWS Hardware Software Рынок IT Игры DVD MacLife News

все новости
архив
поиск
21:59
Завтра откроется флагман розничных продаж Apple
17:58
Шикарный чехол для iPod Hi-Fi
14:56
Австралия позволяет переписывать музыку в iPod
10:21
Тестеры получили первую внешнюю сборку Mac OS X 10.4.7
08:01
Elgato EyeTV 2.2 – новая версия программного DVR
23:55
ezGear – FM-трансмиттер для iPod shuffle
22:29
Mamba S – рюкзак для MacBook
17:50
ShaggyMac представляет набор для ухода за MacBook
13:37
Apple увеличивает производительность MacBook Pro
10:25
Apple обновляет внутреннее ПО Intel Mac
18.05.2006
Grandia III (PS2)

коллекция шаблонов для JRPG

Microsoft Natural Ergonomic Keyboard 4000 v1.0

мечты сбываются, но нет предела совершенству

MAPILab Native POP3 Connector

коннектор для Microsoft Exchange, расширяющий его возможности по работе с POP3 серверами

Винчестеры на 80 Гбайт. Часть 6. WD800JD и WD800JB образца 2006 года

в сравнении с предшественниками и конкурентами

17.05.2006
Supreme Commander (превью)

гигантомания стратегического жанра

ADSL-модем Acorp Sprinter USB

предоставляет минимальный набор возможностей, позволяющих произвести подключение к ADSL-линии

Связь-ЭкспоКомм 2006 - фотообзор

«Театр почти одного актера»

DVD-iТоги: Апрель 2006

старт Blu-ray опять откладывается

16.05.2006
SiN Episodes: Emergence

модификация Half-Life 2 с претензиями

MP3/WMA-плеер MPIO FY700

просто хороший плеер без лишних претензий

iТоги апреля 2006 года

основные события ИТ-индустрии за прошедший месяц

15.05.2006
GOTVIEW PCI DVD2 Lite

TV- и FM-тюнер бюджетного класса с поддержкой аппаратного сжатия в MPEG1/2

Snapz Pro X

профессиональный инструмент для создания скриншотов и записи видео с экрана в Mac OS X

Paradise

Сокаль кончился

Подготовка к выставке за... 15 дней

чистая правда

Портативный внешний винчестер Prestigio Mobile Data Safe

привлекательная внешне, но не очень быстрая модель

13.05.2006
LG Chocolate — GSM телефон со вкусным названием

Официально в России

12.05.2006
Джиттер. Теория. Часть 1

введение, виды джиттера, измерения джиттера

Epson Stylus C48

малыши-карандаши, вариант № 2

Современная оперативная память (RAM FAQ 1.0)

актуальные ответы на насущные вопросы

Boot Camp: Mac OS X и Windows – заклятые... друзья?

Альтернативный взгляд на стратегию гигантов

11.05.2006
Продолжаем тестирование розничных магазинов

На этот раз - Гипермаркет Санрайз ПРО

Motorola C261

бюджетный камерафон в стиле «тонкомото». А получим ли мы все, чего от него ждем?

D-Link DCS-950G

Web-камера с беспроводным интерфейсом и возможностью ночной съемки

Gigabyte i-RAM (GC-RAMDISK)

жесткий диск на базе DDR SDRAM как альтернатива магнитным накопителям

10.05.2006
Dreamfall: The Longest Journey

волшебное приключение по сказочным мирам

MP3/WMA-плееры Orient MP720С и MP730C

покушение на создание топовых моделей с негодными средствами

Обзор небольших утилит

Апрель 2006 года

Поиск

расширенный поиск

Новости Цифрового Дома / 15.05.06

TT DVBS Budget — смотрим спутниковое ТВ под Windows MCE 2005

Digidock SP-4100 — спикерфон для интернет-общения

High Definition видео — сказка или вымысел?

Программы в магазине / 18.05.06

SikUp! - органайзер, будильник, планировщик, адресная книга

TranslateIt! - электронный переводчик

BitDefender 9 - файрвол, антивирус, антиспам, контент-фильтр

Гид по ценам

Сейчас в конференции

Обсуждение статьи iXBT.com: "iXBT: Boot Camp: Mac OS X и Windows – заклятые… друзья?"
Нужен привод для RIP-audio дисков
Набор объективов для DSLR Nikon (D70/D100/D1x/D2h/D...)
Евровидение-2006
Ghost Recon 3 (было ghost recon2)
Любителям тяжелой музыки
Делаем станок для сверления ПП с ЧПУ.
Шутер Sin 2 (cериал Sin Episodes). Часть первая: Emergence.
Выбор лучших болванок для записи на DVD-+R/RW
Обсуждение вопросов гарантийного обслуживания IBM ThinkPad

Награды / 05.05.06

По результатам тестовых испытаний в апреле 2006 года редакцией iXBT.com выбраны лучшие продукты в категориях «Original Design» и «Excellent Package».

Итоги опроса / 07.05.06

Результаты опроса об используемом соединении с Интернет — имена победителей и итоги опроса

Свежие телефоны в базе

· Sony Ericsson Z710i
· Sony Ericsson Z550i
· Sony Ericsson W850i
· Sony Ericsson W710i
· Pantech PG-6200
· Nokia 5500 Sport
· Motorola W220
· Samsung SGH-X820
· Samsung t509
· Amoi M636
· Amoi A869
· Amoi A865
все телефоны поиск по базе

Наши проекты

Digit Life

Комок

RadarSync

AV Media

Заголовки

Архив анонсов статей

Архив анонсов новостей

Каталоги / 01.02.06

Обновление каталога технических описаний принтеров и копировальных аппаратов KYOCERA MITA

Информация

Shop.iXBT.com — магазин ПО

Новый проект — Podcast.iXBT.com

Новый дизайн iXBT.com

Вакансии на сайте iXBT.com!

Ссылки

О сайте

Экспорт в RSS

новые статьи с текстами анонсов
свежие новости всех разделов
ежедневные подкасты в формате mp3
ещё варианты RSS подписок

Есть новости? Присылайте на адрес: news@ixbt.com
По общим вопросам пишите по адресу: info@ixbt.com. О результатах викторин пишите: voting@ixbt.com
Вопросы по проведению PR-акций на сайте, а также приглашения на пресс-конференции присылайте на адрес pr@ixbt.com
Copyright © by iXBT.com, 1997—2006.


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Relmax Inc. began as a Web design studio in 1999 and was incorporated in December, 2000.

Relmax's goal is to apply the extensive knowledge and experience of its designers and programmers to the Internet needs of diverse customers. Thus we have served small organizations, and larger ones.

The IT professionals at Relmax adapt to the customer's needs and each site is an original. We explore your needs and interests to build a site that works for you and accurately reflects the image you wish to promote on the Web.

The company's headquarters are in Oberlin, Ohio, a quiet college town with a rich intellectual and social history.

We look forward to hearing from you and welcome all questions. Please contact us at ClientServices@Relmax.com.

Mikhail Aranovsky
President and founder of Relmax Inc.
Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Relmax Inc. Affiliate Program

The Relmax Inc. Affiliate Program is designed to increase your cash flow as well as our business. By using your personal or business resources such as personal contacts, traditional advertising or your Web site, you can receive commissions of up to 15% for every referral that contracts with us. For example, your Web site can carry a Relmax Inc. banner or text link that will automatically refer clients to us. We track all such referrals and your commission will be added to your account.

We invite you to click on the Terms link below to see in detail how the program works. Click on the Join Our Affiliate Program and fill out our simple application form.

[ Terms ]

[ Join our Affiliate Program ]

[ AFFILIATES - LOG IN ]
Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Contact Information:

If you need assistance or have questions please contact us.
--------
Email:

Technical Support - Support@Relmax.com
Client Services Department - ClientServices@Relmax.com
Sales Department - Sales@Relmax.com
Affiliate Program - Affiliate@Relmax.com
Ask a Question - Info@Relmax.com
Report Abuse - Abuse@Relmax.com
--------
Toll-Free Phone#: (877) RELMAX-3 (877-735-6293)

Toll-Free Fax#: (866) 7-RELMAX (866-773-5629)
--------
Mailing address:

Relmax Inc.
M.P.O. Box 296
Oberlin, OH, 44074-0296
USA

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Relmax Inc.
We design and develop Web sites that sell!

Welcome to Relmax. This is where you need to be for professional Web site design, development, and hosting.

Relmax is an Ohio-based full-service Web development firm specializing in creating Web sites for small and medium size businesses. We evaluate the needs of each company to create a successful site that will bring in visitors, drive sales, and enhance customer service.

Why us? Extensive experience, personal attention, custom Web site design and programming, assistance every step of the way - these are just a few reasons why clients select the Relmax Web design company.

We use all our knowledge of the Web Development industry to provide you with high-quality and easy-to-work-with Web sites. The interfaces we design do not require you to have any programming skills. Our E-commerce solutions help your site sell your product or service, and are tailored to your business! We do not use pre-made templates to design and develop your E-Business.

Start by checking out our portfolio - you need to see what we are capable of. Then, see the feedback our customers sent us.

You can request a free Website design quote by filling out our Estimate Request Form.

Look at our service links below to find out more.

Services Offered:

  • Web Design and Development
  • WebSite Redesign
  • Domain Registration
  • Web Programming
  • Web Hosting
  • Banners Design
  • Flash Presentations
  • And much more...

Have a question? Feel free to contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Name: Rulez666 | Thursday, May 18, 2006 in 15:10:19
[url=http://watchwinder.floclock.info/sale-watch-winder.htm]Sale Watch Winder[/url] * [url=http://watchwinder.floclock.info/box-leather-watch-winder.htm]Box Leather Watch Winder[/url] * [url=http://texas-holdem-analysis-software.iptvgambling.tv/nice-texas-holdem-analysis-software.htm]Nice Texas Holdem Analysis Software[/url] <a href=http://watchwinder.floclock.info/sale-watch-winder.htm >Sale Watch Winder</a> | <a href=http://watchwinder.floclock.info/box-leather-watch-winder.htm >Box Leather Watch Winder</a> | <a href=http://texas-holdem-analysis-software.iptvgambling.tv/nice-texas-holdem-analysis-software.htm >Nice Texas Holdem Analysis Software</a> http://watchwinder.floclock.info/sale-watch-winder.htm http://watchwinder.floclock.info/box-leather-watch-winder.htm http://texas-holdem-analysis-software.iptvgambling.tv/nice-texas-holdem-analysis-software.htm
Name: Rulez666 | Thursday, May 18, 2006 in 15:09:50
[url=http://watchwinder.floclock.info/sale-watch-winder.htm]Sale Watch Winder[/url] * [url=http://watchwinder.floclock.info/box-leather-watch-winder.htm]Box Leather Watch Winder[/url] * [url=http://texas-holdem-analysis-software.iptvgambling.tv/nice-texas-holdem-analysis-software.htm]Nice Texas Holdem Analysis Software[/url] <a href=http://watchwinder.floclock.info/sale-watch-winder.htm >Sale Watch Winder</a> | <a href=http://watchwinder.floclock.info/box-leather-watch-winder.htm >Box Leather Watch Winder</a> | <a href=http://texas-holdem-analysis-software.iptvgambling.tv/nice-texas-holdem-analysis-software.htm >Nice Texas Holdem Analysis Software</a> http://watchwinder.floclock.info/sale-watch-winder.htm http://watchwinder.floclock.info/box-leather-watch-winder.htm http://texas-holdem-analysis-software.iptvgambling.tv/nice-texas-holdem-analysis-software.htm
Name: Rulez666 | Thursday, May 18, 2006 in 11:32:32
[url=http://kote.flopaint.info/nu-kote.htm]Nu Kote[/url] * [url=http://kote.flopaint.info/gun-kote.htm]Gun Kote[/url] * [url=http://kote.flopaint.info/kote-besar.htm]Kote Besar[/url] <a href=http://kote.flopaint.info/nu-kote.htm >Nu Kote</a> | <a href=http://kote.flopaint.info/gun-kote.htm >Gun Kote</a> | <a href=http://kote.flopaint.info/kote-besar.htm >Kote Besar</a> http://kote.flopaint.info/nu-kote.htm http://kote.flopaint.info/gun-kote.htm http://kote.flopaint.info/kote-besar.htm
Name: Rulez666 | Thursday, May 18, 2006 in 11:32:30
[url=http://kote.flopaint.info/nu-kote.htm]Nu Kote[/url] * [url=http://kote.flopaint.info/gun-kote.htm]Gun Kote[/url] * [url=http://kote.flopaint.info/kote-besar.htm]Kote Besar[/url] <a href=http://kote.flopaint.info/nu-kote.htm >Nu Kote</a> | <a href=http://kote.flopaint.info/gun-kote.htm >Gun Kote</a> | <a href=http://kote.flopaint.info/kote-besar.htm >Kote Besar</a> http://kote.flopaint.info/nu-kote.htm http://kote.flopaint.info/gun-kote.htm http://kote.flopaint.info/kote-besar.htm
Name: Cheap Flights | Thursday, May 18, 2006 in 11:29:58
Flights <a href="http://spaces.msn.com/cheap-flights-online/">Cheap Flights</a> Flight http://spaces.msn.com/cheap-flights-online/ fly [URL=http://spaces.msn.com/cheap-flights-online/]cheap flights[/URL]
Name: Cheap Flights | Thursday, May 18, 2006 in 11:29:55
Flights <a href="http://spaces.msn.com/cheap-flights-online/">Cheap Flights</a> Flight http://spaces.msn.com/cheap-flights-online/ fly [URL=http://spaces.msn.com/cheap-flights-online/]cheap flights[/URL]
Name: Rulez666 | Thursday, May 18, 2006 in 09:58:06
[url=http://intimescom.flointim.info/extra-intimes-com.htm]Extra Intimes Com[/url] * [url=http://intimescom.flointim.info/shop-intimes-com.htm]Shop Intimes Com[/url] * [url=http://intimescom.flointim.info/impressive-intimes-com.htm]Impressive Intimes Com[/url] <a href=http://intimescom.flointim.info/extra-intimes-com.htm >Extra Intimes Com</a> | <a href=http://intimescom.flointim.info/shop-intimes-com.htm >Shop Intimes Com</a> | <a href=http://intimescom.flointim.info/impressive-intimes-com.htm >Impressive Intimes Com</a> http://intimescom.flointim.info/extra-intimes-com.htm http://intimescom.flointim.info/shop-intimes-com.htm http://intimescom.flointim.info/impressive-intimes-com.htm
Name: Rulez666 | Thursday, May 18, 2006 in 09:50:19
[url=http://cercleintime.flointim.info/extra-cercle-intime.htm]Extra Cercle Intime[/url] * [url=http://cercleintime.flointim.info/description-cercle-intime.htm]Description Cercle Intime[/url] * [url=http://cercleintime.flointim.info/nice-cercle-intime.htm]Nice Cercle Intime[/url] <a href=http://cercleintime.flointim.info/extra-cercle-intime.htm >Extra Cercle Intime</a> | <a href=http://cercleintime.flointim.info/description-cercle-intime.htm >Description Cercle Intime</a> | <a href=http://cercleintime.flointim.info/nice-cercle-intime.htm >Nice Cercle Intime</a> http://cercleintime.flointim.info/extra-cercle-intime.htm http://cercleintime.flointim.info/description-cercle-intime.htm http://cercleintime.flointim.info/nice-cercle-intime.htm
Name: Rulez666 | Thursday, May 18, 2006 in 09:50:04
[url=http://cercleintime.flointim.info/extra-cercle-intime.htm]Extra Cercle Intime[/url] * [url=http://cercleintime.flointim.info/description-cercle-intime.htm]Description Cercle Intime[/url] * [url=http://cercleintime.flointim.info/nice-cercle-intime.htm]Nice Cercle Intime[/url] <a href=http://cercleintime.flointim.info/extra-cercle-intime.htm >Extra Cercle Intime</a> | <a href=http://cercleintime.flointim.info/description-cercle-intime.htm >Description Cercle Intime</a> | <a href=http://cercleintime.flointim.info/nice-cercle-intime.htm >Nice Cercle Intime</a> http://cercleintime.flointim.info/extra-cercle-intime.htm http://cercleintime.flointim.info/description-cercle-intime.htm http://cercleintime.flointim.info/nice-cercle-intime.htm
Name: Rulez666 | Thursday, May 18, 2006 in 08:33:19
[url=http://blackjack-pizza.iptvgambling.net]Blackjack Pizza[/url] * [url=http://blackjack-pizza.iptvgambling.net/index.htm]Blackjack Pizza[/url] * [url=http://pagegraphics.flographics.info]Page Graphics[/url] <a href=http://blackjack-pizza.iptvgambling.net >Blackjack Pizza</a> | <a href=http://blackjack-pizza.iptvgambling.net/index.htm >Blackjack Pizza</a> | <a href=http://pagegraphics.flographics.info >Page Graphics</a> http://blackjack-pizza.iptvgambling.net http://blackjack-pizza.iptvgambling.net/index.htm http://pagegraphics.flographics.info
Name: Rulez666 | Thursday, May 18, 2006 in 08:33:16
[url=http://blackjack-pizza.iptvgambling.net]Blackjack Pizza[/url] * [url=http://blackjack-pizza.iptvgambling.net/index.htm]Blackjack Pizza[/url] * [url=http://pagegraphics.flographics.info]Page Graphics[/url] <a href=http://blackjack-pizza.iptvgambling.net >Blackjack Pizza</a> | <a href=http://blackjack-pizza.iptvgambling.net/index.htm >Blackjack Pizza</a> | <a href=http://pagegraphics.flographics.info >Page Graphics</a> http://blackjack-pizza.iptvgambling.net http://blackjack-pizza.iptvgambling.net/index.htm http://pagegraphics.flographics.info
Name: Rulez666 | Thursday, May 18, 2006 in 04:11:01
[url=http://bull-semen.albionmedical-vigrx.com/news-bull-semen.htm]News Bull Semen[/url] * [url=http://bull-semen.albionmedical-vigrx.com/nice-bull-semen.htm]Nice Bull Semen[/url] * [url=http://bull-semen.albionmedical-vigrx.com/impressive-bull-semen.htm]Impressive Bull Semen[/url] <a href=http://bull-semen.albionmedical-vigrx.com/news-bull-semen.htm >News Bull Semen</a> | <a href=http://bull-semen.albionmedical-vigrx.com/nice-bull-semen.htm >Nice Bull Semen</a> | <a href=http://bull-semen.albionmedical-vigrx.com/impressive-bull-semen.htm >Impressive Bull Semen</a> http://bull-semen.albionmedical-vigrx.com/news-bull-semen.htm http://bull-semen.albionmedical-vigrx.com/nice-bull-semen.htm http://bull-semen.albionmedical-vigrx.com/impressive-bull-semen.htm
Name: Rulez666 | Thursday, May 18, 2006 in 04:10:44
[url=http://bull-semen.albionmedical-vigrx.com/news-bull-semen.htm]News Bull Semen[/url] * [url=http://bull-semen.albionmedical-vigrx.com/nice-bull-semen.htm]Nice Bull Semen[/url] * [url=http://bull-semen.albionmedical-vigrx.com/impressive-bull-semen.htm]Impressive Bull Semen[/url] <a href=http://bull-semen.albionmedical-vigrx.com/news-bull-semen.htm >News Bull Semen</a> | <a href=http://bull-semen.albionmedical-vigrx.com/nice-bull-semen.htm >Nice Bull Semen</a> | <a href=http://bull-semen.albionmedical-vigrx.com/impressive-bull-semen.htm >Impressive Bull Semen</a> http://bull-semen.albionmedical-vigrx.com/news-bull-semen.htm http://bull-semen.albionmedical-vigrx.com/nice-bull-semen.htm http://bull-semen.albionmedical-vigrx.com/impressive-bull-semen.htm
Name: Life Insurance | Thursday, May 18, 2006 in 02:16:53
insurance <a href="http://life-insurance.ebloggy.com">life insurance</a> Life http://life-insurance.ebloggy.com insurance [URL=http://life-insurance.ebloggy.com]Life Insurance[/URL] quote
Name: Life Insurance | Thursday, May 18, 2006 in 02:16:52
insurance <a href="http://life-insurance.ebloggy.com">life insurance</a> Life http://life-insurance.ebloggy.com insurance [URL=http://life-insurance.ebloggy.com]Life Insurance[/URL] quote
Name: Rulez666 | Wednesday, May 17, 2006 in 17:24:43
[url=http://apachegoldcasino.flogambling.info/sitemap.htm]Very best of Apache gold casino[/url] * [url=http://ncaa-sports-betting.royaltouchcasino.com/sitemap.htm]Latest news about Ncaa sports betting[/url] * [url=http://allmobilecasino.flogambling.info/sitemap.htm]Best of All mobile casino[/url] <a href=http://apachegoldcasino.flogambling.info/sitemap.htm >Very best of Apache gold casino</a> | <a href=http://ncaa-sports-betting.royaltouchcasino.com/sitemap.htm >Latest news about Ncaa sports betting</a> | <a href=http://allmobilecasino.flogambling.info/sitemap.htm >Best of All mobile casino</a> http://apachegoldcasino.flogambling.info/sitemap.htm http://ncaa-sports-betting.royaltouchcasino.com/sitemap.htm http://allmobilecasino.flogambling.info/sitemap.htm
Name: Rulez666 | Wednesday, May 17, 2006 in 17:24:40
[url=http://apachegoldcasino.flogambling.info/sitemap.htm]Very best of Apache gold casino[/url] * [url=http://ncaa-sports-betting.royaltouchcasino.com/sitemap.htm]Latest news about Ncaa sports betting[/url] * [url=http://allmobilecasino.flogambling.info/sitemap.htm]Best of All mobile casino[/url] <a href=http://apachegoldcasino.flogambling.info/sitemap.htm >Very best of Apache gold casino</a> | <a href=http://ncaa-sports-betting.royaltouchcasino.com/sitemap.htm >Latest news about Ncaa sports betting</a> | <a href=http://allmobilecasino.flogambling.info/sitemap.htm >Best of All mobile casino</a> http://apachegoldcasino.flogambling.info/sitemap.htm http://ncaa-sports-betting.royaltouchcasino.com/sitemap.htm http://allmobilecasino.flogambling.info/sitemap.htm
Name: Rulez666 | Wednesday, May 17, 2006 in 06:46:02
[url=http://molten.kronfind.com/molten-chilis.htm]Molten Chilis[/url] * [url=http://molten.kronfind.com/molten-pump-sulfur.htm]Molten Pump Sulfur[/url] * [url=http://molten.kronfind.com/crabapple-lava-molten-tree.htm]Crabapple Lava Molten Tree[/url] <a href=http://molten.kronfind.com/molten-chilis.htm >Molten Chilis</a> | <a href=http://molten.kronfind.com/molten-pump-sulfur.htm >Molten Pump Sulfur</a> | <a href=http://molten.kronfind.com/crabapple-lava-molten-tree.htm >Crabapple Lava Molten Tree</a> http://molten.kronfind.com/molten-chilis.htm http://molten.kronfind.com/molten-pump-sulfur.htm http://molten.kronfind.com/crabapple-lava-molten-tree.htm
Name: Rulez666 | Wednesday, May 17, 2006 in 06:46:00
[url=http://molten.kronfind.com/molten-chilis.htm]Molten Chilis[/url] * [url=http://molten.kronfind.com/molten-pump-sulfur.htm]Molten Pump Sulfur[/url] * [url=http://molten.kronfind.com/crabapple-lava-molten-tree.htm]Crabapple Lava Molten Tree[/url] <a href=http://molten.kronfind.com/molten-chilis.htm >Molten Chilis</a> | <a href=http://molten.kronfind.com/molten-pump-sulfur.htm >Molten Pump Sulfur</a> | <a href=http://molten.kronfind.com/crabapple-lava-molten-tree.htm >Crabapple Lava Molten Tree</a> http://molten.kronfind.com/molten-chilis.htm http://molten.kronfind.com/molten-pump-sulfur.htm http://molten.kronfind.com/crabapple-lava-molten-tree.htm
Name: Baseball Tickets | Wednesday, May 17, 2006 in 05:11:52
Buy <a href="http://baseball-tickets.50webs.com">Baseball Tickets</a> online http://baseball-tickets.50webs.com baseball [URL=http://baseball-tickets.50webs.com]Buy Baseball Ticket[/URL] online.

Have a question? Feel free to contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Links

We recommend submitting your sites to IT-related directory, located at http://www.rfbe.com/directory/. All links from this page were moved to that directory.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Estimate Request Form
Please fill out the following form that will give us a good idea about your project. We will get back to you within 24 hours with an estimate or additional questions about your site. Thank you!

Information about your project:
Are you looking for:
 | New Web site design
 | Re-design of the current Web site
 | Other (please specify below):
Please select features and services you are interested in:
Logo Design
Graphic Design
Shopping Cart
E-commerce solution
Interactive Features (Chat, Forum, Forms)
Flash Animation & Presentation
Web Hosting
Domain Name Registration
Site Maintenance
Editing and Writing
Merchant Account
Credit Card Processing
Search Engine Optimization
Banner Design
Search Capabilities on the Web Site
Database Programming
Custom Web Programming
Other (please specify below):
Estimate Budget: *
How soon do you need to start the project?: *
Time Frame: *
Please provide a brief overview of the project: *
Did anyone refer you? If yes, who?

Your contact information
Your first name *
Last name *
Organization (Company Name)
Address *
Address (additional)
City *
Area (province, state) *
Zip/postal code
Country *
Phone number including area code
Fax number (optional)
Email *
ICQ
Prefered way to contact you:
E-Mail
Phone
ICQ

Have a question? Feel free to contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

To order web hosting simply complete the registration form consisting of several steps. After this you will be taken to the payment form. Your account will be opened within 24 hours after we have received your payment. You will get an e-mail that includes your IP-address, user name, password and a brief manual.

Choose the needed service:

Order web hosting and transfer an existing domain

Register the new domain and order web hosting

Register a new domain (park the domain only without web hosting)

Important! Before your proceed with the registration of your new domain name, click here -- Check Availability -- to find out if it is available.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Payment:

All payments are made in US$ only. Your order will be processed upon receipt of your payment. We recommend you use a credit card for your payment, as this is the fastest way to get your order processed.

We accept:
Visa, MasterCard, American Express and Discover are accepted We accept PayPal

There are currently four payment options:
1. Visa, MasterCard, American Express or Discover online or by phone
2. Check or money order
3. MoneyGram ExpressPayment
4. PayPal
5. Bank Wire Transfer

Important: You have to specify what service you are paying for, such as programming or a domain name. If you use a method of payment other than credit card or PayPal, please inform us right after you have sent your payment to speed up the processing.

Payment by credit card

Please note the following:
1. We currently CANNOT accept payments from Visa Electron and Cirrus Maestro cards.
2. There is a minimum purchase of 3 months per transaction for hosting plans 20 and 50.

Amount to be paid:
Payment by check or money order:

Please make checks payable to Relmax Inc. and mail to:

Relmax Inc.
M.P.O. Box 296
Oberlin, OH, 44074-0296
USA

Payment through MoneyGram ExpressPayment:

Please visit the MoneyGram Money Transfer Agent Locator to find the location near you.

When filling out the blue form, please make sure to specify the following:

RECEIVE CODE - 3263
COMPANY I AM PAYING - Relmax, Inc. (Location - Oberlin, OH)

Write your Account Number (if you don't remember your account number - please contact us).

View MoneyGram ExpressPayment sample form

MoneyGram (through the Agent) will charge you $8.95 per money transfer. This amount is NOT included in your bill.
Payment through PayPal:

Payment by Bank Wire Transfer:

Please contact us for details.

Note: There is a charge of $25 that will be added to your account if you select this payment option.

Have a question? Feel free to contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Here are some examples of our work:

Order your Web site
ScreenShot
Order your Web site

Relmax is known for quality service, affordable prices and great customer satisfaction. Complete the form for your free estimate.
Lambson's Wildlife Art
ScreenShot
Lambson's Wildlife Art

Lambson's art work has been featured in art and outdoor magazines such as Art West, Hunters' Quest, Wildlife Art News, Idaho Wildlife, Cabela's, New Mexico Wildlife, Alaskan Outdoors, and others.
Shopping Center
ScreenShot
StoptooShop.com

The most convenient #1 One Stop Shopping Center. In order to provide the most secure shopping environment for our valued customers, all checkouts are made through our most trusted partner, Amazon.com.
Computer Systems Unlimited
ScreenShot
Computer Systems Unlimited, Inc.

A full service computer/peripheral sales and repair company specializing in custom built Pc's, network design, software integration, and everything in-between.
The CIA Group, LLC
ScreenShot
The Certified Indoor Air Group, LLC

The Certified Indoor Air Group, LLC is a multi-disciplined group of professionals and strategic partners that specialize in Indoor environmental Quality, with a focus on the prevention and solutions of problems associated with microbial and airborne pollution that can adversely affect indoor environments.
Madison Development Company
ScreenShot
Madison Development Company

Company strives for excellence and resident satisfaction with its team of approximately 31 superior employees and resident managers. With 22 properties and over 600 individual suites in and around Greater DC Metro region, MDC ensures a wide variety of apartment styles and communities to choose from.
Byron Savings
ScreenShot
Byron Savings

Byron Savings has been making home ownership a reality for their members since 1975.
Studebaker Electric Company
ScreenShot
Studebaker Electric Company

Since 1953 Studebaker Electric has been providing expert service to the Industrial, institutional, and commercial market.
ScreenShot
Mt.Morris Savings

Mt. Morris Savings is the oldest Savings & Loan Association in Ogle County, founded in 1926, and exists solely to help members with all of their financial needs - from financing their housing requirements, to funding the purchase of a new car, or college education.
PromIndustry AG
ScreenShot
PromIndustry AG

Investment and development company in Moscow, Russia.
ScreenShot
Professional Resume Creation Service

Step-by-step forms generator walk you through the easy to follow process of creating professional looking resume.

Services provided:
  • Website design

  • Custom programming

  • Automated PDF documents generation

  • Website hosting
            •
    A Travel Agency
    ScreenShot
            A Travel Agency Network

    A Travel Agency Inc. has been a part of many changes in the travel industry over the years. They opened in 1994 as a full service brick and mortar business. As the Internet gained popularity, their clients started researching their vacations on the Web. This produced a very savvy traveler, not only in destination information, but pricing. But you still had to come into our office to book. In partnership with top travel providers, they updated their secure website to allow you to reserve and pay for your favorite vacation packages and cruises online, from the comfort of your home or office. They embraced the future and became a Full Service Internet Travel Agency.
    Friends of the Sea (Jamaica)
    ScreenShot
            Friends of the Sea (Jamaica)

    A non-profit, non-governmental organization based in Ocho Rios, Jamaica, Friends of the Sea (FOTS) is working towards raising community environmental awareness and action.
    Services provided:
  • Website design

  • Bulletin board installation and customization

  • Website hosting
            •
    Waldock's System Signals
    ScreenShot
            Waldock's System Signals

    3 trading systems by Andy Waldock - available to lease or purchase.
    Services provided:
  • Website design

  • Database programming

  • E-Commerce development: subscription, purchases

  • Website hosting
            •
    Trackmax Solutions
    ScreenShot
            Trackmax Solutions

    Distributor Resource Management, Inc., DRM is the distribution industry's leading provider of Earned Income Tracking and Contract Management software solutions. Trackmax Solutions is a suite of Trade Spend and Tracking Technologies developed since 1996 that improve Speed, Flow and Quality of its customers' data throughout all trading partners within the supply chain.
    NewsMD Communications
    ScreenShot
            NewsMD Communications

    Company has positioned itself as a leader in television production specializing in providing quality health and medical information to the public. As a full service production company, they cover a broad range of health topics important to consumers.
    Alaska fishing at Wooden Wheel Lodge
    ScreenShot
            Alaska fishing at Wooden Wheel Lodge

    Located on one of the largest Salmon migration routes in the Pacific Northwest and within reach of the Gulf of Alaska, Wooden Wheel Lodge is the best place for Alaska fishing vacation, hunting or eco tours.
    All Therapy Jobs
    ScreenShot
            All Therapy Jobs

    Therapy jobs for physical therapists, respiratory therapists, occupational therapists etc. Nationwide job bank that is viewed by thousands of qualified therapists each day.
    The Cox Company
    ScreenShot
            The Cox Company

    Founded in 1982, The Cox Company is a professional planning, civil engineering, and urban design firm providing services to both public and private sector clients.
    Services provided:
  • Flash site design

  • Web hosting
            •
    ConneXions
    ScreenShot
            ConneXions

    Connexions is a distributor and manufacturer of computer and networking cables, hardware and accessories located in Dayton, OH. Connexions also manufactures a vast array of custom cables, harnesses and assemblies for the communications and data industry. ConneXions Consulting is a Dayton Ohio based division of Studebaker Electric. ConneXions provides IT Consulting services to Ohio and too parts across the country, providing quality custom projects and services to help your companies IT department increase their bottom line.
    This was a Web site re-design project.
    Lake Shore Boats
    ScreenShot
            Lake Shore Boats

    Site will assist you in finding your next boat, wave runner, or Jet Ski as well as find great charter boats to take you out on an adventure. Once you find your next boat in the boat classifieds, you can also browse a list of banks that can offer you special boat financing deals. So whether power boats or sailboats are your favorite, you're sure to find them in Lake Shore Boats used boat sales section.
    ProSubmit
    ScreenShot
            ProSubmit

    ProSubmitinc.com will drive traffic to your website. Site offers Search Engine Submission and Web Site Optimization services.
    Services provided:
  • Website design

  • Flash header design

  • Custom PHP programming

  • E-Commerce integration

  • Website hosting
            •
    Deer Track Golf Course
    ScreenShot
            Deer Track Golf Course

    Deer Track Golf Course is a full service facility with 18 beautifully manicured golf holes. A fully stocked Pro Shop with top of the line golf equipment, outing pavillions and a large multi targeted Driving Range.
    This was a re-design project.
    Best Nurse Jobs
    ScreenShot
            Best Nurse Jobs

    Search through the job listings and find the position that is right for you or find the nurses that you need now on BestNurseJobs.com.
    This was a Web site re-design project.
    Albemarle Place
    ScreenShot
            Albemarle Place

    Future of Central Virginia's town center.
    Western Bid
    ScreenShot
            Western Bid

    Company assists people from Russia in trading on Ebay.
    Detroit Music Festival
    ScreenShot
            Detroit Music Festival

    Official Detroit Music Festival website.
    Make plans to be "Throwin' down in Motown" on 2 big nights: Friday, August 1 and Saturday, August 2 at this year's 3rd Annual Detroit Music Festival!

    The Guinness World Record has officially accepted the Detroit Music Festival 2003 intention to break the record for "the largest amount of people doing a line dance in unison".
    Easy Job
    ScreenShot
            Easy Job Resume Builder

    Expert resume and cover letter creation software that contains and places at YOUR disposal the knowledge and advice of the best professional resume writers.
    This was a Web site re-design project.
    Midwest Discount Golf
    ScreenShot
            Midwest Discount Golf

    Midwest Discount Golf is the best source for low priced Golf Equipment anywhere on the net. They offer top of the line Golf Equipment from manufacturers such as Mizuno, Titleist, Ping, Callaway, Nike and many more at a price too low for their competitors to match.
    ScreenShot
            Vex.ru

    Web site provides information for Russian traders.
    Online Criminal Checks
    ScreenShot
            Online Criminal Checks

    Online information company that provides efficient access to Court Records. With the launch of the first product, NCCriminalCheck©, clients can now get INSTANT ACCESS and INSTANT RESULTS for court records in North Carolina. The searchable database retrieves ALL court records from ALL counties in one simple, inexpensive search.
    WM2ATM
    ScreenShot
            WebMoney ATM Card

    WM2ATM service station is an advanced utility created for WebMoney Transfer users and clients. WebMoney ATM card allows fast and effective conversion method of any electronic currency such as WebMoney into cash.
    Cross-Contact Company
    ScreenShot
            Cross-Contact Company

    One of the largest companies that sell wires and equipment for communication lines in Moscow, Russia.
    Relmax Top 2
    ScreenShot
            Relmax Top - Ranking System

    Web site counter and ranking service for webmasters, and directory developed by Relmax. Helps promote Web sites and track visitors.
    .
    One World United
    ScreenShot
            One World United

    Very effective traffic generation tool. Provides unlimited, targeted, unique, free visitors for your Web site and multiple bonuses for active members.
    Unique Rewards
    ScreenShot
            Unique Rewards

    UniqueRewards is the program that pays cash for signing up for free offers, visiting sites, Reading Emails, Shopping Online and more…
    Michael Reavey Music
    ScreenShot
            Michael Reavey Music

    Michael Reavey Music provides talented, entertaining, and professional live music for events throughout the Boston area and beyond.
    Integlobe Group
    ScreenShot
            Integlobe Group

    Integlobe Group is a professional services firm that offers learning solutions, project management, communications marketing and small business services.
    Central Vacuum
    ScreenShot
            Central Vacuum

    M. D. Manufacturing's dealer in Russia.
    Company offers central vacuum systems.
    Fast cleaning with no noise or dust.
    ScreenShot
            Check2WM.com

    Check cashing service created for WebMoney Transfer, Inc.
    Harmonica Blu Xpress
    ScreenShot
            Harmonica Blu Xpress

    Harmonica Blu leads an exciting and dynamic blues band in the Cleveland area. Get on board the Xpress for your dancing and listening pleasure.
    Send Me Offers
    ScreenShot
            Send Me Offers

    SendmeOffers.com is a source to the newest and hottest product offers sent directly to your email box.
    ScreenShot
            BKLN.NET

    BKLN.NET, Inc. was created as a better alternative for companies faced with the tough decision of choosing where to outsource their mission-critical hosting and programming operations.
    Richard Hawkins Mouthpiece Shop.
    ScreenShot
            Richard Hawkins Mouthpiece Shop.

    Clarinet Mouthpiece Secure Online Sales. Refinishing available. One of the most popular makers of clarinet mouthpieces Richard Hawkins caters to all your clarinet mouthpiece needs. Handcrafted and Beautiful Sounding. Easy Articulation!
    w-loss
    ScreenShot
            Weight Loss Center on the Web

    Products from HerbaLife for weight management and loss, healthy snacking, skin care and much more..
    BasilsGrill
    ScreenShot
            Basil's Grill & Tavern

    The bar in Elyria, OH. Very friendly atmosphere and great food!
    RFBE
    ScreenShot
            Relmax Flash Banner Exchange

    Through our system your Flash banners will direct multitudes of new visitors and customers to your Web site. Flash banners are lively and attract the eyes of Web surfers, resulting in a high click-through rate. Several different banner formats supported.
    Alverson Photo
    ScreenShot
            Alverson Photographers, Inc.

    Experienced Dog Show Photographers for All-breeds, National Specialties, Local Specialties and any other dog show events in all 50 states.
    Northshore
    ScreenShot
            NorthShore Companies

    Founded in 1985, Northshore Properties is a real estate investment and development company based in Oberlin, Ohio.
    FernGullyGraphics
    ScreenShot
            FernGullyGraphics.com

    Web hosting company based in Modesto, CA.

    Relmax has done a complete re-design of the current Web site, logo and banners design.
    Arbitrage Investor
    ScreenShot
            Arbitrage Investor

    Investment company in Chicago.

    We have performed a complete Web site design and development from scratch.
    St.Petersburg String Quartet
    ScreenShot
            St. Petersburg String Quartet

    One of the world's great string quartets, the St. Petersburg's rise to fame has included a Grammy nomination, "Best Record of the month" honors in both Stereo Review and Gramophone, and hundreds of concerts at many of North America's, Europe's and Asia's most prestigious series and festivals.
    Efimov
    ScreenShot
            Cardiac Optical Imaging Laboratory

    Cardiac Optical Imaging Laboratory in Case Western Reserve University, Cleveland (Ohio, USA).

    Also see: Website Redesign Examples

    For a FREE Estimate on your Web
    site design click HERE

    Have a question? Feel free to contact us.

    Bookmark this page

    Call Us Toll-Free

    View design samples

    View logo design samples

    Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
    About the Company | Affiliate Program | Links | Guest Book | Contact Information
    Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

FLASH ANIMATION AND PRESENTATIONS:

This technology gives you the ability to add exciting animation and sound to your Web site. It's fun for visitors and enhances their involvement and interaction. This is a technology of the future.

Samples of Flash Intros:

Flash Intro sample

Flash Intro sample

Samples of Flash Interactive Banners

FREE Estimate on your Flash animation

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

BANNERS:

Banners are a powerful advertising tool that put inviting graphics and text before thousands of potential visitors and customers. When your banners appears on another Web site, one click will bring the Web surfer to you!

Relmax designs custom banners.
To view the samples, follow the link below:

View banners

FREE Estimate on your banner design

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

LOGOS:

Your logo should be an effective and highly recognizable symbol of your company. Put our design team to work for you!

• Webology

Webology - Web design company (Went out of business)
(no URL)
Webology - Web design company (Went out of business)

• FernGullyGraphics.com

FernGullyGraphics.com - Web hosting company
(www.ferngullygraphics.com)
FernGullyGraphics.com - Web hosting company

• Arbitrage Investor

Arbitrage Investor - Investment company based in Chicago, IL
(www.arbitrageinvestor.com)
Arbitrage Investor - Investment company based in Chicago, IL

• BKLN.net

BKLN.net - Web hosting and programming, Brooklyn, NY
(www.bkln.net)
BKLN.net - Web hosting and programming, Brooklyn, NY

• Check2WM

Check2WM - check cashing company
(www.check2wm.com)
Check2WM - check cashing company

• One World United

One World United - Traffic exchange service. Helps your Web site get more visitors.
(www.oneworldunited.com)
One World United - Traffic exchange service. Helps your Web site get more visitors

• Send Me Offers

Send Me Offers - subscription-based Web site
(www.sendmeoffers.com)
Send Me Offers - subscription-based Web site

• Integlobe Group

Integlobe Group is a professional services firm that offers learning solutions, project management and communications marketing services.
(www.integlobegroup.com)
Integlobe Group is a professional services firm that offers learning solutions, project management and communications marketing services

• Midwest Discount Golf

Midwest Discount Golf is the best source for low priced Golf Equipment anywhere on the net.
(www.midwestdiscountgolf.com)
Midwest Discount Golf is the best source for low priced Golf Equipment anywhere on the net

• Relmax Top

Web site counter and ranking service for webmasters, and directory developed by Relmax. Helps promote Web sites and track visitors.
(www.relmaxtop.com)
Web site counter and ranking service for webmasters, and directory developed by Relmax. Helps promote Web sites and track visitors

• Vex.ru

Web site provides information for Russian traders.
(www.vex.ru)
Web site provides information for Russian traders

• Easy Job

Expert resume and cover letter creation software that contains and places at YOUR disposal the knowledge and advice of the best professional resume writers.
(www.relmax.com/clients/easyjob)
Expert resume and cover letter creation software that contains and places at YOUR disposal the knowledge and advice of the best professional resume writers

• Western Bid

Company assists people from Russia in trading on Ebay.
(www.westernbid.com)
Company assists people from Russia in trading on Ebay

• BestNurseJobs.com

Search through the job listings and find the position that is right for you or find the nurses that you need now on BestNurseJobs.com.
(www.bestnursejobs.com)
Search through the job listings and find the position that is right for you or find the nurses that you need now on BestNurseJobs.com

• UniqueRewards

UniqueRewards is the program that pays cash for signing up for free offers, visiting sites, Reading Emails, Shopping Online and more…
(www.uniquerewards.com)
UniqueRewards is the program that pays cash for signing up for free offers, visiting sites, Reading Emails, Shopping Online and more

Click here to receive a FREE Estimate on your LOGO

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Custom Web Programming:

Relmax is known for developing custom Web applications.
Most of the sites can be viewed in Web design portfolio.

Why is custom more important than already created program?
With custom Web development your application will do all the functions necessary for your business to succeed on the Web. The performance will be efficient, system will be easy to operate and understand.

Please read the feedback received from our customers - Testimonials Section.

Need someone to do Web programming job for you?
Request a FREE Estimate now!

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Our Web site designs are tailor-made to fit your needs, the style of your company, and the particular products or services you offer. So we don't post a price list. Contact us and we'll work closely with you to create the best possible site at a price that will be a pleasant surprise.

For Web hosting rates, please click here.

Do you need more information or would
like to know the price for your project?

1. E-MAIL US: SALES@RELMAX.COM,

2. OR FILL OUT THE ONLINE FORM,

3. OR SIMPLY CALL US TOLL-FREE AT
1-877-735-6293.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Relmax.com Privacy Policy:

  1. Overview

    2. Thank you for visiting Relmax.com (the "Web Site") and reviewing our Privacy Policy. Your privacy is important to us, and our policy is simple: we will collect no personally identifiable information about you when you visit the Web Site unless you choose to provide that information. This Privacy Policy does not describe information collection practices on other sites, including those linked to or from the Web Site

  2. What Type of Information We Collect

    3. The server on which the Web Site is located collects and saves only the default information customarily logged by web server software. Such information may include the date and time of your visit, the originating IP address, and the pages and images requested.

  3. Children's Issues

    4. The Web Site is not directed to children under thirteen (13) years of age, and children under such age must not use the web site or services offered on it to submit any individually identifiable information about themselves.

  4. Copyright

    5. The materials found on the Web Site are protected by United States and other copyright laws, except for works of the United States Government pursuant to 1 U.S.C. Section 105. The selection, arrangement and presentation of all materials (including information in the public domain), and the overall design of the Web Site are copyright © May 22, 2005, Relmax, Inc. Permission is granted to view and print materials from Relmax.com for the non-commercial purpose of viewing, reading and retaining for reference. Any other copying, distribution, retransmission or modification of information or materials on this site, whether in electronic or hard copy form, without the express prior written permission of Relmax, Inc., is strictly prohibited.

  5. No Warranties

    6. Relmax.com DOES NOT MAKE ANY EXPRESS OR IMPLIED WARRANTIES, REPRESENTATIONS OR ENDORSEMENTS WHATSOEVER (INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE) WITH REGARD TO THE WEB SITE, THE MATERIALS, ANY PRODUCTS, INFORMATION OR SERVICE PROVIDED THROUGH THE WEB SITE, OR ANY SITES LISTED THEREIN, AND THE WEB SITE WILL NOT BE LIABLE FOR ANY COST OR DAMAGE ARISING EITHER DIRECTLY OR INDIRECTLY FROM ANY SUCH TRANSACTION. THE WEB SITE DOES NOT WARRANT THAT IT WILL BE UNINTERRUPTED OR ERROR-FREE OR THAT DEFECTS IN IT WILL BE CORRECTED. THE WEB SITE IS PROVIDED ON AN "AS IS, AS AVAILABLE" BASIS.
    IN NO EVENT WILL THE WEB SITE OR ITS MEMBERS, MANAGERS, OFFICERS, EMPLOYEES, AGENTS AND THE ASSIGNS OF SAME BE LIABLE FOR (1) ANY INCIDENTAL, CONSEQUENTIAL OR INDIRECT DAMAGES (INCLUDING, BUT NOT LIMITED TO, DAMAGES FOR LOSS OF PROFITS, BUSINESS INTERRUPTION, LOSS OF PROGRAMS OR INFORMATION, AND THE LIKE) ARISING OUT OF THE USE OF OR INABILITY TO USE THE WEB SITE, THE MATERIALS OR ANY INFORMATION, OR TRANSACTIONS PROVIDED ON THE WEB SITE OR DOWNLOADED FROM THE WEB SITE, EVEN IF THE WEB SITE OR ITS AUTHORIZED REPRESENTATIVES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR (2) ANY CLAIM ATTRIBUTABLE TO ERRORS, OMISSIONS OR OTHER INACCURACIES IN THE WEB SITE, THE MATERIALS AND/OR LISTINGS OR INFORMATION DOWNLOADED THROUGH THE WEB SITE. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU. IN SUCH STATES, THE WEB SITE'S LIABILITY IS LIMITED TO THE GREATEST EXTENT PERMITTED BY LAW.

  6. Indemnification

    7. You agree to indemnify, defend and hold harmless the Web Site and its members, managers, officers, employees, agents and the assigns of same, from and against any and all loss, costs, expenses (including reasonable attorneys' fees and expenses), claims, damages and liabilities related to or associated with your use of the Web Site and any violation of this Privacy Policy by you.

  7. Governing Law and Jurisdiction

    8. This Privacy Policy constitutes a contract made under and shall be governed by and construed in accordance with the laws of the State of Ohio.

  8. Last Update

    9. This Privacy Policy was last updated on May 22, 2005.

  9. Contact Information

    10. Questions or comments regarding the Web Site should be sent by e-mail to privacy@relmax.com or by U.S. mail to M.P.O. Box 296, Oberlin, OH 44074-0296, USA.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Current promotion:

FREE DOMAIN NAME!

We will register your domain name at no charge when you purchase our Web site hosting services.
It is really easy:
You sign up for our Plans 200, 350 or 500 for only 6 months or Plan 50 for 12 months and we will register your domain at no charge for the whole year!! But wait, there is more..
Sign up for one full year and we will register your domain FOR 2 YEARS!!

How about some more?
FREE Flash-animated banner for your site (468*60 pixels - $60 value)!
We will add it to your FREE Domain name at no cost for you. ENJOY!

Lets calculate the minimal savings:
You will receive: | Regular price | Cost to you
Domain name | $16.99 | $0.00
Flash Banner | $60.00 | $0.00
You will save at least $76.99
No other company can offer this!

Read more about our hosting Plans - Click Here

Remember, it is a limited time offer! Don't wait!
Start now by choosing a hosting plan.

For more information please e-mail us: info@relmax.com or call us toll-free: 1-877-RELMAX-3.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Web Site Design and Development:

Relmax builds custom Web sites. Each site is built from the ground up with your needs in mind, not from a template shared by many others.

We focus the Relmax team's skills on your project. Each project is given careful individual attention. Relmax is large enough to provide any and all necessary Internet development and design services. But the Relmax staff is highly focused and carries each project through to completion as if it's the ONLY project the company has.

Relmax sites sell! Our design and development team creates eye-catching and inviting, highly interactive and functional sites that attract and keep E-Commerce at your cyberspace location. Your site will be planned and executed so that it will be highly visible on the major Internet search engines. This is how new customers often find you, aside from your own advertising and word of mouth.

If you as a business executive or entrepreneur are not well versed in computer and Internet technology, rest assured with Relmax on the job for you. We use only the best and most current technology to get the job done efficiently and with a beautiful result.

Some of the industry-standard and cutting-edge technologies and programming languages we use during development are: C++, PHP, Perl, Delphi, Java, Java-Script, HTML, DHTML, FLASH, SSI, SSH, SSL; databases: mySQL, pgSQL, mSQL, Oracle and msSQL.

Did another firm or individual create your current site that is now generating more headaches than profits and new customers? Relmax will be glad to review your site and repair or rebuild it.

Relmax can handle basically any Web site design or development task!

E-Commerce Solutions:

One of the many exciting possibilities of the Internet is the Automated Online Store we can create for you. Increase your sales and manage the flow of products and payments with E-Commerce automation! You will not only gain a front-end store but also an Administration Panel to add, remove or modify item information. You will also be able to send newsletters, control the flow of orders, see stats, and much more.

See also:
.:. Website Redesign Services
.:. Web Design Portfolio of satisfied clients

Request a FREE estimate TODAY!

Have a question? Feel free to contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Domain name registration:

A powerful domain name is the key to easy access to your site on the Web. Create an effective and memorable domain name that identifies your company or product and register it with Relmax.

Domain names usually cost $70 a year for the first two years and $35 for each additional year.

However, Relmax Inc. is proud to offer top-level domain name registration for just $16.99 per year (less than 5 pennies a day for your OWN name).

To register your domain name simply click here -- -- and complete your Domain Name Order Form.

You can register for two years or up to ten years, depending on your projected needs and budget. You can even register your domain name without ordering web hosting. And, we do not charge a fee for parking domain names; Yes, the service is free!

Before your proceed with the registration of your new domain name, click here -- Check Availability -- to find out if it is available.

To the registration form >>

Have a question? We are always here to help you.
Please contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Web Hosting Services:

We use top quality server equipment to host your site. In fact, our corporate-quality server can handle anything from a basic personal site to a virtual wholesale or retail outlet employing an extensive product database. We use a variety of tools to monitor the site and track its activity.

We offer you our reliable and high-quality web hosting services at rockbottom rates within the States. Depending on the traffic you are expecting, you can choose any of our plans starting from our "BEGINNERS PLAN 20" from $5.95/month up to "BUSINESS PLAN 500" with disk space of 500 Mb!

View Hosting Pricing

Features: | Plan 20 | Plan 50 | Plan 200 | Plan 350 | Plan 500
Web Space (MB) | 20 | 50 | 200 | 350 | 500
HTTP/FTP Traffic (Bandwidth) | 2 GB | 5 GB | 10 GB | 15 GB | 20 GB
Dedicated IP-address | - | - | + | + | +
Domain name | + | + | + | + | +
Sub-Domains | - | 2 | 10 | 25 | 50
User FTP Login Accounts | 1 | 1 | 10 | 25 | 50
POP3 E-mail | 10 | 25 | 50 | 100 | 250
Auto-Responders | unlimited | unlimited | unlimited | unlimited | unlimited
E-mail Aliases | unlimited | unlimited | unlimited | unlimited | unlimited
Email Forwards | unlimited | unlimited | unlimited | unlimited | unlimited
Web Mail | + | + | + | + | +
E-mail Filter | - | + | + | + | +
Online Control Panel | + | + | + | + | +
MySQL | - | 2 | 4 | 5 | 10
phpMyAdmin 2.2.0 | - | + | + | + | +
Anonymous FTP Server | - | - | + | + | +
Detailed Online Statistics | + | + | + | + | +
Error Log | + | + | + | + | +
FTP Manager | + | + | + | + | +
Web Based File Manager | + | + | + | + | +
Cron Jobs | + | + | + | + | +
Custom Mime Types | + | + | + | + | +
Error Pages (404, 403 ...) | + | + | + | + | +
Password Protected Directories | + | + | + | + | +
PHP 4.2.3 | + | + | + | + | +
Perl 5.6.1 | + | + | + | + | +
Secure Server Capability (SSL) | - | - | + | + | +
CGI-BIN | + | + | + | + | +
Server Side Includes (SSI) | + | + | + | + | +
MS FrontPage Ext. (optional) | + | + | + | + | +
Real Audio/Video | + | + | + | + | +
Search Engine Submission | + | + | + | + | +
Free shopping cart | + | + | + | + | +
CGI-BIN W/Preconfigured Scripts Installed:
Mailing Lists | + | + | + | + | +
Counter | + | + | + | + | +
Clock | + | + | + | + | +
FormMail | + | + | + | + | +
Search Engine | + | + | + | + | +
Chat | + | + | + | + | +
Random HTML | + | + | + | + | +
GuestBook | + | + | + | + | +
Countdown | + | + | + | + | +
CGI EMail | + | + | + | + | +
Rotating banner | + | + | + | + | +
Web Hosting Services/Hardware:
Web Server Software | Apache 1.3.29 | Apache 1.3.29 | Apache 1.3.29 | Apache 1.3.29 | Apache 1.3.29
OS | Linux Redhat | Linux Redhat | Linux Redhat | Linux Redhat | Linux Redhat
24x7x365 Server and Network Monitoring | + | + | + | + | +
Nightly backup | + | + | + | + | +
Service Guarantees:
99% Uptime | + | + | + | + | +
30-Day Money Back | + | + | + | + | +
Prices: |
Setup Fee ($) | $0.00 | $0.00 | $0.00 | $0.00 | $0.00
Per month | $5.95* | $9.95* | $26.95 | $38.95 | $44.95

Order web hosting

* For Plans 20 and 50 we require a minimum purchase of 3 month.

Have a question? Feel free to contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

We provide a wide variety of services on the Web such as, Web programming, banner creation, professional LOGO design, site promotion, maintenance, Flash presentations and animations, and much more.

Relmax's fabulous advertising and promotion elements stand out from the crowd!

Is there another Internet or Web site service
that you need, but do not see on our Web site?

Just ask, we will be glad to provide it for you.

Send us an E-mail or call!

Have any questions? Feel free to contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Special offers:

  • Order one Web site and receive 10% OFF on a second one (equal or lesser value).

  • Buy three banners (including Interactive Flash banners) and get one more
    FOR FREE!

Request Free Estimate on Web Design now!

Have a question? Feel free to contact us.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Relmax.com Terms of Use:

These "Terms of Use" set forth the terms and conditions that apply to your use of http://www.relmax.com (the "Web Site"). By using the Web Site (other than to read this page for the first time), you agree to comply with all of the Terms of Use set forth herein. The right to use the Web Site is personal to you and is not transferable to any other person or entity.

Copyrights and Trademarks
  1. All materials contained on the Web Site are Copyright May 22, 2005, RELMAX, INC. All rights reserved.
  2. No person is authorized to use, copy or distribute any portion the Web Site including related graphics.
  3. RELMAX and other trademarks and/or service marks (including logos and designs) found on the Web Site are trademarks/service marks that identify RELMAX, INC and the goods and/or services provided by RELMAX, INC. Such marks may not be used under any circumstances without the prior written authorization of RELMAX, INC.

Links to Third-Party Web Site
RELMAX, INC may provide hyperlinks to third-party web sites as a convenience to users of the Web Site. RELMAX, INC does not control third-party web sites and is not responsible for the contents of any linked-to, third-party web sites or any hyperlink in a linked-to web site. RELMAX, INC does not endorse, recommend or approve any third-party web site hyperlinked from the Web Site. RELMAX, INC will have no liability to any entity for the content or use of the content available through such hyperlink.

No Representations or Warranties; Limitations on Liability
The information and materials on the Web Site could include technical inaccuracies or typographical errors. Changes are periodically made to the information contained herein. RELMAX, INC MAKES NO REPRESENTATIONS OR WARRANTIES WITH RESPECT TO ANY INFORMATION, MATERIALS OR GRAPHICS ON THE WEB SITE, ALL OF WHICH IS PROVIDED ON A STRICTLY "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND AND HEREBY EXPRESSLY DISCLAIMS ALL WARRANTIES WITH REGARD TO ANY INFORMATION, MATERIALS OR GRAPHICS ON THE WEB SITE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. UNDER NO CIRCUMSTANCES SHALL THE SITE OWNER OR PUBLISHER BE LIABLE UNDER ANY THEORY OF RECOVERY, AT LAW OR IN EQUITY, FOR ANY DAMAGES, INCLUDING WITHOUT LIMITATION, SPECIAL, DIRECT, INCIDENTAL, CONSEQUENTIAL OR PUNITIVE DAMAGES (INCLUDING, BUT NOT LIMITED TO LOSS OF USE OR LOST PROFITS), ARISING OUT OF OR IN ANY MANNER CONNECTED WITH THE USE OF INFORMATION OR SERVICES, OR THE FAILURE TO PROVIDE INFORMATION OR SERVICES, FROM THE WEB SITE.

Changes to These Terms of Use
RELMAX, INC reserves the right to change these Terms of Use at any time by posting new Terms of Use at this location. You can send e-mail to RELMAX, INC with any questions relating to these Terms of Use at terms@relmax.com.

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Testimonials:

"It has been a pleasure working with Mikhail Aranovsky, President of Relmax, Inc. He is professional, efficient and creative. He was available 24/7 throughout the process of creating my website. I will continue doing business with him in the future and certainly recommend his expertise to others. "

- Maria Dorfner -
Founder/CEO
NewsMD Communications

"I have been working with Mikhail Aranovsky and his company Relmax, Inc. on various projects over the past year.

I have always found the work that Mikhail and Relmax, Inc. has done for us to be of very high quality. Mikhail is flexible, accommodating and goes the extra mile to ensure that everything is always in good working order. He is also available almost 24 hours a day, seven days a week for any queries.

I would highly recommend Relmax, Inc. based upon the experiences we have had doing business with this organization over the past year."

- Gary Gruzd -
Interdesign Enterprises, Inc.
(www.BestNurseJobs.com)

"Relmax staff, your technical skills and business relations have been superb. After performing a thorough search for custom web designers prior to choosing your company, I have been very pleased with your patience, ability, and ultimately the final products. The quality is great, the coordination and development fantastic, and the website cost-effective. Would recommend your services to any business or personal interest in need of a great looking website."

- Austin Cox -
The Cox Company
(www.CoxCompany.com)

"Relmax has been a pleasure to work, the staff is the most comprehensive and knowledgeable I have ever dealt with. This is our fourth and final attempt at a website, thanks to Relmax. They truly have given us the tool we were looking for to help better serve our clients."

- Chad D. Studebaker -
President
ConneXions
(www.CableConneXion.com)

"My project for a new online business was very complicated and complex but Relmax handled it with great ease and professionalism. The lines of communication were always open and they never hesitated to implement any changes I wanted done. Their rates were also very affordable. I would not hesitate in referring someone to them for any and all their online needs. I recommend them highly for their quality of work, professionalism, affordable rates, and honesty."

- Kevin Disbrow -
Owner
Lake Shore Boats
(www.LakeShoreBoats.com)

"Relmax is the first and only web developers I found who take personal pride In every ounce of there work. I would not go with another company! They are always quick with projects and there flash, graphic and programming designers are the best in the field! I must thank them once again for my online business success!"

- Charles Nevery -
President/CEO
ProSubmit, LLC
(www.ProSubmitInc.com)

"The Relmax web designing skills turned the Detroit Music Festival's vision into reality. Your patience, excellence and attentiveness to details is defining... Relmax is a web designer's web designer!"

- Paulette Brown -
Executive Assistant/PR
Detroit Music Festival
(www.DetroitMusicFestival.net)

"Thanks very much for all of your help in the creation and promotion of my website. Thanks especially for your frequent communication, there wasn't a question that you weren't able to help me with. All comments I've received about the site have been positive, and I owe it all to your team! I'm glad this is only the beginning of many future collaborations."

- Michael Reavey -
President, Michael Reavey Music
(www.MichaelReaveyMusic.com)

"For years I have searched for a company that would cater a website to my craft, clarinet mouthpiece making. When I started working at the Oberlin Conservatory of Music it was my plan to find such a company in the greater Cleveland area. To my great surprise, I found Relmax, Inc. What a fantastic experience working with this company and its designers. With simple ideas that can expand into something eye catching and entertaining to serious online secure pay, Relmax has really worked hard to satisfy my needs and accomplished a website that I always hoped for. What a terrific crew of people! Thanks Mikhail!"

- Richard Hawkins -
Clarinetist/Mouthpiece Maker
Prof. Oberlin Conservatory of Music
(www.RichardHawkinsMouthpiece.com)

"hi guys. i just wanted to thank everyone for their effort in creating basilsgrill.com. i'm getting a ton of response, and a lot of that translates into greater name and product recognition. the programs are very clean and efficient, yielding fast loading, streamlined pages.

i'm especially pleased with response time whenever i want to put a new idea to work for me on the site. this is a lot more than i expected in the way of a promotional tool. again, thank you. you can use me for a reference any time."

- Chris Christo -
(www.BasilsGrill.com)

"I would recommend Relmax for webhosting and all of your web related needs. I am very pleased with hosting features and reliability (not to mention price!) and personally enjoy the benefits of custom programming that they have written for me. They can do it all, and when it comes to "customer service", there is NONE better!"

- Robert Ashley -
(PepperBob.com & WinFreePostage.com)

"Mikhail and his team showed great professionalism and innovation during the development of our web site. Not only did they provide us with a great product, but they also listened to our requirements for the project, this is something that is hard to find these days. Not to mention that they did all of this for a very reasonable price. On a scale from 1-10 I would say that Relmax, Inc gets a 10! This great company comes highly recommended by me, let them be an example for how a true web development company should conduct business. Many thanks to the development team at Relmax.com".

- Fernando Alfaro -
(FernGullyGraphics.com, Inc.)

"Everything's working great. Very fast email responses and good customer service and that's why I affiliate/promote your company for Web hosting.

Keep up the great hosting service! Best I have had yet!!"

- James Malloy -

"Everything looks great! You did a great job. We do not need any changes, it all looks good".

- F-A-B-Worm Farm -

"SbySC has had a beautiful website for over a year and received some hits - mostly by local customers & Oberlin College students.
In May of 2000 I was contacted by Relmax Inc.
Mikhail Aranovsky helped me with a shopping cart, newsletter, and a super stats check. Mikhail is always available to answer questions & responds within hours to any of my inquires. He is always patient with my lack of computer knowledge.
My website is now very easy to work with and is receiving more hits than ever. I am now getting orders off the Internet.
To put it simply, I am getting Results from my website now that Relmax is involved".

- Patricia Haumann -
(www.sbysc.com)

"I must say that I enjoy working with you. Thanks for meeting the deadline".

- Holly Stabin -
(www.loveanddiamonds.com)

"WEB-site of my laboratory is nice and easy to maintain. Assistance was always in time and to the point. I look forward to work with you".

- Igor Efimov -
(Efimov.CWRU.edu)

"I'm very impressed at how easy everything sets up and works. The Relmax customer service has been very helpful and quick to respond to every question that I have had. I really appreciate how quick my account was setup. You also seemed to be one of the few that had good pricing, features I was looking for, and you all looked organized. I will be sure to recommend your services to others who are interested. Thanks".

- Orlando Castillo -

"You guys hit the nail in the head with the design. Thanks for all of your help!! You are really making things go smoothly on my end".

- Robert Haas -
(Webology)

"Thank you for the excellent speedy service, it is great! Anytime you need a referance for a new client you can send them my way".

- Sandra Bond -
(World Class Production Services)

Request Your Free Estimate Today or Contact Us

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


Relmax. Professional Website Design, Development and Hosting Company

Relmax Inc.
Development's Menu
Web Design and Development
Domain Name Registration
Web Hosting
More...
Portfolio
Web sites
Flash
Banners
Logos
Programming
Prices
Order
Free Estimate
Web Hosting
Domain Name
More...
Payment
About the Company
Links
Contact Information
Affiliate program

Website Redesign:

Does your Web site need to be redesigned or enhanced? Does it have all the functionality you need to grow your business? What about the look of the site? Does it look "old" compared to your competitors' sites?

You might be losing a huge chunk of potential business because your site was not really designed properly and just hasn't kept up with your needs. Maybe it's not well-maintained, or has broken links, or just doesn't have the features customers expect.

Relmax Web Development is here to help you. We are experts in redesigning Internet sites as well as developing new ones. We will create a solution for you that will not only look good and work well, but will also be optimized for search engines.

And now, please take a moment to look at the redesign samples below.

Before | After
Lambson Wlidlife Art
Old Lambson Wlidlife Art Web Site • ScreenShot | New Lambson Wlidlife Art Web Site • ScreenShot
StoptooShop.com
Old StoptooShop.com Web Site • ScreenShot | New StoptooShop.com Web Site • ScreenShot
ConneXions
Old ConneXions • ScreenShot | New ConneXions Web Site • ScreenShot
Deer Track Golf Course
Old Deer Track Golf Course • ScreenShot | New Deer Track Golf Sourse Web Site • ScreenShot
Best Nurse Jobs
Old Best Nurse Jobs • ScreenShot | New Best Nurse Jobs Web Site • ScreenShot
Easy Job - Resume Builder
Old Easy Job • ScreenShot | New Easy Job Web Site • ScreenShot

See also:
.:. Web Site Design Services
.:. Web Design Portfolio of satisfied clients

Bookmark this page

Call Us Toll-Free

View design samples

View logo design samples

Home | Services | Portfolio | Order | Payment | Promotion of the Week | Specials
About the Company | Affiliate Program | Links | Guest Book | Contact Information
Copyright © 1999-2005 Relmax Corporation. All rights reserved. Privacy Policy | Terms of Use


'Тест Лайн' - лаборатория восстановления данных и ремонта HDD

Восстановление данных и ремонт жестких дисков (HDD)
TestLine.ru || Лаборатория восстановления данных
О лаборатории: основной сферой деятельности лаборатории является восстановление данных, файлов с логически или физически испорченных носителей информации (жестких дисков - HDD, RAID-массивов, Flash-памяти). В лаборатории реанимируют Ваш носитель информации, восстановят данные и Ваше спокойствие! Хотите проверить? Звоните в нашу диспетчерскую 105-75-94 и Вы получите исчерпывающую информацию по всем вопросам восстановления.
Меню:
Восстановление данных и носителей информации
Главная страница
О компании
Восстановление данных
Ремонт жестких дисков
Статистика поломок
Статьи по теме
Программы, утилиты
Заявка через интернет
Консультации
Наши скидки
Контактная информация

Скидки на оказание услуг
Все услуги, связанные с восстановлением данных и ремонтом носителей информации, а также ремонтом и обслуживанием компьютеров и оргтехники Вы можете заказать с 10% скидкой.

Прямо сейчас с сайта Вы можете распечатать дисконтную карту. Подробнее в разделе "Наши скидки".

Если на Вашем компьютере пропала информация или винчестер стал издавать странные стуки, перестал определяться - специалисты нашей лаборатории к Вашим услугам!

Наша служба способна:

  • Отремонтировать HDD всех модификаций производства: Seagate, Western Digital, Fujitsu, Quantum, Samsung, Maxtor, Conner, IBM, HP, Kalok, Teac, Daeyoung, Xebec;
  • Извлечь пользовательскую информацию с поврежденных или частично неисправных накопителей, а так же с исправных накопителей с разрушенной логической структурой;
  • Восстановить формат нижнего уровня;
  • Восстановить служебную информацию;
  • Восстановить или изменить параметры в паспорте диска;
  • Заменить дефектные сектора и дорожки на резервные или их исключение из работы;
  • Переконфигурировать HDD;
  • Отключить неисправные магнитные головки.

Сколько это стоит? Цены среднерыночные, но поскольку все зависит от конкретной ситуации наша компания осуществляет индивидуальный подход к каждому клиенту. Звоните прямо сейчас в нашу диспетчерскую по телефону 105-75-94 - наши администраторы ответят на любой интересующий Вас вопрос и/или примут заказ. Также Вы можете заказать услугу через сайт с описанием сути проблемы.

На заметку

Восстановить разрушенную информацию на жестком диске и снизить степень риска еще большего разрушения возможно только в специализированных организациях - ЦЕНТРАХ СПАСЕНИЯ ИНФОРМАЦИИ, использующие современные технологии на базе специализированного программного обеспечения и оборудования

Эти организации имеют высококлассных подготовленных специалистов с большим опытом работы в области восстановления информации и углубленного технологического ремонта любых магнитных носителей. Восстановление данных как правило является их основным видом деятельности, что повышает надежность в работе.

В разделе "Статьи по теме" Вы можете найти дополнительную тематическую информацию. Например можете прочитать глоссарий терминов, связанных с HDD и восстановлением данных.

Наша лаборатория осуществляет бесплатную курьерскую доставку в пределах Московской кольцевой дороги.

В случае доставки оборудования клиентом, наша лаборатория осуществляет бесплатную диагностику в присутствии клиента и предоставляет льготное обслуживания с 15 процентной скидкой.

Каждый посетитель раздела НАШИ СКИДКИ имеет возможность распечатать для себя ДИСКОНТНУЮ КАРТУ для получения льготного обслуживания с 10 процентной скидкой при первом обращении.

Клиентам из городов центрального региона услуги по восстановлению данных производятся в день обращения. Срочность выполнения заказа дополнительно не оплачивается.

Другие проекты нашей компании:
ADSL провайдер - выделенная линия в интернет в Москве. Скорость канала до 7,5 Мбит/сек. "Мастер большого города" - абонентское обслуживание компьютеров и оргтехники. Ремонт компьютеров, ноутбуков, мониторов, принтеров, копиров, факсов. "Мастер на все руки" - решение любых хозяйственных и бытовых проблем Доска объявлений, компьютерная барахолка по продаже компьютеров и оргтехники

Единая диспетчерская 105-75-94
Электронная почта по общим вопросам: info@testline.ru

Адрес лаборатории: Москва, ул. Касаткина д.3а , ЗАО "Завод Стрела". Телефон на проходной: 223. Время работы с 9.30 до 18.00 без выходных.

:: Главная страница :: Контакты ::

Дизайн и сопровождение:
ADSL провайдер "Московские сети"